Jump to content

[1.12.x] Anatid Robotics / MuMech - MechJeb - Autopilot - [2.14.1] [1st April 2022]


sarbian
 Share

Recommended Posts

Last version I used was dev #1146.  I see there is now dev #1148.  I'll try that.  I always use the dev builds, not the Curse nor SpaceDock versions.   When I used 1146, and it failed, I tried removing and installing multiple times.   I'm off to try #1148.  thanks

EDIT #1:  Well #1148 worked no better..  When I put a MJ1_AR202 on a capsule in the VAB, I don't get a Delta-V window  Only thing I see (even without adding the AR202) is a small window in the upper left corner of the screen.  When opened, it shows two options:  "Custom Window" and "Settings"

EDIT #2:  Started a new game with  MJ2 as the ONLY mod in Sandbox mode (not Career).   Delta-V Stats appear in VAB.  All windows available on Launch Pad.  So, the hunt begins to find the mod that's killing MJ2 in Career mode.  I use only about 45 mods, so hopefully, I can find ther miscreant quickly.

EDIT # 3:  I added back some mods.  MJ2 was not working, e.g., no Delta-V window in VAB.  Removed all mods again, except MJ2.    Not seeing Delta-V window in VAB.  My GameData folder has only three folders:  Squad, SquadExpansions, MechJeb2

EDIT #4:  Removed MJ2 and re-installed it.  Delta-V now showing in VAB.   More experiments to follow.

EDIT #5: (4 hours after #4).  Incrementally adding mods.   MJ2 appears to be working as advertised.

Edited by Apollo13
Link to comment
Share on other sites

Is there any remedy for roll crazyness using smart a.s.s for ascents? no matter if i set the aero surface authority to a tiny amount or full deflection range all MJ does is just jitter around the roll input and slowly turn, leaving me at random angles until i take control myself. Force roll works correctly in everything else but not smart a.s.s

Link to comment
Share on other sites

  • 2 weeks later...

BUG report:

When I use Ascent Guidance and Smart A.S.S , my rocket start to roll and lost control.

This bug appear all the time I launch.

KSP.log→https://1drv.ms/u/s!Av3iukGYy2izpRczm6ACtpViCh3l?e=YfCrdD

video→https://1drv.ms/v/s!Av3iukGYy2izpRkkwfiZdO1l_gBJ?e=mQ8Dxc

all the mod in gamedata→https://1drv.ms/t/s!Av3iukGYy2izpRpo6F7Ox002AdO3?e=ZKXvIr

Link to comment
Share on other sites

5 hours ago, easterlywave said:

BUG report:

When I use Ascent Guidance and Smart A.S.S , my rocket start to roll and lost control.

This bug appear all the time I launch.

KSP.log→https://1drv.ms/u/s!Av3iukGYy2izpRczm6ACtpViCh3l?e=YfCrdD

video→https://1drv.ms/v/s!Av3iukGYy2izpRkkwfiZdO1l_gBJ?e=mQ8Dxc

all the mod in gamedata→https://1drv.ms/t/s!Av3iukGYy2izpRpo6F7Ox002AdO3?e=ZKXvIr

For the rolling issue here my solution : deactivate the rolling for the elevon at the back of your rocket.

Link to comment
Share on other sites

  • 2 weeks later...

Hi, does anyone know if there is any issues with "Kill H/S" I've always used the keep surf and Kill H/s to create a craft that can perfectly hover if needed. 

I've returned to KSP and if I try and use this feature now it'll instantly tilt my craft a few degrees after pressing kill h/s even on a craft that is just a few small engines under a tank and then a control probe. In the past this would always perfectly hover and not move at all until it ran out of fuel? 

It's strange how it'll first now tilt these few degrees and fall into a crash without being able to save it's self

 

Thank you 

Link to comment
Share on other sites

  • 2 weeks later...

我不认为MechJeb在职业模式中禁用某些功能的游戏玩法很好,因为大多数填满科技树的人都不再需要MechJeb了。

Quote

I don't think MechJeb's gameplay of disabling certain features in career mode is great since most people who fill up the tech tree don't need MechJeb anymore.

 

Edited by Vanamonde
Please post in English when not using the International subforums.
Link to comment
Share on other sites

KSP v1.12.4.3187

MJ2 v2.14.2.0

I only just started using MechJeb this week now that landings and dockings have lost there charm after years of playing unmodded KSP (except SCANsat). MJ2 is proving to be quite handy but I've encountered a problem with it trying to land on the opposite side of the Mun from the chosen target or (as far as I can tell) trying to go straight through the Mun while still targeting the opposite side of the Mun from the chosen target.

I see this was a problem that was fixed a long time ago and there's been no recent posts about a recurrence so I'm guessing it's a mod conflict unless anyone has a better idea what's causing this. I can supply the log the next time it happens, but in the meantime, here's my mod list in case anyone has a good guess which one it might be. (I'm not uninstalling mods one-at-a-time/launching KSP/landing on Mun/exiting KSP 185 times to find the culprit.)

Spoiler

000_AT_Utils
000_ClickThroughBlocker
000_FilterExtensions
000_FilterExtensions_Configs
000_Harmony
000_TexturesUnlimited
000_Toolbar
000_USITools
001_ToolbarControl
002_CommunityPartsTitles
999_KSP-Recall
AdjustableModPanel
AdjustmentTool
AllYAll
AntennaHelper
AquilaEnterprises
ARPIcons
ASET
Astrogator
AstronomersVisualPack
AutoHibernate
AutoQuickSaveSystem
AviationLights
B9PartSwitch
BetterBurnTime
BetterCrewAssignment
BetterKerbol
BetterKerbolRescale
BetterLoadSaveGame
BetterOrderPartsNumbered
BetterTimeWarp
BurstAtomicThrustModule
Bydysawd
CameraFocusChanger
Chatterer
ChromaWorks
CommunityCategoryKit
CommunityDeltaVMaps
CommunityResourcePack
ConformalDecals
ConstantTWR
CrewLight
CriticalTemperatureGauge
CTTP
DatedQuickSaves
Diazo
DistantObject
DockingCamKURS
DockRotate
DraggableAltimeter
DraggableControls
DraggableNavball
DynamicBatteryStorage
EasyVesselSwitch
EditorExtensionsRedux
EnvironmentalVisualEnhancements
EVAEnhancementsContinued
EvaFollower
ExperimentTracker
ExtraDockingPorts
Firespitter
FlagRotate
FMRS
FP_DPSoundFX
FreeLaunchClamps
FruitKocktail
GravityTurn
IDFlags
IndicatorLights
IndicatorLightsCommunityExtensions
JSI
KAS
KeepItStraight
KerbalChangelog
KerbalFoundries
KerbalImprovedSaveSystem
KerbalInventoryForAll
KerbalJointReinforcement
KGEx
KIS
Kopernicus
kOS
KSP-AVC
KSPCommunityFixes
KSPWheel
KSP_PartVolume
LandingHeight
MagiCore
MagicSmokeIndustries
ManeuverNodeEvolved
ManeuverQueue
MechJeb2
MechJebForAll
MK1CabinHatch
Mk2Expansion
Mk3Expansion
ModActions
ModularFlightIntegrator
ModuleAnimateGenericEffects
NavBallDockingAlignmentIndicatorCE
NavyFish
Nereid
NightShift
OrbitalTug
Parallax
Parallax_StockTextures
ParkingBrake
PartAngleDisplay
PartCommanderContinued
PartWizard
PatchManager
PAWRangeBuff
PhantomAerospace
PlanetInfoPlus
PlanetShine
PoodsSkyboxes
PreciseNode
QuantumStrutsContinued
QuickMods
RCSBuildAid
RealPlume
RealPlume-Stock
RealTimeClock2
ReCoupler
RecoveryController
ReentryParticleEffectRenewed
RemoteTech
ResourceMonitors
ReStock
ReStockPlus
RestockRigidLegs
RocketSoundEnhancement
RocketSoundEnhancementDefault
RSSDateTime
SCANsat
Scatterer
ScattererAtmosphereCache
ScienceAlert
ScienceLabInfo
Shabby
ShipEffectsContinued
ShipManifest
Sigma
SimpleRepaint
SituationModuleInfo
SlingShotter
SmartParts
SmokeScreen
SOS
SpaceTuxLibrary
SpeedUnitAnnex
Stock folder: Squad
StageRecovery
StationKeeping
StockDefaultSettings
StockWaterfallEffects
StoreMyReports
SurfaceLights
Targetron
TextureReplacer
ThrottleControlledAvionics
TrackingLights
TrackingStationAmbientlight
TrackingStationEvolved
Trajectories
TriggerTech
TweakScale
TweakScaleCompanion
UmbraSpaceIndustries
VariantPersist
VesselView
WasdEditorCamera
Waterfall
WaterfallRestock
WaypointManager
WhoAmI
zFinal_FilterExtensions
999_Scale_Redist.dll
KIS-restackibility.cfg.txt
ModuleManager.4.2.2.dll
ModuleManager.ConfigCache
ModuleManager.ConfigSHA
ModuleManager.Physics
ModuleManager.TechTree
S.A.V.E.dat

 

Link to comment
Share on other sites

  • 3 weeks later...

How is "drop solids early" supposed to work? 

I have a shuttle where I start the main engines (stage 4) wait a few moments for things to stabilize and then start the ascent autopilot, which auto-stages to stage 3 which ignites the solids and releases the launch clamps.

If I have "drop solids early" enabled, no matter what value I indicate for lead time, about 1 second later the solids are decoupled and go flying away.

(I thought I'd try dropping them early to see if it would help them separate a little more cleanly.)

Link to comment
Share on other sites

1 hour ago, Kurld said:

How is "drop solids early" supposed to work? 

 

        // detect if this part is an SRB, will be dropped in the next stage, and we are below the enabled dropSolidsLeadTime
        public bool isBurnedOutSRBDecoupledInNextStage(Part p)
        {
            return dropSolids && p.IsThrottleLockedEngine() && LastNonZeroDVStageBurnTime() < dropSolidsLeadTime && p.IsDecoupledInStage(vessel.currentStage - 1);
        }

It should move to the next stage if the engine is throttle locked (SRB should be), the displayed current stage remaining burn time (in MJ windows is less than the set time and is decoupled in the next stage.

A screenshot of your stages and the MJ dV window may help.

 

 

Link to comment
Share on other sites

I'll get back with that later today or tomorrow, I'm in a "test flight" at the moment, trying to get smart on the landing assistance part of MJ2. 

I staged manually with a second or so left on the SRB burn and everything looked so pretty. So if I can figure out what I'm doing wrong, that would be cake.

Link to comment
Share on other sites

A problem ive always had with MJ is when using the ascent guidance it insists on forcing a certain roll angle. It used to be only until the gravity turn began. MJ gave roll control back to me. But now it holds a certain roll the whole time ascent guidance is activated. I just want AG to do its thing and let me handle roll. Is this possible? I would use Force Roll, but that handles pitch and yaw as well.

Edited by Motokid600
Link to comment
Share on other sites

22 hours ago, sarbian said:

It should move to the next stage if the engine is throttle locked (SRB should be), the displayed current stage remaining burn time (in MJ windows is less than the set time and is decoupled in the next stage.

A screenshot of your stages and the MJ dV window may help.

 

 

See below.  Let me know if I can provide any other information.  When I launch this I stage #4 with spacebar, let it settle down and then engage the ascent autopilot, which immediately stages #3.  With the "drop early" option selected, the decoupler in stage 2 activates approx. 1 second after engaging the autopilot.  The solid rockets in stage 2 are separator motors for the SRBs in stage 3.

Thanks!

jAEdyAY.png

Edited by Kurld
clarification
Link to comment
Share on other sites

I just did a test with stock parts and a similar staging and it worked fine. My guess is that MJ does not understand properly your separator motors. What kind of engine do you use for that ? If you are not using the stock Sepratron then can you try with those ?

 

15 hours ago, Motokid600 said:

I just want AG to do its thing and let me handle roll. Is this possible?

No. The current code take over all the axis controls and it won't change at this point.

Link to comment
Share on other sites

3 hours ago, sarbian said:

 

No. The current code take over all the axis controls and it won't change at this point.

Is there a way then for it to hold a roll of my choosing then? Or do I have to start using Force Roll? I've tried reorientating my craft in the VAB, but even then it still does a 180 roll off the pad. 

Edited by Motokid600
Link to comment
Share on other sites

5 hours ago, sarbian said:

I just did a test with stock parts and a similar staging and it worked fine. My guess is that MJ does not understand properly your separator motors. What kind of engine do you use for that ? If you are not using the stock Sepratron then can you try with those ?

It's the nosecone from the Photon Corp. SRB parts.

I tried some other nosecone and stuck a sepratron in it and MJ did the same thing.

The SRBs have 3 different thrust curves you can select, so I'm wondering if that is the issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...