sarbian

[1.7.x] Anatid Robotics / MuMech - MechJeb - Autopilot - [2.8.4] [14 June 2019]

Recommended Posts

9 hours ago, LTQ90 said:

hi Clinton.

go in your gamedata/mechjeb2/parts and edit the file named MechJebNoCommandPod.cfg

inside this you can unlock all tech with this statement :unlockTechs = start

Hope it helps you.

Ah fair enough.

But I presume that this will be thrashed everytime I update MechJeb

I might have to might my own mod for this and uploaded it considering the others have bitrotted it seems. 

Share this post


Link to post
Share on other sites

With the latest dev versions, simply add an empty folder to GameData named "MechJebUnlocked"

See:

On 6/10/2019 at 5:14 AM, Jim DiGriz said:

Just created a new dev build #884:

https://ksp.sarbian.com/jenkins/job/MechJeb2-Dev/884/

It has an update to that MM config file:

https://github.com/MuMech/MechJeb2/pull/1164

You all should be able to:

1.  make an empty folder in GameData named MechJebUnlocked

2.  delete the ModuleManager.ConfigCache file to force MM to reupdate

3.  restart KSP

4.  gloriously cheat your way to orbit

 

Share this post


Link to post
Share on other sites

I get this oscillation on burns with this Dragon's internal engines. I assume this means the internal engines are imbalanced? Or is it a MJ thing?

 

Share this post


Link to post
Share on other sites

Hello. I have a bit of silly question about MJ and RO. I am pretty sure the problem is known and there are workarounds, but i didn't find such answer.

So the problem is - MJ logic vs RO mechanics.

At the end of maneuver excecution MJ tries to throttle down to make less error in impulse, but in RO 50% throttle is not 50% engine power, due to limited throttlong(often unthrottlable). So when hitting final 5-10 m/s MJ tries to throttle down, but can't do it due to physics and overshoot planned maneuver. When maneuver finished MJ shuts down engines like hud button, but throttle input is still ~40-60%. Due to that engines immediately re-ignites to work 0.5sec(while throttle input reaches 0). And we have wasted ignition.

So the quesrion us simple any way to speed up throttle input or any other way to fix wasting igniton problem

Share this post


Link to post
Share on other sites
Posted (edited)

@mwg_test this does not happen if MJ ist set to RSS/RO mode and when "RCS for ullage"* is enabled, too.

At least for me with the latest versions I used,

#880 (see https://ksp.sarbian.com/jenkins/job/MechJeb2-Dev/880/ )
and
even newer MechJeb-v2.7.0-314-g075b0b65 (see https://discord.gg/Rahy2rk #mechjeb-pvg pinned messages)

*you obviously need working RCS forward for that

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
5 hours ago, Gordon Dry said:

@mwg_test this does not happen if MJ ist set to RSS/RO mode and when "RCS for ullage"* is enabled, too.

At least for me with the latest versions I used,

#880 (see https://ksp.sarbian.com/jenkins/job/MechJeb2-Dev/880/ )
and
even newer MechJeb-v2.7.0-314-g075b0b65 (see https://discord.gg/Rahy2rk #mechjeb-pvg pinned messages)

*you obviously need working RCS forward for that

I think i did not describe problem cooreclty.
Here is the vid with J-2 engine with 3 ignitions.


when i start excecuting maneuver MJ ignites engine(0.20) 2 ignitions left.
when maneuver almost completed(20m\s left 0.49) MJ make throttle down.
when 1m\s left to do throttle is about 60%. 
manuver node completed in a moment, and MJ shuts down engine, But throttle is still ~50%. And due to that engine momentally re-ignites for 1 second. And wasting ignition for nothing. 

Also second question about maneuver planner - is the any way to make with it somtheing like GTO-GSO burn without making it in 2 burns(change inclination and periapsis in 1 burn)?
thanks

Share this post


Link to post
Share on other sites
Posted (edited)

Anyone else running into the issue where the autolander tends to just put you down 1/4 a planet away from the requested landing site?

I have quite a few mods, but none that I am aware of, that should cause this issue.

EDIT: List of mods. Current Count: 102.

Spoiler

KSP: 1.7.3 (Win64) - Unity: 2017.1.3p1 - OS: Windows 10  (10.0.0) 64bit
000_AT_Utils - 1.8.1
ClickThroughBlocker - 0.1.7.2
Filter Extensions - 3.2.3.2
TexturesUnlimited - 1.4.8.22
Toolbar - 1.7.22
USI Tools - 1.1
ToolbarControl - 0.1.8.2
CommunityPartsTitles - 0.4.4
Airplane Plus - 26.0
Animated Decouplers - 1.4.2
Astronomer's Visual Pack - 3.8.1
AtmosphereAutopilot - 1.5.15
B9 Part Switch - 2.6
BDArmory - 1.3.1
Bluedog Design Bureau - 1.5.2
Chatterer - 0.9.96.2332
CommNetAntennasExtension - 2.0.1
CommNetAntennasInfo - 2.1
Community Category Kit - 4.1
Community Resource Pack - 1.1
CommunityTechTree - 3.3.7
ConfigurableContainers - 2.4.6
Contract Configurator - 1.27.1
CryoEngines - 0.7.1
CryoTanks - 1.1.4
Community Terrain Texture Pack - 1.0.4
DeployableEngines - 1.0.1
DistantObjectEnhancement - 1.9.1
DynamicBatteryStorage - 2.0.1
EditorExtensionsRedux - 3.3.21
Endurance Continued - 1.9
Environmental Visual Enhancements - 1.4.2.2
Firespitter - 7.12
FShangarExtender - 3.5.5
GroundConstruction - 2.4.1
Grounded - 5.0
Hangar - 3.3.7
HeatControl - 0.4.12
JanitorsCloset - 0.3.6
K2CommandPodContinued - 1.1.8.7
JSIPartUtilities - 0.4.3
JSIAdvTransparentPods - 0.1.20
RasterPropMonitor - 0.30.6
KAS - 1.4.7097.36908
KAX - Kerbal Aircraft Expansion /L - 2.8.0.1
Kerbin Environmental Institute - 1.2.9.10
KerbalAtomics - 1.0.3
Kerbal Engineer Redux - 1.1.6
Kerbal Foundries - 2.3.7.17
KerbalKonstructs - 1.7.0.3
WaterLaunchSites - 0.9.1
HyperEdit - 1.5.8
Kerbonov - 2.0.1.1
InlineBallutes - 1.2.9.8
Kerbal Inventory System - 1.22.7090.200
<b><color=#CA7B3C>Kopernicus</color></b> - 1.7.3.1
<b><color=#ffffff>KSC Extended</color></b> - 1.1
KSP-AVC Plugin - 1.3.1
KSPWheel - 0.15.13.32
MarkIVSystem - 3.0.4
MechJebForAll - 1.3.0.5
MoarFilterExtensionConfigs - 1.0.4.1
ModularFlightIntegrator - 1.2.6
NearFutureAeronautics - 1.0.4
NearFutureConstruction - 1.1.2
NearFutureElectrical - 1.0.2
NearFutureLaunchVehicles - 1.1.11
NearFutureProps - 0.5.1
NearFuturePropulsion - 1.1.1
NearFutureSolar - 1.0.3
NearFutureSpacecraft - 1.2.4
OpenCockpit - 1.2.1
OuterPlanetsMod - 2.2.5
OPT Legacy Spaceplane Parts - 1.3.1
OPT Reconfig - 1.5
PatchManager - 0.0.16.4
PhysicsRangeExtender - 1.15
Kerbal Planetary Base Systems - 1.6.9
RATPack - 0.4.2.5
RCS Build Aid - 0.9.8
RemoteTechRedevAntennas - 0.1.1
ReStock - 0.1.4
ReStockPlus - 0.1.4
RetractableLiftingSurface - 0.1.6
RetroFuture - 0.2.1
RLA_Reborn - 0.15.1.9
SafeBrakes - 1.1
SCANsat - 1.1.8.11
ScienceLabInfo - 0.9.5
SpeedUnitAnnex - 1.3.5
StationPartsExpansionRedux - 1.2.1
SXTContinued - 0.3.28.2
TAC Fuel Balancer - 2.21.4
TextureReplacer - 3.7
ThrottleControlledAvionics - 3.5.7
TokamakIndustries - 0.1.18
<b><color=#ffffff>Tundra</color> <color=#0090ff>Space Center</color></b> - 1.1
USI Core - 1.1
Freight Transport Tech - 1.1
NuclearRockets - 1.1
USI Alcubierre Drive - 1.1
Kerbal Actuators - 1.7.1

 

Edited by Mekan1k

Share this post


Link to post
Share on other sites

I’ve had that issue.  Mechjeb is a Swiss Army knife not an x-acto.  So the configuration of your craft (rcs torque, engine twr) plus orbit height play into accuracy.  I’ve had more accurate landings with mechjeb the more over designed my vessel is.

Share this post


Link to post
Share on other sites

So,  people used to say that MJ have some issues with landing on atmosphere planets like Eve or Kerbin (some kind of Landing Guidance problem when reentry will overheat ). And since i haven't use this for a long time, so i dont know is that kind of problem was fix, or is there any way to land with mechjeb without overheat ship part .I just reinstalled this mod and that is all i care. THANKS 

Share this post


Link to post
Share on other sites
Posted (edited)

Is there an option to forbid MechJeb to use RCS and allow Reaction Wheels only for any rotations (like Smart A.S.S or when Execute next node), even if RCS is activated?

Sometimes this feature ruins my very precise trajectory direction that i set up before.

Edited by Dizor

Share this post


Link to post
Share on other sites

Another couple of suggestions:

1. Please add 3 more toggleable buttons to Toolbar Continued that will toggle features:
  - Execute/Stop Next Node (you dont need to open any window to perform maneuvers)
  - Auto-warp on/off
  - Autostage Once (you dont need to open Utilities window for this)

2. Please make all options in Ascent Guidance window to work only during ascending with autopilot engaged. I noticed that these options are taken into account during executing common maneuvers on orbit.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.