sarbian

[1.7.x] Anatid Robotics / MuMech - MechJeb - Autopilot - [2.8.4] [14 June 2019]

Recommended Posts

Posted (edited)

Won't hurt, will it?

I'm still continuing my career I started in 2017, after I had the tech tree complete, I never looked back. Maybe there're changes to MJ/tech tree now I'm not aware of.

Edited by VoidSquid

Share this post


Link to post
Share on other sites

Hi,

I have reinstalled ksp ans all mods to go from version 1.4.3 to 1.7.3... and now mechjeb works great as always, but everytime I put a new ship on the launchpad I have to enable all the windows I need and rearrange them. In the old version mechjeb remebered my activated windows and the locations...

It would be great if you could fix this or tell me if I'm missing some tweaks or options.

Greetings

paw

 

PS Im using

MechJeb 2 (2.8.4.0)

KSP Version 1.7.3.2594

Making History 1.7.1

Breaking Ground 1.2.0

 

 

Share this post


Link to post
Share on other sites

I've been having a problem with Mechjeb.
Whenever I activate the landing guidance the warp function pretty much breaks, it'll teleport my craft a bit ahead on the orbital trajectory and send it waaay off where I want it to land.
This problem persists with the craft even after I do a landing without auto warp activated and endure the ages a Minmus landing will take.
If I launch the craft for orbit after a landing it'll bug out the second I try to hit warp.
I've tried googling the problem but came up short handed unfortunately...
Anyone experienced something similar?
Unfortunately no logs as it wont make the game crash, and I'm not very tech savvy...

Share this post


Link to post
Share on other sites
6 hours ago, paw said:

Hi,

I have reinstalled ksp ans all mods to go from version 1.4.3 to 1.7.3... and now mechjeb works great as always, but everytime I put a new ship on the launchpad I have to enable all the windows I need and rearrange them. In the old version mechjeb remebered my activated windows and the locations...

It would be great if you could fix this or tell me if I'm missing some tweaks or options.

Greetings

paw

 

PS Im using

MechJeb 2 (2.8.4.0)

KSP Version 1.7.3.2594

Making History 1.7.1

Breaking Ground 1.2.0

 

 

I don't know why, but for me Mechjeb only occasionally memorizes my windows. So after a while suddenly it has memorized them. Later, if I've been using a different set of windows, it will suddenly memorize that new configuration.

Share this post


Link to post
Share on other sites

Hi, so I'm having an issue with Rendezvous Auto Pilot. RCS is hyper sensitive, which is not entirely the mods fault but when a new maneuver mode generates, it will automatically fire the engine with 1. Not being over the target hub but 2. not being in the maneuver mode window. Please help because I suck at this game.

Share this post


Link to post
Share on other sites
Posted (edited)

I suggest you try out this mod:

Easy to use, and for me, allows faster and easier docking, plus usually requires less RCS fuel.

Here's a good review, if you're interested:

Spoiler

 

 

 

Edited by VoidSquid

Share this post


Link to post
Share on other sites

With the ascent guidance module, would it be possible to have the autopilot start by activating the next stage automatically?  This is basically for putting together an Apollo-Style Mun Lander, where the upper half of the lander separates from the bottom for ascent back to orbit.

 

(or, alternatively, if someone could point out to me how to make this work manually, that’d be fine as well)

Share this post


Link to post
Share on other sites
7 hours ago, horngeek said:

With the ascent guidance module, would it be possible to have the autopilot start by activating the next stage automatically?  This is basically for putting together an Apollo-Style Mun Lander, where the upper half of the lander separates from the bottom for ascent back to orbit.

 

(or, alternatively, if someone could point out to me how to make this work manually, that’d be fine as well)

You could try the Ascent Guidance, as it normally does wait for a staging.  Disable the descent engine is likely needed to allow the throttle to go up before the staging.

Alternately, manual ascent without atmosphere is fairly easy from Mun and smaller bodies.  Go straight up for a bit then pitch over to near horizontal and just maintain your radar altitude trending mostly up until you hit the apoapsis target.

Share this post


Link to post
Share on other sites
2 hours ago, Jacke said:

You could try the Ascent Guidance, as it normally does wait for a staging.  Disable the descent engine is likely needed to allow the throttle to go up before the staging.

Alternately, manual ascent without atmosphere is fairly easy from Mun and smaller bodies.  Go straight up for a bit then pitch over to near horizontal and just maintain your radar altitude trending mostly up until you hit the apoapsis target.

Tbh on the second point I don’t get my fun from this game from piloting stuff manually- but yeah, on the first in my specific case I ended up simply activating the guidance and letting it use the remaining fuel in the descent engine before jettisoning it.  Clean, no, but meh :V

Share this post


Link to post
Share on other sites
15 hours ago, savagekerbal said:

Hi, so I'm having an issue with Rendezvous Auto Pilot. RCS is hyper sensitive, which is not entirely the mods fault but when a new maneuver mode generates, it will automatically fire the engine with 1. Not being over the target hub but 2. not being in the maneuver mode window. Please help because I suck at this game.

I don't use the Rendevous Autopilot anymore. I use Maneuver Planner to setup a Hohmann, then use Rendevous Planner to do a "match velocities at closest approach". With the hyper-efficiency of the new Hohmann, this seems to be far more fuel efficient, and makes rescue missions far more do-able. For me. Your mileage may vary.

I would respectfully suggest that the hyper-sensitivity of the RCS is a design flaw in the craft, and needs to be addressed in the VAB.

And you do not suck at this game, you just need to get more experience. We all start out feeling the way you do, I promise :):)

Share this post


Link to post
Share on other sites

So I've now learned that its not just Rendevous Autopilot thats having the premature firing of the rockets. I was doing a Duna Mission and it fired the engines 26 days before the maneuver node.

Share this post


Link to post
Share on other sites

From time to time it happens that KSP and MJ have a hickup regrading physics, just restart KSP.

Share this post


Link to post
Share on other sites
1 hour ago, savagekerbal said:

Sadly its reoccuring

Because I am an English teacher, (well, EFL anyhow), I fixed your spelling of "sadly".

Now, why don't you tell us what version of KSP you are using, what version of MJ2 you are using, what your OS happens to be, and then attach your logfiles as described in the first post of this thread. Then we can perhaps begin to help you diagnose the problem.

Share this post


Link to post
Share on other sites
19 hours ago, El Sancho said:

I fixed your spelling of "sadly".

A bit OCD, eh?

That would be perfectly me then, lol :D 

Share this post


Link to post
Share on other sites

Seeking some advice.  I have not had too many issues with MJ in past versions, but only recently started playing again.  Repeatedly under 1.7.1, with the current version of MJ, my Landers on ascent which have like 700 DV or so act weird.  On ascent, they look good, hitting target level, then when doing the burn for making Munar orbit, at the last couple seconds instead of raising the PE to roughly the AO, the AO is suddenly kicked up by about 1K and my PE is way low.... sometimes still negative!  I have tried the first two ascent modes, tried toggling corrective burn, limiting for overheat, always the same result.... I even made darn sure I have serious reaction wheels on board.... same thing on two different landers... oddly, this doesn't happen with any launch vehicle on Kerbin.... my only solution is a low enough target alt then a manual node to try to pull the orbit far enough to the side to raise the PE to prevent a crash.... any thoughts on what to check greatly appreciated, just never recall this being a serious issue.

EDIT: MJ is version 2.7.3.0.

EDIT: In repeated testing I see a pattern - its as if at very late in the burn suddenly what should be the power used to raise the PE is instead kicking up that AO as I saw before for instance, a target of 12K results in a  17K AO, and about a 7K or so PE..... the balance of what should be going to raise the PE seems to be going into raising the AO... is this possibly some kind of TWR issue?  My electrics look fine, no loss of power or anything...

Edited by LanderDude
Additional Information for analysis

Share this post


Link to post
Share on other sites

I come seeking some advice.

I have a plane that can smoothly take off from the runway with out problems and is stable in flight with SAS, but when I use the Space Plane Guidance settings and activate it right at throttle up , it will start to wobble and crash before taking off. It doesn't matter what settings I have in the space plane guidance.

If I get the plane in the air, take it up to 500m and then try to use the Space Plane Guidance to maintain that altitude, it starts porpoising though the air, diving and climbing, until it crashes. Even if I turn the pitch control of the control surfaces off, the plane will porpoise when Space Plane Guidance is turned on...which seems like SAS is acting weird under mechjeb control

Any advice? I am sure this is a case of operator error (i.e. I am messing up) but I can't figure out what I am doing wrong. 

Share this post


Link to post
Share on other sites

I'm no expert, but do you have all the Mechjeb instances turned off except one, and does the nav ball look right for the direction up/down/forward the spaceplane is going?

Edited by LanderDude
clarity

Share this post


Link to post
Share on other sites

A quit and restart of KSP and then reloading the craft seems to have gotten rid of the problem. I'm not sure what was going on, but everything works fine now.

Share this post


Link to post
Share on other sites

I find that the "intercept target at chosen time" function is broken in all builds following #875.

Share this post


Link to post
Share on other sites

Does anyone know how to get mechjeb to stop rolling your rockets? I have force roll turned off but that does nothing at all. Using current version of mechjeb2 2.8.4.0.

Share this post


Link to post
Share on other sites
1 minute ago, RYU AZUKU99 said:

Does anyone know how to get mechjeb to stop rolling your rockets? I have force roll turned off but that does nothing at all. Using current version of mechjeb2 2.8.4.0.

This one has been present for a loooong time, and I have never really figured it out. I personally leave Force Roll toggled ON and my rockets don't roll, but YMMV.

One thing you can try is rotating the rocket 90 degrees in the VAB. Load the rocket, save it under a different name so you're not changing your original savefile, then pick it up by the command part, (or hold Shift and pick it up by anything), then tap Q once to rotate it 90 degrees and save. Try that both with and without Force Roll. If that doesn't fix it, then load the original savefile, save it under a different name again, pick it up and tap E once to rotate it 90 degrees the other way and save, then try that both with and without Force Roll. Somewhere in those 4 possibilities you should find a config that works. Good luck. I know how infuriating this problem can be.

Share this post


Link to post
Share on other sites

Okay, I've been trying to figure out how to use MJ for the past several hours to land my Mk1 lander can design on the Mun.  But I can't figure out how to do it, I'm 90% certain it's just my stupid and not something to do with MJ.  Can someone give me detailed instructions on how to utilize MJ to land on the Mun so I can see if I'm right and it's just my stupid?

Share this post


Link to post
Share on other sites

Hi @sarbian!

I would like to request that "Vessel Type" (e.g., Ship, Probe, Relay) be added to the possible information in the custom window editor. One reason for my request is that some contracts require you to have a vessel of the required type, and with the stock naming configuration, it is entirely possible for the vessel type to change without realizing that it has. Another reason is that I literally spent 30 minutes trying to figure out why my probe wasn't responding to commands, only to learn that I had accidentally configured a stage as "debris", thus making it uncontrollable. I have the vessel name added to a couple of different windows via the window editor, but it would be nice to also see the type.

Thank you for all of the amazing working you do and have done!

Also added as a feature request on Github.

Share this post


Link to post
Share on other sites

Any way to make MJ more accurate landing on a planet with atmosphere? tend to end up several km away from landing point

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.