sarbian

[1.7.x] Anatid Robotics / MuMech - MechJeb - Autopilot - [2.8.4] [14 June 2019]

Recommended Posts

1 hour ago, icecold951 said:

So far, the dev version

has worked for me. I thought Mechjeb had updated to 1.3.1. There are issues, but nothing breaking.

I've long learned to limit fins to about 20-30 percent. Solves that issue for the most part. It is over correcting.

Same with engine gimbals and RCS power and even the reaction wheels. Some unstable designs fly just fine with MechJeb if you pull down those values a bit (like half).

Share this post


Link to post
Share on other sites

While the dev version fixed the landing issue, it refuses to start auto warp.  I have to give it a kick by setting it to 5x before it will take off.

Coming out of auto warp is fine.

Share this post


Link to post
Share on other sites
30 minutes ago, Critter79606 said:

While the dev version fixed the landing issue, it refuses to start auto warp.  I have to give it a kick by setting it to 5x before it will take off.

Coming out of auto warp is fine.

That isn't necessarily a bad thing, actually. Kind of a way to CONFIRM, you wanted it in auto warp.

Share this post


Link to post
Share on other sites
6 minutes ago, icecold951 said:
38 minutes ago, Critter79606 said:

While the dev version fixed the landing issue, it refuses to start auto warp.  I have to give it a kick by setting it to 5x before it will take off.

Coming out of auto warp is fine.

 

I think the over-correcting wobbling and the not entering warp on ascent are perhaps related.

The reason for not entering warp seems to be because it hasn't managed to lock onto the direction to the node, it keeps trying but over-compensates and never thinks its quite there. Manually entering warp locks the attitude and MJ will then go ahead and control warp to finish the maneuver. 

Share this post


Link to post
Share on other sites
23 hours ago, Foxster said:

 

I think the over-correcting wobbling and the not entering warp on ascent are perhaps related.

The reason for not entering warp seems to be because it hasn't managed to lock onto the direction to the node, it keeps trying but over-compensates and never thinks its quite there. Manually entering warp locks the attitude and MJ will then go ahead and control warp to finish the maneuver. 

The wobbling affects my craft regardless of what im doing, whether my craft has fins or not. limiting the reaction wheels/gimbals helps on some occasions yet on others it simply makes it worse.

Share this post


Link to post
Share on other sites

First of all, a massive thank you to @sarbian and other contributors for the now YEARS of development of this mod, possibly the most important mod in use in KSP today.  Going back a few pages trying to see what is currently going on in the latest Dev build and why things aren't quite behaving right I was pretty p'ed off to see some of the attitude thrown his, and others who have inputed into this project, way.  I for one value the work he and they have done for nothing more than the enjoyment of it.  So firstly I'd just like to say thank you and wish all of you involved in this Mod a very merry Christmas and a happy new year.  Joyeux noël!

So back to the main reason I was having a lurk, quite a few of my designs are having issues with control overreaction when using MechJeb. @Foxster seems to have identified the same above.  Unless the active docking port is aligned on the longitudinal axis, during docking the port 'swings' over the target port, never quite lining up.   When aligned it works fine. Likewise a rover tends to 'snake', particularly with all wheel steering and the forward velocity  increases and decreases sinusoidally around the target speed.  Autowarp struggles to kick in as the alignment takes a very long time to settle down.  Rolls during ascents tend to be very violent and take a long time to correct.  So much so that I now disable roll on fins.  This all sounds like (to my uneducated ears) issues with the underlying PID control.  So my question - does anyone have, or is willing to provide, a guide to tweaking this? Does this work? I've always just left it alone, but I'm struggling now.  My very seasick Kerbals will thank you!!  Currently at work, so no logs etc at this point, but if this is not a common problem and unique to me I'll happily provide once home again.

 

Again, a very merry Christmas and a happy new year to you all.

 

*Edited because I can't spell 

Edited by XrayLima

Share this post


Link to post
Share on other sites

The issue when a port is not aligned with the CoM is not shocking. I guess it could be fixed with some math...

The oscillation on Roll could have 2(+?) origins. 1) I messed up somewhere and something related to pitch or yaw ended up on Roll with the codes changes since the last release 2) The Roll PID needs totally différents settings (but it would then fail on vessel that don't look like a rocket)

Share this post


Link to post
Share on other sites

@sarbian I just wanted to mention that i finally got time to fool around with the different dev versions, and #769 does have auto warp issues.  Sometimes you can set it to x5 and it will kick start it, other times it will stay at x5 and not come out of warp when it's supposed to.

#768 works 99% of the time on auto warp entry (100% with a kick start), 100% on auto warp exit, and landing works correctly (at least on the Mun).

It looks like something changed in #769 definitely broke something with the auto warp.

I also wanted to mention how much I appreciate this mod, and the work everyone puts into it.  I can't imagine playing without it.

Share this post


Link to post
Share on other sites
On 21.12.2017 at 4:34 PM, sarbian said:

The issue when a port is not aligned with the CoM is not shocking. I guess it could be fixed with some math...

The oscillation on Roll could have 2(+?) origins. 1) I messed up somewhere and something related to pitch or yaw ended up on Roll with the codes changes since the last release 2) The Roll PID needs totally différents settings (but it would then fail on vessel that don't look like a rocket)

i (and more users according to posts i have read) have seen this problem from day 1 on 1.3.0 ( over-correcting wobbling and not entering warp )
and not just  in MJ

this problem is/was in TCA KOS and RT autopilots 
my guess is that the changes in KSP 1.3.x require the PID to be re tuned

Edited by danielboro

Share this post


Link to post
Share on other sites

I'm using dev #769 and I think I see an issue with rover autopilot. I never used MJ before, but I tried to google and looks like people didn't have such issues before.

I'm adding n waypoints, "drive" button appears, I press it and... "heading control" auto checks, waypoint index is set to "0 of n" aaaand my rover is heading north. From what I googled, it should start with index of first waypoint, and waypoints are indexed from 1.

Share this post


Link to post
Share on other sites

I am having the same problem as jamqdlatwith rover autopilot both on the stable as well as the dev version, where rovers don't follow the waypoints.

Share this post


Link to post
Share on other sites
On 12/17/2017 at 1:11 PM, Critter79606 said:

While the dev version fixed the landing issue, it refuses to start auto warp.  I have to give it a kick by setting it to 5x before it will take off.

Coming out of auto warp is fine.

This has been happening to me in the previous versions of MJ: I had to nudge it a bit then it starts. I was thinking about making a meme" MechJeb why you no auto warp?!

Share this post


Link to post
Share on other sites
On 12/23/2017 at 5:26 PM, Kerbital said:

This has been happening to me in the previous versions of MJ: I had to nudge it a bit then it starts. I was thinking about making a meme" MechJeb why you no auto warp?!

It's because it will only autowarp when angular velocity has dropped below a certain threshold. (0.001 IIRC)

Manually engaging timewarp works because it effectively cancels any remaining angular velocity.

Complex craft or imbalanced RCS make it hard for MJ to do that on its own so the solution  is (as is often the case) to improve one's craft design or live with workarounds such as manually engaging timewarp.

Enabling auto-RCS under attitude control can help because it turns off RCS when coarse adjustment is no longer necessary, at which point reaction wheels can take over for fine adjustments. Assuming of course that your craft has sufficient reaction wheels. Again it's all about craft design.

Share this post


Link to post
Share on other sites
12 hours ago, Starwaster said:

It's because it will only autowarp when angular velocity has dropped below a certain threshold. (0.001 IIRC)

Manually engaging timewarp works because it effectively cancels any remaining angular velocity.

Complex craft or imbalanced RCS make it hard for MJ to do that on its own so the solution  is (as is often the case) to improve one's craft design or live with workarounds such as manually engaging timewarp.

Enabling auto-RCS under attitude control can help because it turns off RCS when coarse adjustment is no longer necessary, at which point reaction wheels can take over for fine adjustments. Assuming of course that your craft has sufficient reaction wheels. Again it's all about craft design.

i have to disagree
on moving from 1.2.2 to 1.3.0 and still in 1.3.1 non of my craft start the autowarp
my crafts did not change only KSP did
and until MJ changes to match the changes in KSP, we will have this problem.

Edited by danielboro

Share this post


Link to post
Share on other sites
4 hours ago, danielboro said:

i have to disagree
on moving from 1.2.2 to 1.3.0 and still in 1.3.1 non of my craft start the autowarp
my crafts did not change only KSP did
and until MJ changes to match the changes in KSP, we will have this problem.

It's working for me. Looking at a simple craft in orbit right now, Hohmann transfer to Mun, autowarp. Auto RCS.

Craft pointed to node and then autowarp. Boom bang done.

I'm not sure what changes you think happened in KSP that MJ has to match but they aren't there. We can actually look for these changes ourselves you know. 

Share this post


Link to post
Share on other sites

Now that I'm getting into some bigger ships again, the auto warp not starting is happening more often.  The small ships seem to be able to snap to the point needed for MJ to start the auto warp, the larger mass ships can't as easily.

Share this post


Link to post
Share on other sites
1 hour ago, Critter79606 said:

Now that I'm getting into some bigger ships again, the auto warp not starting is happening more often.  The small ships seem to be able to snap to the point needed for MJ to start the auto warp, the larger mass ships can't as easily.

Yeah there's a line of code which is trying to settle angular momentum, it probably needs to be angular velocity instead. Ship size will matter.

EDIT:  possible fix:  https://github.com/MuMech/MechJeb2/pull/973

Edited by Jim DiGriz

Share this post


Link to post
Share on other sites
3 hours ago, Jim DiGriz said:

Yeah there's a line of code which is trying to settle angular momentum, it probably needs to be angular velocity instead. Ship size will matter.

EDIT:  possible fix:  https://github.com/MuMech/MechJeb2/pull/973

Edit: oops no never mind, LESS THAN.... but now you're lowering it... hmmmmm

Edited by Starwaster

Share this post


Link to post
Share on other sites

I may put a configurable value somewhere for that. Better than enduring pages after pages of posts :wink:

Share this post


Link to post
Share on other sites
On 12/7/2017 at 9:02 PM, Nicias said:

Still not working.

I seem to be on #768. Screenshot attached:

https://imgur.com/a/Jljjp

 

 

I'm still having this trouble with the dV calculator not using drop-tanks properly. With #771.  Am I the only one having this trouble. 

Share this post


Link to post
Share on other sites
11 minutes ago, Nicias said:

I'm still having this trouble with the dV calculator not using drop-tanks properly. With #771.  Am I the only one having this trouble. 

I think I asked for an exemple craft earlier. And if I did not then I am now.

Share this post


Link to post
Share on other sites
12 hours ago, Starwaster said:

Edit: oops no never mind, LESS THAN.... but now you're lowering it... hmmmmm

for a 250t ship that's the same threshold.  might need to be a higher number, though, it was based on one rocket test in stock.

Share this post


Link to post
Share on other sites

@sarbian, I've noticed a landing issue that you can easily duplicate with the AeroEquus or any stock craft I think. Once in orbit, I normally use 80k, using all default settings set KSC as landing site. Ship warps to burn point, burns, oscillates a few times for dv correction, Then once in atmosphere fires up engine in retro position and never shuts down. Ship lands far to the west of intended landing location. Admittedly I may be missing selecting some alternate setting but I don't know what.

As an aside, normally for a USA type landing the engine and tank would be decoupled once return burn is complete but doing so results in substantially missing landing zone. Is there a way to compensate?

Share this post


Link to post
Share on other sites

HI, happy new year (almost).

Question... trying to use MJ to plot a trajectory to some asteroids, and I can't using MJ. Both the advanced xfer to another planet and the regular xfer to another planet say "ejection optimization failed; try manual selection". Anyone else having this issue? (tried using #769-773 builds).

Edited by ksp_circles
pressed save too soon.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.