JPLRepo

[1.9.x] Tarsier Space Technology with Galaxies (V7.10) 29th Feb 2020

Recommended Posts

I just started to use those SDDs, and those can really change the way you approach collecting of science.  Quite nice! 

Share this post


Link to post
Share on other sites

Is there any way to change where the images are saved if "save to file" is checked?

Is this in a config file somewhere or is it hard-coded?

Share this post


Link to post
Share on other sites

Playing around with new mods on my 1.8.1 save but trying to keep part bloat down manually.

Do the science drives work any diferently to the stock science container?

Share this post


Link to post
Share on other sites
On 6/1/2020 at 1:21 PM, Deathninja said:

Playing around with new mods on my 1.8.1 save but trying to keep part bloat down manually.

Do the science drives work any diferently to the stock science container?

No, they use their own module.

Create your own MM patch .cfg file and paste in the below and this should change them to work like stock (not tested):

//This patches the Tarsier Space Technoplogies Science Hard Drives to function using the same system as the Squad Science Container
//Find all parts that have the TST Science Drive module
@PART[*]:HAS[@MODULE[TSTScienceHardDrive]]:AFTER[TarsierSpaceTech]
{
//Remove the science drive module
    -MODULE[TSTScienceHardDrive]
    {
		}
//Add the Squad science container module
    MODULE
    {
      name = ModuleScienceContainer
      
      reviewActionName = #autoLOC_502201 //#autoLOC_502201 = Review Stored Data
      storeActionName = #autoLOC_502202 //#autoLOC_502202 = Store Experiments
      evaOnlyStorage = True // i.e. can nearby regular vessels also do this, or EVA only
      storageRange = 1.3
      canBeTransferredToInVessel = True
      canTransferInVessel = True
      showStatus = True
    }
}

 

Share this post


Link to post
Share on other sites
On 4/26/2020 at 7:39 AM, grego1672 said:

hi, does this mod works with ksrss? thank you

 

I don't know what that is. So probably not? but who knows.

On 5/11/2020 at 1:30 PM, Sarxis said:

I just started to use those SDDs, and those can really change the way you approach collecting of science.  Quite nice! 

Glad you like them. They are very handy.

On 6/1/2020 at 6:34 AM, Cooper42 said:

Is there any way to change where the images are saved if "save to file" is checked?

Is this in a config file somewhere or is it hard-coded?

It's hard coded at the moment.

On 6/9/2020 at 4:48 PM, Davian Lin said:

@JPLRepo
fix and some updates for russian localization
include this in the next update of the mod pls
https://drive.google.com/drive/folders/1mySKNFrcHQbkdHj3iiZ2w47mAmLAqi-s?usp=sharing

Thank You very much. Will look at these for the next update.

Share this post


Link to post
Share on other sites

Well done for this mod it is looking great.

I took some nice picture but here is the problem.

I have a contract to take a picture of the sun and when I do it tell me that I already have taken this picture, wich I did not. And it is not validating the contract neither.

Hope you can help, I am looking forward to discover and take pictures of all planets of the galaxie :)

Here is my log : https://drive.google.com/file/d/1AygFQbyXesdZICmFhgo66Jc98F94HqMX/view?usp=sharing

Thank you 

 

jxck.png

 

uyzp.png

Share this post


Link to post
Share on other sites
19 hours ago, Oli said:

Well done for this mod it is looking great.

I took some nice picture but here is the problem.

I have a contract to take a picture of the sun and when I do it tell me that I already have taken this picture, wich I did not. And it is not validating the contract neither.

Hope you can help, I am looking forward to discover and take pictures of all planets of the galaxie :)

Here is my log : https://drive.google.com/file/d/1AygFQbyXesdZICmFhgo66Jc98F94HqMX/view?usp=sharing

Thank you

Did you transmit the science?

Share this post


Link to post
Share on other sites
12 hours ago, Brigadier said:

Did you transmit the science?

Yes I did and then I got the message in the second picture

Share this post


Link to post
Share on other sites
On 6/17/2020 at 2:21 AM, Oli said:

Yes I did and then I got the message in the second picture

Sounds very strange will have to take a look into it when I got some spare time but right now busy preparing the 1.10 release. So after that.

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/16/2020 at 9:21 AM, Oli said:

Yes I did and then I got the message in the second picture

Yeah, sorry, I should have looked closer.

The only thing I can see at the moment is that you have a number of contracts without an agent title specified.  This is an old error and the fix for it consists of creating a MM patch to write text to the agent node's title field for each contract without an agent title already.  Save the code below to a .cfg file in your GameData directory.  I place all of my custom MM scripts in a separate directory under GameData.

// Fix missing agent title string by looking for any agent without a title and adding something

@AGENT[*]:HAS[~title]:FINAL { title = #$name$ }

I don't know if any of the offending contracts is your RB (I wouldn't know how to look into that) one but this should clean up your log file a bit.

Edited by Brigadier
Clarity

Share this post


Link to post
Share on other sites

Thanks a lot !

So I create a folder MM in GameData with the .cfg inside. Sadly it did not solve the problem. Anything else I can try ?

Thank you for your help

 

 

Share this post


Link to post
Share on other sites
17 hours ago, Oli said:

Thanks a lot !

So I create a folder MM in GameData with the .cfg inside. Sadly it did not solve the problem. Anything else I can try ?

Thank you for your help

You're welcome.

Sure, if I understand you correctly, that should work.  If the contract is still there uncompleted, post another log file to confirm the MM script worked and if there's anything obvious (at least to me), and we'll proceed from there.  This was probably a long shot anyway.

JPLRepo might like to see the contents of other files, if he's got the time.

Share this post


Link to post
Share on other sites
1 hour ago, Oli said:

Ok, Here is my last log : https://drive.google.com/file/d/1nHcAucWSZ3eBTpF4nCENnY7mYEl0pOpB/view?usp=sharing

Did I put the MM folder correctly ?

Yikes, 1000+ NREs and another 1000+ errors in that log from Kerbalism, Ground Construction, Contract Configurator, etc.  I think you've got more problems than not being able to take a sun picture.  Honestly, I don't know where to start!  I'm sure there's an incompatibility in there somewhere with 100+ mods.

I don't know how far you are in your game, but I would consider starting from scratch with a new, clean KSP install, slowly adding mods and checking the log for inconsistencies.

Also, in the future, when you're posting a log for issue resolution, provide the log from the shortest game time necessary to highlight the problem since it reduces the size and makes it easier to read.  Don't play the game as you normally would.  You started this game at 08:18 and didn't finish it until 22:30 - 14 hours later!  I should have given you better instructions.

Share this post


Link to post
Share on other sites

Ok, Thank you !

I read your message after a big glitch on my first minus base and i had made some big mistake in my 3 months of discovery of the game. So I took few hours to clean up my mods for a fresh start.

Here is my (almost) clean log : https://drive.google.com/file/d/1ssoL1HDXjB_E9odWL4LyY46DvSitoHp1/view?usp=sharing

I still get a warning but no error. I havent play yet but your mod is install and I will try it asap as I am restarting form the beginning :)

Here is the list of the mods that creates errors in the log... 

KIS / KAS / Easy Vessel Switch / Scan Sat / Global Construction / Extra planetary launchpad / Hangar / Configurable containers / Kerbal Engineer Redux

I am using CKAN so I was thinking the mods should come with all what hey need but I was wrong.

I am not sure I will enjoy my game that much without the · first mods on the list but will see.

How bad it will be if install them if there is error in the log but look fine in game ? :p

Anyway thanks for your help I let you know asap that I can send a telescope to try it.

Thanks for your big advice I am going to my new game 

Share this post


Link to post
Share on other sites

Ok, let us know how it goes.  I don't see anything very serious in the log.

3 hours ago, Oli said:

I havent play yet but your mod is install

I'm sure you know that the mod isn't mine and I can't take credit for it.:D

Share this post


Link to post
Share on other sites
On 6/25/2020 at 6:13 AM, Oli said:

Ok, Thank you !

I read your message after a big glitch on my first minus base and i had made some big mistake in my 3 months of discovery of the game. So I took few hours to clean up my mods for a fresh start.

Here is my (almost) clean log : https://drive.google.com/file/d/1ssoL1HDXjB_E9odWL4LyY46DvSitoHp1/view?usp=sharing

I still get a warning but no error. I havent play yet but your mod is install and I will try it asap as I am restarting form the beginning :)

Here is the list of the mods that creates errors in the log... 

KIS / KAS / Easy Vessel Switch / Scan Sat / Global Construction / Extra planetary launchpad / Hangar / Configurable containers / Kerbal Engineer Redux

I am using CKAN so I was thinking the mods should come with all what hey need but I was wrong.

I am not sure I will enjoy my game that much without the · first mods on the list but will see.

How bad it will be if install them if there is error in the log but look fine in game ? :p

Anyway thanks for your help I let you know asap that I can send a telescope to try it.

Thanks for your big advice I am going to my new game 

Straight away in your log I see that you are running KSP 1.9 with Contract Configurator... which doesn't support KSP 1.9. So my guess is it's probably breaking things in contracts.

I'd suggest:

A) start a fresh install of KSP (you can have multiple copies of KSP on your machine). - Using KSP 1.9.1 (notice in your log you are still running KSP 1.9.0)
B) only install this mod. V7.10 goes with KSP 1.9.1.
C) try the pictures of the sun etc contracts.

I just tried this in a fresh career game and the contract worked fine for me.

 

Share this post


Link to post
Share on other sites

I have a hubble-style 3.75m telescope, service bay, solar panel and comm dish as basic models, so they still need texturing. Would be willing to donate them and further models should you want to extend the mod with new parts.

 

Share this post


Link to post
Share on other sites
2 hours ago, TampaPowers said:

I have a hubble-style 3.75m telescope, service bay, solar panel and comm dish as basic models, so they still need texturing. Would be willing to donate them and further models should you want to extend the mod with new parts.

 

Thanks. If you want to. I can look at adding them in and add you to the credits for the mod. PM me the details.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.