JPLRepo

[1.9.x] Tarsier Space Technology with Galaxies (V7.10) 29th Feb 2020

Recommended Posts

I was launching my game while I was checking on the status of this mod... I saw that the 1.4.1 release was available and immediately Alt+F4 and relaunched... I'm so excited! @JPLRepo, how much code do you normally have to change with each new release version?

Share this post


Link to post
Share on other sites

Dunno if you're taking suggestions, but could you add an early tier telescope? It should be kinda crude; b/w with low zoom. I hope you do add something like that; I'm dying to recreate the Ranger program!

Share this post


Link to post
Share on other sites

I have been using this mod successfully with a telescope in orbit around Kerbin out beyond the orbit of Minmus.  No issues at all.  All planets and galaxies show up as advertised.

I have been thinking about placing a telescope in Kerbol orbit out beyond the orbit of Jool.  When I placed one out there using Hyperedit as a test, the planets all showed up but attempts to target a galaxy resulted in a "no target" message.

I am running a sandbox game and am not running Research Bodies.  I have not upgraded to 1.4 yet, nor have I updated to latest version of TST.

Is this a limitation of the mod or do I potentially have an issue?

Love this mod btw.  Thank you for the quick update to 1.4.  Appreciate the effort that goes into this.

MM

Share this post


Link to post
Share on other sites
On 4.12.2017 at 9:15 PM, JPLRepo said:

If you changed your key mapping then you are probably using the wrong keys....
The chemcam uses the "Translation" key mapping from the in game settings. which by default is IKJL. But it will be whatever you might have remapped those to.

Hm. I've been told to remap my rover driving keys to IKJL, so this clashes heavily.

Share this post


Link to post
Share on other sites

@JPLRepo, FYI, I raised a minor issue on GitHub pointing out that the AGExt action names for the Science Storage Devices aren't clear.

I hope that you're still maintaining this fun and useful mod.

Share this post


Link to post
Share on other sites
15 hours ago, Brigadier said:

@JPLRepo, FYI, I raised a minor issue on GitHub pointing out that the AGExt action names for the Science Storage Devices aren't clear.

I hope that you're still maintaining this fun and useful mod.

I thought I was... is something broken?

Share this post


Link to post
Share on other sites

I've noticed that when I open the telescope camera GUI, Distant Object Enhancement planet flares disappear until I close the GUI again. Am I doing something wrong; is this a known issue; or should I get together a bug report? Thanks!

Share this post


Link to post
Share on other sites
3 hours ago, JPLRepo said:

I thought I was... is something broken?

No, nothing broken; on the contrary, everything's great under KSP 1.4.4 AFAIK and I'm finally comfortable with the scopes and contracts in my career game.  It's just that I hadn't seen you on this topic for a while.  When a mod dev goes quiet, it can be an omen, but then I remembered that you're Squad Staff so how far could you possibly be :blush:

Share this post


Link to post
Share on other sites
18 minutes ago, Brigadier said:

No, nothing broken; on the contrary, everything's great under KSP 1.4.4 AFAIK and I'm finally comfortable with the scopes and contracts in my career game.  It's just that I hadn't seen you on this topic for a while.  When a mod dev goes quiet, it can be an omen, but then I remembered that you're Squad Staff so how far could you possibly be :blush:

Yeah. Bit busy, all my mods should be working in 1.4.4 although they don't say that.. will do a round of updates soon

Share this post


Link to post
Share on other sites

@JPLRepo, This is a fantastic mod, your telescopes and hard drive should be stock parts in game. I put your hard drives on pretty much everyone of my ships, instead of that stupid science container that you have to EVA and walk to to put anything inside (The game devs seem hooked on making the game pointlessly difficult and complicated). I hope you continue to have the time to continue to keep this mod up to date and functional until they stop updating KSP permanently.....

I'd also love to see any ideas or additions you have to this mod or any other mods you make!

Thank you for your hard work!

 

JoE_Smash

Share this post


Link to post
Share on other sites
7 hours ago, JoE Smash said:

@JPLRepo, This is a fantastic mod, your telescopes and hard drive should be stock parts in game. I put your hard drives on pretty much everyone of my ships, instead of that stupid science container that you have to EVA and walk to to put anything inside (The game devs seem hooked on making the game pointlessly difficult and complicated). I hope you continue to have the time to continue to keep this mod up to date and functional until they stop updating KSP permanently.....

I'd also love to see any ideas or additions you have to this mod or any other mods you make!

Thank you for your hard work!

 

JoE_Smash

Thanks. You do realize I am a KSP dev?

Share this post


Link to post
Share on other sites
8 hours ago, JoE Smash said:

that stupid science container that you have to EVA and walk to to put anything inside

If you stay in the ship, you can right click it and then collect all.

Share this post


Link to post
Share on other sites
On 6/28/2018 at 3:28 PM, JPLRepo said:

Thanks. You do realize I am a KSP dev?

Negative, I do now though....

I was aware some of the modders are also devs but I don't have straight who is who....RoverDude is one? Porkjet? I don't know who else....I just started playing KSP less than a month ago when I noticed it on sale on Steam....

I don't understand why devs have to mod their own game though?

Why don't you just add all this stuff to the game? Are you just testing it to see what people like the most by downloading it?

 

Share this post


Link to post
Share on other sites

I seem to have found a small problem. When looking at any planet it seems to use the sun direction that comes to your ship. so when looking next to the sun at jool i see only night at jool, when it should be full day there.

Notice in the image that jool has the same Crescent shape as the Mun. Same thing happens with Duna.

LdrOXkl.jpg

Share this post


Link to post
Share on other sites

I was thinking, why not add another telescope to the mod?

something like this from ProbePlus Mod,  a short size telescope,

clwd8Gl.png

or a medium size part

kR99Xe6.png

it would be nice add part like those, especiallly when you want to send a probe to take pictures to a planet or an asteroid or take pictures of the surface of a body from an orbit, it wont be needed a big vehicle  to it.

Share this post


Link to post
Share on other sites
15 hours ago, Bartom said:

I was thinking, why not add another telescope to the mod?

something like this from ProbePlus Mod,  a short size telescope,

<snip pic>

or a medium size part

<snip pic>

it would be nice add part like those, especiallly when you want to send a probe to take pictures to a planet or an asteroid or take pictures of the surface of a body from an orbit, it wont be needed a big vehicle  to it.

Anyone who has the free spare time and is willing to create a model can do so. I would be more than happy to incorporate it into the mod.
I have had several people over the years come to me offering to create one.. and None have ever come back to me with a completed model.
I myself simply do not have the spare free time to create one at the moment.

Share this post


Link to post
Share on other sites
7 hours ago, JPLRepo said:

Anyone who has the free spare time and is willing to create a model can do so. I would be more than happy to incorporate it into the mod.
I have had several people over the years come to me offering to create one.. and None have ever come back to me with a completed model.
I myself simply do not have the spare free time to create one at the moment.

I have some ideas, three to be precise, but i only know the 3d modeling and texturize. give me some days and i will show you an idea just for begin.

 

Share this post


Link to post
Share on other sites
6 hours ago, JDCollie said:

Does anyone happen to know if the 1.4.1 version is compatible with 1.4.4?

Yup, should be fine. I’ll do an update on the version checking once 1.4.5 is released. Been a bit busy lately.

Share this post


Link to post
Share on other sites
12 hours ago, JPLRepo said:

Yup, should be fine. I’ll do an update on the version checking once 1.4.5 is released. Been a bit busy lately.

Awesome! Thanks for the reply :D

Share this post


Link to post
Share on other sites

Regarding the issue with action goup names mentioned by Brigardier: The AGEx mod is not the reason for this issue since the same issue appears on a fresh install of KSP 1.4.1 and just this mod installed:

dKx6Mb9.png

edit: @JPLRepo I don't know how to create a proper pull request, so I have to write it here:

In the 'TSTScienceHardDrive.cs', line 134:

[KSPAction("fillDrive")]
public void ActivateAction(KSPActionParam param)
{
	fillDrive();
}

But it must be:

[KSPAction("#autoLOC_TST_0069")]
public void ActivateAction(KSPActionParam param)
{
	fillDrive();
}

Same in line 200:

[KSPAction("expfillDrive")]
public void expfillActivateAction(KSPActionParam param)
{
	expfillDrive();
}

Must be:

[KSPAction("#autoLOC_TST_0073")]
public void expfillActivateAction(KSPActionParam param)
{
	expfillDrive();
}

Since I'm already looking through the files:

The action group names for the Spacetelescope don't use the localization.cfg as well.

In the 'TSTSpaceTelescope.cs', line 547:

[KSPAction("OpenCamera")]
public void ActivateAction(KSPActionParam param)
{
	eventOpenCamera();
}

Muste be:

[KSPAction("#autoLOC_TST_0084")]
public void ActivateAction(KSPActionParam param)
{
	eventOpenCamera();
}

In line 628:

[KSPAction("CloseCamera")]
public void DeactivateAction(KSPActionParam param)
{
	eventCloseCamera();
}

Muste be:

[KSPAction("#autoLOC_TST_0085")]
public void DeactivateAction(KSPActionParam param)
{
	eventCloseCamera();
}

 

Edited by 4x4cheesecake

Share this post


Link to post
Share on other sites

Hello everyone,

I got a problem with the mod. I just started a new run with the latest KSP Version and used an older release of the mod. I started a probe with the telescope on it but when I tried to open it, nothing happened. Then I installed the latest version of the mod, started the old save-file where i put the probe in space and now there isn't even the option to open the telescope. I think I installed everything correctly (not new to using mods) but can't figure out my mistake. The save is in carreer mode. I use a lot of other mods, non of them ever conflicted to this mod.

Does anyone have the same issue or know a way to help me?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.