Angel-125

[1.5.x] Mark One Laboratory Extensions (M.O.L.E.)

Recommended Posts

@Angel-125

so basically add 

Spoiler

 

@PART[ScienceBox]
{
    MODULE
    {
        name = WBIModuleScienceExperiment
        experimentID = WBIEmptyExperiment
        defaultExperiment = WBIEmptyExperiment
        experimentActionName = Do Nothing
        resetActionName = Reset Nothing
        useStaging = False
        useActionGroups = True
        hideUIwhenUnavailable = True
        xmitDataScalar = 0.0001
        dataIsCollectable = False
        interactionRange = 1.2
        rerunnable = False
        resettable = False
        usageReqMaskInternal = 1
        usageReqMaskExternal = 8
    }

    MODULE
    {
        name = WBIExperimentManifest
        defaultExperiment = WBIEmptyExperiment
    }
}

 

to the part that carries the experiments up or down (and twice the upper module to fit two experiments on one part right?

or do I just literally copy paste the Mole18 set and add an @PART[xxxx] to whatever part I want to act like a MOLE lab?

Share this post


Link to post
Share on other sites
1 hour ago, BRAAAP_STUTUTU said:

@Angel-125

so basically add 

  Hide contents

 

@PART[ScienceBox]
{
    MODULE
    {
        name = WBIModuleScienceExperiment
        experimentID = WBIEmptyExperiment
        defaultExperiment = WBIEmptyExperiment
        experimentActionName = Do Nothing
        resetActionName = Reset Nothing
        useStaging = False
        useActionGroups = True
        hideUIwhenUnavailable = True
        xmitDataScalar = 0.0001
        dataIsCollectable = False
        interactionRange = 1.2
        rerunnable = False
        resettable = False
        usageReqMaskInternal = 1
        usageReqMaskExternal = 8
    }

    MODULE
    {
        name = WBIExperimentManifest
        defaultExperiment = WBIEmptyExperiment
    }
}

 

to the part that carries the experiments up or down (and twice the upper module to fit two experiments on one part right?

or do I just literally copy paste the Mole18 set and add an @PART[xxxx] to whatever part I want to act like a MOLE lab?

Just add the science experiment and the lab itself.

Share this post


Link to post
Share on other sites
3 hours ago, Angel-125 said:

Just add the science experiment and the lab itself.

Okay,will do

Edited by BRAAAP_STUTUTU

Share this post


Link to post
Share on other sites

Welp @Angel-125, that didn't have the expected result, it added a resource converter for labtime but none of the manifest and other features

 

I do have Bluedog_DB installed however, which appears to break your MOLE parts while adding the functionality to his, 

copying their MM patches and adding BDB as a req and putting it in the tantares patches folder seems to work though, might have to try the other thing without BDB installed

Edited by BRAAAP_STUTUTU

Share this post


Link to post
Share on other sites
On 11/9/2018 at 6:49 AM, Bombaatu said:

Hey, @Angel-125 - something strange cropped up last night. I have a new 1.5.1 install with MOLE, DSEV, PathFinder and a host of other mods. I was in the VAB & had both MechJeb's & KER's dV windows up. Neither the Fulcrum nor the OMS would report their dV to those windows. Any other engine does. Strangely, you do see dV when on the launch pad; just not in the VAB


I encountered that too...  and stumbled into finding the "next engine" solution.  And found a bug in the process, when you save and reload the craft the setting is not preserved (you have to go through "next engine" again), ditto when you revert to the VAB.

Also noted that the mode names don't match the table that Jade of MAAR posted...  in the sandbox there's KeroLox and Raptalox - shouldn't KeroLox be LFO?

 

Share this post


Link to post
Share on other sites

Just curious, as this was one of the main mods I used a few months ago, how did you update it to 1.5 after the Mk1 pod was revamped?

Share this post


Link to post
Share on other sites
32 minutes ago, sslaptnhablhat said:

Just curious, as this was one of the main mods I used a few months ago, how did you update it to 1.5 after the Mk1 pod was revamped?

wasn't that revamp just purely visual though?

Share this post


Link to post
Share on other sites
23 minutes ago, BRAAAP_STUTUTU said:

wasn't that revamp just purely visual though?

it was but now everything looks weird af

Share this post


Link to post
Share on other sites
34 minutes ago, BRAAAP_STUTUTU said:

wasn't that revamp just purely visual though?

Uhh, yes, that's why I was asking...? The Mk1 pod is now much more BDB-alike and wouldn't fit in with this mod, and I think it may have been stretched too.

Share this post


Link to post
Share on other sites
2 hours ago, sslaptnhablhat said:

Uhh, yes, that's why I was asking...? The Mk1 pod is now much more BDB-alike and wouldn't fit in with this mod, and I think it may have been stretched too.

Wouldn’t call it BDB-alike, it’s severely lacking in the specular maps and detail departement for it to be called bdb-alike...

Not sure if angel125 has made new models yet but right now he is probably too busy with some new shinies for pathfinder and his ufo project

  • Like 1

Share this post


Link to post
Share on other sites

@Angel-125 did u ever got the weldable ports working, and if so do they dissapear when welded like the konstruction mod?

Its not an issue or that with the new functionality of EL, i was just curious.

Share this post


Link to post
Share on other sites
6 hours ago, Space Kadet said:

@Angel-125 did u ever got the weldable ports working, and if so do they dissapear when welded like the konstruction mod?

Its not an issue or that with the new functionality of EL, i was just curious.

I have been focusing my efforts elsewhere. And with EL's new construction docking ports, my welding ports aren't that needed. @taniwha did a great job on those construction ports. Once the dust settles on Pathfinder, I may have to create some MOLE-alike construction ports.

Share this post


Link to post
Share on other sites
2 minutes ago, Angel-125 said:

I have been focusing my efforts elsewhere. And with EL's new construction docking ports, my welding ports aren't that needed. @taniwha did a great job on those construction ports. Once the dust settles on Pathfinder, I may have to create some MOLE-alike construction ports.

Apologies for my ignorance and also for the off-topic-ness, but do you have a link to these EL docking ports please??

  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, Dafni said:

Apologies for my ignorance and also for the off-topic-ness, but do you have a link to these EL docking ports please??

And apologies for mine, but what are these ports?

  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, Dafni said:

Apologies for my ignorance and also for the off-topic-ness, but do you have a link to these EL docking ports please??

 

4 hours ago, razark said:

And apologies for mine, but what are these ports?

The construction ports come from Extraplanetary Launchpads by @taniwha

 

  • Like 2

Share this post


Link to post
Share on other sites

Just for some clarity, they're not actual ports in that you can dock to them (you cannot), but rather they are construction "pads" that self-destruct when you finalize a build, leaving the new build a permanent part of the mothership.

  • Like 2

Share this post


Link to post
Share on other sites
2 hours ago, taniwha said:

Just for some clarity, they're not actual ports in that you can dock to them (you cannot), but rather they are construction "pads" that self-destruct when you finalize a build, leaving the new build a permanent part of the mothership.

Ah.

I don't really follow EL1 closely, so I was unaware of them.  Sounds like a pretty useful idea, if I understand correctly.  (But what happens if I were to put it inside the new build?)

 

1It just seems a little more complex than what I want out of a building system.  I've used it as a part of the Simple Construction mod, so I don't know all it's features.

Share this post


Link to post
Share on other sites
2 hours ago, razark said:

Ah.

I don't really follow EL1 closely, so I was unaware of them.  Sounds like a pretty useful idea, if I understand correctly.  (But what happens if I were to put it inside the new build?)

 

1It just seems a little more complex than what I want out of a building system.  I've used it as a part of the Simple Construction mod, so I don't know all it's features.

kerbal explosivyness!

Share this post


Link to post
Share on other sites
5 hours ago, razark said:

(But what happens if I were to put it inside the new build?)

I'm not quite sure what you mean, but you can have any number of disposable pads on both mother ship and on the built section. It's a good way to expand your base or station.

Share this post


Link to post
Share on other sites
On 4/30/2018 at 5:42 AM, MaverickSawyer said:

That would explain it. Thanks for the clarification.

17 hours ago, Dafni said:

Apologies for my ignorance and also for the off-topic-ness, but do you have a link to these EL docking ports please??

I know @RoverDude's weldable ports in his construction mod work for,  well, welding parts together.

Share this post


Link to post
Share on other sites

@Sudragon:not to belittle roverdude's construction ports (they were actually the final inspiration for EL's pads), but while his ports are for welding parts together, my pads are for building them together. ie, as I see it, there should be nothing stopping one from using both systems.

Share this post


Link to post
Share on other sites
1 hour ago, taniwha said:

@Sudragon:not to belittle roverdude's construction ports (they were actually the final inspiration for EL's pads), but while his ports are for welding parts together, my pads are for building them together. ie, as I see it, there should be nothing stopping one from using both systems.

Indeed, there's more than one way to build a space station.

Share this post


Link to post
Share on other sites
On 11/20/2018 at 7:50 AM, sslaptnhablhat said:

Uhh, yes, that's why I was asking...? The Mk1 pod is now much more BDB-alike and wouldn't fit in with this mod, and I think it may have been stretched too.

The old style Mk1 pod is still included in 1.5.1, you just need to tweak a line in the config to make it show up. (And do the opposite tweak to the new pod to hide it, they don't peacefully coexist.)

Share this post


Link to post
Share on other sites
14 hours ago, Warhorse said:

The old style Mk1 pod is still included in 1.5.1, you just need to tweak a line in the config to make it show up. (And do the opposite tweak to the new pod to hide it, they don't peacefully coexist.)

I tried to do this & couldn't get the pod to show up. Do you know what needs to be tweaked?

Also, there is a new mod called Old Parts Redux that does restore the old Mk 1 Command Pod (among other things), so the two can co-exist, albiet with different names.

Share this post


Link to post
Share on other sites
2 hours ago, Bombaatu said:

I tried to do this & couldn't get the pod to show up. Do you know what needs to be tweaked?

Also, there is a new mod called Old Parts Redux that does restore the old Mk 1 Command Pod (among other things), so the two can co-exist, albiet with different names.

You need to find the line that says  "category = none"  and change it to "category = Pods"  in the config for the old-style pod. (The capital "P" is important in this case.) Then go into the config for the new pod and change  "category = Pods"  to  "category = none". Oddly, it seems that it is necessary to edit the relevant config files directly, I could not get this to work using ModMan patches. Of course, that may simply be due to my inexperience writing such patches ...  Good luck!  :)

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now