Jump to content

[Min KSP: 1.12.2] Mark One Laboratory Extensions (M.O.L.E.)


Angel-125
 Share

Recommended Posts

13 hours ago, Angel-125 said:

Odd that WBT won't load, can you try the latest from GitHub?

Ok - here's what I did:

  • Fresh clean install of KSP 1.11.2
  • Downloaded WildBlueTools from github - latest version - and installed it
  • Launched, checked logs - no errors other that complaining there was no Tweakscale module
  • Downloaded MOLE from github - latest version - and installed. Deleted the 000WildBlueTools folder and re-copied from the stand-alone download
  • Launched - loaded ~75 patches - can see the texture-switching functionality in afore-mentioned MOLE parts. However, I am seeing module-load errors:
    Spoiler

    [LOG 07:35:43.226] AssemblyLoader: Loading assemblies
    [ERR 07:35:43.299] ADDON BINDER: Cannot resolve assembly: WildBlueTools, Culture=neutral, PublicKeyToken=null

    [ERR 07:35:43.299] ADDON BINDER: Cannot resolve assembly: WildBlueTools, Culture=neutral, PublicKeyToken=null

    [ERR 07:35:43.304] AssemblyLoader: Exception loading 'MoleUtils': System.Reflection.ReflectionTypeLoadException: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown.
      at (wrapper managed-to-native) System.Reflection.Assembly.GetTypes(System.Reflection.Assembly,bool)
      at System.Reflection.Assembly.GetTypes () [0x00000] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0 
      at AssemblyLoader.LoadAssemblies () [0x000e6] in <06f13185617646e5bc801baeab53ab75>:0 

    Additional information about this exception:

     System.IO.FileNotFoundException: Could not load file or assembly 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

    [LOG 07:35:43.314] VesselModules: Found VesselModule of type AxisGroupsModule with order 999

     

  • I did notice that MOLE was packaged with WBI Tools version 1.82.0, whereas the stand-alone WBI Tools that I downloaded was 1.82.1.

  • Replaced all WBI folders except MOLE folder with folders from WBI Tools - still getting above log errors but again, part-switching is working.

  • Re-copied fresh KSP install & installed MOLE via CKAN, along with dependencies. Selected WBI Simplified Play Mode in that selection screen. Only loaded 28 patches. No MOLE tab in VAB. Texture issue is back. Far more extensive error messages: 

    Spoiler

    [LOG 07:47:23.168] AssemblyLoader: Loading assemblies
    [ERR 07:47:23.239] ADDON BINDER: Cannot resolve assembly: WildBlueTools, Culture=neutral, PublicKeyToken=null

    [ERR 07:47:23.239] ADDON BINDER: Cannot resolve assembly: WildBlueTools, Culture=neutral, PublicKeyToken=null

    [ERR 07:47:23.244] AssemblyLoader: Exception loading 'MoleUtils': System.Reflection.ReflectionTypeLoadException: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown.
      at (wrapper managed-to-native) System.Reflection.Assembly.GetTypes(System.Reflection.Assembly,bool)
      at System.Reflection.Assembly.GetTypes () [0x00000] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0 
      at AssemblyLoader.LoadAssemblies () [0x000e6] in <06f13185617646e5bc801baeab53ab75>:0 

    Additional information about this exception:

     System.IO.FileNotFoundException: Could not load file or assembly 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

    [ERR 07:47:23.247] ADDON BINDER: Cannot resolve assembly: BARISBridge, Culture=neutral, PublicKeyToken=null

    [ERR 07:47:23.247] ADDON BINDER: Cannot resolve assembly: BARISBridge, Culture=neutral, PublicKeyToken=null

    [ERR 07:47:23.249] AssemblyLoader: Exception loading 'WildBlueTools': System.Reflection.ReflectionTypeLoadException: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown.
      at (wrapper managed-to-native) System.Reflection.Assembly.GetTypes(System.Reflection.Assembly,bool)
      at System.Reflection.Assembly.GetTypes () [0x00000] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0 
      at AssemblyLoader.LoadAssemblies () [0x000e6] in <06f13185617646e5bc801baeab53ab75>:0 

    Additional information about this exception:

     System.TypeLoadException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. assembly:BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null type:<unknown type> member:(null) signature:<none>

     System.TypeLoadException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. assembly:BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null type:<unknown type> member:(null) signature:<none>

     System.TypeLoadException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. assembly:BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null type:<unknown type> member:(null) signature:<none>

     System.TypeLoadException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. assembly:BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null type:<unknown type> member:(null) signature:<none>

     System.TypeLoadException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. assembly:BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null type:<unknown type> member:(null) signature:<none>

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

    [LOG 07:47:23.256] VesselModules: Found VesselModule of type AxisGroupsModule with order 999

    (Yes, the BARISBridge folder was present)

  • Finally, I replaced but the MOLE folder with the folders from the WBI Tools download (excluding Classic Stock Resources) & launched - issue resolved but am still seeing this in the log:

    Spoiler

    [LOG 07:58:36.119] AssemblyLoader: Loading assemblies
    [ERR 07:58:36.190] ADDON BINDER: Cannot resolve assembly: WildBlueTools, Culture=neutral, PublicKeyToken=null

    [ERR 07:58:36.190] ADDON BINDER: Cannot resolve assembly: WildBlueTools, Culture=neutral, PublicKeyToken=null

    [ERR 07:58:36.194] AssemblyLoader: Exception loading 'MoleUtils': System.Reflection.ReflectionTypeLoadException: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown.
      at (wrapper managed-to-native) System.Reflection.Assembly.GetTypes(System.Reflection.Assembly,bool)
      at System.Reflection.Assembly.GetTypes () [0x00000] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0 
      at AssemblyLoader.LoadAssemblies () [0x000e6] in <06f13185617646e5bc801baeab53ab75>:0 

    Additional information about this exception:

     System.IO.FileNotFoundException: Could not load file or assembly 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

    [LOG 07:58:36.206] VesselModules: Found VesselModule of type AxisGroupsModule with order 999

    So - conclusion. Works if you download it from github, doesn't work with CKAN

Edited by Bombaatu
Link to comment
Share on other sites

6 hours ago, Bombaatu said:

Ok - here's what I did:

  • Fresh clean install of KSP 1.11.2
  • Downloaded WildBlueTools from github - latest version - and installed it
  • Launched, checked logs - no errors other that complaining there was no Tweakscale module
  • Downloaded MOLE from github - latest version - and installed. Deleted the 000WildBlueTools folder and re-copied from the stand-alone download
  • Launched - loaded ~75 patches - can see the texture-switching functionality in afore-mentioned MOLE parts. However, I am seeing module-load errors:
      Hide contents

    [LOG 07:35:43.226] AssemblyLoader: Loading assemblies
    [ERR 07:35:43.299] ADDON BINDER: Cannot resolve assembly: WildBlueTools, Culture=neutral, PublicKeyToken=null

    [ERR 07:35:43.299] ADDON BINDER: Cannot resolve assembly: WildBlueTools, Culture=neutral, PublicKeyToken=null

    [ERR 07:35:43.304] AssemblyLoader: Exception loading 'MoleUtils': System.Reflection.ReflectionTypeLoadException: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown.
      at (wrapper managed-to-native) System.Reflection.Assembly.GetTypes(System.Reflection.Assembly,bool)
      at System.Reflection.Assembly.GetTypes () [0x00000] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0 
      at AssemblyLoader.LoadAssemblies () [0x000e6] in <06f13185617646e5bc801baeab53ab75>:0 

    Additional information about this exception:

     System.IO.FileNotFoundException: Could not load file or assembly 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

    [LOG 07:35:43.314] VesselModules: Found VesselModule of type AxisGroupsModule with order 999

     

  • I did notice that MOLE was packaged with WBI Tools version 1.82.0, whereas the stand-alone WBI Tools that I downloaded was 1.82.1.

  • Replaced all WBI folders except MOLE folder with folders from WBI Tools - still getting above log errors but again, part-switching is working.

  • Re-copied fresh KSP install & installed MOLE via CKAN, along with dependencies. Selected WBI Simplified Play Mode in that selection screen. Only loaded 28 patches. No MOLE tab in VAB. Texture issue is back. Far more extensive error messages: 

      Reveal hidden contents

    [LOG 07:47:23.168] AssemblyLoader: Loading assemblies
    [ERR 07:47:23.239] ADDON BINDER: Cannot resolve assembly: WildBlueTools, Culture=neutral, PublicKeyToken=null

    [ERR 07:47:23.239] ADDON BINDER: Cannot resolve assembly: WildBlueTools, Culture=neutral, PublicKeyToken=null

    [ERR 07:47:23.244] AssemblyLoader: Exception loading 'MoleUtils': System.Reflection.ReflectionTypeLoadException: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown.
      at (wrapper managed-to-native) System.Reflection.Assembly.GetTypes(System.Reflection.Assembly,bool)
      at System.Reflection.Assembly.GetTypes () [0x00000] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0 
      at AssemblyLoader.LoadAssemblies () [0x000e6] in <06f13185617646e5bc801baeab53ab75>:0 

    Additional information about this exception:

     System.IO.FileNotFoundException: Could not load file or assembly 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

    [ERR 07:47:23.247] ADDON BINDER: Cannot resolve assembly: BARISBridge, Culture=neutral, PublicKeyToken=null

    [ERR 07:47:23.247] ADDON BINDER: Cannot resolve assembly: BARISBridge, Culture=neutral, PublicKeyToken=null

    [ERR 07:47:23.249] AssemblyLoader: Exception loading 'WildBlueTools': System.Reflection.ReflectionTypeLoadException: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown.
      at (wrapper managed-to-native) System.Reflection.Assembly.GetTypes(System.Reflection.Assembly,bool)
      at System.Reflection.Assembly.GetTypes () [0x00000] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0 
      at AssemblyLoader.LoadAssemblies () [0x000e6] in <06f13185617646e5bc801baeab53ab75>:0 

    Additional information about this exception:

     System.TypeLoadException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. assembly:BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null type:<unknown type> member:(null) signature:<none>

     System.TypeLoadException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. assembly:BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null type:<unknown type> member:(null) signature:<none>

     System.TypeLoadException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. assembly:BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null type:<unknown type> member:(null) signature:<none>

     System.TypeLoadException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. assembly:BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null type:<unknown type> member:(null) signature:<none>

     System.TypeLoadException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. assembly:BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null type:<unknown type> member:(null) signature:<none>

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'BARISBridge, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

    [LOG 07:47:23.256] VesselModules: Found VesselModule of type AxisGroupsModule with order 999

    (Yes, the BARISBridge folder was present)

  • Finally, I replaced but the MOLE folder with the folders from the WBI Tools download (excluding Classic Stock Resources) & launched - issue resolved but am still seeing this in the log:

      Reveal hidden contents

    [LOG 07:58:36.119] AssemblyLoader: Loading assemblies
    [ERR 07:58:36.190] ADDON BINDER: Cannot resolve assembly: WildBlueTools, Culture=neutral, PublicKeyToken=null

    [ERR 07:58:36.190] ADDON BINDER: Cannot resolve assembly: WildBlueTools, Culture=neutral, PublicKeyToken=null

    [ERR 07:58:36.194] AssemblyLoader: Exception loading 'MoleUtils': System.Reflection.ReflectionTypeLoadException: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown.
      at (wrapper managed-to-native) System.Reflection.Assembly.GetTypes(System.Reflection.Assembly,bool)
      at System.Reflection.Assembly.GetTypes () [0x00000] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0 
      at AssemblyLoader.LoadAssemblies () [0x000e6] in <06f13185617646e5bc801baeab53ab75>:0 

    Additional information about this exception:

     System.IO.FileNotFoundException: Could not load file or assembly 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

     System.IO.FileNotFoundException: Could not load file or assembly 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'WildBlueTools, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

    [LOG 07:58:36.206] VesselModules: Found VesselModule of type AxisGroupsModule with order 999

    So - conclusion. Works if you download it from github, doesn't work with CKAN

It sounds like there is an issue with the CKAN config then. I'll definitely need help to fix that. CKAN should always pull the latest Wild Blue Tools. Thanks for investigating! :)

Link to comment
Share on other sites

Ok, @Angel-125 - there is still an issue and it's an incompatibility between latest MOLE & latest WildBlueTools. The issue may *not* be CKAN but rather this incompatibility. This is causing the MoleUtils to not load - it even becomes corrupted, from what I can see.

To test:

Fresh install. Download latest MOLE & WildBlueTools from github. Install all of the folders from MOLE & launch game. Go into VAB & pull up a MOLE. Right-click - note that the 'Manage Operations' and 'Start Lab Time' buttons are present - all good. 

Now, shut down & deletethe 000WildBlueTools folder, replacing it with the one from the one in WBITools 1.82.1. Launch & repeat test. Note the buttons are no longer present. Check the log & you will see that the MoleUtils.dll would not load. Here's the kicker - deleting the 000WildBlueTools folder & replacing it again with the one from MOLE 1.26.0 DOES NOT WORK - relaunch & you will see the same issue. The only recourse is to replace BOTH the 000WildBlueTools & MOLE folders. Once that is done, normal function is restored.

Link to comment
Share on other sites

  • 2 weeks later...

@Angel-125  I love this mod and have used it for years!

With that said, I was getting the bug where KSP 1.12 would not load, and the only thing that resolved it was deleting this mod.

I know you are busy, so I know a fix isn't going to be immediate, but I wanted you to know.

Thanks again for this awesome mod!

Edited by Thraken
Link to comment
Share on other sites

25 minutes ago, Thraken said:

@Angel-125  I love this mod and have used it for years!

With that said, I was getting the bug where KSP 1.12 would not load, and the only thing that resolved it was deleting this mod.

I know you are busy, so I know a fix isn't going to be immediate, but I wanted you to know.

Thanks again for this awesome mod!

I am waiting for 1.12.1 before addressing issues in my mods. It seems that 1.12 isn’t stable yet.

Link to comment
Share on other sites

  • 1 month later...
  • 5 weeks later...

I found a balance issue. A MOLE Battery Module weighs twice too much.

It weighs 5 times more than a Zs-12-1K Rechargeable Battery Bank but holds only 2.5 times more power.
Or, it weighs 2 times more than a ReStock+ part, Zs-18-2500 Rechargeable Battery Bank but it holds the same amount of power.

Edited by Krzeszny
typo
Link to comment
Share on other sites

  • 2 weeks later...
  • 3 months later...

Hello, I recently completed some month long solar observation studies and thermal experiments from this mod in orbit at the mun and recovered them on kerbin. When I did so, the contracts for each experiment recovery were completed. But it seems I was awarded about ten times the amount of science, funds, and reputation that was listed in the contract details. My messages inbox shows about ten messages of completion for each contract, too, even though I only accepted each contract once. Is this a bug, or is there another explanation?  I thought it was odd that the funds reward was so low for the contracts (about one thousand funds). The mission was challenging, but I'm not sure it deserves a reward of 1200 science and bumping my reputation from 45% to 78%. Thanks

Edit: Seems I am unable to reproduce this bug. Sorry for the false alarm. Thanks for the great mod.

Edited by Joontry
Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...

Hello, thanks for the great mod. I have a contract to complete the Breakthrough Technologies Research LDEF study on the surface of the Mun and recover it. I'm having trouble because there is no LDEF part dedicated to Breakthrough Technologies Research, and the Modular Experiment Wedge only has a capacity for 150 Lab Time, while the experiment requires 180 lab time. Is there another part I am supposed to use? Or is there any other part that can have the experiment loaded into it and has a capacity of 180 Lab Time? Thank you

EDIT: If its intentional for it not to be possible to do Breakthrough Technologies Research LDEF without building a manned base with a laboratory, that is totally cool. Kind of makes sense. I just thought maybe this is not intentional. In which case, if there is a template for a module manager patch that would increase the Lab Time capacity of the Modular Experiment Wedge, I would love to see it. thanks

Edited by Joontry
Link to comment
Share on other sites

  • 4 weeks later...

EDIT: Please disregard this post -- LinuxGuruGamer pointed out the missing dependency in another mod that seems to have been causing this issue... 

Thanks again, LGG!

Edited by Ayelmar
Answered in a different post.
Link to comment
Share on other sites

  • 1 month later...

Does anyone know how to set the playmode for MOLE independently from other WildBlueIndustries mods?
(i'm currently stuck with pristine playmode, which I only wanted for the Heisenburg airship parts which were playing up due to the reconfigurable storage...)

Thanks in advance!

Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...

It's possibly a WBI tools problem but I encounter it when using MOLE tanks with Cryo(LH2+Oxidizer) configuration. (I have cryo tanks installed)

Dynamic battery storage failed to work and spawn these error log like crazy:

[EXC 23:14:44.914] ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
    System.ThrowHelper.ThrowArgumentOutOfRangeException (System.ExceptionArgument argument, System.ExceptionResource resource) (at <9577ac7a62ef43179789031239ba8798>:0)
    System.ThrowHelper.ThrowArgumentOutOfRangeException () (at <9577ac7a62ef43179789031239ba8798>:0)
    DynamicBatteryStorage.ModuleCryoTankPowerHandler.ReloadModuleNode () (at <ce8c094d51db45938ad65ca113e0ce60>:0)
    DynamicBatteryStorage.ModuleCryoTankPowerHandler.GetFuelTypes () (at <ce8c094d51db45938ad65ca113e0ce60>:0)
    DynamicBatteryStorage.ModuleCryoTankPowerHandler.Initialize (PartModule pm) (at <ce8c094d51db45938ad65ca113e0ce60>:0)
    DynamicBatteryStorage.VesselElectricalData.SetupDataHandler (PartModule pm) (at <ce8c094d51db45938ad65ca113e0ce60>:0)
    DynamicBatteryStorage.VesselData.RefreshData (System.Boolean fromScratch, System.Collections.Generic.List`1[T] vesselParts) (at <ce8c094d51db45938ad65ca113e0ce60>:0)
    DynamicBatteryStorage.VesselData..ctor (System.Collections.Generic.List`1[T] vesselParts) (at <ce8c094d51db45938ad65ca113e0ce60>:0)
    DynamicBatteryStorage.VesselElectricalData..ctor (System.Collections.Generic.List`1[T] vesselParts) (at <ce8c094d51db45938ad65ca113e0ce60>:0)
    DynamicBatteryStorage.VesselDataManager.RefreshVesselData () (at <ce8c094d51db45938ad65ca113e0ce60>:0)
    DynamicBatteryStorage.VesselDataManager.FixedUpdate () (at <ce8c094d51db45938ad65ca113e0ce60>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

 

Link to comment
Share on other sites

Hi @Angel-125, or anyone who could help.

Is there any walkthrough in regards to the experiment research thingies (couldn't find anything yet... )

- dependencies

- steps and exampleq

Seems that depending on what are you getting in WB & Tools, this is not entirely clear, even though there's been some effort for it to be intuitive, at least to me.

 

Thank you !

Link to comment
Share on other sites

  • 3 months later...

Hello, @Angel-125!  I installed MOLE and the MOLE CRP play mode through CKAN, and I noticed in the GameData\WildBlueIndustries\MOLE\ModuleManagerPatches folder, the RealPlume .cfg file is missing the period before the file extension; the filename is "MM_RealPlumecfg", as opposed to "MM_RealPlume.cfg".  I put the period in the filename in my local installation myself and restarted after deleting all the MM cache files and I haven't noticed any wonkiness yet, I just thought you might want to know.

Link to comment
Share on other sites

@Angel-125 Howdy. Seeing the same thing that Nizrael reported earlier this week as well. 

Also need to report that something with the Bigby Orbital Workship isn't playing along with the latest version of Extraplanetary Launchpads (v. 6.99.3.0). I've fiddled around a bit with putting some of my craft up for construction both in a Mk 3 Drydock in LKO as well as with a Pathfinder Rangeland Launch Pad. The majority of my craft load and build okay; the ones that contain BOWs do not. Both seem to instantly complete construction, though in the case of the Rangeland, an immediate RUD usually happens as well. Using MOLE Classic Stock Play Mode v.1.27.0 with Wild Blue Tools 1.88.1 in KSP 1.12.3.

Log file for the session in which I did all this.

Also, got a bone to pick with you re: the Classic Stock Nukeworks. Formula for making nuclear fuel requires Hexagen, but if I'm seeing the data for that resource correctly, Hexagen should only be available at Kerbol and Jool. Makes it a might difficult to harvest.

Link to comment
Share on other sites

  • 3 weeks later...

I'm running MOLE in Classic Stock Resources mode and am having an issue with the Fulcrum engine. It operates on "Keralox" or "Raptalox" instead of LFO. I found Raptalox in the tank configs but not Keralox. Am I missing something? Also, the tank with dual-engine mount points from MOLE cannot change its config from LFO to one of the other fuel types.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...