politas

CKAN (The Comprehensive Kerbal Archive Network); v1.26.2 - Dragon

Recommended Posts

CKAN.dmg not working really. It will show up as a CKAN.app but it does nothing but goes to the web shortcut to mono. Is this the way it was intended to work? It would be nice not using terminal and/or crossover to get this done. 

Share this post


Link to post
Share on other sites
4 hours ago, TherinWhitten said:

CKAN.dmg not working really. It will show up as a CKAN.app but it does nothing but goes to the web shortcut to mono. Is this the way it was intended to work? It would be nice not using terminal and/or crossover to get this done. 

I just replaced that download with a test build that others have reported better results with, because you're right, that file wasn't working and it's not nice to leave it up there as if it was. You might have a better experience if you re-download now.

Share this post


Link to post
Share on other sites

Noob question: I'm running Linux Mint 18.2 Sonya 64-bit.  Do I need to build CKAN from sources to install it here?

I tried downloading ckan_1.24.1_all.deb and installing it with dpkg and entered A World Of Pain.  (Can't load dependencies, e.g. mono...)

If no, a pointer would be great.  Thanks in advance and for this tool: it looks just great.  (I installed it on a Windows work machine without problem.)

Share this post


Link to post
Share on other sites
20 minutes ago, Hotel26 said:

Noob question: I'm running Linux Mint 18.2 Sonya 64-bit.  Do I need to build CKAN from sources to install it here?

You shouldn't need to, no. Just make sure mono is installed and run the binary as 'mono ./ckan.exe'.
 

20 minutes ago, Hotel26 said:

I tried downloading ckan_1.24.1_all.deb and installing it with dpkg and entered A World Of Pain. 

You don't need to install with the .deb, all that does is pull in mono-complete for convenience. If you don't use the .deb, install mono yourself. You'll need to find instructions for your distro.
Mint doesn't appear to ship mono at all :confused: (though there are references to it on the community site?), so you'll have try the Debian or Ubuntu packages. I can't tell you which, as apparently Mint is based on both. Personally, I'd try Debian.

Explaining the the incredibly informative "World Of Pain" console output you got when you tried to install the .deb so we can see what's going on might be helpful too... I don't use mint, but I do have some Debian-foo.

Edited by steve_v

Share this post


Link to post
Share on other sites
52 minutes ago, steve_v said:

Explaining the the incredibly informative "World Of Pain"

It's a reference to a scene in The Big Lebowski...  which isn't what you wanted to know, I know.  :) You've already been incredibly helpful.  Let me try what you've given to me and, win or fail, I'll report back so that others can find the way.

https://www.ghacks.net/2015/03/28/how-to-install-mono-on-linux-mint/

So Synaptic Package Manager doesn't know about CKAN at all.  So I attempted this from the cmd-line using dpkg again:

sudo dpkg -i /home/kmk/Downloads/ckan_1.24.1_all.deb
Selecting previously unselected package ckan.
(Reading database ... 373830 files and directories currently installed.)
Preparing to unpack .../Downloads/ckan_1.24.1_all.deb ...
Unpacking ckan (1.24.1) ...
dpkg: dependency problems prevent configuration of ckan:
 ckan depends on mono-runtime (>= 5.0); however:
  Version of mono-runtime on system is 4.2.1.102+dfsg2-7ubuntu4.

dpkg: error processing package ckan (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for desktop-file-utils (0.22+linuxmint1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Errors were encountered while processing:
 ckan
 

So, Synaptic shows the installed version as 4.2.1.102+dfsg2-7ubu while the latest version is 5.10.1.20-0xamarin1+
Why it didn't update, I don't know, but I'll attempt to force its opinion on this matter...

OK, so: sudo apt-get -f install forced an upgrade of all the mono stuff.  dpkg -i ckan_1.24.1_all.deb then has appeared to have worked.  :)

AND: ckan runs.  Lift-off...

Muchas gracias, muchacho!

Edited by Hotel26

Share this post


Link to post
Share on other sites
43 minutes ago, Hotel26 said:

 ckan depends on mono-runtime (>= 5.0); however:
  Version of mono-runtime on system is 4.2.1.102+dfsg2-7ubuntu4.

See if there is a >=5.0 mono-runtime package available in the repos. If there is, install it and try again. If Mint has the new version of apt, you can have it try to resolve dependencies automatically by using apt install <file.deb> rather than dpkg -i.
Otherwise, it's off to mono-project.com for an unofficial update. As the package on your system is from Ubuntu, you're probably best using the packages for that distro.
Add the repo as described there, apt update, and apt install mono-complete.

 

43 minutes ago, Hotel26 said:

Beware random outdated blogs... Take care what you add to sources.list, especially if apt wants to remove anything when you install from an unofficial repo. You can make a right mess, and on FDN we call the result a FrankenDebian.

That one is not too far off the mark (though it references ancient packages for an unsupported Debian release), but you'd be better following the instructions on the mono-project download page I linked.
 

-----------------

43 minutes ago, Hotel26 said:

Synaptic shows the installed version as 4.2.1.102+dfsg2-7ubu while the latest version is 5.10.1.20-0xamarin1+
Why it didn't update, I don't know, but I'll attempt to force its opinion on this matter...

Looks like you have the mono-project repo in your sources already (-xamarin versions are from there), it probably has a lower priority than the official mint repos, which is why it didn't get pulled in automatically.
IIRC, synaptic (I just use apt at the console) sets priorities in it's own special way...

Edited by steve_v

Share this post


Link to post
Share on other sites
1 hour ago, steve_v said:

Beware random outdated blogs

The ghacks.com citation refers to wheezy but Linux Mint Sonya is based on Debian 8, jessie, as shown in your link.  I'm going to update my repository information with the Jessie links...

Thanks a lot, bud.

Share this post


Link to post
Share on other sites

How often does the repository update ?

I am currently very impatient and starting CKAN every half hour because know mod I want has been updated. :P Wondering if I just am a bit to impatient ? 

For my frail mental health it would be calm me down a bit if I know. Thank god, there is not not F5 function. That would surely send me directly to the nuthouse.

Edited by Sunesha

Share this post


Link to post
Share on other sites
5 hours ago, Sunesha said:

How often does the repository update ?

I am currently very impatient and starting CKAN every half hour because know mod I want has been updated. :P Wondering if I just am a bit to impatient ? 

For my frail mental health it would be calm me down a bit if I know. Thank god, there is not not F5 function. That would surely send me directly to the nuthouse.

It's scatterer isn't it? I've been waiting for Ckan to catch it too. There's a 1.42 version up on Github right now.

Share this post


Link to post
Share on other sites
6 hours ago, Sunesha said:

How often does the repository update ?

There's a bot that looks for updates more or less continuously, but it typically takes 3-4 hours to do a complete pass of all the mods. I believe that mods hosted on SpaceDock get updated quicker by scripts that react to uploads on the fly, so they don't have to wait.

6 hours ago, Sunesha said:

I am currently very impatient and starting CKAN every half hour

You can just click the Refresh button, it does the same thing.

23 minutes ago, frog352000 said:

It's scatterer isn't it? I've been waiting for Ckan to catch it too. There's a 1.42 version up on Github right now.

Looks like that version got indexed yesterday:

https://github.com/KSP-CKAN/CKAN-meta/blob/master/Scatterer/Scatterer-2-v0.0329_for_1.4.2.ckan

... but its data on SpaceDock says KSP 1.4.1, so that's what it is in CKAN. (And the GitHub release has no machine readable versioning data to speak of.) Hopefully the SpaceDock folks will add a version option for 1.4.2 soon.

Share this post


Link to post
Share on other sites

 

 

3 hours ago, HebaruSan said:

There's a bot that looks for updates more or less continuously, but it typically takes 3-4 hours to do a complete pass of all the mods. I believe that mods hosted on SpaceDock get updated quicker by scripts that react to uploads on the fly, so they don't have to wait.

You can just click the Refresh button, it does the same thing.

Can't believe that missed that refresh button, cant see the tree in the forest symptom.  

Cool I can chill a bit then, will probably check tomorrow or just install it manually and calm down a notch :wink:

3 hours ago, frog352000 said:

It's scatterer isn't it? I've been waiting for Ckan to catch it too. There's a 1.42 version up on Github right now.

It's Kopernicus, the last one need for my standard install. Didn't wanna mention it by name as I can actually wait for the normal process to have its course. But is the last juicy one :wink:

Share this post


Link to post
Share on other sites

You may have  a problem with Github indexing - I've now got 3 mods awaiting updates that CKAN hasn't picked up on (Stock visual enhancements,  Contract Configurator and Oh Scrap) - I got updates for Interstellar Fuel Switch and Trajectories today, but they were both on SpaceDock - and I know those updates were published after the Github ones I mentioned.

Share this post


Link to post
Share on other sites
4 hours ago, severedsolo said:

You may have  a problem with Github indexing - I've now got 3 mods awaiting updates that CKAN hasn't picked up on (Stock visual enhancements,  Contract Configurator and Oh Scrap) - I got updates for Interstellar Fuel Switch and Trajectories today, but they were both on SpaceDock - and I know those updates were published after the Github ones I mentioned.

Looks like the bot was running a bit behind, but has caught up.

Share this post


Link to post
Share on other sites

Don't know if you need to know, but I thought I'd make an announcement.  Improved Chase Camera is now KSP-AVC supported.  I'm guessing with a proper version file, you can index it?

link to version file:  

https://github.com/PapaJoesSoup/ImprovedChaseCamera/blob/master/Distribution/GameData/ImprovedChaseCamera/ImprovedChaseCamera.version

Share this post


Link to post
Share on other sites
26 minutes ago, Papa_Joe said:

Don't know if you need to know, but I thought I'd make an announcement.  Improved Chase Camera is now KSP-AVC supported.  I'm guessing with a proper version file, you can index it?

Thanks for the information! Your new fork is now indexed.

Share this post


Link to post
Share on other sites
On 3/30/2018 at 2:55 PM, HebaruSan said:

I just replaced that download with a test build that others have reported better results with, because you're right, that file wasn't working and it's not nice to leave it up there as if it was. You might have a better experience if you re-download now.

I have the mono framework 5.1.4.6 installed. Can use CKAN on Crossover. I just tried with the DMG. It went a step further with the CKAN.app” is an application downloaded from the Internet. Are you sure you want to open it?. I select yes and at the same time checking the security panel to see of the app has the option to "Open Anyway". It does not, and still refers me to the mono Download page. 

 

I appreciate all this hard work you do man. Just giving you the information I get when I try. Let me know if you need more. 

 

In a nutshell, DMG is still not performing yet. I ONLY have crossover now for CKAN lol. 

Share this post


Link to post
Share on other sites
10 minutes ago, TherinWhitten said:

I just tried with the DMG. It went a step further with the CKAN.app” is an application downloaded from the Internet. Are you sure you want to open it?. I select yes and at the same time checking the security panel to see of the app has the option to "Open Anyway". It does not, and still refers me to the mono Download page. 

Well, that was weird. The old file was still there. Thanks for letting me know. I guess I either uploaded the wrong file or canceled out of the update somehow.

I've re-replaced it and double checked it, and now I see what I expect to see when I re-download it.

Share this post


Link to post
Share on other sites
1 minute ago, HebaruSan said:

Well, that was weird. The old file was still there. Thanks for letting me know. I guess I either uploaded the wrong file or canceled out of the update somehow.

I've re-replaced it and double checked it, and now I see what I expect to see when I re-download it.

You want me to test it right now?

I got some time to verify this for you.

 

Share this post


Link to post
Share on other sites
1 minute ago, TherinWhitten said:

You want me to test it right now?

I got some time to verify this for you.

Sure, that would be great. Thanks!

Share this post


Link to post
Share on other sites
1 minute ago, HebaruSan said:

Sure, that would be great. Thanks!

Ok so I JUST tried the new update: 

It opened up the security panel for me to approve and open anyway like a normal Mac app does when it's an unsigned developer.  After that step, the app pops up an install files screen normally, whether it is to install or send separate app to application folder. 

This did NOT happen with CKAN. It gets to that point. I hope I am making sense here lol. Afterwards, it did not send it to the application folder ( I verified this) , nor did any secondary panel pop up to install it or send it to the application folder. 

 

To me I sound clear as mud lol. I don't know how well you know Mac OS. 

Share this post


Link to post
Share on other sites
2 minutes ago, TherinWhitten said:

To me I sound clear as mud lol. I don't know how well you know Mac OS. 

Heh, what did happen though? It's not supposed to be an installer, it's just an app bundle inside a disk image, just like the previous download.

Share this post


Link to post
Share on other sites
20 minutes ago, HebaruSan said:

Heh, what did happen though? It's not supposed to be an installer, it's just an app bundle inside a disk image, just like the previous download.

As far as I know exe files don't normally work with Mac. Mono is the framework to allow mac to read exec files.  Crossover does it by running windows base frameworks (Net Framework) to do the grunt work for it. 

I opened the app and I see Mac OS folder with two exec files. One of the exec files is tagged as usable by crossover. 

Basically, once the app opened, nothing happened. No CKAN explorer popped up looking for KSP folder, nothing.  Something is not talking. Let me play around using bash and mono and try to figure it out. 

 

I opened the app itself and clicks on the Exec file for bash, this what was in bash. 

Therins-iMac:~ therinwhitten$ /Volumes/CKAN/CKAN.app/Contents/MacOS/CKAN ; exit;

 

Just that.

Wait! we got wake up! One sec. Let me play some more. I think it is working. I want to try to find what changed for you. 

 

Final Update! Mono 32 booted up and ran CKAN

Step 1: Double Click DMG File

Step 2: Accept and Open App

Step 3: Right Click App and click "Open Contents"

Step 4: Click on Bash Exe, Watch to ensure bash binds with Mono

Step 5: Move App from mounted Image to Applications Folder

Profit!

 

CKAN Now opens without bash being open. Weird.  It is good now. Works great man! THANK YOU!

Edited by TherinWhitten
Changes

Share this post


Link to post
Share on other sites

FUUUUUUUUUUUU....i was installing RO/RSS and at 99% ...ERROR... you shouldent make it so it has to install all mods over again after a error.

Share this post


Link to post
Share on other sites

Hey all. A new backport for kerbalism for 1.3.1 has overwritten my 1.4 version and broken my mod currently. I have 1.3.1 set as a compatible version for some other mods, which is I guess why ckan allows this to happen? Is there any way to switch to a version of kerbalism that isn't the most current? Thanks for the awesome tool btw, it's really opened up mods to me without all the hassle of folders and rars.

Share this post


Link to post
Share on other sites
3 hours ago, PTackett said:

Hey all. A new backport for kerbalism for 1.3.1 has overwritten my 1.4 version and broken my mod currently. I have 1.3.1 set as a compatible version for some other mods, which is I guess why ckan allows this to happen?

Yes, I think that's correct. The backport has a higher version number, so it is counted as the latest release.

3 hours ago, PTackett said:

Is there any way to switch to a version of kerbalism that isn't the most current?

I would try removing Kerbalism, temporarily removing 1.3.1 from the compatible version list, and reinstalling Kerbalism. That should eliminate the backport from consideration.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.