politas

CKAN (The Comprehensive Kerbal Archive Network); v1.26.2 - Dragon

Recommended Posts

9 hours ago, Papa_Joe said:

@HebaruSan, due to multiple requests for a KSP 1.3.1 specific version of PlanetShine, I  have distributed a version specific release.

Of course this throws off the latest release tag in GitHub, so I wanted to give you a heads up on the specific GitHub release tags and version files for each version.

Thanks for the info, it looks like the new version was indexed as expected:

https://github.com/KSP-CKAN/CKAN-meta/compare/fed1341bb6...f7252f12fd

7 hours ago, Captainfisher said:

On installing CKAN I recieved a message saying it needs permission to create a new url handler. I pressed yes, but could someone explain what this means and whether I should have pressed yes or no? Thanks for your help.

It's trying to add support for URLs of the form ckan://PlanetShine to your system. I don't think it's used very often, so it doesn't much matter what you click.

Share this post


Link to post
Share on other sites

General FYI, Curse has changed some aspect of their policies or hosting practices that has frozen the API service that CKAN uses to query Curse:

https://www.cfwidget.com/

Quote

Due to changes made to the availability of CurseForge data to third party services we are no longer able to provide fresh data. All data served by this service is accurate as of March 17th 2018. I am working with the CurseForge team to determine the long term status of this service, whether that's shutting down part of (or all of) it, or changes that will allow the service to fetch fresh data again. This page will be updated with any news. Please reach out to me via email (sryan@twitch.tv) with any questions.

Details are sketchy at this point, but the effect is that versions of mods uploaded to Curse in the past month have not been indexed in CKAN, and they probably won't be indexed in the future unless this service is restored. For more information you can read comments from the developer who maintains the API service at https://github.com/KSP-CKAN/NetKAN/pull/6481 .

If you are a modder with mods hosted on Curse and would like them to be indexed in CKAN, my unofficial personal recommendation (not speaking for the CKAN team) is to select an alternate hosting service. We can switch your mod's listing relatively painlessly if you contact us via:

Share this post


Link to post
Share on other sites
On 4/14/2018 at 1:23 AM, politas said:

CKAN Release v1.25.0 "Wallops" is released

@politas/ @HebaruSan, thanks for the continued development of CKAN.

Even after reviewing the release notes I can't determine if this release fixes the problems with downloading Sarbian's dev versions for Mechjeb.  I guess I could just try it and find out myself...

Share this post


Link to post
Share on other sites
2 hours ago, Brigadier said:

@politas/ @HebaruSan, thanks for the continued development of CKAN.

Even after reviewing the release notes I can't determine if this release fixes the problems with downloading Sarbian's dev versions for Mechjeb.  I guess I could just try it and find out myself...

Yup, that should be fixed; admittedly the description isn't as transparent as it could be:

Quote
  • [Core] Don't crash if download_hash isn't set (#2313 by: HebaruSan; reviewed: politas)

Share this post


Link to post
Share on other sites

Why is nobody uploading mods to CKAN anymore? Can I contribute in any way to upload other peoples mods?

Regards and best wishes,

Share this post


Link to post
Share on other sites
3 hours ago, Prowler_x1 said:

Why is nobody uploading mods to CKAN anymore?

People are still uploading mods to CKAN.

3 hours ago, Prowler_x1 said:

Can I contribute in any way to upload other peoples mods?

For that we like to make sure the mod author is OK with it, so other ways of contributing would probably be better. There's a list of options here:

https://github.com/KSP-CKAN/CKAN/blob/master/CONTRIBUTING.md

3 hours ago, Prowler_x1 said:

Regards and best wishes,

Cheers!

Share this post


Link to post
Share on other sites

Man, there are so many mods now you need CKAN just to keep track of them all...

Share this post


Link to post
Share on other sites
On 4/19/2018 at 11:04 PM, HebaruSan said:

People are still uploading mods to CKAN.

For that we like to make sure the mod author is OK with it, so other ways of contributing would probably be better. There's a list of options here:

https://github.com/KSP-CKAN/CKAN/blob/master/CONTRIBUTING.md

Cheers!

HebaruSan,

I'm sorry if my comments sounded off-base or even offensive. Not my intention. (English is not my first language) Please let me re-phrase.

 

I see several mods going up on SpaceDock from devs who were placing mods on CKAN in previous versions, their updates for 1.4.2 are not showing up on CKAN.

After speaking with one of the Devs he told me the following:

 

___Some Dev___

I've been using Spacedock to handle CKAN uploads and everything was fine until the last release 1.4.1 to 1.4.2 Spacedock had an option to automatically mark the existing 1.4.1 file as 1.4.2 compatible and I did this, but it is apparently not working, as the only mod that made it to CKAN was ___Some Mod___.

Soo... I just went ahead and re-uploaded all the files for the mods and specifically marked them as 1.4.2 compatible. With any luck the CKAN team will get them and update accordingly.

Thanks again! ___Some Dev___

 

I hope this information helps you and the Dev community to make their mods available via CKAN - SpaceDock.

Thanks again for being such a cool dude, your reply gave me a deeper understanding of how awesome the people in this community are.

Regards and best wishes.

 

 

Share this post


Link to post
Share on other sites
2 hours ago, Prowler_x1 said:

I'm sorry if my comments sounded off-base or even offensive. Not my intention. (English is not my first language) Please let me re-phrase.

You don't need to worry, I didn't have that impression.

2 hours ago, Prowler_x1 said:

I see several mods going up on SpaceDock from devs who were placing mods on CKAN in previous versions, their updates for 1.4.2 are not showing up on CKAN.

Do you remember which mods had this problem? If so, please let us know:

Share this post


Link to post
Share on other sites

Looks like CKAN hasn't autodetected the DLC for me and considers all MH-dependent mods incompatible.

Share this post


Link to post
Share on other sites

Hi and first of all, thanks for your work!
I'm trying to install two mods of DMagic, CapCom and Contracts Window +, but they are listed as 1.4.1. On its official forum pages thay are both listed as 1.4.X, so are their dependencies. What should i do? Wait for an update or open an issue on github?
Thanks!

Share this post


Link to post
Share on other sites
2 hours ago, garwel said:

Looks like CKAN hasn't autodetected the DLC for me and considers all MH-dependent mods incompatible.

It's looking for the file GameData/SquadExpansion/MakingHistory/readme.txt. Do you have that file in that location?

 

1 hour ago, RedDragon91GoW said:

Hi and first of all, thanks for your work!
I'm trying to install two mods of DMagic, CapCom and Contracts Window +, but they are listed as 1.4.1. On its official forum pages thay are both listed as 1.4.X, so are their dependencies. What should i do? Wait for an update or open an issue on github?
Thanks!

An issue on GitHub is the ideal place for such reports.

Share this post


Link to post
Share on other sites
5 hours ago, politas said:

It's looking for the file GameData/SquadExpansion/MakingHistory/readme.txt. Do you have that file in that location?

Yep. Could it be because my KSP installation is on disk D: (although it is still a Steam folder)? But other mods are detected ok.

Share this post


Link to post
Share on other sites
49 minutes ago, garwel said:

Yep. Could it be because my KSP installation is on disk D: (although it is still a Steam folder)? But other mods are detected ok.

No, it looks like there is a bug, but it may be specific to GUI, as I'm able to install TweakscaleMakingHistoryConfigs from the command line.

Share this post


Link to post
Share on other sites

CKAN Release v1.25.1 "Broglio" is released!

68747470733a2f2f75706c6f61642e77696b696d


Changes since 1.25.0

Features

  • [GUI] Replace empty max KSP version string with "any" (#2420 by: DasSkellet; reviewed: HebaruSan, politas)

Bugfixes

  • [GUI] Splitter and tabstrip visual improvements (#2413 by: HebaruSan; reviewed: politas)
  • [GUI] Fix "Collection was modified" exception for redundant optional dependencies (#2423 by: HebaruSan; reviewed: politas)
  • [core] Treat installed DLC as compatible dependency (#2424 by: HebaruSan; reviewed: politas)
  • [GUI] Ignore splitter exceptions (#2426 by: HebaruSan; reviewed: politas)

Internal

  • [Build] Add more tests (#2410 by: HebaruSan, DasSkelett; reviewed: politas)
  • [Updater] AutoUpdate: tokens and tests (#2411 by: HebaruSan; reviewed: politas)

Notes

  • The auto-update function in previous releases may fail trying to upgrade to this version. In that case, you will need to download it manually and replace your previous copy.
  • You don't need to download AutoUpdate.exe. This is used internally by CKAN when a new version is released.
  • Windows users must have .NET 4.5 installed. SImply download the ckan.exe file and either store it in your game directory or somewhere in your filesystem that you have non-admin write access. Never run the CKAN client as Administrator!
  • libcurl is no longer used by CKAN for Linux or Mac. If you experience problems downloading, please contact us
  • Mac/Linux/Mono users: please use the new cert-sync tool, to update mono's certificate store.
  • Mac Users: You should only need to download and install the CKAN.dmg
  • The .deb file is for automated installation on Debian-based Linux distributions - Use dpkg-install/apt-get/apt to install the .deb file and you will then be able to run CKAN with just ckan instead of mono ckan.exe. All required libraries should be pulled in as dependencies.
  • This release of the CKAN has not been tested on Mono releases prior to 5.0.1. We highly recommend upgrading to the latest stable release of Mono from mono-project.com You will need the equivalent of the mono-complete package for your OS.

News and appreciations

  • Splitters have been resized and more sensible minimum sizes set.
  • Mods depending on Making History DLC will now actually show up as available when it is present.
  • @DasSkelett and @HebaruSan continue adding valuable code to the project, please give them some love!
  • In the metadata side @linuxgurugamer is still making updates faster than I can keep up with!
  • As always, we love contributions in any form: issues, code, metadata updates, even friendly discussions and polite references on the forums!

Share this post


Link to post
Share on other sites

My mods won't update since 2 days ago. I resorted to re-installing them to make them update. I made small video(2min) showing what trouble I have as I feel my english in written form is lacking. Especially when it comes to english terms about tech. I tried to find some log concerning CKAN but didn't manage to find one. 

I also checked write permissions on CKAN Folder in the KSP folder. Also that it wasn't read only.

System:

Spoiler

Kerbal Space Program 1.4.2

Operating System
            Windows 10 Pro 64-bit
        CPU
            AMD FX-8350    39 °C
            Vishera 32nm Technology
        RAM
            16,0GB Dual-Channel DDR3 @ 803MHz (9-9-9-24)
        Motherboard
            Gigabyte Technology Co. Ltd. 970-GAMING (CPU 1)    37 °C
        Graphics
            PHL BDM3270 (2560x1440@59Hz)
            4095MB NVIDIA GeForce GTX 970 (Gigabyte)    34 °C
        Storage
            111GB KINGSTON SUV400S37120G (SSD)    28 °C
            931GB Seagate ST1000DM003-1SB10C (SATA)    31 °C
            931GB Seagate ST1000DM003-1CH162 (SATA)    29 °C
            931GB Seagate ST1000DM003-1CH162 (SATA)    31 °C
            232GB Western Digital WDC WD2500BEVS-22UST0 (SATA)    28 °C
            1863GB Western Digital WD Ext HDD 1021 USB Device (SSD)    28 °C
        Optical Drives
            No optical disk drives detected
        Audio
            VB-Audio VoiceMeeter VAIO

Computer type: Desktop
    Installation Date: 2017-12-25 22:19:52
    Serial Number: 
        Windows Security Center
            User Account Control (UAC)    Enabled
            Notify level    0 - Never Notify
        Windows Update
            AutoUpdate    Notify prior to download
        Windows Defender
            Windows Defender    Disabled
        Firewall
            Firewall    Enabled
            Display Name    Panda Firewall
        Antivirus
                Windows Defender
                    Antivirus    Disabled
                    Virus Signature Database    Up to date
                Panda Antivirus Pro
                    Antivirus    Enabled
                    Virus Signature Database    Up to date
        .NET Frameworks installed
            v4.7 Full
            v4.7 Client
            v3.5 SP1
            v3.0 SP2
            v2.0 SP2
 

A small video(2min), where I show whats happening

Spoiler

 

 

Edited by Sunesha

Share this post


Link to post
Share on other sites
8 minutes ago, Sunesha said:

My mods won't update since 2 days ago

Thanks @Sunesha,

I discovered the error too today, we ( @HebaruSan ) are working on this, see https://github.com/KSP-CKAN/CKAN/issues/2428 .

This should only affect Scatterer, all other mods should be fine.

Edited by DasSkelett
Adding info

Share this post


Link to post
Share on other sites
41 minutes ago, Sunesha said:

My mods won't update since 2 days ago. I resorted to re-installing them to make them update. I made small video(2min) showing what trouble I have as I feel my english in written form is lacking. Especially when it comes to english terms about tech. I tried to find some log concerning CKAN but didn't manage to find one. 

Thanks for the video. We have an investigation in progress for this here:  https://github.com/KSP-CKAN/CKAN/issues/2428

You mentioned that you had this problem for other mods as well, but so far it looks as though the cause is specific to Scatterer. Do you by any chance remember the other mods that had problems upgrading? That could be very helpful in identifying the cause; thanks!

Share this post


Link to post
Share on other sites
1 hour ago, HebaruSan said:

Thanks for the video. We have an investigation in progress for this here:  https://github.com/KSP-CKAN/CKAN/issues/2428

You mentioned that you had this problem for other mods as well, but so far it looks as though the cause is specific to Scatterer. Do you by any chance remember the other mods that had problems upgrading? That could be very helpful in identifying the cause; thanks!

Yes, I experienced the same thing with "VesselMover Continued" yesterday. I see what happens next time I need mod update, maybe my system is always acting up like scatterer update issue.

Share this post


Link to post
Share on other sites

@HebaruSan, please add the following mod to CKAN. It's on Github

https://github.com/TykoTek/EngineTweaks_for_MakingHistory/releases/tag/v1

EngineTweaks_for_MakingHistory

This mod adjusts the specs on Making History engines and 3 stock engines to balance them and ensure every engine has a unique niche. The changes are balanced against other engines. If the thrust is changed, weight is also adjusted accordingly.

WARNING: Recommend only using with a new save. Amongst other things, this mod removes the Poodle from the game which could have a serious impact on existing games.

Google Sheets link documenting all changes: https://docs.google.com/spreadsheets/d/1tzovHSBZm_4_xLrglqAKbmLzeGQozpZfQr2YAaOTs8k/edit?usp=sharing

Requires Module Manager

Share this post


Link to post
Share on other sites
19 minutes ago, Tyko said:

@HebaruSan, please add the following mod to CKAN. It's on Github

https://github.com/TykoTek/EngineTweaks_for_MakingHistory/releases/tag/v1

EngineTweaks_for_MakingHistory

This mod adjusts the specs on Making History engines and 3 stock engines to balance them and ensure every engine has a unique niche. The changes are balanced against other engines. If the thrust is changed, weight is also adjusted accordingly.

WARNING: Recommend only using with a new save. Amongst other things, this mod removes the Poodle from the game which could have a serious impact on existing games.

Google Sheets link documenting all changes: https://docs.google.com/spreadsheets/d/1tzovHSBZm_4_xLrglqAKbmLzeGQozpZfQr2YAaOTs8k/edit?usp=sharing

Requires Module Manager

There's a good guide for doing this yourself: https://github.com/KSP-CKAN/CKAN/wiki/Adding-a-mod-to-the-CKAN

Following that guide, adding your mod to Spacedock is probably the easiest method, since it can submit the mod to CKAN when you submit it - plus it has the bonus of your mod being updated on CKAN when you make changes to it via Spacedock.

Plus it's a good platform for folks to find your mod who aren't using CKAN.

Edited by Rohaq

Share this post


Link to post
Share on other sites
8 minutes ago, Rohaq said:

There's a good guide for doing this yourself: https://github.com/KSP-CKAN/CKAN/wiki/Adding-a-mod-to-the-CKAN

Following that guide, adding your mod to Spacedock is probably the easiest method, since it can submit the mod to CKAN when you submit it - plus it has the bonus of your mod being updated on CKAN when you make changes to it via Spacedock.

Plus it's a good platform for folks to find your mod who aren't using CKAN.

Thanks! Is this all you need? 

{
    "spec_version" : 1,
    "identifier"   : "EngineTweaks_MH",
    "$kref"        : "#/ckan/github/TykoTek/EngineTweaks_for_MakingHistory",
    "license"      : "MIT License",
    "ksp_version"  : "1.4.99",
    "resources": {
        "homepage": "https://forum.kerbalspaceprogram.com/index.php?/topic/174303-14x-engine-tweaks-for-making-history/"
    }
}

I appreciate the suggestion about Spacedock. I'll look at adding a repository there too eventually.

Share this post


Link to post
Share on other sites
7 minutes ago, HebaruSan said:

Done (as "MakingHistoryEngineTweaks").

Thanks! did I do something wrong? I see it come up under Filter (New) but there's no checkbox next to it as if I was running an incompatible version of KSP (I'm running 1.4.2)

MtoKGaX.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.