politas

CKAN (The Comprehensive Kerbal Archive Network); v1.26.2 - Dragon

Recommended Posts

hi guys,

i added 2 weeks ago my new mod on spacedock, i ticked to get it on CKAN bit there is still nothing,

 i guess you have something to do ( or i?), here some maybe useful info for you:

License: GPLv3

Identifier on spacedock: 1245

  no dependency mod

there is an included KSP-AVC file inside the download

https://spacedock.info/mod/1245/Ablative-Airbrake

thank you, tell me if you need something else or if there is anything i have to do. :)

Share this post


Link to post
Share on other sites
On 3/21/2017 at 5:41 PM, Skalou said:

hi guys,

i added 2 weeks ago my new mod on spacedock, i ticked to get it on CKAN bit there is still nothing,

 i guess you have something to do ( or i?), here some maybe useful info for you:

License: GPLv3

Identifier on spacedock: 1245

  no dependency mod

there is an included KSP-AVC file inside the download

https://spacedock.info/mod/1245/Ablative-Airbrake

thank you, tell me if you need something else or if there is anything i have to do. :)

All done

Share this post


Link to post
Share on other sites
11 hours ago, justjr said:

Why STX is not on CKAN? At least, not as 1.2.2 compatible.

You mean this? Good up to 1.2.x, and its in CKAN.

 

Share this post


Link to post
Share on other sites
15 hours ago, Murdabenne said:

USI Exploration Pack is at 0.7.4 - CKAN still sitting at 0.7.3 after almost a couple of weeks.

U need to ping Roverdude about that, he maintains his own files

Share this post


Link to post
Share on other sites
On 22/03/2017 at 8:27 AM, stibbons said:

This is why I want to use a private repository. That *doesn't* appear in the general CKAN listing. It's explicitly opt-in, like subscribing to the mechjeb or scansat CI repos, but with an added step as I wasn't even planning on trying to get it on the "official" repository list. 

Shouldn't be a problem. It's just a tarball of .ckan files, grouped in folders named as the mod identifiers.

20 hours ago, Murdabenne said:

USI Exploration Pack is at 0.7.4 - CKAN still sitting at 0.7.3 after almost a couple of weeks.

 

4 hours ago, linuxgurugamer said:

U need to ping Roverdude about that, he maintains his own files

Specifically, it looks like some of his AVC files need some work 

Unexpected character encountered while parsing number: :. Path '', line 1, position 3.

is what NetKAN robot is reporting on USI-SRV, KaribouExpeditionRover and USI-SubPack. @RoverDude, are you about?

Share this post


Link to post
Share on other sites
12 minutes ago, politas said:

Shouldn't be a problem. It's just a tarball of .ckan files, grouped in folders named as the mod identifiers.

 

Specifically, it looks like some of his AVC files need some work 


Unexpected character encountered while parsing number: :. Path '', line 1, position 3.

is what NetKAN robot is reporting on USI-SRV, KaribouExpeditionRover and USI-SubPack. @RoverDude, are you about?

Yup!  Sub pack and Srv-Pack are now part of the expedition pack.  KER is now part of MKS.  So those mods should be removed from CKAN.

Share this post


Link to post
Share on other sites
16 minutes ago, politas said:

Shouldn't be a problem. It's just a tarball of .ckan files, grouped in folders named as the mod identifiers.

Yup yup. I've got a build plan that just generates the ckan and adds it to a tarball, has been running well for the last week or so. Thanks for the confirmation though. :)

Share this post


Link to post
Share on other sites
46 minutes ago, RoverDude said:

Yup!  Sub pack and Srv-Pack are now part of the expedition pack.  KER is now part of MKS.  So those mods should be removed from CKAN.

 @RoverDudeAh that makes good sense - I did see that with a conflict for Karibou a few weeks ago, so uninstalling all my USI then reinstalling one at a time saving KER to last worked for me - they showed conflicts and refused to install as long as I installed MKS etc prior. The Exploration Pack (I assume you meant Exploration when you said "expedition") is still on 7.3 in CKAN, although AVC shows 7.4 available; is the 7.4 version the one that now has the Survival and Sub incorporated into it?  If so then I need to uninstall USI Survival and the Otter, before I update the Exploration pack once it shows up in CKAN.  Maybe the updated ones should mark the old (now included) ones as not compatible, since attempting to install the update fails due to the files already being there for the old stand-alones.

FYI I am running CKAN with 1.2.0 1.2.1 and 1.2.2 compatibility allowed because so many other mods are functional although they have not updated for 1.2.2 specifically, if that makes a difference. That's why the "old" mods show up (They are 1.2.1, like the Karibou stand alone)

Edited by Murdabenne
CKAN details added.

Share this post


Link to post
Share on other sites
11 hours ago, Murdabenne said:

 @RoverDudeAh that makes good sense - I did see that with a conflict for Karibou a few weeks ago, so uninstalling all my USI then reinstalling one at a time saving KER to last worked for me - they showed conflicts and refused to install as long as I installed MKS etc prior. The Exploration Pack (I assume you meant Exploration when you said "expedition") is still on 7.3 in CKAN, although AVC shows 7.4 available; is the 7.4 version the one that now has the Survival and Sub incorporated into it?  If so then I need to uninstall USI Survival and the Otter, before I update the Exploration pack once it shows up in CKAN.  Maybe the updated ones should mark the old (now included) ones as not compatible, since attempting to install the update fails due to the files already being there for the old stand-alones.

FYI I am running CKAN with 1.2.0 1.2.1 and 1.2.2 compatibility allowed because so many other mods are functional although they have not updated for 1.2.2 specifically, if that makes a difference. That's why the "old" mods show up (They are 1.2.1, like the Karibou stand alone)

USI-EXP is failing to update because:

Could not find UmbraSpaceIndustries/SubPack entry in zipfile to install

Looks like @RoverDude needs to fix up the install instructions for that one.

Share this post


Link to post
Share on other sites

We managed to get OPM-VO listed on CKAN earlier fine but I was just wondering, will CKAN automatically update to new release versions that are posted to the GitHub repo or will I have to edit any meta data manually?

I apologize for the n00by question. :D 

Share this post


Link to post
Share on other sites
50 minutes ago, Poodmund said:

We managed to get OPM-VO listed on CKAN earlier fine but I was just wondering, will CKAN automatically update to new release versions that are posted to the GitHub repo or will I have to edit any meta data manually?

If I read this netkan file correctly (vref tag to AVC file in the github-release), you just need to raise the version number in the .version file in the release zip on github. The CKAN bot should find the new release, download it, check the .version file and automatically index the new version. You can also check the result here: http://status.ksp-ckan.org/ and here.

Edited by Jebs_SY

Share this post


Link to post
Share on other sites
4 hours ago, Poodmund said:

We managed to get OPM-VO listed on CKAN earlier fine but I was just wondering, will CKAN automatically update to new release versions that are posted to the GitHub repo or will I have to edit any meta data manually?

I apologize for the n00by question. :D 

 

3 hours ago, Jebs_SY said:

If I read this netkan file correctly (vref tag to AVC file in the github-release), you just need to raise the version number in the .version file in the release zip on github. The CKAN bot should find the new release, download it, check the .version file and automatically index the new version. You can also check the result here: http://status.ksp-ckan.org/ and here.

Yep, CKAN will read the .version file included with each GitHub release and use that to set KSP version ranges. If you need to change the min version on one of the dependencies, the .netkan file will need to be updated, though.

Share this post


Link to post
Share on other sites
On 05/04/2017 at 6:26 AM, Jim123 said:

i cant add a install or i dont know how?

Click "Add New" in the "Select  KSP Installation" window, browse to the folder where your KSP install is located, select the buildID.txt or buildID64.txt file, and then click "Open"

Share this post


Link to post
Share on other sites

Hey politas,

 

Great Work with CKAN!! Thank you!

I love it! :wink:

 

 

Do you have an estimation, when the newest version of  Stock Visual Enhancements (in CKAN: 1.1.6 - newest: 1.2.1) will be available on CKAN?

Edited by N3N

Share this post


Link to post
Share on other sites
3 hours ago, N3N said:

Do you have an estimation, when the newest version of  Stock Visual Enhancements (in CKAN: 1.1.6 - newest: 1.2.1) will be available on CKAN?

If I see this correct, SVE installation now became easier, because it now installs the "default" versions of MM, EVE, Scatterer and then SVE configures them with MM patches.

So the CKAN installation should be more easy, cause it just needs MM, EVE, Scatterer as dependency and then install the SVE and the SVE-Textures.

But I don't know if that changes can be incorporated by the CKAN database without breaking the install possibilities for older versions of KSP/SVE. Hmm.

Share this post


Link to post
Share on other sites

In the country where I live, the internet can be slow sometimes, so downloading large files is a long long wait and downloading is error. If you correct this problem, it is very annoying.

This is very useful except for the error, thank you.

Translating using Google Translate can be a mistake.

Share this post


Link to post
Share on other sites

Hello, I've started encountering an odd error when trying to install several different mods. At first I thought it was just the one mod, but it's starting to pop up with multiple attempts. NavballUpDefault, the mod mentioned is not installed:
 

Quote

Unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately.



Cannot install NavballUpDefault, module not available.
 

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
CKAN.ModuleNotFoundKraken: Cannot install NavballUpDefault, module not available
   at CKAN.CkanModule.FromIDandVersion(IRegistryQuerier registry, String mod, KspVersionCriteria ksp_version)
   at CKAN.RelationshipResolver.<RelationshipResolver>c__AnonStorey0.<>m__0(String name)
   at System.Linq.Enumerable.WhereSelectListIterator`2.MoveNext()
   at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
   at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
   at CKAN.RelationshipResolver..ctor(IEnumerable`1 module_names, RelationshipResolverOptions options, IRegistryQuerier registry, KspVersionCriteria kspversion)
   at CKAN.MainModList.ComputeConflictsFromModList(IRegistryQuerier registry, IEnumerable`1 change_set, KspVersionCriteria ksp_version)
   at CKAN.Main.<UpdateChangeSetAndConflicts>c__async1.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at CKAN.Main.<ModList_CellValueChanged>c__async0.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.CompilerServices.AsyncMethodBuilderCore.<>c.<ThrowAsync>b__6_0(Object state)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
----------------------------------------
ckan
    Assembly Version: 0.0.0.0
    Win32 Version: 0.0.0.0
    CodeBase: file:///K:/Documents%20and%20Settings/Admin/My%20Documents/Game%20Mods/KSP/1.2.2/ckan.exe
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Transactions
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Transactions/v4.0_4.0.0.0__b77a5c561934e089/System.Transactions.dll
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Numerics
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Numerics/v4.0_4.0.0.0__b77a5c561934e089/System.Numerics.dll
----------------------------------------
System.Runtime.Serialization
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Serialization/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Serialization.dll
----------------------------------------
System.Xml.Linq
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll
----------------------------------------
System.Data
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
Anonymously Hosted DynamicMethods Assembly
    Assembly Version: 0.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/mscorlib/v4.0_4.0.0.0__b77a5c561934e089/mscorlib.dll
----------------------------------------
Microsoft.CSharp
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.CSharp/v4.0_4.0.0.0__b03f5f7f11d50a3a/Microsoft.CSharp.dll
----------------------------------------
System.Dynamic
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Dynamic/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Dynamic.dll
----------------------------------------
System.EnterpriseServices
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.EnterpriseServices/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.EnterpriseServices.dll
----------------------------------------
Accessibility
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.



I also get this when updating the repositories on launch, though I haven't noticed any major issue that is obviously a result of it:
 

Quote

Error!

Failed to connect to repository. Exception: Too many mods provide Scatterer-config:
Scatterer-config 2:v0.0300
* SVE-Scatterer-Config 2:1.1.6

Edited by elanachan

Share this post


Link to post
Share on other sites
On 08/04/2017 at 3:03 AM, mulfucer said:

In the country where I live, the internet can be slow sometimes, so downloading large files is a long long wait and downloading is error. If you correct this problem, it is very annoying.

This is very useful except for the error, thank you.

Translating using Google Translate can be a mistake.

If you go to the "Contents" tab of the large mods you wish to download, you can pre-download them, which I have found helps a lot with poor Internet connections.

20 hours ago, elanachan said:

Hello, I've started encountering an odd error when trying to install several different mods. At first I thought it was just the one mod, but it's starting to pop up with multiple attempts. NavballUpDefault, the mod mentioned is not installed:
 



I also get this when updating the repositories on launch, though I haven't noticed any major issue that is obviously a result of it:
 

See my signature for the link to the error ticket for the Module Not Found on an unrelated module. That one is evading efforts to resolve it so far. Following those workaround instructions should solve your other problem, too.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.