politas

CKAN (The Comprehensive Kerbal Archive Network); v1.26.4 - Orion

Recommended Posts

7 minutes ago, MikeO89 said:

Been using ckan for awhile. Today I tried to start it and got this.

 

Error in autoupdate. The request was aborted: Could not create SSL/TLS secure channel.

Sounds like GitHub throttling. Try again later.

Share this post


Link to post
Share on other sites
3 minutes ago, I3laze said:

Is GitHub down? I'm getting Connection to https://github.com/KSP-CKAN/CKAN-meta/archive/master.tar.gz could not be established. Trying to re download my mods from my .ckan file. 

No, but we just had 4 issue reports come in nearly simultaneously reporting this, so something's up.

Since SSL/TLS was mentioned, I wonder whether it's related to the last glitch with GitHub (the one that fixed itself before I could figure out what was happening).

Share this post


Link to post
Share on other sites
Just now, HebaruSan said:

No, but we just had 4 issue reports come in nearly simultaneously reporting this, so something's up.

Since SSL/TLS was mentioned, I wonder whether it's related to the last glitch with GitHub (the one that fixed itself before I could figure out what was happening).

Yeah I get the SSL/TLS message too

Share this post


Link to post
Share on other sites
On 2/8/2018 at 1:57 PM, kostor said:

Hi there,

Having trouble with "Could not create SSL/TLS secure channel."

I understood it has to do with Spacedoc, yet any answer I found was about a month ago.

The problem still exists?

 

Thanks.

On 2/8/2018 at 2:45 PM, HebaruSan said:

As I feared, while trying to figure this out, it seems to have started working again randomly.

@kostor, @Fobok, and @EasyAce, can you confirm?

The mystery is finally solved!

https://news.ycombinator.com/item?id=16278620

Quote

Just a quick preview...we will be posting a blog post tomorrow morning with an update. Because of the delayed final blog post, we are delaying things by one week. The plan is to do a 1hr brownout on February 8th, followed by a permanent deployment on February 22nd. We realize that no matter how much notice (announced roughly a year ago), there are bound to be some systems that are both incompatible and unknowingly running on production systems. So, the hope is that a 1hr brownout will help to unearth such systems and give folks time to get them updated.

So that outage was a short preview of GitHub permanently turning off TLS 1/1.1 services, which they just did. TLS 1.2 is required now. Investigation proceeding here:

Edited by HebaruSan

Share this post


Link to post
Share on other sites

I'm on 4.7 of .NET framework, and I'm having the problem. Is there a configuration or something I have to activate? (I've done the 'ckan update' route, with no luck.)

Edit: Yeah, I realized right after I clicked send I should report to the GitHub issue.

Edited by Fobok

Share this post


Link to post
Share on other sites
2 minutes ago, Fobok said:

I'm on 4.7 of .NET framework, and I'm having the problem. Is there a configuration or something I have to activate?

Thanks for trying it. I don't know, unfortunately.

2 minutes ago, Fobok said:

(I've done the 'ckan update' route, with no luck.)

Did "ckan update" work, or print errors?

Share this post


Link to post
Share on other sites
5 minutes ago, HebaruSan said:

Thanks for trying it. I don't know, unfortunately.

Did "ckan update" work, or print errors?

It showed the following:

PS D:\ckan> ./ckan update
Downloading updates...
Connection to https://github.com/KSP-CKAN/CKAN-meta/archive/master.tar.gz could not be established.
Updated information on 0 available modules

 

Share this post


Link to post
Share on other sites

Is there any way of retrieving my cache I deleted from Ckan/Downloads folder. I pressed clear Cache in the options. 

Share this post


Link to post
Share on other sites
7 minutes ago, I3laze said:

Is there any way of retrieving my cache I deleted from Ckan/Downloads folder. I pressed clear Cache in the options. 

You have my sympathy. I believe that button just deletes the files.

Share this post


Link to post
Share on other sites
Just now, HebaruSan said:

You have my sympathy. I believe that button just deletes the files.

I thought doing a clean install would solve it so cleared the cache first. ;.; 

I'm not a software tech guy so I wonder how long something like this could take to resolve?

Share this post


Link to post
Share on other sites

A quick look at the source shows that the target framework is set to 4.5 in the config files.  I am not a .NET dev but would simply updating those and recompiling fix it?

Share this post


Link to post
Share on other sites

Ah, good ole TLS problems. Been dealing with this repurposed bovine waste enough at work, so not surprised this is finally hitting the consumer level.

 

Share this post


Link to post
Share on other sites

I'm having errors, when I try to load CKAN.exe it says "Error in autoupdate: 
    The request was aborted: Could not create SSL/TLS secure channel." Any help?

Share this post


Link to post
Share on other sites
Just now, V3ndicity said:

I'm having errors, when I try to load CKAN.exe it says "Error in autoupdate: 
    The request was aborted: Could not create SSL/TLS secure channel." Any help?

Try reading any of the posts before yours.

Share this post


Link to post
Share on other sites

For all interested, there is a working test build listed in the thread on Github.

2 hours ago, Vigoroushydro said:

CKAN is broken, get to fixing please because you got a lot of people relying on it.

Be patient.  This just happened today, and there is already a working test build.  We (modders) don't get paid, this is not our day job.  So sometimes things may take a little while.  That being said, as I said, there is a working build if you look at the Github repo

Share this post


Link to post
Share on other sites
3 hours ago, Vigoroushydro said:

CKAN is broken, get to fixing please because you got a lot of people relying on it.

I think you need to increase your support level before you can start demanding a fix. ;-)

Please remember that this is a work of love, not a service you are purchasing. The developer has no obligation to drop their other commitments just to fix an extra bit for a game.

Share this post


Link to post
Share on other sites

For those who just want to play the game through CKAN - Go to the Game Directory > CKAN and open up GUIConfig.xml.  Under "CheckForUpdatesOnLaunch", set it to false. Relaunch CKAN and you'd still get an error, click "Continue". You should be able to run KSP from there. You can still uninstall mods but keep note that it'll throw out an error for every click - but you can just click Continue to keep skipping it.

Share this post


Link to post
Share on other sites
7 hours ago, HebaruSan said:

So that outage was a short preview of GitHub permanently turning off TLS 1/1.1 services, which they just did. TLS 1.2 is required now. Investigation proceeding here:

Wait, CKAN is still using TLS1.1? :confused: Why?

TLS 1.2 has been around for ~5 years now, why on earth do you guys not have support for it? Everything supports 1.2 these days.

Share this post


Link to post
Share on other sites
7 minutes ago, steve_v said:

Wait, CKAN is still using TLS1.1? :confused: Why?

TLS 1.2 has been around for ~5 years now, why on earth do you guys not have support for it? Everything supports 1.2 these days.

Default behavior of .NET 4.5, see https://github.com/KSP-CKAN/CKAN/pull/2297. No piece of CKAN code specifies any version of TLS (except now it will have to, to fix this).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.