politas

CKAN (The Comprehensive Kerbal Archive Network); v1.26.4 - Orion

Recommended Posts

59 minutes ago, HebaruSan said:

That's not what you need, though. You probably just need to mark KSP 1.6 as compatible, because AirplanePlus isn't supported on 1.7 yet.

https://github.com/KSP-CKAN/CKAN/wiki/User-guide#choosing-compatible-game-versions

Wow...just how in the world did you divine that from his post?  Wait...I'm thinking of something...can you read my mind too?? :sticktongue:

Share this post


Link to post
Share on other sites
2 minutes ago, Brigadier said:

Wow...just how in the world did you divine that from his post?  Wait...I'm thinking of something...can you read my mind too?? :sticktongue:

Heh heh. :)  I cheated, slightly:

 

 

Share this post


Link to post
Share on other sites

Hi,

I got a message about this, reposting it here since this is the correct forum:

 

 

I updated my mod Full AutoStrut on SpaceDock and it's update isn't showing up in NetKan's pull requests for some unknown reason.

thanks!

https://github.com/Xyphos/KSP_FullAutoStrut
 

https://spacedock.info/mod/1479/FullAutoStrut

 

I'm guessing that maybe the bot is broken and needs to be restarted

Share this post


Link to post
Share on other sites
1 hour ago, BenderIsGreat1a2b3 said:

Will CKAN still work if I upgrade my Mac to Catilina?

The GUI probably won't, because Mono only supports WinForms in 32-bit mode on Mac, which Catalina doesn't support (see https://github.com/mono/mono/issues/6701). But you should still be able to run CKAN's command line tools or ConsoleUI.

Share this post


Link to post
Share on other sites
2 hours ago, HebaruSan said:

The GUI probably won't, because Mono only supports WinForms in 32-bit mode on Mac, which Catalina doesn't support (see https://github.com/mono/mono/issues/6701). But you should still be able to run CKAN's command line tools or ConsoleUI.

I've upgraded earlier this week to Catalina and can confirm that this is case. The command line and ConsoleUI options work fine, and performance (at least with ConsoleUI) is considerably better than the WinForms front-end, although not quite as functional.

Edited by CaffeineAddict
Spell checked upgraded to make more sense

Share this post


Link to post
Share on other sites

If I switch to 1.7 compatibility, install a mod that isn't available in 1.6.1, and then turn off 1.7 compatibility, will the installed 1.7 mod still be listed as available for mods that require it?

Alista's AT-Utils mod requiries Configurable Containers Core. CCC is only available for 1.7.2 so blocks the installation of AT-Utils, and therefore the entire chain of mods I want. I've left a note on the CC discussion, but Alista has said previously that he is a bit snowed under for the time being so might not have seen it yet. I'd like to install the 1.7.2 CCC, then remove the 1.7 compatibility so I don't accidently install/upgrade any mods that have a specific 1.6.1 version (such as Kopernicus)


Thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.