politas

CKAN (The Comprehensive Kerbal Archive Network); v1.27.2 - Chandrasekhar

Recommended Posts

1 minute ago, HebaruSan said:

Have you tried reading the sentence that I quoted?

I dont really know what I have to move, the XML?

Share this post


Link to post
Share on other sites
1 minute ago, JordanLOL said:

I dont really know what I have to move, the XML?

Thanks, I'll file a feedback report with our translator about the clarity of that line. :wink:
@DasSkelett

Share this post


Link to post
Share on other sites
6 minutes ago, JordanLOL said:

I dont really know what I have to move, the XML?

 

3 minutes ago, HebaruSan said:

Thanks, I'll file a feedback report with our translator about the clarity of that line. :wink:
@DasSkelett

Beep boop feedback report received.
That sentence really got messed up somehow, the error message is not where it should be, going to fix that.

Yes, your guess is correct @JordanLOL, it's the "GUIConfig.xml" that should be moved, so that CKAN creates a new one.
You should check the settings after you moved the file and restarted CKAN, since moving/deleting the file will reset them to defaults.

Share this post


Link to post
Share on other sites

FYI, SpaceDock is going to have some scheduled downtime for maintenance starting about 14 hours from now, expected to last up to 8 hours, during which CKAN may be unable to download some mods. Some significant infrastructure and code updates will take place, which may require some fast reactions and hot patching with hair on fire despite extensive preparations, so the 8 hours is not a 100% guarantee. Please be patient and do not freak out.

Share this post


Link to post
Share on other sites
3 minutes ago, HebaruSan said:

FYI, SpaceDock is going to have some scheduled downtime for maintenance starting about 14 hours from now, expected to last up to 8 hours, during which CKAN may be unable to download some mods. Some significant infrastructure and code updates will take place, which may require some fast reactions and hot patching with hair on fire despite extensive preparations, so the 8 hours is not a 100% guarantee. Please be patient and do not freak out.

Best of luck !

Share this post


Link to post
Share on other sites
Posted (edited)

Just a question about how CKAN is handling forks these days. Specifically, I'm talking Kopernicus, which has had a hard for off a dead end 1.8.1 compatiple version and jump to the fork for 1.9.x compatible. There are dependencies that will be affected as well.  I see the 1.8.1 listed in CKAN, but nothing of the version linked below.  There are also "unofficial" forks being done by maintainers of other mods, like Jesus' version someone linked to in another forum post (part of RO?).  Anyway, whats the process for continuing a no-longer-developed version into a current forked one going forward, and the dependencies which all apparently point to their dependencies to the old version (things like OPM, EVE, Scatterer, Distant Object Enhancement, Planetshine, JNSQ, et al.), yet appear to work on the new fork?

 

 

Edited by Murdabenne

Share this post


Link to post
Share on other sites
3 hours ago, Murdabenne said:

Kopernicus

The CKAN team is aware of developments with Kopernicus and has discussed how to handle it.

Keep an eye on the releases. When the "Pre-release" marker disappears, then it's time to start thinking about CKAN.

https://github.com/prestja/Kopernicus/releases

v0gg3KZ.png

Share this post


Link to post
Share on other sites
Posted (edited)

oops (too late)

10 hours ago, Murdabenne said:

I'm talking Kopernicus, which has had a hard for off a dead end 1.8.1 compatible version and jump to the fork for 1.9.x compatible. There are dependencies that will be affected as well. 

If I wanted to understand what can happen, id check,   "provides"   and   "any_of" in the relationships section of the ckan spec to see which of various approaches would work.

https://github.com/KSP-CKAN/CKAN/blob/master/Spec.md

Edited by AxleGreaser
context

Share this post


Link to post
Share on other sites

The CKAN client v1.28.0-PRE1 "Drake" is released!

This is a pre-release because there are several large changes that we expect will have bugs. This means that it is opt-in only; the client will not auto-update to this release. Please try it if you can and report any problems in the bug tracker:

Also comment below with your feedback. These changes will be included in a full release once we are confident they are solid.

68747470733a2f2f6d69722d73332d63646e2d63

Changes since 1.27.2

Features

  • [Multiple] Show DLC in recommendations list (#3038 by: HebaruSan; reviewed: DasSkelett)
  • [Multiple] Prompt user to overwrite manually installed files (#3043 by: HebaruSan; reviewed: DasSkelett)
  • [GUI] Master search bar and misc GUI clean-up (#3041 by: HebaruSan; reviewed: DasSkelett)
  • [GUI] Added Chinese translation of multiple search category fields. (#3053 by: hyx5020; reviewed: HebaruSan)
  • [Build] Create a system menu entry for ConsoleUI (#3052 by: HebaruSan; reviewed: DasSkelett)
  • [Multiple] Non-parallel GitHub downloads, one progress bar per download (#3054 by: HebaruSan; reviewed: DasSkelett)
  • [Core] Multi-match 'find', allow 'as' for Ships and GameData (#3064 by: HebaruSan; reviewed: DasSkelett)
  • [GUI] Release date column (#3096 by: HebaruSan; reviewed: techman83)

Bugfixes

  • [CLI] Restore cmdline update message (#3042 by: HebaruSan; reviewed: DasSkelett)
  • [Core] Don't try to install multiple versions of the same mod (#3051 by: HebaruSan; reviewed: DasSkelett)
  • [GUI] Unbreak reinstall right click (#3055 by: HebaruSan; reviewed: DasSkelett)
  • [GUI] Don't save registry when opening settings (#3058 by: DasSkelett; reviewed: HebaruSan)
  • [Core] Move WebException stack trace from User error to verbose log (#3062 by: HebaruSan; reviewed: DasSkelett)
  • [Core] Multi-find fixes (#3074 by: HebaruSan; reviewed: DasSkelett)
  • [GUI] Fix crash on marking all updates (#3079 by: HebaruSan; reviewed: DasSkelett)
  • [Core] Use authToken for Curl (#3086 by: HebaruSan; reviewed: DasSkelett)
  • [GUI] Be more specific in GUI config parse error (#3090 by: HebaruSan, DasSkelett; reviewed: DasSkelett)

Internal

  • [Netkan] Purge stale cache entries for SpaceDock (#2859 by: HebaruSan; reviewed: DasSkelett)
  • [Netkan] NetKAN warnings (#3045 by: HebaruSan; reviewed: DasSkelett)
  • [Netkan] Support fallback URLs for netkan validate-ckan (#3060 by: HebaruSan; reviewed: DasSkelett)
  • [Netkan] Netkan warning for archived repos, set bugtracker for GitHub (#3061 by: HebaruSan; reviewed: DasSkelett)
  • [Netkan] Check mixed case version files (#3065 by: HebaruSan; reviewed: DasSkelett)
  • [Netkan] Netkan warning for tags (#3072 by: HebaruSan; reviewed: DasSkelett)
  • [Core] Cache hashes on disk (#3080 by: HebaruSan; reviewed: DasSkelett)
  • [Multiple] Don't fallback to Curl on 404, allow smaller GUI (#3084 by: HebaruSan; reviewed: DasSkelett)
  • [Build] Move Travis CI to GitHub Workflows (#3085 by: DasSkelett; reviewed: techman83)
  • [Build] Don't run workflow steps that require secrets on forks (#3089 by: DasSkelett; reviewed: HebaruSan)
  • [Build] Run workflows in Mono Docker containers (#3091 by: DasSkelett; reviewed: HebaruSan)
  • [Netkan] Generate release_date property in netkan (#3059 by: HebaruSan; reviewed: DasSkelett)

https://github.com/KSP-CKAN/CKAN/releases/tag/v1.28.0-PRE1

Edited by HebaruSan

Share this post


Link to post
Share on other sites

Side note, there are several new UI pieces in this pre-release, which by and large are pretty rough. I'm certainly no UI/UX designer, and as much as I appreciate his work I don't think @DasSkelett is, either. If you are a UI/UX person and you see ways to improve any of the new stuff (especially the download progress bars and search boxes), we would love to hear from you! Even something as simple as a png marked up with better ways to handle layout, alignment, etc., could allow us to improve the look and feel of the eventual full release.

Thanks in advance!

Share this post


Link to post
Share on other sites

Question: Why is it that if Waz said that EnvironmentalVisualEnhancements is specifically made to work with StockVisualEnhancements, CKAN would complain that it's a directly conflict with it?

 

Compatibility with other Mods

EVE is compatible with most mods, but in particular it is tested to inter-operate well with these visual mods:

  • Scatterer - makes atmospheres realistically "haze".
  • PlanetShine - makes the glow from planets/moons produce ambient light.
  • Stock Visual Terrain - make the terrain detail of the stock planets much better quality.

There are also a number of excellent mods that provide advanced configurations beyond the sample ones shipped alongside EVE:

Share this post


Link to post
Share on other sites
21 minutes ago, DefenderX1 said:

Question: Why is it that if Waz said that EnvironmentalVisualEnhancements is specifically made to work with StockVisualEnhancements, CKAN would complain that it's a directly conflict with it?

SVE conflicts with EnvironmentalVisualEnhancements-HR, which is the default/sample configuration of EVE. Since SVE is also "just" a configuration for EVE, you can't install it with the stock configs side by side.
But SVE doesn't conflict with EVE itself, nor the other way around.
To install SVE, you need to remove the default configs (named "Environmental Visual Enhancements - Stock Planet Config files" in CKAN, identifier "EnvironmentalVisualEnhancements-HR") first.

Share this post


Link to post
Share on other sites
On 7/1/2020 at 3:09 PM, HebaruSan said:

The CKAN client v1.28.0-PRE1 "Drake" is released!

This is a pre-release because there are several large changes that we expect will have bugs. This means that it is opt-in only; the client will not auto-update to this release. Please try it if you can and report any problems in the bug tracker:

Also comment below with your feedback. These changes will be included in a full release once we are confident they are solid.

https://github.com/KSP-CKAN/CKAN/releases/tag/v1.28.0-PRE1

Thanks to all those who have taken the plunge to test this out! If GitHub's download stats are any indication, we've got a fairly sizable group of beta testers out there. But so far we haven't received feedback, good or bad, from anybody:

Downloads total.svg?label=Drake&style=social
Forum posts 0
Issues submitted 0

I suppose we can consider no news to be good news, but if you notice anything off while running this build, please don't hesitate to point it out! And if everything seems OK, feel free to tell us that, too, since it would help us to understand how things are working out.

Share this post


Link to post
Share on other sites

@DasSkelett @HebaruSan I have a feature request/bug report.  I am using Drake.

If you revert to an older version of a mod that mod uninstalls and installs the version you request.  Which is good, but this also has a side effect of uninstalling mods dependent on the mod you change, but doesn't reinstall any of these..

Yesterday I updated ClickThruBlocker to latest.  Found the new version buggy so reverted to the previous version.  This had the side effect of uninstalling everything that had ClickThruBlocker as a dependency, i.e. (most of LGG's mods) But then didn't reinstall any of them.

Share this post


Link to post
Share on other sites
9 minutes ago, Tonka Crash said:

@DasSkelett @HebaruSan I have a feature request/bug report.  I am using Drake.

If you revert to an older version of a mod that mod uninstalls and installs the version you request.  Which is good, but this also has a side effect of uninstalling mods dependent on the mod you change, but doesn't reinstall any of these..

Yesterday I updated ClickThruBlocker to latest.  Found the new version buggy so reverted to the previous version.  This had the side effect of uninstalling everything that had ClickThruBlocker as a dependency, i.e. (most of LGG's mods) But then didn't reinstall any of them.

Thanks! Documented here for tracking:  https://github.com/KSP-CKAN/CKAN/issues/3098

think this would have worked the same in v1.27.2, since we haven't made many changes to the install flow recently. I'll take a look, but newly broken stuff or problems with new functionality will be a higher priority.

Share this post


Link to post
Share on other sites

CKAN believes I have installed RCS Build Aid, it has AD next to it.

This is preventing me from installing RCS Build Aid Continued.

I have nothing in my GameData folder related to either mod. Is there anyway to get CKAN to forget/ignore/RemoveTheADflag on the original RCS so I can install the correct version?

 

Share this post


Link to post
Share on other sites
3 hours ago, Cruesoe said:

CKAN believes I have installed RCS Build Aid, it has AD next to it.

This is preventing me from installing RCS Build Aid Continued.

I have nothing in my GameData folder related to either mod. Is there anyway to get CKAN to forget/ignore/RemoveTheADflag on the original RCS so I can install the correct version?

Have you tried clicking "Refresh"? That should re-run the scan for manually installed modules. If it still says "AD" after that, then try File → Open KSP Directory to make sure you're looking at the right folder.

Share this post


Link to post
Share on other sites
4 hours ago, HebaruSan said:

Have you tried clicking "Refresh"? That should re-run the scan for manually installed modules. If it still says "AD" after that, then try File → Open KSP Directory to make sure you're looking at the right folder.

Thanks. I resolved it after an epiphany. When I tried to remove RCSBuildAid I must of miss-clicked and dragged it inside another mods folder.  It was sitting there inside a subfolder giving me issues on CKAN.

Deleted it, properly this time, and everything works as it should.

User error, apologies all, carry on.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.