Jump to content

CKAN (The Comprehensive Kerbal Archive Network); v1.28.0 - Dyson


politas
 Share

Recommended Posts

New CKAN Release - v1.22.4 "Uchinoura"

450px-M-V_with_Astro-E_satellite.jpg

 

Japanese M-V rocket with Astro-E satellite in Uchinoura Space Center, Japan


Changes since 1.22.3

Bugfixes

  • [GUI] Update Forum Thread link to new thread (#2079 by: politas; reviewed: linuxgurugamer)
  • [core] Move downloads outside of gui transaction (#2073 by: archer884; reviewed: politas)
  • [CLI] Fix crash in "ckan available" with curly braces in mod name (#2111 by: HebaruSan; reviewed: politas)
  • [core] Check grandparent+ directories for find and find_regexp (#2120 by: HebaruSan; reviewed: politas)
  • [core] Add test to cover missing directory entries (#2125 by: HebaruSan; reviewed: politas)
  • [Build] Fix build.ps1 script failing when spaces exist in source path (#2121 by: ayan4m1; reviewed: dbent)
  • [core] Perform directory root comparison in case-insensitive way (#2122 by ayan4m1; reviewed: politas)
  • [Build] Expand .gitignore to handle packages in subdirectories and build output (#2116 by ayan4m1; reviewed: politas)
  • [GUI] Allow uninstall of incompatible mods in GUI (#1929 by ayan4m1; reviewed: politas)
  • [core] Loop to find max KSP version instead of assuming ordering (#2131 by hebaruSan; reviewed: politas)

Features

  • [GUI] Quit on ctrl-q and alt-f,x (#2132 by hebaruSan; reviewed: politas)

Notes

  • Windows users must have .NET 4.5 installed.
  • libcurl is no longer used by CKAN for Linux or Mac. If you experience problems downloading, please contact us
  • Mac/Linux/Mono users: please use the new cert-sync tool, to update mono's certificate store.
  • Mac Users: There is a MacOS CKAN App launcher available thanks to the wonderful Maxzhao.
  • This release of the CKAN has not been tested on Mono 3.2.8. We highly recommend upgrading to the latest stable release of Mono from mono-project.com You will need the equivalent of the mono-complete package for your OS.

Release image public domain, courtesy NASA

A sudden flood of bugfixes has pushed me to release a new version of the CKAN client (to be fair, a few of them have been in the dev branch for some time) Ayan4m1 is back from hibernation, and making some great contributions, but I have to give special props for this release to @HebaruSan, who has been making some great contributions both in code and metadata, and has joined the CKAN team. An excellent first contribution also by archer884, moving downloads outside the timed transaction for installs, which should prevent a few issues where a transaction fails simply because a download is slow.

Link to comment
Share on other sites

39 minutes ago, Botch said:

It's likely just me but I can't seem to find ckan.exe in latest build. I'm starting with newly DLed clean version of ksp on windows and DLed the .zip version  from github

It's still being built. Should be there in a few minutes. Ignore the .zip unless you want to build the code from scratch.

CKAN 1.22.3 had a new record for us of 145,936 client downloads, which as was noted earlier in the thread, pushed us over 1 million total downloads! Massive, massive thanks to the great @pjf and every other CKAN contributor individually and collectively, and especially to all of you users for putting your trust in us to look after your precious KSP installations! I am awed and humbled by it all.

 

Sorry for the delay. The ckan.exe file is there now!

Edited by politas
Link to comment
Share on other sites

So, I just went to install the latest CKAN update, and when it was at nearly finishing, it crashed.

So I decided to try to launch it and it says this:
"Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item."

Note, I'm on an admin account, and previous to updating, it was working.

Now, I try to go under the Control Panel to uninstall, but then, it's not on the list, so I tried to do it manually, and claims I need admin perms to remove the file (CKAN.exe) and refuses to do it, even if I click OK.

Anyway I can fix? 

Link to comment
Share on other sites

I don't understand why you people want to run CKAN as administrator. It is indicative that you have some serious issues with permissions on your PCs, that are not CKAN's fault. 

You should not be running CKAN as administrator!!!!!!! 

CKAN is not "installed" in the sense of a regular Windows app; it is simply an executable file that you run as required. Your ordinary user account should be able to run such executables on your own machine. Save ckan.exe in your user directory and run it from there. If it doesn't prompt you to select your KSP installation, open up RegEdit, Go to CurrentUser\software\ckan and delete everything, then try again, adding your KSP installation from scratch (select the BuildID.txt file, not the folder)

You should not be running CKAN as administrator!!!!!!! 

You should not be running CKAN as administrator!!!!!!! 

You should not be running CKAN as administrator!!!!!!! 

I don't know how seriously I can stress this. I believe CKAN is a safe application, but you are giving your entire computer over to an unsigned program downloaded from the Internet. This is such a bad idea that I am frankly astounded that anybody even considers it!

Link to comment
Share on other sites

New CKAN Release v1.22.5 "Xichang (西昌)"

68747470733a2f2f75706c6f61642e77696b696d

Changes since 1.22.4

Bugfixes

  • [GUI] Fix crash on startup (#2138 by HebaruSan; reviewed: Olympic1)
  • [Core] Fix exception installing some mods (#2137 by HebaruSan; reviewed: Olympic1)

Notes

  • Windows users must have .NET 4.5 installed.
  • libcurl is no longer used by CKAN for Linux or Mac. If you experience problems downloading, please contact us
  • Mac/Linux/Mono users: please use the new cert-sync tool, to update mono's certificate store.
  • Mac Users: There is a MacOS CKAN App launcher available thanks to the wonderful Maxzhao.
  • This release of the CKAN has not been tested on Mono 3.2.8. We highly recommend upgrading to the latest stable release of Mono from mono-project.com You will need the equivalent of the mono-complete package for your OS.

Release image CC-BY-SA, courtesy CGWIC

Once again, we've had to rush out a quick urgent bug-fix release. Excellent work by @HebaruSan identifying and fixing the bugs so quickly!

 

Edited by politas
Link to comment
Share on other sites

14 hours ago, ARandomSerpent said:

Note, I'm on an admin account

Why, in the name of Dog, are you running CKAN as administrator?
I hope this is not your usual user account, I thought that kind of foolery died with Win'98, when M$ stopped encouraging it.
Running as admin by default means anything you run has the ability to compromise your entire system, and will almost certainly lead to permissions issues at some point.
People doing this is half the reason Windoze is such a juicy target for malware and viruses. Don't do this. Bad Idea doesn't even begin to cover it.

 

9 hours ago, politas said:

you are giving your entire computer over to an unsigned program downloaded from the Internet. This is such a bad idea that I am frankly astounded that anybody even considers it!

This ^. x900. Gah.

 

14 hours ago, ARandomSerpent said:

Anyway I can fix?

This is not CKANs problem. It's a permissions problem caused by running as admin.
I'd suggest inspecting (and fixing) the offending file permissions, possibly from safe mode. Ask google for details.
Then again, if it were me I'd probably just nuke the whole OS install from orbit...

Edited by steve_v
Link to comment
Share on other sites

My CKAN says "Cannot find *insert mod* entry in zipfile to install" in some of the mods I try to install, or saying "Too many mods provide *insert mod*" if I try to install especially SVE, EVE or DOE. I have a completely clean GameData folder, and it haven't had mods ever. So is it a problem with CKAN 1.22.4, because it has never happened in previous CKAN versions?

Link to comment
Share on other sites

7 minutes ago, Carraux said:

The latest version has serious problems with SSL/TLS connections when downloading from Spacedock. Currently I am not able to download anything from Spacedock via CKAN.

No, spacedock's SSL certificate expired today 2017-10-15, I assume they'll have it in order soon.

Link to comment
Share on other sites

1 hour ago, herrozerro said:

spacedock's SSL certificate expired today 2017-10-15

I ran into this problem too, myself.

Failed to download "https://spacedock.info/mod/219/StageRecovery/download/1.7.2" - error: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.

Out of curiosity is there a way to temporarily tell CKAN to ignore this error accept all SSL certificates?  I thought the there was some kind of flag you could pass to the .Net libraries.

I tried installing the expired SpaceDock certificate to my Windows certificate store but not sure that actually did anything.

Appended EDIT: FYI 1.22.3 behaved nicely when the SSL error came up, but I think (?) there might be a regression as all I did was drop in the new CKAN version (1.22.5) and now I get a Kraken exception right after it hits the SSL error :-S.

Edited by Fwiffo
Link to comment
Share on other sites

I think that was the issue.   Good excuse to run my regular pruning of old cert files anyway.  It seems I had a couple dozen old files which have either been revoked or expired (likely expired.)  Several companies have consolidated their lower security keys under their high security keys as they expire now that it has been established what level of security is sufficient for a 20 year root key.

By using a secondary key signed by the root key for most key signing purposes, the use of the root key can be reduced and limited to a small amount of high-entropy data making it very hard to crack.

I guess I'll wait for SpaceDock to update their key then.  It should take around 48 hours, considering it expired on a weekend. 

Edited by Ruedii
More info.
Link to comment
Share on other sites

Getting an issue with CKAN crashing when selecting a mod that causes a popup (eg Distant Object Enhancement and any other that pops up asking you to choose a config). It's fine until I hit the 'Apply Changes' and install. I then get a crash saying:

 

************** Exception Text **************
CKAN.TooManyModsProvideKraken: Too many mods provide EnvironmentalVisualEnhancements-Config:
EnvironmentalVisualEnhancements-HR 2:EVE-1.2.2-1
* GPPCloudsHighRes 1.5.3
* GPPCloudsLowRes 1.5.3
* StockVisualEnhancements 3:1.2.7.0
   at CKAN.RelationshipResolver.ResolveStanza(IEnumerable`1 stanza, SelectionReason reason, RelationshipResolverOptions options, Boolean soft_resolve, IEnumerable`1 old_stanza)
   at CKAN.RelationshipResolver.Resolve(CkanModule module, RelationshipResolverOptions options, IEnumerable`1 old_stanza)
   at CKAN.RelationshipResolver.AddModulesToInstall(IEnumerable`1 modules)
   at CKAN.RelationshipResolver..ctor(IEnumerable`1 modules, RelationshipResolverOptions options, IRegistryQuerier registry, KspVersionCriteria kspversion)
   at CKAN.RelationshipResolver..ctor(IEnumerable`1 module_names, RelationshipResolverOptions options, IRegistryQuerier registry, KspVersionCriteria kspversion)
   at CKAN.ModuleInstaller.ResolveModules(IEnumerable`1 modules, RelationshipResolverOptions options)
   at CKAN.Main.InstallMods(Object sender, DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

 

 

**EDIT**
I should add that selecting the dependency config file first and then clicking on DOE or EVA, etc, it installs fine

Edited by Be4st
Link to comment
Share on other sites

Running into a lot of trouble with the latest CKAN.   1.22.5

1. The check boxes are very slow to click to select some items - for instance, which mod you want to install.  2-3 seconds of latency between click and checkmark appearing.

2. When trying to install Realism Overhaul - I get an error about "Too many mods provide RSS textures".  There are 3 RSS texture packs, and you have to pick one - this has always worked afaik.

https://imgur.com/a/2CYQV

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...