Jump to content

CKAN (The Comprehensive Kerbal Archive Network); v1.28.0 - Dyson


Recommended Posts

19 minutes ago, HebaruSan said:
1 hour ago, Titan 3001 said:

My CKAN will not open at all normally without throwing this error log

https://www.dropbox.com/s/3a1u6fh0ubr4te4/CKAN error log.txt?dl=0

Click Continue, then Refresh.

I tried that and I got another exception which I clicked continue and then my refresh page said that it couldn't connect to https://github.com/KSP-CKAN/CKAN-meta/archive.tar.gz and froze. I am not sure what is going on there. Do you want me to get the second error log?

Link to post
Share on other sites
17 hours ago, Titan 3001 said:

I tried that and I got another exception which I clicked continue and then my refresh page said that it couldn't connect to https://github.com/KSP-CKAN/CKAN-meta/archive.tar.gz and froze. I am not sure what is going on there. Do you want me to get the second error log?

Sounds a bit like this issue:

Can you post your observations there?

Link to post
Share on other sites

Hey guys, GPP has updated, but CKAN isn't showing the latest version of the main mod. The textures and visual parts (which are part of the main folder)  updated fine, but he main mod folder is still one version behind. I created an issue on ckan and linked my netkan for someone to look at and check for some errors. There shouldn't be but I have been wrong before.

Link to post
Share on other sites

One of my few complaints about this project is that every time I need to download an updated version of netkan.exe, I can't find it.

You really need to put a link to it on the CKAN page somewhere.

So, obviously I need it, can someone get me a good link?

Link to post
Share on other sites
1 minute ago, linuxgurugamer said:

One of my few complaints about this project is that every time I need to download an updated version of netkan.exe, I can't find it.

You really need to put a link to it on the CKAN page somewhere.

So, obviously I need it, can someone get me a good link?

The nightly build is always at:

Link to post
Share on other sites
3 minutes ago, linuxgurugamer said:

One of my few complaints about this project is that every time I need to download an updated version of netkan.exe, I can't find it.

You really need to put a link to it on the CKAN page somewhere.

So, obviously I need it, can someone get me a good link?

https://ckan-travis.s3.amazonaws.com/netkan.exe

Found it here:
https://github.com/KSP-CKAN/CKAN/wiki/Adding-a-mod-to-the-CKAN

Link to post
Share on other sites
4 minutes ago, linuxgurugamer said:

Now, what about putting a link to it on the main CKAN GitHub page?

It's a developer tool, not a user tool. The wiki link cited by @Galileo seems sufficient for me. But you're as much a member of the team as I am, for longer.

Link to post
Share on other sites
Just now, HebaruSan said:

It's a developer tool, not a user tool. The wiki link cited by @Galileo seems sufficient for me. But you're as much a member of the team as I am, for longer.

Yes, but I mainly look at PRs, I don't do coding.  I have plenty of other coding to do.

 

Link to post
Share on other sites
9 hours ago, HebaruSan said:

Sounds a bit like this issue:

Can you post your observations there?

Probably not there but I can give you the error log from after I click refresh. When I hit refresh an exception window opens up like when I try to open CKAN. I can click on buttons 'details' for the log, 'Quit' which will quit CKAN entirely and the last button is "Continue' which freezes on the update page that says i can't connect to the link already stated.

Here is the second error log https://www.dropbox.com/s/974dp2fhw9w8gos/CKAN error log 2.txt?dl=0

I also get this error when I start CKAN first with only a dismiss option Error in autoupdate: The request was aborted: Could not create SSL/TLS secure channel.

I cannot program at all, please help!

Link to post
Share on other sites
1 hour ago, Titan 3001 said:

Probably not there but I can give you the error log from after I click refresh. When I hit refresh an exception window opens up like when I try to open CKAN. I can click on buttons 'details' for the log, 'Quit' which will quit CKAN entirely and the last button is "Continue' which freezes on the update page that says i can't connect to the link already stated.

Here is the second error log https://www.dropbox.com/s/974dp2fhw9w8gos/CKAN error log 2.txt?dl=0

I also get this error when I start CKAN first with only a dismiss option Error in autoupdate: The request was aborted: Could not create SSL/TLS secure channel.

Hmm, this looks like a problem:

ckan
    Assembly Version: 1.22.0.0
    Win32 Version: 1.22.6
    CodeBase: file:///C:/Users/Allen/Documents/KSP%20mods/ckan.exe

The 1.22 versions no longer work. Try the latest version:

Link to post
Share on other sites
9 minutes ago, Topside08 said:

Alright I promise I'm not dumb what do I press to install only the mod and its dependency

Try using the "ckan compat" commands to add 1.2 as a compatible version:

njWVbUo.png

The "--allow-incompatible" flag only applies to the direct arguments provided on the command line at the moment, not dependencies.

Alternately, you could try "ckan install planetshine planetshine-config-default --allow-incompatible --no-recommends".

Link to post
Share on other sites
Spoiler

C:\...>ckan.exe install --no-recommends AnyResContinued
About to install...

 * AnyRes Continued 2.0.2.1 (spacedock.info, 44.2 KB)

Continue? [Y/n]

Downloading "https://spacedock.info/mod/1681/AnyRes Continued/download/2.0.2.1"
0 B/sec - downloading - 0 B left - 100%
Unhandled Exception: CKAN.InvalidModuleFileKraken: C:\Users\glalm\AppData\Local\Temp\tmp99E5.tmp has length 45239, should be 45237
   at CKAN.NetModuleCache.Store(CkanModule module, String path, String description, Boolean move)
   at CKAN.NetAsyncModulesDownloader.ModuleDownloadsComplete(NetModuleCache cache, Uri[] urls, String[] filenames, Exception[] errors)
   at CKAN.NetAsyncModulesDownloader.<>c__DisplayClass8_0.<DownloadModules>b__3(Uri[] _uris, String[] paths, Exception[] errors)
   at CKAN.NetAsyncDownloader.triggerCompleted(Uri[] file_urls, String[] file_paths, Exception[] errors)
   at CKAN.NetAsyncDownloader.FileDownloadComplete(Int32 index, Exception error)
   at System.Net.WebClient.OnDownloadFileCompleted(AsyncCompletedEventArgs e)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()

 

I'm sure there's a better place to report this but I'm not sure where that is I got the same error when installing with the GUI but CLI was easier to copy paste I'm installing for 1.3.1 the version CKAN is having issues installing is for 1.4.1 so i'm not sure thats right either

Edited by Topside08
Extra info
Link to post
Share on other sites

I am getting an error while updating Kerbalism mod. All other mods were updated successfully

KSP 1.41 - Kerbalism installed 1.4.0.1 - Update 1.4.0.2

Error message:

Spoiler

Unhandled exception:
CKAN.InvalidModuleFileKraken: C:\Users\kmock\AppData\Local\Temp\tmpAD4B.tmp has length 3722547, should be 3722557
   in CKAN.NetModuleCache.Store(CkanModule module, String path, String description, Boolean move)
   in CKAN.NetAsyncModulesDownloader.ModuleDownloadsComplete(NetModuleCache cache, Uri[] urls, String[] filenames, Exception[] errors)
   in CKAN.NetAsyncModulesDownloader.<>c__DisplayClass8_0.<DownloadModules>b__3(Uri[] _uris, String[] paths, Exception[] errors)
   in CKAN.NetAsyncDownloader.triggerCompleted(Uri[] file_urls, String[] file_paths, Exception[] errors)
   in CKAN.NetAsyncDownloader.FileDownloadComplete(Int32 index, Exception error)
   in System.Net.WebClient.OnDownloadFileCompleted(AsyncCompletedEventArgs e)
   in System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   in System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   in System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   in System.Threading.ThreadPoolWorkQueue.Dispatch()

 

Link to post
Share on other sites
7 hours ago, Bersagliere81 said:

I am getting an error while updating Kerbalism mod. All other mods were updated successfully

KSP 1.41 - Kerbalism installed 1.4.0.1 - Update 1.4.0.2

Made some changes, click Refresh and try again.

Link to post
Share on other sites
  • Geonovast locked and unpinned this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...