linuxgurugamer

[1.5.*] BetterTimeWarpContinued - Customizable Time Warp, and Lossless Physics Warp

Recommended Posts

This is a continuation of the Better Time Warp mod originally made by @MrHappyFace, who hasn't been around since Sept. 3.  The original thread can be found here:http://forum.kerbalspaceprogram.com/index.php?/topic/77565-*

This first post is mostly copied from the original thread

Download: http://spacedock.info/mod/1162/BetterTimeWarpContinued

Source:https://github.com/linuxgurugamer/BetterTimeWarp

License:  GPLv3

The new version for KSP 1.4.1 has new dependencies

New Dependencies

CKAN has been updated to install the dependencies, if needed.

Basic GUI:

hkJmQxT.png

 

Advanced GUI with Settings:

7DJrzKZ.png

Gifs:

Without Lossless Physics Warp: http://gfycat.com/ObedientFlawedArctichare

With Lossless Physics Warp: http://gfycat.com/DeepSkeletalKoala

1,000,000x time warp in low orbit: http://gfycat.com/GrandNervousGoldfinch

 

Better Time Warp is HappyFaceIndustries' first mod, which adds the ability to customize your time warp.

It has many of the same features as Time Control, and WarpUnlocker, but with a stylish UI and customization features.

Features:

 

  • Customizable physics and regular (On-Rails) warp
  • Lower-than-1 physics warp can be used to help with laggy, high part ships. It is also pretty good for cinematics
  • 0x time warp can be used to freeze time
  • Great for ion engines! 1 hour burn completed in 3 minutes at 20x physical warp.
  • Higher warp settings can be used in lower orbits
  • Lossless Physics, meaning that you can keep accurate physics simulation even at high physical time warp
  • Non-Intrusive UI, which can be disabled using F2
  • Can be enabled/disabled in the settings file, without uninstalling or deleting
  • Self regenerating settings file
  • Persistent time warp selections
  • Works in space center and tracking station
  • All planets get the same altitude limits for time warp: 0m for 1-1000, 100,000m for 10,000x, and 2,000,000m for 100,000x

 

Bugs:

 

  • Physics warp below x0.1 or above x100 is kind of buggy
  • Rarely, if using low (less than 0.1) physics warp on EVA, your kerbal will go flying off at about 7x light speed
  • More will be added to this list as they are found.

 

Donations gratefully accepted
Patreon.png

 

Edited by linuxgurugamer
  • Like 26

Share this post


Link to post
Share on other sites
11 hours ago, Theglitchofthekraken said:

Well, it doesn't show up for me.

If you mean "in CKAN", take that up with CKAN. They're quick to fix the metadata but they don't always know it's not there.

Share this post


Link to post
Share on other sites

@linuxgurugamer some bugreport: settings.dat file generates in \BetterTimeWarp\settings.dat ignoring existing BetterTimeWarp\PluginData\settings.dat

PS: Thx for your effort! :)

Share this post


Link to post
Share on other sites
14 hours ago, Theglitchofthekraken said:

Well, it doesn't show up for me.

Be a little patient, CKAN isn't not instantaneous.

Adding a new mod to CKAN needs manual intervention to avoid mistakes.  

For now, install it by hand

52 minutes ago, ZobrAA said:

@linuxgurugamer some bugreport: settings.dat file generates in \BetterTimeWarp\settings.dat ignoring existing BetterTimeWarp\PluginData\settings.dat

PS: Thx for your effort! :)

Thanks, will fix and update soon

  • Like 1

Share this post


Link to post
Share on other sites
22 hours ago, linuxgurugamer said:

Rarely, if using low (less than 0.1) physics warp on EVA, your kerbal will go flying off at about 7x light speed

That could be a mod on its own :D

Thanks for maintaining another mod :)

Share this post


Link to post
Share on other sites

New release 2.3.1

  • Changed settings file to live in PluginData as a true .cfg file
  • Fixed "enabled" setting in cfg file to be in a node
  • Updated link in Readme.md file
     

Please note that old settings are NOT preserved, you will need to reenter any custom changes

  • Like 3

Share this post


Link to post
Share on other sites

I have noticed that the " Better Time Warp" button in flight is placed right on top of the signal strength. Is it possible to move it somehow?

Share this post


Link to post
Share on other sites

Excellent mod! Thanks for updating it! The mod works for me but I have some interface issues.

One is that there no 'big B' button in flight or in map mode - only in space center and in tracking station. If I open the window in KSC then it stays on screen also for flight and I can only use it this way. Selecting new warp speeds in tracking station has no influence when I go to a ship.

The second issue appears is that after going flying a ship all previously created 'profiles' in tracking station are gone.

Third is that when I create a 'profile' and then try to delete it there is a popup window confirming the deletion but this little popup cannot be closed other than by exiting KSP.

 

Edit: I have B button in flight now... I've removed KER and installed MechJeb instead in the meantime. I've also noticed the small button on top of signal strength now too - it's quite inconvenient and I would prefer to only have a toolbar button. Deletion issue still persists.

Edited by Raphaello

Share this post


Link to post
Share on other sites

I'm glad to see you have taken this up! You're a busy kerbal these days.

I appreciate you may just be planning to do maintenance, but there are two features I would like to see in a timewarp mod:

  • display of the current physical time ratio (I used to use a KerboKatz mod to see this but it seems to have got lost somewhere around 1.0).
  • A facility to dynamically adjust the physwarp factor to maintain a given physical time ratio.

When circumnavigating in a rover with a fat part count, a bit of physwarp doesn't really seem to do much harm. The rover is bumping along the ground at 20 m/s, not zooming through the atmosphere at 2000 m/s. However if the physical time ratio drops below 1, an already-long drive around a planet can get reeeeally long - and one is getting an unfair advantage with effectively superkerbal reflexes when approaching hazards.

Just wishlist stuff, but thanks for considering it!

  • Like 1

Share this post


Link to post
Share on other sites

It is back! Using a nuclear tug with 0.05 TWR and Time Control was only letting me do 5.4x physical where I got 1fps while accelerating. With this I was able to do 30x physical warp at 0.2-0.3FPS. 372 part vessel  =)

Share this post


Link to post
Share on other sites

Any chance you could add an option in the settings cfg file to disable the button in game? It takes up valuable real estate and at least for me, it's only something I use once in an entire game. Or maybe have it appear only when viewing the KSC.

Share this post


Link to post
Share on other sites
13 hours ago, MalevolentNinja said:

Any chance you could add an option in the settings cfg file to disable the button in game? It takes up valuable real estate and at least for me, it's only something I use once in an entire game. Or maybe have it appear only when viewing the KSC.

I've made an enhancement request to keep track of it.

In the meantime, why not try Janitor's Closet?  Latest version is here:  https://github.com/linuxgurugamer/JanitorsCloset/releases/tag/0.2.11.5

This version is a beta, but it's only bug fixes, and I expect to release this as a full release in a day or so.  It is also available in CKAN

 

 

Edited by linuxgurugamer
  • Like 1

Share this post


Link to post
Share on other sites

I had no idea your excellent Janitor's Closet mod could hide toolbar buttons.  Thanks.

 

My game is starting to look like a LGG complete overhaul for KSP :)

Edited by MalevolentNinja

Share this post


Link to post
Share on other sites

I have it installed but ill be damned if I can figure out how to use it. Hitting the > key still only goes so high depending on altitude. Alt-> still only allows up to 4x speed so i must be doing something wrong. 

I see the settings at the top but how do I choose a faster speed?

Share this post


Link to post
Share on other sites

Am I the only one here who can't access the UI in flight? :huh: The characteristic B button to bring it up is nowhere to be seen outside the space center/tracking station, which is extremely irritating since I have a situation where I routinely want to switch between regular and massive overkill physics warp right in the middle of an ascent. This should be possible given the use of the UI at the launchpad the pictures.

EDIT: I got it working in flight, but the UI has a number of issues. I can't move the thing out of the way or minimize it or indeed hide it with the annoyingly non-existent B icon.

Edited by wadusher1

Share this post


Link to post
Share on other sites
8 hours ago, Biggen said:

I have it installed but ill be damned if I can figure out how to use it. Hitting the > key still only goes so high depending on altitude. Alt-> still only allows up to 4x speed so i must be doing something wrong. 

I see the settings at the top but how do I choose a faster speed?

Do you see the B icon on the toolbar?    You will still be limited in atmosphere

7 hours ago, wadusher1 said:

Am I the only one here who can't access the UI in flight? :huh: The characteristic B button to bring it up is nowhere to be seen outside the space center/tracking station, which is extremely irritating since I have a situation where I routinely want to switch between regular and massive overkill physics warp right in the middle of an ascent. This should be possible given the use of the UI at the launchpad the pictures.

EDIT: I got it working in flight, but the UI has a number of issues. I can't move the thing out of the way or minimize it or indeed hide it with the annoyingly non-existent B icon.

Can you elaborate?

In addition to the button on the toolbar, there is a little down arrow at the top where you can open up the window.  

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

The UI is a bit confusing, especially since there aren't defaults installed.  I'm going to write up some instructions, and maybe add some defaults as well

There is a bug, the initial custom defaults aren't installed

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

I just released an update:  2.3.2

  • Renamed settings.dat to BetterTimeWarp.cfg

I had forgotten to rename a file, so the defaults weren't there.

If you have already set up values, then you don't need this.

If you haven't, then this is very important:

YOU MUST DELETE THE PluginData DIRECTORY BEFORE INSTALLING THIS. Deleting the entire directory works as well.

THIS GOES DOUBLE FOR CKAN!!!!

This is an odd case with CKAN, where I've put a file in which CKAN will consider to be a new file, and won't overwrite the existing file

Share this post


Link to post
Share on other sites
11 hours ago, wadusher1 said:

EDIT: I got it working in flight, but the UI has a number of issues. I can't move the thing out of the way or minimize it or indeed hide it with the annoyingly non-existent B icon.

I'm working on adding an option to hide the B icon.  But other than that, your issues don't make sense.

Please double-check your install, if it is still happening with the newest release, please post a link to a log file.

Share this post


Link to post
Share on other sites
4 hours ago, linuxgurugamer said:

Do you see the B icon on the toolbar?    You will still be limited in atmosphere

Can you elaborate?

In addition to the button on the toolbar, there is a little down arrow at the top where you can open up the window.  

The B icon is there in the space center but not in flight. I can get the window in flight by having it open in the space center then going to the VAB and to a spacecraft, but then I can't move it or turn it off. Also, in-flight that little arrow does nothing. I haven't tested if the arrow works in the space center.

I have no clue if I'm using the latest version. I'll re-download it and see if the problem persists. As for toggling the B icon, I suggest keeping it in the toolbar in flight by default. I'll take toolbar clutter over a confusing UI any day. :)

Edited by wadusher1

Share this post


Link to post
Share on other sites
1 hour ago, wadusher1 said:

The B icon is there in the space center but not in flight. I can get the window in flight by having it open in the space center then going to the VAB and to a spacecraft, but then I can't move it or turn it off. Also, in-flight that little arrow does nothing. I haven't tested if the arrow works in the space center.

I have no clue if I'm using the latest version. I'll re-download it and see if the problem persists. As for toggling the B icon, I suggest keeping it in the toolbar in flight by default. I'll take toolbar clutter over a confusing UI any day. :)

It will be there by default, I had requests to have an option to be able to disable it.  

Sounds like I need your log file please.

And to relieve your toolbar clutter, you can try using The Janitor's Closet

Edited by linuxgurugamer
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now