linuxgurugamer

[1.9.x] BetterTimeWarpContinued - Customizable Time Warp, and Lossless Physics Warp

Recommended Posts

Just now, linuxgurugamer said:

OK, sounds like a directory got changed.  I'll look into it

Much appreciated :) 

Share this post


Link to post
Share on other sites

I'm having some trouble when my craft go into time warp, where they jump to another location in space as soon as I go into time warp. I've only seen it after I installed this mod. Anyone familiar with this?

Share this post


Link to post
Share on other sites
7 hours ago, AmpCat said:

I'm having some trouble when my craft go into time warp, where they jump to another location in space as soon as I go into time warp. I've only seen it after I installed this mod. Anyone familiar with this?

I've met 2 problems with this mod :

  • When I use lose-less physical warp during docking maneuvers, the ships appear to move relatively to each other (target ship appears to shift to another point in space, at a distance that does not evolve over time but depends on the warp level). However, it is not impactfull since stopping time warp sends the ships back to the position they were before. --> considering the lack of impact and the fact my install is not the cleanest ever, I don't want to bother LGG with that.
  • In the past, I've had ship orbits evolve over time (phantom forces during warp). I don't remember what was causing it (maybe not even this mod) but it was just a bad install.

Could you give some more details about your problem ? Any log info ?

Share this post


Link to post
Share on other sites
12 hours ago, Altaille said:

I've met 2 problems with this mod :

  • When I use lose-less physical warp during docking maneuvers, the ships appear to move relatively to each other (target ship appears to shift to another point in space, at a distance that does not evolve over time but depends on the warp level). However, it is not impactfull since stopping time warp sends the ships back to the position they were before. --> considering the lack of impact and the fact my install is not the cleanest ever, I don't want to bother LGG with that.
  • In the past, I've had ship orbits evolve over time (phantom forces during warp). I don't remember what was causing it (maybe not even this mod) but it was just a bad install.

Could you give some more details about your problem ? Any log info ?

I just noticed it again last night while in the middle of testing something, but sometimes restarting the game seems to fix it. I'll try it again and see.

Basically, what seems to happen is I'll do something like set up an intercept to the Mun, and the conics will show me making a good capture, but as soon as I hit any time warp (even just 5), the conic suddenly jumps to me WAY undershooting the Mun. Then coming out of time warp, I have to do another burn to get back on course. Usually the second one works properly. Last night I was noticing it when I tried to use MechJeb's landing guidance tool. It occasionally jumps to x5 time warp, and the whole ship would lurch way off, as if the positional math going into time-warp had the wrong initial conditions.

I'll see if it happens again. Last time I had a big problem with this, uninstalling better time warp didn't fix it, but a clean install (and then reinstalling all the same mods) did. I only have seen it again after putting better time warp back in, but not right off. Seems something, somewhere, gets corrupted.

Edit: It didn't seem to show up while in an orbit, but if I were trying to intercept and dock to another ship, even if we were both in stable orbits, it would sometimes occur.

Edited by AmpCat

Share this post


Link to post
Share on other sites
12 hours ago, Altaille said:

When I use lose-less physical warp during docking maneuvers, the ships appear to move relatively to each other (target ship appears to shift to another point in space, at a distance that does not evolve over time but depends on the warp level)

That is KSP.  If you do the same thing without this mod, you will see the same thing.

Share this post


Link to post
Share on other sites

Okay, trying it again in a simple orbit around the Mun at 9k. It does happen any time I go into time warp, (even in orbit) but not when I increase warp, slow it down, or come out. I seem to be jumping about 2 degrees around the orbit each time I go in. Physics warp (and the slow-mo option in Better Time Warp) doesn't cause an issue. Hyper time warp setting causes a large jump, but possibly because the first warp setting is x10, rather than x5. It does seem to jump approximately twice as far, but hard to pin an exact number on it.

Here's a link to some logs. Let me know if there's another log file that might be helpful. Going to try removing the mod it and see how it behaves.

https://drive.google.com/drive/folders/1bkDjVVgZh7I3Qcs24KXr4kOSCgQ9fa7C?usp=sharing

Edit: Uninstalled, didn't seem to help too much, though the jump ahead now seems only about 1 degree, rather than 2 before. Maybe I'm just seeing things. Going to try a clean install next. Anyone know of any other mods that fiddle with the physics in vacuum that might be doing this? 

Edited by AmpCat

Share this post


Link to post
Share on other sites

Okay, so I did a clean install, deleted everything but my saves and settings.cfg, and I'm still getting the little lurch, so no change from just uninstalling better time warp. The big difference is that while the lurch isn't as big, the problem I had earlier was using something like the Landing Guidance in MechJeb or doing a planet intercept, it doesn't throw my actual trajectory off anymore. With landing it'd throw me off enough to crash into the ground or something, while on intercepts I'd be fine and lined up, then suddenly after a short timewarp I was no longer even getting near the gravity well.

I don't think it's conclusive evidence that BetterTimeWarp is really the root cause or not, but it does start pointing some fingers. If it occurs again and/or I decide to install the mod again, I'll update you guys.

Edit: For clarification, there was no difference in the clean install vs deleting the mod. Including those changes where it'd lurch bad during a descent. Just deleting the mod seemed to make the difference, but it's not conclusive.

Edited by AmpCat

Share this post


Link to post
Share on other sites
On 9/22/2019 at 11:19 PM, linuxgurugamer said:

That is KSP.  If you do the same thing without this mod, you will see the same thing.

Stupid me, looks like I should play stock more !

Thanks for continuing this mod. I think I would never play with electric engines without it.

Share this post


Link to post
Share on other sites
On 9/23/2019 at 3:46 AM, AmpCat said:

Okay, so I did a clean install, deleted everything but my saves and settings.cfg, and I'm still getting the little lurch, so no change from just uninstalling better time warp. The big difference is that while the lurch isn't as big, the problem I had earlier was using something like the Landing Guidance in MechJeb or doing a planet intercept, it doesn't throw my actual trajectory off anymore. With landing it'd throw me off enough to crash into the ground or something, while on intercepts I'd be fine and lined up, then suddenly after a short timewarp I was no longer even getting near the gravity well.

I don't think it's conclusive evidence that BetterTimeWarp is really the root cause or not, but it does start pointing some fingers. If it occurs again and/or I decide to install the mod again, I'll update you guys.

Edit: For clarification, there was no difference in the clean install vs deleting the mod. Including those changes where it'd lurch bad during a descent. Just deleting the mod seemed to make the difference, but it's not conclusive.

I had this exact problem, for me it happened when I had Breaking Ground robotics on-board that weren't locked. I thought it may have had to do with the ReCoupler mod, but I see you do not have that one installed. Were there robotics parts on the vessel when this happened?

Edited by Jognt

Share this post


Link to post
Share on other sites
2 hours ago, Jognt said:

I had this exact problem, for me it happened when I had Breaking Ground robotics on-board that weren't locked. I thought it may have had to do with the ReCoupler mod, but I see you do not have that one installed. Were there robotics parts on the vessel when this happened?

No, no robotics parts on this one. It does have a scanning arm from breaking ground, as well as ground science experiments.

Share this post


Link to post
Share on other sites

I've got a 3 Hour burn scheduled and really need to get this work. Whatever I seem to do I just get the Cannot warp when accelerating" warning. Is there  a simple duffers guide anywhere? I tried the Readme in the folder, but it seems truncated.

I've tried holding down left Alt as I click the second triange... nothing seems to work.

 

Cheers for any pointers.

 

SJ

 

Share this post


Link to post
Share on other sites
6 minutes ago, serjames said:

I've got a 3 Hour burn scheduled and really need to get this work. Whatever I seem to do I just get the Cannot warp when accelerating" warning. Is there  a simple duffers guide anywhere? I tried the Readme in the folder, but it seems truncated.

I've tried holding down left Alt as I click the second triange... nothing seems to work.

 

Cheers for any pointers.

 

SJ

 

I believe it is shift, not alt

Share this post


Link to post
Share on other sites

I cannot seem to get this mod to work on 1.6.1. I do have tons of other mods. I have installed ToolbarControl and ClickThroughBlocker with 1.6.1 versions and the toolbar works fine, it just has no BetterTimeWarp tab. Any ideas?

Share this post


Link to post
Share on other sites

Hi,

Sorry. Still not working. Most frustrating. Am in the middle of this blooming nuclear burn... and cannot get it to work. Do I have to preselect any of the settings. Can someone walk me through exactly where I'm going wrong with this ? :-/

What I've done:

1) Clicked the drop down arrow.

2) Selected Hyper warp

3) Hold down Shift (or alt) and then click the second warp arrow ?

Share this post


Link to post
Share on other sites
19 hours ago, serjames said:

Hi,

Sorry. Still not working. Most frustrating. Am in the middle of this blooming nuclear burn... and cannot get it to work. Do I have to preselect any of the settings. Can someone walk me through exactly where I'm going wrong with this ? :-/

What I've done:

1) Clicked the drop down arrow.

2) Selected Hyper warp

3) Hold down Shift (or alt) and then click the second warp arrow ?

Alt + > should give you physwarp.. you can tell which warp you’re in by the amount of grey/green triangles in the top left. 

If you alt+warp without throttle, do you see only 4 triangles in Total? If so, thats physwarp. If more, its freezewarp. 

Share this post


Link to post
Share on other sites

Hi Space, Nerd, thanks for the heads up. I'm actually 99% sure I did try ALL the options in the drop down. Is it possible I have missed something somewhere ?

I will uninstall the mod and try and re-install.

 

Magically I managed to get the game to stay stable minimised in the background for the 3.5hrs it took to run the burn last night.... Miracle in itself frankly :-) I watched some of Roverdudes videos instead.....

 

Will try again tonight - cheers.


SJ

1 minute ago, Jognt said:

Alt + > should give you physwarp.. you can tell which warp you’re in by the amount of grey/green triangles in the top left. 

If you alt+warp without throttle, do you see only 4 triangles in Total? If so, thats physwarp. If more, its freezewarp. 

Will check - thanks for confirming Alt... I've tried both... anyone got a link to a youtube of this actually working ? I've tried looking :-)

Share this post


Link to post
Share on other sites

Ok, solved. I was clicking the green warp arrows.

 

The correct procedure is to select Hyper warp OR Physics warp.

Then hold left ALT and Press the "." button ("." or ">") on the KEYBOARD  :-)

Thanks for your patience with me... I blame the age / or alcohol...

Edited by serjames

Share this post


Link to post
Share on other sites
2 hours ago, serjames said:

Ok, solved. I was clicking the green warp arrows.

 

The correct procedure is to select Hyper warp OR Physics warp.

Then hold left ALT and Press the "." button ("." or ">") on the KEYBOARD  :-)

Thanks for your patience with me... I blame the age / or alcohol...

Cheers! I’ll blame the inconsistent interaction design though. 

Holding ALT while clicking the warp arrows should also enable physwarp. Because it would make sense. 

Share this post


Link to post
Share on other sites
12 hours ago, serjames said:

Then hold left ALT and Press the "." button ("." or ">") on the KEYBOARD 

In case anyone else has this problem, it is worth mentioning that KSP's Mod key is OS-specific. It is Alt only on Windows.

Share this post


Link to post
Share on other sites

It doesn't seem to be working for me. I extracted it but it doesn't seem to work, since the arrow to the side of of the time warp thing doesn't show. Does this work with 1.7.3 too or only with 1.7.2?

Share this post


Link to post
Share on other sites
17 minutes ago, AnFa said:

It doesn't seem to be working for me. I extracted it but it doesn't seem to work, since the arrow to the side of of the time warp thing doesn't show. Does this work with 1.7.3 too or only with 1.7.2?

Sounds like you are missing the dependencies:

New Dependencies

Share this post


Link to post
Share on other sites

I created a new setting called "RSS" with time warp factors from Real Solar System. It works fine. But everytime I leave VAB the Standard Warp Setting is activated again. Did I miss fixing the choosen setting?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.