DoctorDavinci

[1.4.x] BDArmory Continued v1.2.2.2 [8/8/2018] + Vessel Mover, Camera Tools, BDMk22, Destruction Effects, Burn Together

Recommended Posts

12 minutes ago, XOC2008 said:

re: camera bias. I have noticed on some occasions that an aircraft will refuse to fire until you switch to and away from it. Not sure if that's camera bias or something hanging in the code but it will continue to pick a weapon and chase and never fire until you switch vessels. This has happened for some time.

Yes I have seen that too but I was told it may have to do with BDA thinking a weapon has an obstruction. It might have something to do with missile rails. I was told to shorten the length to it's smallest and give it a couple clicks on the height so the fins of the missiles aren't clipped. You can scroll up and look at the previous pages to see my posts and the Dev's responses.

Edited by greydragon70

Share this post


Link to post
Share on other sites
2 minutes ago, greydragon70 said:

Yes I have seen that too but I was told it may have to do with BDA thinking a weapon has an obstruction. It might have something to do with missile rails. I was told to shorten the length to it's smallest and give it a couple clicks on the height so the fins of the missiles aren't clipped. You can scroll up and look at the previous page to see my posts and the Dev's responses.

I know. I'm a tester for BDAc and SM Industries, just tossing in my observations as well to see if it helps at all. It's not always related to an obstruction, and is really unclear what causes it. I've seen it primarily with guns, not so much with missiles since I usually use Red Vs Blue rails and pylons. It HAS happened less with newer versions so perhaps that wrinkle is finally being ironed out.

Share this post


Link to post
Share on other sites
1 hour ago, XOC2008 said:

I know. I'm a tester for BDAc and SM Industries, just tossing in my observations as well to see if it helps at all. It's not always related to an obstruction, and is really unclear what causes it. I've seen it primarily with guns, not so much with missiles since I usually use Red Vs Blue rails and pylons. It HAS happened less with newer versions so perhaps that wrinkle is finally being ironed out.

I have also noticed an "observer bias" where observed teams of same aircraft consistently lose matches by either not firing weapons or pulling harder on the controls than the other team's equivalents, and one of my friends have also noticed the same. I've mitigated it by testing from a spectatir that's a cockpit with a few i-beams to keep it straight which I named "the judge" and it fixed the problem. Would be interesting to know the reason of this.

Share this post


Link to post
Share on other sites

I tested quite a bit with the universal ammo box. It seemed to be broken. 

Reproduction steps:

1. Have a vulcan turret and a universa;l ammo box.

2. fire the vulcan turret.

Share this post


Link to post
Share on other sites
20 minutes ago, Xd the great said:

I tested quite a bit with the universal ammo box. It seemed to be broken. 

Reproduction steps:

1. Have a vulcan turret and a universa;l ammo box.

2. fire the vulcan turret.

1. Did you set the ammo in the ammo box to the correct ammo for the weapon?

2. Provide a log.

(I know for a fact the universal ammo box works fine on my install so I feel there is a conflict somewhere if you did not set the ammo)

Share this post


Link to post
Share on other sites
1 hour ago, XOC2008 said:

1. Did you set the ammo in the ammo box to the correct ammo for the weapon?

2. Provide a log.

(I know for a fact the universal ammo box works fine on my install so I feel there is a conflict somewhere if you did not set the ammo)

I doubt if I have to set ammo (I didnt have to do that before), but i didnt and there is no such option on the right click popup

Share this post


Link to post
Share on other sites
2 hours ago, NotAnAimbot said:

I have also noticed an "observer bias" where observed teams of same aircraft consistently lose matches by either not firing weapons or pulling harder on the controls than the other team's equivalents, and one of my friends have also noticed the same. I've mitigated it by testing from a spectatir that's a cockpit with a few i-beams to keep it straight which I named "the judge" and it fixed the problem. Would be interesting to know the reason of this.

I have noticed that too... I was getting angry that my super jet fighter that was better on paper kept losing to an inferior model. I switched the camera point of view to the enemy to understand what it was doing that was so good and alas... now they lost 4 times in a row. Dunno.

Share this post


Link to post
Share on other sites
1 hour ago, Xd the great said:

I doubt if I have to set ammo (I didnt have to do that before), but i didnt and there is no such option on the right click popup

Then there is something wrong because you have to set the ammo type on the universal ammo box in the SPH/VAB for the weapon  utilizing it. And I know that it has always needed to be set for the correct ammo. The only ammo boxes not needing set are the dedicated 20mm, 30mm, 50cal, and cannonshell boxes.

Share this post


Link to post
Share on other sites
3 hours ago, XOC2008 said:

Then there is something wrong because you have to set the ammo type on the universal ammo box in the SPH/VAB for the weapon  utilizing it. And I know that it has always needed to be set for the correct ammo. The only ammo boxes not needing set are the dedicated 20mm, 30mm, 50cal, and cannonshell boxes.

Alright, will try reinstalling.

Share this post


Link to post
Share on other sites
8 hours ago, XOC2008 said:

re: camera bias. I have noticed on some occasions that an aircraft will refuse to fire until you switch to and away from it. Not sure if that's camera bias or something hanging in the code but it will continue to pick a weapon and chase and never fire until you switch vessels. This has happened for some time.

I have seen before that if you are hovering with the mouse over the vessel switcher/bda gui then the active vessel will not fire.

Share this post


Link to post
Share on other sites
5 hours ago, XOC2008 said:

Then there is something wrong because you have to set the ammo type on the universal ammo box in the SPH/VAB for the weapon  utilizing it. And I know that it has always needed to be set for the correct ammo. The only ammo boxes not needing set are the dedicated 20mm, 30mm, 50cal, and cannonshell boxes.

Do i rightclick or use the action group menu?

Share this post


Link to post
Share on other sites
16 minutes ago, Xd the great said:

Do i rightclick or use the action group menu?

It's a right click menu...

Share this post


Link to post
Share on other sites
2 hours ago, XOC2008 said:

It's a right click menu...

The universal ammo box is based on the firespitter tank contents switcher,  as such , it will be non functional if you do not have firespitters  dll  installed.  With all the dependencies  correct  you will still have to select the correct ammo for the weapon,  The Universal Ammo box does not contain some miracle all purpose ammunition ( never has ) It provides universal storage for many different ammo types ,  removing the need to add 40 or more different ammo boxes to BDA (which would be silly)

  Method of use, ensure you have the FireSpitter dll (about time this function was brought in house really) Check the editor menu for the type of ammo the weapon needs,  fit weapon to craft , fit universal ammo box,  right click the ammo box  and click the next tank setup button until  the correct ammo shows for the weapon. Fit weapon manager ,  It is now ready for use. 

NOTE,  not all listed ammo types listed in the part cfg  may show, several types are specific to other weapon mods, and if the other mod is not installed that ammo type will not be available for selection.

Edited by SpannerMonkey(smce)

Share this post


Link to post
Share on other sites

Im very confused on how to install BDA for KSP 1.4.3 I did a fresh install of the game, a fresh install of bda, and then it says modual manager is missing. please help!!! im very new to ksp mods so help is very very deeply appreciated.  Thanks to the development team for making such a great mod! 

Share this post


Link to post
Share on other sites
19 hours ago, greydragon70 said:

I have noticed on some occasions that an aircraft will refuse to fire until you switch to and away from it.

I believe this also has something to do with BDAc's clearance check... it seems that these clearance check rules are relaxed if the vessel that was not launching missiles suddenly isn't the active vessel anymore.

That's my observations anyway.

Share this post


Link to post
Share on other sites
5 hours ago, Ian Luedke said:

Im very confused on how to install BDA for KSP 1.4.3 I did a fresh install of the game, a fresh install of bda, and then it says modual manager is missing. please help!!! im very new to ksp mods so help is very very deeply appreciated.  Thanks to the development team for making such a great mod! 

Module Manager is a required dependancy ... please visit the thread below and install as directed

 

Share this post


Link to post
Share on other sites
2 hours ago, Soulless_R6 said:

Just thought I'd say hi and thanx for the teams efforts in keeping the explosions going :wink:

Welcome to the forum :wink:

Glad to see the approval of your first post go through so quickly

Edited by DoctorDavinci

Share this post


Link to post
Share on other sites

having a problem with the flight ai, my planes will go up very slowly and once they hit the minimum alititude they immediatley dive below the minimum altitude and start the cycle all over again, they never kill each other

Share this post


Link to post
Share on other sites
2 minutes ago, AtleSt said:

having a problem with the flight ai, my planes will go up very slowly and once they hit the minimum alititude they immediatley dive below the minimum altitude and start the cycle all over again, they never kill each other

Sounds like you need more powerful engines or more engines ... how heavy is your aircraft? .... modded engines or stock? .... how many engines?

Your description is quite vague ... more context please :)

Share this post


Link to post
Share on other sites

ok, the planes are pretty weak (biplanes) they are using modded propellers (airplane plus) and the engines are pretty useless. i could probably understand why the ai cant handle it

Edited by AtleSt

Share this post


Link to post
Share on other sites
7 minutes ago, AtleSt said:

ok, the planes are pretty weak (biplanes) they are using modded propellers (airplane plus) and the engines are pretty useless. i could probably understand why the ai cant handle it

Airplane plus is the problem ... solution is to not use airplane plus

We have no control over AP+ and can not guarantee that BDAc will work as advertised if using AP+ parts on your craft ... if this is not acceptable to you then please refer to the AP+ thread and ask to have the issue fixed ... nothing we can do about it as we have no control over the AP+ mod

TL;DR is if your using AP+ parts and experiencing an issue whith BDAc it's not our issue, take it the to AP+ thread as we have no control over the situation ... Either AP+ fixes itself to work with BDAc or you're pooched, nothing we can do about it as AP+ is not in within our control

Edited by DoctorDavinci

Share this post


Link to post
Share on other sites
1 minute ago, DoctorDavinci said:

Airplane plus is the problem ... solution is to not use airplane plus

We have no control over AP+ and can not guarantee that BDAc will work as advertised if using AP+ parts on your craft ... if this is not acceptable to you then please refer to the AP+ thread and ask to have the issue fixed ... nothing we can do about it as we have no control over the AP+ mod

TL;DR is if your using AP+ parts and experiencing an issue whith BDAc it's not our issue, take it the to AP+ thread as we have no control over the situation ... Either AP+ fixes itself to work with BDAc or you're pooched, nothing we can do about it as AP+ is not in our comtrol

:/ a bit hard to make ww1 style biplanes without ap+, ill figure it out. thanks

Share this post


Link to post
Share on other sites
19 minutes ago, AtleSt said:

:/ a bit hard to make ww1 style biplanes without ap+, ill figure it out. thanks

Unfortunate as it is, we have no control over AP+ and as such we are unable to assist you in your efforts to create WW1 aircraft replica's

If the caretaker of AP+ were to be interested in working with the BDAc team then we would be happy to oblige, however until then there is nothing that is within our power to do

The BDAc team appologises for any inconvenience in this matter, however, as stated, this is an issue that is not within our control ... only @blackheart612 can rectify the issue and until such time we are not able to do anything about it

Again, the BDAc team appologises for any inconvenience you may be experiencing due to a mod that is not compatible with BD Armory Continued not working with BD Armory Continued 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.