DoctorDavinci

[1.4.x] BDArmory Continued v1.2.2.2 [8/8/2018] + Vessel Mover, Camera Tools, BDMk22, Destruction Effects, Burn Together

Recommended Posts

12 minutes ago, Cassel said:

I was using default settings for those rockets.

Ok, so try not to use default settings. They are a bit bad. If I remember correctly, the default settings for laser guided missiles are 0, aka crash into water. Try increasing that to 2000 just to be safe.

Share this post


Link to post
Share on other sites
2 hours ago, Xd the great said:

Ok, so try not to use default settings. They are a bit bad. If I remember correctly, the default settings for laser guided missiles are 0, aka crash into water. Try increasing that to 2000 just to be safe.

Ok, it is working now, thanks.

Share this post


Link to post
Share on other sites

I have a minor problem.  Attempting to fire missiles with "FIRE" bound to Mouse0 (left mouse button) does not work.  Gatlings do, though. And binding it to another key (currently using F) also works. 

Certainly not a critical issue, but if someone knows what's happening here (or can fix it for the next version) that would be appreciated.

Share this post


Link to post
Share on other sites
1 hour ago, Atlessa said:

I have a minor problem.  Attempting to fire missiles with "FIRE" bound to Mouse0 (left mouse button) does not work.  Gatlings do, though. And binding it to another key (currently using F) also works. 

Certainly not a critical issue, but if someone knows what's happening here (or can fix it for the next version) that would be appreciated.

Please consult the BDPedia (KSPedia) in game for detailed instructions on the operation of BDAc

Use the weapon manager to fire missiles, this is how the system is designed to work

As stated, please read the manual

Share this post


Link to post
Share on other sites

So just so I understand you correctly; the manual will explain to me why binding "fire" to F will work with ALL weapons, but binding it to Mouse0 will only work with guns, and not with missiles or bombs?

Because if this is intended behavior then [I do not understand.]

Edited by Vanamonde

Share this post


Link to post
Share on other sites

If you want to fire missiles with your mouse, bind Arm/Disarm to a key and then you can arm weapons in-flight and fire everything with the mouse.

Share this post


Link to post
Share on other sites
On 8/30/2018 at 4:12 PM, Atlessa said:

So just so I understand you correctly; the manual will explain to me why binding "fire" to F will work with ALL weapons, but binding it to Mouse0 will only work with guns, and not with missiles or bombs?

 

On 8/30/2018 at 4:23 PM, Deathpuff12 said:

If you want to fire missiles with your mouse, bind Arm/Disarm to a key and then you can arm weapons in-flight and fire everything with the mouse.

@Atlessa perhaps if you read the manual you would know about the Arm/Disarm master switch that @Deathpuff12 mentions above

And in all actuality the bug is that you can fire guns without switching on the master Arm/Disarm ... technically the guns should not fire if the master switch is off in the weapon manager 

Take the above suggestion and please refrain from throwing insults at people as it is not constructive and only serves to make people want to ignore you

That is all

Share this post


Link to post
Share on other sites

Wow, guys, really?  Is my problem THAT hard to understand?

 

I go into the simulation on a rover with missiles (I use a rover to not have to worry about crashing into the face of Kerbin),  I arm everything, press F, the missiles fire.

Then, without changing ANYTHING on the vehicle, I go into the BDA setting, bind "fire" to mouse0, go back into the sim, and the missiles do NOT fire.  No way is this behavior caused by the aforementioned arm/disarm, as that is a requirement to have the F key function in the first place as well, is it not?

 

Share this post


Link to post
Share on other sites
On 8/31/2018 at 3:16 PM, Atlessa said:

Wow, guys, really?  Is my problem THAT hard to understand?

 

I go into the simulation on a rover with missiles (I use a rover to not have to worry about crashing into the face of Kerbin),  I arm everything, press F, the missiles fire.

Then, without changing ANYTHING on the vehicle, I go into the BDA setting, bind "fire" to mouse0, go back into the sim, and the missiles do NOT fire.  No way is this behavior caused by the aforementioned arm/disarm, as that is a requirement to have the F key function in the first place as well, is it not?

 

As doc mentioned, YOU HAVE TO ARM BEFORE FIRING. THE MISSILES AINT BROKE, THE GUNS ARE.

Did you arm before firing with the mouse? 

And did you bind firing to the mouse?

Share this post


Link to post
Share on other sites
2 hours ago, Xd the great said:

As doc mentioned, YOU HAVE TO ARM BEFORE FIRING. THE MISSILES AINT BROKE, THE GUNS ARE.

Did you arm before firing with the mouse? 

And did you bind firing to the mouse?

 

On 8/31/2018 at 9:16 AM, Atlessa said:

[...] I arm [the missiles] press F [...] missiles fire [...]

 

Quote

Then, without [disarming them, I] bind "fire" to mouse0 [...] and the missiles do NOT fire.

 

(and yes, I did have missiles left on the vehicle)

 

I really can't explain it any simpler than this.

Edited by Atlessa

Share this post


Link to post
Share on other sites
13 minutes ago, Atlessa said:

 

 

(and yes, I did have missiles left on the vehicle)

 

I really can't explain it any simpler than this.

Hmm. I will test this. I AM NOT A BDAC DEV, SO THE FOLLOWING IS MY PURE GUESSING:

Assuming you installed stuff correctly, as most missiles require a lock, if you dont have a lock, no mouse fire.

Share this post


Link to post
Share on other sites
Just now, Xd the great said:

Hmm. I will test this. I AM NOT A BDAC DEV, SO THE FOLLOWING IS MY PURE GUESSING:

Assuming you installed stuff correctly, as most missiles require a lock, if you dont have a lock, no mouse fire.

 

But why is Mouse0 treated differently from F?

Share this post


Link to post
Share on other sites
36 minutes ago, Atlessa said:

 

But why is Mouse0 treated differently from F?

So you dont misfire a missile at the ksc while opening the resource tab?

Share this post


Link to post
Share on other sites
On 8/31/2018 at 2:16 AM, Atlessa said:

Wow, guys, really?  Is my problem THAT hard to understand?

 

I go into the simulation on a rover with missiles (I use a rover to not have to worry about crashing into the face of Kerbin),  I arm everything, press F, the missiles fire.

Then, without changing ANYTHING on the vehicle, I go into the BDA setting, bind "fire" to mouse0, go back into the sim, and the missiles do NOT fire.  No way is this behavior caused by the aforementioned arm/disarm, as that is a requirement to have the F key function in the first place as well, is it not?

 

Did you click and hold the mouse button?

3 hours ago, Xd the great said:

Hmm. I will test this. I AM NOT A BDAC DEV, SO THE FOLLOWING IS MY PURE GUESSING:

Assuming you installed stuff correctly, as most missiles require a lock, if you dont have a lock, no mouse fire.

 

3 hours ago, Xd the great said:

So you dont misfire a missile at the ksc while opening the resource tab?

Nope, missiles require no lock to fire. With or without mouse. 

Share this post


Link to post
Share on other sites

No need for profanity, guys, even when masked by character substitutions. 

Share this post


Link to post
Share on other sites

@Atlessa Im gonna runthe usual diagnostics, so here we go:

1. Did you install the bdac, pre and module manager correctly?

2. Did you install through CKAN?

Off the top of my head, can you mount missiles to the jeans missile turret and try again?

Share this post


Link to post
Share on other sites

I need some assistance on the damage modeling of this mod.
the cannon weapons are a bit underwhelming in terms of damaging anything with armor.

I did a test with 2 simple tanks each with 90mm of armor and each armed with an Abrams turret. (ammo was about 60 rounds for each)
both tanks blasted at each other until empty with only minimal damage no parts destroyed.
second test was same tanks same armor but armed with 2 50cal turrets and 2500 rounds. The 50 cals did objectively more damage and were actually able to destroy some of the armor plating.

How can I boost the destructive power and armor penetration of my bigger guns to make this more realistic?

Share this post


Link to post
Share on other sites
3 hours ago, Warth_IX said:

I need some assistance on the damage modeling of this mod.
the cannon weapons are a bit underwhelming in terms of damaging anything with armor.

I did a test with 2 simple tanks each with 90mm of armor and each armed with an Abrams turret. (ammo was about 60 rounds for each)
both tanks blasted at each other until empty with only minimal damage no parts destroyed.
second test was same tanks same armor but armed with 2 50cal turrets and 2500 rounds. The 50 cals did objectively more damage and were actually able to destroy some of the armor plating.

How can I boost the destructive power and armor penetration of my bigger guns to make this more realistic?

Are you sure that the tanks scored direct hits?

The aiming of guns by AI is a bit... off

But, as an advice, if you want to make the weapons more powerful, increase muzzle speed in the .cfg files. Or increase the tnt mass in the resource or bullet def files. Or just increase the mass of bullet. Or just increase the calibre of bullet to something insane, aka 1500mm cannon.

Edited by Xd the great

Share this post


Link to post
Share on other sites
1 hour ago, Xd the great said:

Are you sure that the tanks scored direct hits?

The aiming of guns by AI is a bit... off

But, as an advice, if you want to make the weapons more powerful, increase muzzle speed in the .cfg files. Or increase the tnt mass in the resource or bullet def files. Or just increase the mass of bullet. Or just increase the calibre of bullet to something insane, aka 1500mm cannon.

Yeah I am sure that they are hitting one another range is less than 100 meters pretty much point blank.
can someone help clarify How the damage and armor elements interact with one another?
 

What I am looking for is to understand the logic behind the damage calculations and the Armor Penetration calculations.
I want to understand what the effect of changing the mass or velocity or the tnt values will be.

Also I have tried adding resource cost to the armor as well as getting the armor resource to have a scaling weight so that it has some drawbacks. However it seems to have no effect. is there something that is disabling the evaluation of these resources?

Share this post


Link to post
Share on other sites
2 hours ago, Warth_IX said:

Yeah I am sure that they are hitting one another range is less than 100 meters pretty much point blank.
can someone help clarify How the damage and armor elements interact with one another?
 

What I am looking for is to understand the logic behind the damage calculations and the Armor Penetration calculations.
I want to understand what the effect of changing the mass or velocity or the tnt values will be.

Also I have tried adding resource cost to the armor as well as getting the armor resource to have a scaling weight so that it has some drawbacks. However it seems to have no effect. is there something that is disabling the evaluation of these resources?

Increase bullet mass/calibre/tntmass/muzzle velocity increases bullet damage. If you want to blow up a tank, increase tnt mass. If you want armour penetration, increase the rest of the three.

I dunno about the armour, ask the devs.

Also, just as a precaution, check for installing in the wrong place, wrong/missing dependencies, incompatible versions of ksp and bdac and its dependencies, no ckan install.

In the ksp world, do what you want, and keep a backup before you mess with .cfgs and any other files 

Share this post


Link to post
Share on other sites
9 hours ago, Xd the great said:

@Atlessa Im gonna runthe usual diagnostics, so here we go:

1. Did you install the bdac, pre and module manager correctly?

2. Did you install through CKAN?

Off the top of my head, can you mount missiles to the jeans missile turret and try again?

 

1. Well, since literally everything else worked splendidly, I assume I did?

2. Yes

 

Also:  I had to do a complete refresh today since some other mod (or combination of mods) broke my install, and now everything works as I would expect it to.  Whatever the bug was, I can no longer reproduce it.

 

 

Edit: Also I agree with Warth_IX, the tank cannons perform VERY underwhelmingly as far as I could tell.

Edited by Atlessa

Share this post


Link to post
Share on other sites
42 minutes ago, Atlessa said:

 

1. Well, since literally everything else worked splendidly, I assume I did?

2. Yes

 

Also:  I had to do a complete refresh today since some other mod (or combination of mods) broke my install, and now everything works as I would expect it to.  Whatever the bug was, I can no longer reproduce it.

 

 

Edit: Also I agree with Warth_IX, the tank cannons perform VERY underwhelmingly as far as I could tell.

Yeah, dont install through ckan.

The tank cannons are ap, try testing against thickest armour.

Share this post


Link to post
Share on other sites

IMHO pretty much all the guns are greatly underpowered. But I have noticed that heavy caliber cannons are too underpowered compared to light caliber guns.

Share this post


Link to post
Share on other sites
7 hours ago, dundun92 said:

IMHO pretty much all the guns are greatly underpowered. But I have noticed that heavy caliber cannons are too underpowered compared to light caliber guns.

Yeah, i agree.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.