Jump to content

[1.8.x] Kerbal Foundries -- Continued - Tracks, Wheels, and Gear


Recommended Posts

2 minutes ago, Shadowmage said:

Yeah, I'm not sure that I could add colliders that wouldn't interfere with either the suspension mechanics or collision response.

The real question would be -- does a 'trigger' collider also trigger other 'trigger' colliders?  Or is it only physicsCollider->triggerCollider interactions?  (more of a rhetorical question / request for information, likely only a few on the forums would be able to answer that).

The trigger colliders are basically removed from normal physics interactions and they can overlap with different types of triggers. They basically exist only for code checking that type of trigger. So I'd say it would be safe to add a trigger collider.

Except if you're talking linking said trigger collider to things there's already programming links to, like wheel colliders. God knows what would happen with wheel colliders mixed in with ksp wheel. I suspect doom. Doooooommm!!!!!

Link to post
Share on other sites
15 hours ago, TiktaalikDreaming said:

The trigger colliders are basically removed from normal physics interactions and they can overlap with different types of triggers. They basically exist only for code checking that type of trigger. So I'd say it would be safe to add a trigger collider.

Except if you're talking linking said trigger collider to things there's already programming links to, like wheel colliders. God knows what would happen with wheel colliders mixed in with ksp wheel. I suspect doom. Doooooommm!!!!!

I don't know how he did it but the ALG stuff works now

 

Link to post
Share on other sites
17 hours ago, Phoenix Nebula said:

I keep having a problem were my vehicles jump around with any of the wheels and treds. Any idea if I'm missing something?

I would need more information to even know where to start investigating.  Logs, screenshots, vids, craft files.

There is a number of things that could interfere with the physics simulation, both known and unknown.  Figuring out precisely what it is will require more details.

Link to post
Share on other sites
3 minutes ago, Phoenix Nebula said:

Okay so I got the wheel problem sorted out. Though I'm now having trouble with the repulsiors. Also some tank treads veer to the right.

https://www.youtube.com/watch?v=VOmTtMWyxNw&feature=youtu.be

What was the problem (and solution), if you don't mind me asking?

-- will try to take a look at the video a bit later; it is returning an 'inaccessible' error currently, probably not done uploading yet.

 

Wheels veering to the right -- this can be caused by (a combination of) 1.) slight misalignment of the parts in the editor, 2.) imprecision in Unitys physics engine, and 3.) a low-level code/physics integration error that I have not been able to track down (issue ticket: https://github.com/shadowmage45/KSPWheel/issues/9 )

Link to post
Share on other sites

I'm not sure how i fixed the wheel problem, the problem was the same problem the repulsiors were having and some of them would cause the whole vehicle to jump around and send dust effects everywhere. I think it might have been a collision issue. As for the tank treds it wasn't misalignment because I used symmetry mode in the editor.

Link to post
Share on other sites
18 hours ago, achroma said:

Am i crazy or did the ALG used to have nesting tubes for further extension?

Could have at some point.

When I took over the mod/models, all I had to start with was some .mu model files and a couple of textures.  Entirely new plugin = new feature set (the old code was so broken, I couldn't even use it for reference).  I also have/had never used the old versions, so have no reference on what the original feature set was.

However, I do believe that I added in a 'strut length' adjustment to the current versions, so perhaps the feature you are looking for is there but merely named differently?

Link to post
Share on other sites

Naw i found em, just noticed how short they were! Went into the configs and lengthened the max travel aaaand the tubes were then floating mid-air :D

So i went back to some older KSP versions and found that I was the crazy one! Might i add though, the longer they can be, the better. 

By the by, thank you for the immense effort that you must have put into resuscitating this mod. Its genuinely huge.

Link to post
Share on other sites
17 hours ago, achroma said:

Naw i found em, just noticed how short they were! Went into the configs and lengthened the max travel aaaand the tubes were then floating mid-air :D

So i went back to some older KSP versions and found that I was the crazy one! Might i add though, the longer they can be, the better. 

By the by, thank you for the immense effort that you must have put into resuscitating this mod. Its genuinely huge.

I was just about to fire up an older KSP and check because I wasn't sure, either! :) Thanks for doing that.

Also echoing the thanks for KF adding these awesome gear back!

Link to post
Share on other sites

I just started using this mod for the first time. It nicely fills in the parts gap for wheels and landing legs. Great job.

One thing I'm noticing though is that the L-shaped legs start deployed on the launch pad, even though they are stowed in the VAB. If I press G they will stow themselves, but I have to do this every time. Is this a known bug or something I've somehow messed up?

Link to post
Share on other sites
4 minutes ago, JonathanPerregaux said:

Is this a known bug or something I've somehow messed up?

Neither; that is a new and as-of-yet unreported bug.  File it on the bug tracker please :)  (otherwise I'll forget about it and it'll never get fixed)

Link to post
Share on other sites
On 8/7/2017 at 8:02 AM, Shadowmage said:

Neither; that is a new and as-of-yet unreported bug.  File it on the bug tracker please :)  (otherwise I'll forget about it and it'll never get fixed)

Goes to show how many people actually use that part, doesn't it?  Sad really...

Link to post
Share on other sites

 

On 8/7/2017 at 10:57 AM, JonathanPerregaux said:

One thing I'm noticing though is that the L-shaped legs start deployed on the launch pad, even though they are stowed in the VAB. If I press G they will stow themselves

One weird thing I have found with the heavy and medium landing gear is that I have to press G twice to get the landing gear to stow after take-off. 

Link to post
Share on other sites
On 8/10/2017 at 5:13 PM, Gaalidas said:

Goes to show how many people actually use that part, doesn't it?  Sad really...

And even  fewer people actually file stuff on the tracker.  :(   (still waiting for that one to show up)

 

On 8/10/2017 at 7:26 PM, TheKurgan said:

 

One weird thing I have found with the heavy and medium landing gear is that I have to press G twice to get the landing gear to stow after take-off. 

File a bug report on one of the repositories, that will ensure that it doesn't get forgotten about, and infinitely increases the likelihood of it getting fixed.

 

5 minutes ago, NomenNescio said:

Have you considered adding the sounds and dust effects to the stock wheels?

https://github.com/shadowmage45/KSPWheel/issues/24

Wouldn't be just dust/sounds (those are quite integrated into KSPWheel), but would be a complete overhaul/conversion of the stock parts to use KSPWheel.  There is a patch set floating around somewhere that you can try if you want ( https://github.com/shadowmage45/KSPWheel/tree/master/GameDataDisabled/Patches/Stock ), but it hasn't been worked on in awhile, and I'm not sure if it was updated with either sound or dust.

Link to post
Share on other sites
  • 2 weeks later...
15 hours ago, Shadowmage said:

Updated KF release is available:

https://github.com/shadowmage45/KerbalFoundries2/releases/tag/2.0.2.8

Mostly just includes an updated KSPWheel with a few fixes in it.  See link for change-log and downloads.

Did this update change the Repulsors' location in the tech tree? I can't seem to find them in Advanced Motors anymore.

Link to post
Share on other sites
On 8/26/2017 at 1:41 PM, Shadowmage said:

Updated KF release is available:

https://github.com/shadowmage45/KerbalFoundries2/releases/tag/2.0.2.8

Mostly just includes an updated KSPWheel with a few fixes in it.  See link for change-log and downloads.

 

On 8/27/2017 at 7:00 AM, Ivy said:

Did this update change the Repulsors' location in the tech tree? I can't seem to find them in Advanced Motors anymore.

 

I CAN CONFIRM this update breaks all three models of Repulsor on existing ships, preventing them from being loaded.  It also removes Repulsors from the community tech tree.

Currently I had to downgrade using the CKAN command line to version 2.0.2.7, because I am a cheesing slime who uses repulsors to delithobrake my poorly-designed planes and landers on rough terrain.

I did not have to downgrade KSPWheel, only Kerbal Foundries, so I assume the issue lies there.

Edited by John4
clarify
Link to post
Share on other sites
1 hour ago, John4 said:

 

 

I CAN CONFIRM this update breaks all three models of Repulsor on existing ships, preventing them from being loaded.  It also removes Repulsors from the tech tree.

Currently I had to downgrade using the CKAN command line to version 2.0.2.7, because I am a cheesing slime who uses repulsors to delithobrake my poorly-designed planes and landers on rough terrain.

I did not have to downgrade KSPWheel, only Kerbal Foundries, so I assume the issue lies there.

Are you using CTT (Community Tech Tree)?  -- The only changes to repulsors were to 'fix' the CTT patch to use the proper part/module names.  That change should not effect the stock tech-tree.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...