Mythos

KSP monitor switching

Recommended Posts

I'm currently in test stage to migrate my savefile from 1.1.3 to 1.2.2 so I have both versions running. Today I started KSP 1.1 and was quite irritated that it refused to start as usual but on my second monitor instead.

Playing around with some windows settings (that I did not touch beforehand) did not change that behavior. Testing other games told me its a KSP issue only. Starting KSP 1.2 again I was quite surprised that it started on the primary monitor. Finally I searched the registry, having some hidden windows settings in mind, but instead I found

"HKCU\Software\Squad\Kerbal Space Program\UnitySelectMonitor_somenumber = 0"

I then changed the value from 0 to 1. And that did the trick and switched KSP 1.1 back to primary monitor.

But then I noticed KSP 1.2 is now running on second monitor... How funny, both have exact opposite monitor preferences :confused: 

To clean things up I just renamed that registry key and tested again. Conclusion is KSP 1.1 did not have that registry property at all, it appears when KSP 1.2 is started first time. But when it is there also KSP 1.1 does his thing with it, which is just the opposite thing you'd expect.

Just telling you in case someone else encounters this problem as well...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now