Jump to content
  • 0

Right-Click rotates camera very crazy


Question

If I right click in flight or anywhere, my camera rotates very crazy! With right click I doesn't mean something like "drag'n drop", noooooo, I mean a normal right click! And the rotation comes before the real "right-click" is executed, that means, "righ-click -> rotate -> click to open part gui". Can any body help me?

OS: Windows 10 64-bit
KSP: v1.2.2.1622-64-bit (unmodded)

Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0

This seems as if the right-click was binded to a camera control in the settings. You may check if something shows in the Settings/Game/Camera section (both keys and axes). Can't tell how a mouse click could be registered with settings, it never does on my system, but your configuration could possibly allow something different.

To let us diagnose your issue, would be best to examine your settings.cfg file (please upload and link). Also output_log file, please, it always helps. I'd also like to find a better description of the kind of rotation the camera shows (e.g., it rotates same way if the pointer is left/right/above/below the center? rotation goes with same speed all the time, or changes with cursor position?); if you can, uploading a video showing the issue would make things more evident.

Link to post
Share on other sites
  • 0

Can you try with a new save please, it looks like you are using a modded save.

[ERR 14:27:46.692] Cannot find a Module of typename 'InterVesselManager'

[ERR 14:27:46.693] ScenarioModule is null.

[ERR 14:27:46.693] Cannot find a Module of typename 'KPBSScenario'

[ERR 14:27:46.694] ScenarioModule is null.

[ERR 14:27:46.695] Cannot find a Module of typename 'SCANcontroller'

[ERR 14:27:46.696] ScenarioModule is null.

KBPS is from Kerbal Planetary Base Systems.

Also what mouse do you have and have you changed the mouse polling rate?

Link to post
Share on other sites
  • 0
5 minutes ago, sal_vager said:

Can you try with a new save please, it looks like you are using a modded save.

[ERR 14:27:46.692] Cannot find a Module of typename 'InterVesselManager'

[ERR 14:27:46.693] ScenarioModule is null.

[ERR 14:27:46.693] Cannot find a Module of typename 'KPBSScenario'

[ERR 14:27:46.694] ScenarioModule is null.

[ERR 14:27:46.695] Cannot find a Module of typename 'SCANcontroller'

[ERR 14:27:46.696] ScenarioModule is null.

KBPS is from Kerbal Planetary Base Systems.

Also what mouse do you have and have you changed the mouse polling rate?

So, at first, there is no diference with a nes game state, and i had tested ist without mouse(also with touchpad) and i changed the polling rate, but nothing happens.

Link to post
Share on other sites
  • 0

 

11 minutes ago, Panakotta00 said:

So, at first, there is no diference with a nes game state, and i had tested ist without mouse(also with touchpad) and i changed the polling rate, but nothing happens.

Okay, does this still happen with a polling rate of 125?

Have you tried updating your drivers and restarting the computer?

Do you have any other controllers plugged in?

Can you provide you dxdiag hardware report please.

Link to post
Share on other sites
  • 0
34 minutes ago, sal_vager said:

 

Okay, does this still happen with a polling rate of 125?

Have you tried updating your drivers and restarting the computer?

Do you have any other controllers plugged in?

Can you provide you dxdiag hardware report please.

Yes
Yes
No
The only thing I can say is, that there is no problem with ksp

Link to post
Share on other sites
  • 0
5 minutes ago, Panakotta00 said:

Yes
Yes
No
The only thing I can say is, that there is no problem with ksp

You still have a problem though, even if no one else has this problem it would be good to find how to fix it.

Link to post
Share on other sites
  • 0

 

1 minute ago, Panakotta00 said:

If you had seen the video, than you know that comes in the space center too.

Yes I watched the video, the view does not move that way for me, I don't know why it is doing this, you said is earlier.

 

1 hour ago, Panakotta00 said:

The only thing I can say is, that there is no problem with ksp

Does this happen in other games? How do you know this is not a KSP problem?

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...