Jump to content
  • 0

Mechjeb Problem Executing Nodes


Question

I'm having issues with mecjeb not working properly.

it has worked perfectly but stopped doing so a week ago.

it sets up a maneuver but... does not Automatically timewarp to the node anymore, nor does it execute at the node, although it does maneuver the craft around so it is in the right direction for the burn 

Can anyone make sense of what is happening here?

this data is from the debug menu in Mechjeb.

[Error]: MechJeb module MechJebModuleNodeExecutor threw an exception in OnFixedUpdate: System.MissingMethodException: Method not found: 'TimeWarp.SetRate'.
  at MuMech.MechJebModuleWarpController.IncreaseRegularWarp (Boolean instant) [0x00000] in <filename unknown>:0 
  at MuMech.MechJebModuleWarpController.WarpRegularAtRate (Single maxRate, Boolean instantOnIncrease, Boolean instantOnDecrease) [0x00000] in <filename unknown>:0 
  at MuMech.MechJebModuleWarpController.WarpToUT (Double UT, Double maxRate) [0x00000] in <filename unknown>:0 
  at MuMech.MechJebModuleNodeExecutor.OnFixedUpdate () [0x00000] in <filename unknown>:0 
  at MuMech.MechJebCore.FixedUpdate () [0x00000] in <filename unknown>:0 

 

is there something I can edit within the Mecjeb folder or is it something editable somewhere else?

any help would be greatly appreciated

Edited by jonpen69
Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Having somewhat the same issue. Mechjeb worked fine till this morning. 

This is what happened last time i used it.

I'm building a space station these past two days, i got three modules docked with the core of the station. All of them followed the exact same procedure. Mechjeb does the "matching planes", "hohmann transfer" and/or "fine tuning closest approach" aand then "match speed with target".

After that, i take up control and dock myself.

The last module i sent up to the station went like this. I got to a 72,000 orbit myself.  Turned on mechjeb to match planes with target. It did perfectly. Then i used mechjeb to create a node with hohmann transfer. It does create a node, points the craft to the blue triangle on the navball, and even warps close to the execution. 
But then, right before the burn, it won't execute, it just passing idle straddling along its orbit. I then decided to give it another try. Deleted the old node and created a new one with mechjeb. Same thing, it points correctly to where its suppost to go, but it won't execute.l

PS: The engine is active, like i said, the "match planes with target" procedure worked like it should. It just stopped working out of the blue. The mechjeb tab up in the screen is still there. I can still open it with no problem. Mechjeb green light is lit. I haven't changed the main rocket for the past 8-10 launches. Everything below the docking port attached to the module is the exact same. Even though its unmanned, i have a communication's relay satellites in orbit, signal loss is not a problem, i checked it. Electrical charge is not a problem, i have four 600 batteries and solar panels to deal with the power demand. Fuel is not a problem, for the past few missions, i can go from launch to the final docking movement and still have almost 80% of liquid fuel/oxider on the last stage, thanks to, obviously, mechjeb. I know i'm dragging extra fuel that i wont use, but i totally don't care, i just want my Mechjeb awesome autopilot back, lol.

 

Edited by PayadorPerseguido
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...