CobaltWolf

[1.6.X] Surface Experiment Pack - Deployable science for KIS/KAS! (v2.7 - 13/Jan/19)

Recommended Posts

@CobaltWolf, I didn't realise this was your mod as I installed via CKAN (until I saw the KIS containers that matched the descent module). Just want to say fantastic work!

yetk5pC.png

Share this post


Link to post
Share on other sites
On 4/14/2018 at 8:25 PM, Rohaq said:

Just a minor thing: The Forum Thread URL on Spacedock needs updating: https://spacedock.info/mod/318/Surface Experiment Pack - I had to track this thread down via Google :) 

First, I presume that the link displayed in CKAN under Metadata is pointing to the same out-dated place and that it can be corrected in the netkan file.  I'd take a crack at submitting a PR but I don't know where the netkan file is.

Second, what would cause all of the Central Stations (CS) to explode?  I had two stations established:

  1. First one just off the runway and I had been slowly adding to it over time.  Everything was working well as I went through the learning curve and up the tech tree.
  2. Second one in the nearest grasslands to the KSC.  I had sent an Engineer out to set it up and everything was stable when I left but no experiments were running.  I returned with a Scientist but on approach (within 500m) the CS exploded.  On return to the KSC, I noticed that the first CS had also self-destructed leaving only a couple of solar panels rocking on the ground.

KSP v1.4.2, SEP v2.6.  I inadvertently overwrote the output_lot file but I might be able to recreate because I use S.A.V.E.  I just have to find the best save and start over.

Edited by Brigadier

Share this post


Link to post
Share on other sites
On 6/1/2018 at 4:02 AM, Brigadier said:

First, I presume that the link displayed in CKAN under Metadata is pointing to the same out-dated place and that it can be corrected in the netkan file.  I'd take a crack at submitting a PR but I don't know where the netkan file is.

Yeah, the .netkan file uses SpaceDock as a reference to pull this information down. It's possible it could be patched there, but the preference is generally to use references to a primary source that the author updates directly, to avoid them having to remember to manually update the netkan alongside it.

Share this post


Link to post
Share on other sites
On 5/29/2018 at 2:19 AM, Zorg said:

@CobaltWolf, I didn't realise this was your mod as I installed via CKAN (until I saw the KIS containers that matched the descent module). Just want to say fantastic work!

Lovely image! Would I be able to include it in the thread OP? :)

Share this post


Link to post
Share on other sites
9 minutes ago, CobaltWolf said:

Lovely image! Would I be able to include it in the thread OP? :)

Sure thing!

Share this post


Link to post
Share on other sites

I'm just in love with this mod, here's mine :)

 

Mun SEP base done! looks like playing stationeers (don't look at the reversed lander, it's normal)

screenshot11.png

 

Nice SEP solar panels, and over 17000 EC charge..

screenshot12.png

 

screenshot13.png

 

good morning Bob (after an hour spent puting this lander the right way)

screenshot15.png

 

Even in Vessel Viewer, love it!

screenshot17.png

 

 

 

Share this post


Link to post
Share on other sites

Hello, I am not sure if I posted here before saying what a wonderful mod sep is, but i sure can say it again! :):)

Anyways, I have two questions: 1) Well, what's with all the floating? Is this a result of stock ksp behavior that causes ships to jump up and down on scene load? I imagine the game lifting vessels slightly off the ground as it loads them, so that they will not clip into the ground, but in the sep case, due to ground thethers, the instruments get stuck in the air?

AKi0RxD.jpg

2) How can i see experiment results when completing sep experiments. There is nothing in the individual experiments' right click menus. The only action that seems available is Transmit Results in the right click menu for the central station, and when i click Transmit Results, i only get a floating transmission text and not the usual experiment result pop up that describes the result of the experiment.

PS: Also I went and tried checking out the results in the archives, yes they are there, but they sure are weird. I have so far only set up a sep in the far side crater, but for some experiments i have empty (no science) archives from the far side crater along with completed results from the highlands???

E6cDfHQ.png

PPS: Why is a single experiment listed three times with three different results? Are these the different results from various different calibration levels?

GRsFE1C.png

 

Edited by canisin
fixed images.

Share this post


Link to post
Share on other sites
3 hours ago, canisin said:

PPPS: How the hell do i embed imgur pictures? Weren't they supposed to be automatic?

It is automatic, but you're not providing the right link.  You're posting a link to the imgur post, not the image itself.

Share this post


Link to post
Share on other sites
19 hours ago, Geonovast said:

It is automatic, but you're not providing the right link.  You're posting a link to the imgur post, not the image itself.

Thanks a lot! Fixed them.

Share this post


Link to post
Share on other sites
On 5/31/2018 at 8:02 PM, Brigadier said:

Second, what would cause all of the Central Stations (CS) to explode?  I had two stations established:

  1. First one just off the runway and I had been slowly adding to it over time.  Everything was working well as I went through the learning curve and up the tech tree.
  2. Second one in the nearest grasslands to the KSC.  I had sent an Engineer out to set it up and everything was stable when I left but no experiments were running.  I returned with a Scientist but on approach (within 500m) the CS exploded.  On return to the KSC, I noticed that the first CS had also self-destructed leaving only a couple of solar panels rocking on the ground.

KSP v1.4.2, SEP v2.6.  I inadvertently overwrote the output_lot file but I might be able to recreate because I use S.A.V.E.  I just have to find the best save and start over.

So, I reverted to a previous save and started again, but this time on the Mun.  I placed (attached via KIS/KAS, using the Electric Screwdriver and using 'H') the CS and several experiments on the surface, connected (using the Port Attachment Tool), calibrated and started them.  Construction of the experiments went very well until I boarded the ship and returned to orbit.  As I was departing, I noticed that the experiment array started vibrating, eventually leaping off the surface and flipping over.  From the Tracking Station I can focus on all of the parts and everything seems stable, except that it's flipped over and I've lost one solar panel.

Am I doing something wrong during this process?  Now running on KSP 1.4.3 and I have WorldStablizer v0.9.2 installed, amongst other mods; happy to post the mod list, if need be.

Edited by Brigadier
Added new KSP version

Share this post


Link to post
Share on other sites

I've got the same floating issue reported by Canisin. I attached my SEP central station and several experiments to the surface of the Mun. I took off, and went back to Kerbin, and returned on a later mission to add some more experiments, but when I got there, the central station and several other parts (a couple of experiments, and power extenders etc) are now just about head height off the ground, and I can no longer attach plugs to any of them.

Share this post


Link to post
Share on other sites

CKAN does NOT take you to this thread by default when you click on the link to go to the forum thread in the lower right of CKAN. It goes to a "does not exist" forum page.

Also, this looks like a great mod and I really want to use it.....but there's no point if it takes like 100 days to run an experiment and the parts explode or float away in that time period.....

Please update it @CobaltWolf?!

Edited by JoE Smash

Share this post


Link to post
Share on other sites
On 1/21/2017 at 10:55 PM, CobaltWolf said:

dulcXgY.png

yetk5pC.png

I have a question: What are the visual mods that you in these banners? Post-rendering + EVE + Scatterer or something?

 

Share this post


Link to post
Share on other sites

@Catatau_27 The 2nd picture is by me. The depth of field effects and bloom effects you're seeing are from KS3P. The terrrain textures are also not stock they are from SVT (Stock Visual Terrain).

I do have EVE and Scatterer of course but they only affect atmospheric bodies so they don't come into play here.

I cant speak for Cobalt's banner for certain but lens dust, film grain and depth of field effects are visible and so it looks like KS3P again.

 

Share this post


Link to post
Share on other sites
14 minutos atrás, Zorg disse:

@ Catatau_27  A segunda foto é por mim. A profundidade dos solos e o efeito da flor que você está vendo são do KS3P. As texturas terrrain também não são ações que são da SVT (Stock Visual Terrain).

Eu tenho EVE  e Scatterer, claro, mas eles são afetados os corpos atmosféricos, então eles não entram em jogo aqui.

A cobalto por certo, mas a poeira da lente, o som do filme e a profundidade do campo são e então ele se parece com o KS3P novamente.

 

Ah obrigada, é maravilhoso o efeito que causa, espero que este mod visual não consuma muita RAM, pois utilizo quase 100 mods, talvez mais (ainda não contei todos = x)

Ps: Obrigado pelo link, eu não sabia que esse mod foi atualizado, então parei de usá-lo, agora vou reutilizá-lo. <3 Obrigado novamente =)

Edited by Catatau_27

Share this post


Link to post
Share on other sites
1 minute ago, Catatau_27 said:

Oh thanks, it's wonderful the effect that causes, I hope this visual mod does not consume much RAM, because I use almost 100 mods, maybe more (I still have not counted all = x)

Oh thanks, it's wonderful the effect that causes, I hope this visual mod does not consume much RAM, because I use almost 100 mods, maybe more (I still have not counted all = x).

Ps: Thanks for the link, I did not know that this mod was updated, so I just stopped using it, now I'll reuse it. <3 Thanks again =)

You're welcome. From the description and from my own experience KS3P does not have a big effect on performance. 

Share this post


Link to post
Share on other sites
2 minutes ago, Zorg said:

Seja bem-vindo. A partir da descrição e da minha própria experiência, o KS3P não tem um grande efeito no desempenho. 

Can you tell if this visual mod is working fine in 1.4.4?

Share this post


Link to post
Share on other sites
1 minute ago, Catatau_27 said:

Can you tell if this visual mod is working fine in 1.4.4?

Not sure, I am still on 1.4.3. I think it should work, just give it a try. If you need any help with configuring it you can always post in the KS3P thread.

Share this post


Link to post
Share on other sites

Has there been any reply or resolution to the experiments floating away after departure from the surface of the Mun, etc.?

Share this post


Link to post
Share on other sites

Joe Smash, I have not seen any myself (and I have looked). I now have a sep station that isn't just floating above the terrain, it has inverted itself and is no longer functional because it is out of electricity, and since the solar panels are now facing the Mun, it won't charge any more...

Share this post


Link to post
Share on other sites
1 hour ago, Michel Bartolone said:

Joe Smash, I have not seen any myself (and I have looked). I now have a sep station that isn't just floating above the terrain, it has inverted itself and is no longer functional because it is out of electricity, and since the solar panels are now facing the Mun, it won't charge any more...

Awesome....

May as well uninstall then....

Edited by JoE Smash

Share this post


Link to post
Share on other sites
11 hours ago, Michel Bartolone said:

Joe Smash, I have not seen any myself (and I have looked). I now have a sep station that isn't just floating above the terrain, it has inverted itself and is no longer functional because it is out of electricity, and since the solar panels are now facing the Mun, it won't charge any more...

Oi @Michel Bartolone , I am trying to advance back to where I was (I had a career malfunction), so I am not quite to making a Mun base again yet. When I get back to my old tech level, I had an idea about this....

Have you tried attaching the experiments to anything else other than the ground? (Or is that not possible, I haven't checked)

I know it would increase the payload fairly significantly, but have you tried attaching them to like those square cement looking platforms..."CB1 Ground Base" that come with KIS....those weigh 0.3 tons a piece. Next tier up they have "Ground Pylons for 0.2 tons.... 

And I haven't even tried the Asphalt Tiles from Kerbal Hacks:

Basically I'm wondering if they still float away if you attach them to something else structural that you attach to the ground first. I understand that doing this is not supposed to be necessary. You are supposed to be able to simply attach them directly to the surface with a wrench or screwdriver. I was just wondering if attaching them to something else might be a workaround....since the author of this mod seems MIA....

Share this post


Link to post
Share on other sites
7 hours ago, JoE Smash said:

Basically I'm wondering if they still float away if you attach them to something else structural that you attach to the ground first. I understand that doing this is not supposed to be necessary. You are supposed to be able to simply attach them directly to the surface with a wrench or screwdriver. I was just wondering if attaching them to something else might be a workaround....since the author of this mod seems MIA....

I'm not MIA, I've just sort of given up on trying to fix it since I spent years trying to figure out why this mod keeps breaking, and despite finding several possible causes and correcting them, this keeps happening. I stopped enjoying working on SEP since all it does is generate issues that are beyond my ability to solve.

But, yes if you attach to those ugly concrete bases it will work fine. I'd like to note that there is basically nothing different between those bases and the SEP experiments (ie the colliders, attach points, etc).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.