CobaltWolf

[1.6.X] Surface Experiment Pack - Deployable science for KIS/KAS! (v2.7 - 13/Jan/19)

Recommended Posts

Hi, new to this mod and am having a problem where there is no context menu on right click (engineer in focus, using SEP port attachment tool) and not getting the menu for linking power after setting up base station, experiment and plugs.... using the latest KAS and SEP pack... anyone got this working with 1.4.5?  I am guessing it just doesn't work with that version perhaps.   Any advice greatly appreciated, I feel this mod fills a HUGE hole in the base game, i.e. nothing to really do in EVA and missing out on setting up experiments in the field.

Share this post


Link to post
Share on other sites

 

Quote

 

Equip item AKI-G09 Physical Areodynamics and Gravitation Test in mode Part

Cannot find object for EVA item: bn_l_mid_a01

 

After KIS update to 1.15 don't equip item for experiment.  @CobaltWolf

Share this post


Link to post
Share on other sites

I haven't had much chance to play recently - how well do these work now that the old-style KAS has been depreciated?

Share this post


Link to post
Share on other sites

I don't actually know, and I'm pretty busy both IRL and trying to get things finished for the BDB update.

Share this post


Link to post
Share on other sites
On 1/24/2017 at 10:00 PM, AlbertKermin said:

The magnetometer, retro-reflector, seismic sensor and heat probe will work anywhere.

The CCID scanner and Solar wind Spectorometer will only work on planets without an atmosphere.

The weather station will only work on planets with an atmosphere.

Does the surface gravimeter work in both, or just one?

Share this post


Link to post
Share on other sites

It seems explosions have returned to the service experiments with the new KAS. Haven't done extensive testing, but have had the first experiment site blow up in a lot time on the first site made after the update. Everything installed normally, but when returning to the site later, boom.

UPDATE: It seems dropping the parts on the surface rather than attaching them to the surface of the planet/moon before connecting them together does not have this problem.

Edited by JeffreyCor

Share this post


Link to post
Share on other sites
On 11/11/2018 at 12:17 AM, JeffreyCor said:

It seems explosions have returned to the service experiments with the new KAS. Haven't done extensive testing, but have had the first experiment site blow up in a lot time on the first site made after the update. Everything installed normally, but when returning to the site later, boom.

UPDATE: It seems dropping the parts on the surface rather than attaching them to the surface of the planet/moon before connecting them together does not have this problem.

Hmm. I know that there's been significant under-the-hood changes for KAS in V1.0 and later. I wonder if that's partially to blame?

 

Speaking of which, there may need to be some changes made to the electrical cables to reflect the new features of KAS.

Share this post


Link to post
Share on other sites
3 hours ago, MaverickSawyer said:

Speaking of which, there may need to be some changes made to the electrical cables to reflect the new features of KAS.

Yes, but I think it may not be too bad. The SEP station can be used as the cable origin, and the plugs can probably now be part of the destination part (see the new pylons with built in fuel-pipe ports). Which that's handy.
What I don't know is if a single part can be the origin of multiple cables. @IgorZ?

Share this post


Link to post
Share on other sites
1 hour ago, helaeon said:

What I don't know is if a single part can be the origin of multiple cables.

It should be. However, I haven't did extensive testing for this use-case. If there are troubles, feel free to file a bug.

Share this post


Link to post
Share on other sites
7 hours ago, Ocid said:

Just wanted to say this is a lovely little mod.

i8XxiQp.jpg

D'awwwww... cute little outpost!

Share this post


Link to post
Share on other sites

Hi,

I cannot attach any plugs into SEP Central Station anymore. It worked the last time I played..
If I remove the existing plugs, they also cannot be attached anymore.
The experiments are still plugable.. any ideas?

Those are the updates I did after I played last time..

Downloading "https://spacedock.info/mod/1324/Crew%20R%26R/download/1.1.9"
Downloading "https://github.com/snjo/Firespitter/releases/download/7.11.0/Firespitter.zip"
Downloading "https://spacedock.info/mod/834/KEI/download/1.2.9.4"
Downloading "https://spacedock.info/mod/1949/KerbalGPS%20Revived/download/1.1.0.12"
Downloading "https://spacedock.info/mod/141/scatterer/download/0.0336"
Downloading "https://spacedock.info/mod/56/WasdEditorCameraContinued/download/0.6.14.2"

 

screenshot169.png

Share this post


Link to post
Share on other sites
On 10/29/2018 at 9:17 AM, Dimentia said:

 

After KIS update to 1.15 don't equip item for experiment.  @CobaltWolf

@I'll submit a small patch to KIS to bring back reverse compatibility. Its only a few lines of code and I don't know why IgorZ made it so difficult. I'll also maybe fork the ancient KAS and bring back the old version. 

Share this post


Link to post
Share on other sites

I seem to be having an issue in v1.5.1 in which I can't equip the screwdriver and thus, can not install any power plugs into the SEP central station or experiments. I have tried reinstalling the mod and that did nothing. I can equip the wrench, just fine.

EDIT: Is there a reason I don't see a .CFG file for the wrench or the electric screwdriver? As of right now, I only see the .CFG file for the screwdriver; I wanted to cross reference it with the wrench .CFG to see if there is a disparity that I can just change to reflect the wrench, since I can equip/use that tool without issue. Either that or I wanted to move the electric screwdriver over to the Basic Science category in R&D, so that I don't have to cheat to buy Advanced Electrics, perhaps allowing me to  install power plugs with that tool, instead.

Edited by HeyThisIsntFallout
Additional questions

Share this post


Link to post
Share on other sites
1 hour ago, HeyThisIsntFallout said:

I seem to be having an issue in v1.5.1 in which I can't equip the screwdriver and thus, can not install any power plugs into the SEP central station or experiments. I have tried reinstalling the mod and that did nothing. I can equip the wrench, just fine.

EDIT: Is there a reason I don't see a .CFG file for the wrench or the electric screwdriver? As of right now, I only see the .CFG file for the screwdriver; I wanted to cross reference it with the wrench .CFG to see if there is a disparity that I can just change to reflect the wrench, since I can equip/use that tool without issue. Either that or I wanted to move the electric screwdriver over to the Basic Science category in R&D, so that I don't have to cheat to buy Advanced Electrics, perhaps allowing me to  install power plugs with that tool, instead.

KAS/KIS got rewritten recently. The mod still works in the old versions (I don't know what version number specifically, sorry). I haven't had time to try and figure out what is wrong with this mod to make it work. I am trying to get an update out for my main project at the moment.

Share this post


Link to post
Share on other sites
On 12/9/2018 at 4:26 PM, Ger_space said:

Hi,

I made this mod runnign under KSP 1.5.1 

I uploaded the ancient version of KAS and a patched version of KIS here: 
https://github.com/GER-Space/Assets/releases/tag/1.0

 

 

36 minutes ago, Stone Blue said:

@HeyThisIsntFallout you could try uninstalling KIS and KAS, and using the version that GER_space recompiled and linked to, in the post right above yours vOv

I saw the linked post, but had a small reservation of downloading files not released by the authors. This seems to have worked, however and my PC isn't blowing up :D I appreciate the work @Ger_space.

Share this post


Link to post
Share on other sites

Same issue here with screwdriver not being able to equip... Ill try the workaround with GER_Space KIS/KAS Recompile, hope it works.

Still hope this mod gets updated to latest KSP version someday soon :) 

Share this post


Link to post
Share on other sites

A workaround for the screwdriver not equipping can be to use the power screwdriver that is part of KAS. Have to move further down the tech tree to be able to do this but can be a potentially acceptable trade off for now. :)

Share this post


Link to post
Share on other sites
Posted (edited)

2IDzDxwl.png

Updated configs for screwdriver, golfclub, cardboard box and fallen kerbal to work with latest KIS.  Tested in 1.5.1 and 1.6.  I'll bung you the code on Discord.  Will still need a proper recompile for 1.6 though.

Edited by Friznit

Share this post


Link to post
Share on other sites

@DMagic think you could make sure the code is up to snuff? We can cut a release this weekend. :)

Share this post


Link to post
Share on other sites

Alrighty!

Surface Experiment Pack v2.7

  • Compatible with KSP 1.4.x, 1.5.x, 1.6.x
  • Fixes for the new KIS/KAS syntax  courtesy of @Friznit

Available on Github and Spacedock, if it's not showing up on CKAN it should next time the bot scrapes or whatever. :)

Share this post


Link to post
Share on other sites
10 hours ago, CobaltWolf said:

Available on Github and Spacedock, if it's not showing up on CKAN it should next time the bot scrapes or whatever. :)

First, thanks for the update and notification that it's compatible with 1.4 and 1.5.

Second, it is, in fact, showing up on CKAN but shows only 1.6 compatibility.  I'm sure one can alter something to reflect the broader compatibility, I just don't know what.

Share this post


Link to post
Share on other sites
On 1/9/2019 at 9:59 PM, Friznit said:

2IDzDxwl.png

Updated configs for screwdriver, golfclub, cardboard box and fallen kerbal to work with latest KIS.  Tested in 1.5.1 and 1.6.  I'll bung you the code on Discord.  Will still need a proper recompile for 1.6 though.

Hey! What magic is in that picture?

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.