Jump to content

[1.6.X] Surface Experiment Pack - Deployable science for KIS/KAS! (v2.7 - 13/Jan/19)


Recommended Posts

11 hours ago, Stratickus said:

Yes, the AKI Power Transfer Conduits

Are you connecting them via the right click menu? Been a while since I even opened this in game, I don't recall what the actual button label is. Basically you have to attach a power connector to each node, then right click one to start the 'pipe', then move to the other one and use its right click menu to finish the pipe.

Link to post
Share on other sites
6 hours ago, CobaltWolf said:

Are you connecting them via the right click menu? Been a while since I even opened this in game, I don't recall what the actual button label is. Basically you have to attach a power connector to each node, then right click one to start the 'pipe', then move to the other one and use its right click menu to finish the pipe.

Correct, I have been right clicking the power conduits to try and connect them to each other. I had been using the old version of SEP and KAS that was listed several posts ago, but have since updated all the associated mods. The SEP station in the picture is a brand new station, not one of the old ones.

Picture

Imgur and Flickr (or the website) were being weird and I couldn't embed the photo.

Link to post
Share on other sites
1 hour ago, Stratickus said:

Correct, I have been right clicking the power conduits to try and connect them to each other. I had been using the old version of SEP and KAS that was listed several posts ago, but have since updated all the associated mods. The SEP station in the picture is a brand new station, not one of the old ones.

Picture

Imgur and Flickr (or the website) were being weird and I couldn't embed the photo.

Can't see anything on the menu in that picture. Any chance you can up the resolution?

Link to post
Share on other sites
31 minutes ago, MaverickSawyer said:

Can't see anything on the menu in that picture. Any chance you can up the resolution?

When I click the link and hover over the picture it gives me a zoom in option. Not sure what the resolution is, but it fills the whole screen. What info from the menu are you looking for?

Link to post
Share on other sites

That fix was KIS compatability (specifically, Kerbals ability to equip objects).  I've used SEP successfully with the latest version of KAS so not sure if that's the issue.  I've not tried for a couple of weeks though - will test again later this evening.

Edited by Friznit
Link to post
Share on other sites
15 hours ago, Stone Blue said:

It should be, unless there were major changes again to KAS after this post by Cobalt... vOv

Nope.  I thought I'd remembered it'd been updated - but I hadn't been getting it to work for me.  I reinstalled and I can now see the power conduits (which I wasn't before), so it was probably something in my install.

Link to post
Share on other sites
20 hours ago, MaverickSawyer said:

There's a couple of options missing from that menu, most importantly the "Link" option.

That's exactly the problem I was pointing out. I cannot link the experiments to the Central Station, or anything.

19 hours ago, Stone Blue said:

It should be, unless there were major changes again to KAS after this post by Cobalt... vOv

Cobalt's post is what prompted me to update SEP, KIS/KAS. Previously I had be using the 'old' KIS/KAS in order to retain SEP functionality.

Link to post
Share on other sites
53 minutes ago, Stratickus said:

Cobalt's post is what prompted me to update SEP, KIS/KAS. Previously I had be using the 'old' KIS/KAS in order to retain SEP functionality.

Ahhh... ok... I guess I missed that in all the posts since & just before your post listing what all versions you were running :P...

No idea how often he may check this thread, but @DMagic might be the one to maybe look into this, or at least maybe know who to help with it.

PS- @CobaltWolf the SEP version listed above the download links in the OP still shows 2.6, and the github link points to 2.5... maybe edit the link to point to the releases page, instead of a specific tag? that way you would never have to update the link? vOv
ie use this?  :P

  https://github.com/CobaltWolf/Surface-Experiment-Pack/releases

Edited by Stone Blue
Link to post
Share on other sites

I'm not sure if this is by design, an oversight or just a bug, but:

 

I ran and transmitted 3 experiments at a location. I subsequently went back and added further experiments, and set the previous experiments to re-run, thinking to get data for the lab. They were at 100% both times.

 

The experiments have now completed, but I have no option to retrieve data for the 3 experiments that are on their second run (the lab fodder); is this intentional?

Link to post
Share on other sites

Even when there's zero Science to be obtained from normal experiments the Science dialog is accessible to allow data to be extracted for taking to a lab, though.

 

So the SEP package isn't working how I expected it to.

 

This presumably means I have to extract for the lab first, then send home to Kerbin on the second run through.

Link to post
Share on other sites

So, for everyone with no Link right click option on SEP power plugs I've found a solution: you need to bring back LEGACY folder inside KAS mod folder. It contains old KAS.dll which has some modules still needed for SEP power plugs to function. I think you may delete Parts folder inside LEGACY folder if you don't need deprecated KAS parts.

Enjoy! :) 

Link to post
Share on other sites
  • 4 weeks later...

I ran into an issue with the golf club - I simply can't equip it. The log says "evaTransform not found". Other equippable items such as the wrench work just fine. It's KSP 1.4.2 (older version since I want to use a mod that's only available up to that version so far), all mods installed via CKAN, so no idea whether it might be a version mismatch problem. It's obviosly not a game breaking or even major issue, but it also obviously would be nice to have it working :)

Link to post
Share on other sites

KIS changed quite considerably, which means SEP items got updated to the new format so you need both updated...and they may only work on 1.6.1

If you're using the old version of KIS then you need an old version of SEP as well.

Link to post
Share on other sites

Is SEP meant to generate contracts in Career mode either through the stock contract generator or CC?

I noticed nightingale wrote a config file for SEP located in ContractConfigurator > science.

The experiment definitions don't quite seem to match up though.

The file that nightengale wrote has the experiment definitions as:

EXPERIMENT
    {
        name = SEP_Retroreflector
    }

Where the SEP config file has them listed as:

EXPERIMENT_DEFINITION
{
	id = SEP_Retroreflector_Basic
----

EXPERIMENT_DEFINITION
{
	id = SEP_Retroreflector_Detailed
----

etc

Not sure if that matters..

Cheers,

Link to post
Share on other sites
2 hours ago, Friznit said:

KIS changed quite considerably, which means SEP items got updated to the new format so you need both updated...and they may only work on 1.6.1

If you're using the old version of KIS then you need an old version of SEP as well.

Ah okay, that'd explain it. Time for some manual installing then I guess ;)

Link to post
Share on other sites
14 hours ago, Phelan said:

It's KSP 1.4.2 (older version since I want to use a mod that's only available up to that version so far), all mods installed via CKAN, so no idea whether it might be a version mismatch problem.

I don't know your mod situation but you know that almost all mods that work in 1.4.x will work in 1.6.1?  Have you tried it on a clean 1.6.1 install?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...