dboi88

Coyote Space Industries - Dboi's Dev Thread

Recommended Posts

2 hours ago, Sassenach said:

Hmm, reloading a save causes the ship to blow up horribly, with the following in the log:
 

  Reveal hidden contents

[LOG 15:57:21.926] Unpacking Custom Freighter
[LOG 15:57:22.068] [F: 228003]: CSIfreightersmallrecycler collided into CSIfreighterhull - relative velocity: 624.5953 - impact momentum: 2689257.0
[LOG 15:57:22.069] CSIfreightersmallrecycler Exploded!! - blast awesomeness: 0.5
[LOG 15:57:22.070] [CSIfreightersmallrecycler]: Deactivated
[LOG 15:57:22.071] [F: 228003]: CSIcommandbridge (Custom Freighter) collided into CSIfreighterhull - relative velocity: 44.77626 - impact momentum: 192788.7
[LOG 15:57:22.072] CSIcommandbridge (Custom Freighter) Exploded!! - blast awesomeness: 0.5
[LOG 15:57:22.073] [CSIcommandbridge (Custom Freighter)]: Deactivated
[LOG 15:57:22.084] [F: 228003]: CSIfreighterevaprep collided into CSIfreighterhull - relative velocity: 49.27322 - impact momentum: 212150.8
[LOG 15:57:22.085] CSIfreighterevaprep Exploded!! - blast awesomeness: 0.5
[LOG 15:57:22.086] [CSIfreighterevaprep]: Deactivated
[LOG 15:57:22.087] [F: 228003]: CSIfreighterCargoBay collided into CSIfreighterWorkshop - relative velocity: 7952.475 - impact momentum: 397623.8
[LOG 15:57:22.088] CSIfreighterCargoBay Exploded!! - blast awesomeness: 0.5
[LOG 15:57:22.089] [CSIfreighterCargoBay]: Deactivated
[LOG 15:57:22.174] [F: 228003]: CSIfreighterhangerbay collided into CSIfreighterhull - relative velocity: 29.39459 - impact momentum: 126561.3
[LOG 15:57:22.175] CSIfreighterhangerbay Exploded!! - blast awesomeness: 0.5
[LOG 15:57:22.178] [CSIfreighterhangerbay]: Deactivated
[LOG 15:57:22.180] [F: 228003]: CSIfreighterreartrussk collided into C3.Kontainer.04 - relative velocity: 26.85821 - impact momentum: 3867.6
[LOG 15:57:22.180] CSIfreighterreartrussk Exploded!! - blast awesomeness: 0.5
[LOG 15:57:22.181] [CSIfreighterreartrussk]: Deactivated
[LOG 15:57:22.193] ScaleModList: listSize 205 maxListSize 788
[LOG 15:57:22.198] 6 explosions created.
[LOG 15:57:22.255] [F: 228007]: C3.Kontainer.04 collided into C3.Kontainer.04 - relative velocity: 13.79771 - impact momentum: 1986.9
[LOG 15:57:22.256] C3.Kontainer.04 Exploded!! - blast awesomeness: 0.5
[LOG 15:57:22.257] [C3.Kontainer.04]: Deactivated
[LOG 15:57:22.262] 1 explosions created.
[LOG 15:57:22.262] Packing Custom Freighter Debris for orbit
[LOG 15:57:22.263] Packing Custom Freighter Debris for orbit
[LOG 15:57:22.274] [F: 228008]: C3.Kontainer.04 collided into C3.Kontainer.04 - relative velocity: 11.30025 - impact momentum: 1627.2
[LOG 15:57:22.275] C3.Kontainer.04 Exploded!! - blast awesomeness: 0.5
[LOG 15:57:22.276] [C3.Kontainer.04]: Deactivated
[LOG 15:57:22.280] 1 explosions created.

 

I'm really struggling to recreate this, is it completely repeatable? 

Share this post


Link to post
Share on other sites

huh, cleaned out the dev install, put only your mod back in, tried to repeat and couldn't. Sorry, looks like something in my clutter was causing problems.

 

edit: huh, nevermind, it is back to doing it again. I think it might have something to do with the modules installed.

edit2: Not the modules, had some gigantor solar panels mounted, one of which was attached to a workshop module mounted in the second to rearmost starboard node. Removing it seems to fix the problem.

edit3: Trying to narrow down: other objects attached to the workshop module also cause massive structural failure, doesn't seem to matter which of the five nodes the workshop is placed in, no other module tested so far (not exhaustive) has yielded same problem. Seems I was either very lucky or unlucky to find this error.

edit4: might be worth noting that this problem does not occur if reloading a vessel stationary on the runway.

Edited by Sassenach

Share this post


Link to post
Share on other sites
1 hour ago, Sassenach said:

huh, cleaned out the dev install, put only your mod back in, tried to repeat and couldn't. Sorry, looks like something in my clutter was causing problems.

 

edit: huh, nevermind, it is back to doing it again. I think it might have something to do with the modules installed.

edit2: Not the modules, had some gigantor solar panels mounted, one of which was attached to a workshop module mounted in the second to rearmost starboard node. Removing it seems to fix the problem.

edit3: Trying to narrow down: other objects attached to the workshop module also cause massive structural failure, doesn't seem to matter which of the five nodes the workshop is placed in, no other module tested so far (not exhaustive) has yielded same problem. Seems I was either very lucky or unlucky to find this error.

edit4: might be worth noting that this problem does not occur if reloading a vessel stationary on the runway.

I suppose it could be something to do with the animation, maybe a collider got animated by accident, I'll see if i can replicate.

I took a look at the mass for the small modules, these are the figures that came out of the USI balance spreadsheet, greenhouse, mostly empty space, 4 tons, cupola spacious but a fully kitted out living space, 15 tons, power reactor, machinery but not necessarily heavy machinery 20 tons and the recycler, heavy duty and dense machinery 40 tons.

I also found the issue with the storage module the fuelswitch module was missing it's GUI setting.

Cheers

Share this post


Link to post
Share on other sites
2 hours ago, Sassenach said:

edit2: Not the modules, had some gigantor solar panels mounted, one of which was attached to a workshop module mounted in the second to rearmost starboard node. Removing it seems to fix the problem.

edit3: Trying to narrow down: other objects attached to the workshop module also cause massive structural failure, doesn't seem to matter which of the five nodes the workshop is placed in, no other module tested so far (not exhaustive) has yielded same problem. Seems I was either very lucky or unlucky to find this error.

I'd imagine it's because the workshop is the heaviest module, but the problem is that the weight balancing function only works on parts that are a leaf in the part tree and so should only be used on parts that do not allow surface attach, i've fixed that now so all surface attachments will need to go on the freighter hull.

Share this post


Link to post
Share on other sites

I forgot the launchpad module! One of the main roles i want this freighter for is a mobile construction vessel. So i spent the day texturing the Launchpad. It was really fun to be able to texture something from scratch using everything I've learnt so far. I'm quite happy with my 'style' now. I love this launchpad so much i want to go and make a ground based version for all my bases :D

gG29Xd1.png

buMKMSV.png

Here's a shot from the launchpad tests.

2hYKjhp.gif

I've also repurposed the cargobay model into a large KIS container/OSE Workshop assembly space so you can store/assemble large volume parts. One last part i'm going to make pre-release is a recycling module so there will be a full set of EL/OSE equivalent parts available in the Freighter From Factor.

Share this post


Link to post
Share on other sites

I have had my first review, shame he did it on none working dev build but ¯\_(ツ)_/¯ 

 

 

Share this post


Link to post
Share on other sites
On 4/18/2017 at 1:09 PM, Aeoncypher said:

This looks amazing man and that launch pad is awesome cant wait to try that out. Keep it up!

Cheers, i'll probably get another release out tomorrow once i polish off the final piece for the EL line up of parts, the grinder, and that'll be about ready for release once i finish the configs.PzhPCo3.gif

Share this post


Link to post
Share on other sites

Cant wait man, looks awesome. also i didn't see a known issue thing anyway so ima throw it out here.  After throttling engines off the ship will start to spin unsure why.

Also is the price for the hull supposed to be so high?

jTbtigq.png

 

Edited by Aeoncypher
.

Share this post


Link to post
Share on other sites
On 2.2.2017 at 7:32 PM, dboi88 said:

I've discovered sharp and smooth edges last night, so it looks like this now.

:)  this success feeling I had times before some time .. So what I wanted to say super project, really succeeded. beautiful design.

Share this post


Link to post
Share on other sites
49 minutes ago, Aeoncypher said:

Cant wait man, looks awesome. also i didn't see a known issue thing anyway so ima throw it out here.  After throttling engines off the ship will start to spin unsure why.

Also is the price for the hull supposed to be so high?

jTbtigq.png

 

Hey, thanks for trying it out. Yes the cost isn't actually the freighter hull, it's the insanely expensive fuel. If you empty the tanks you will see the true cost of the part.

I'm unable to reproduce the problem with the craft spinning, are you using any other mods? and could you send me a saved game to investigate?

25 minutes ago, RaendyLeBeau said:

:)  this success feeling I had times before some time .. So what I wanted to say super project, really succeeded. beautiful design.

Thankyou for the kind words

Edited by dboi88

Share this post


Link to post
Share on other sites
1 minute ago, dboi88 said:

Hey, thanks for trying it out. Yes the cost isn't actually the freighter hull, it's the insanely expensive fuel. If you empty the tanks you will see the true cost of the part.

I'm unable to reproduce the problem with the craft spinning, are you using any other mods? and could you send me a saved game to investigate?

Thankyou for the kind words

Ill remove everything but required stuff and try it again just to eliminate any variables

Share this post


Link to post
Share on other sites
8 minutes ago, Aeoncypher said:

Ill remove everything but required stuff and try it again just to eliminate any variables

Cheers, i'd like to take a look at the issue even if it is due to conflict with another mod so i can try and resolve. :) 

Share this post


Link to post
Share on other sites
4 minutes ago, dboi88 said:

Cheers, i'd like to take a look at the issue even if it is due to conflict with another mod so i can try and resolve. :) 

Sure thing For sure looks like an issue with one of my mods unsure which i have quite an extensive mod list right now

Share this post


Link to post
Share on other sites

808249c3eb.gif

Heres what i mean its subtle ive had it a worse. Also  sorry gif takes a second to start im really bad at making gifs Sorry. even with the USI weight transfer on and sas it still does it i can send you my save and mods list if you'd like but ive never done that before and have zero idea how. 

Share this post


Link to post
Share on other sites
5 hours ago, Aeoncypher said:

808249c3eb.gif

Heres what i mean its subtle ive had it a worse. Also  sorry gif takes a second to start im really bad at making gifs Sorry. even with the USI weight transfer on and sas it still does it i can send you my save and mods list if you'd like but ive never done that before and have zero idea how. 

You've not by any chance got something big and heavy in that hanger bay have you? So it looks to me that it isn't after burning but actually happening while burning which would suggest the COM and COF are misaligned. It'll probably make sense when i take a look at the save.

If you do a quicksave (F5) then go to Kerbal Space Program\saves\[Your Save Name]\ and then send me the 'quicksave.sfs' file, for your mod list i can deal with just a screenshot of your gamedata folder.

6 hours ago, ExplodingWaffle101 said:

Will you add allistas hangar mod support?

Yes the relevant game objects required are already in the models i just need to take a look at the configs. The Hanger Bay and Cargo bay's will be supported.

Share this post


Link to post
Share on other sites
3 hours ago, Aeoncypher said:

@dboi88 https://www.dropbox.com/sh/jib2sjzmvpogsik/AAAGElFja2yKmWfgJ6xUCcY1a?dl=0 theres the save file i did the testing and stuff on just a sandbox and thats the only ship in flight.

-snip-

 theres the mod list sorry for the amount of mods in here, and Sorry it took so long i had to go to work.

Thanks for doing this for me. I'll take a look when i get home from work later :) 

Share this post


Link to post
Share on other sites
Just now, dboi88 said:

Thanks for doing this for me. I'll take a look when i get home from work later :) 

 

Not a problem let me know if you need help with anything else related to this ill do what i can. Gl man keep up the amazing work

Share this post


Link to post
Share on other sites

Latest Release v0.1.6

v0.1.6 Change Log

  • Complete overhaul of CFG's and MM Patches
  • Added Descriptions For Parts
  • Added New EL Parts
  • Added More Texture/Normal/Spec Map Improvements
Edited by dboi88

Share this post


Link to post
Share on other sites
On 4/21/2017 at 4:57 AM, Aeoncypher said:

@dboi88 https://www.dropbox.com/sh/jib2sjzmvpogsik/AAAGElFja2yKmWfgJ6xUCcY1a?dl=0 theres the save file i did the testing and stuff on just a sandbox and thats the only ship in flight.

-snip-

 theres the mod list sorry for the amount of mods in here, and Sorry it took so long i had to go to work.

Ok i've tested and tested and can't find anything wrong, it could be it was something that I happened to fix in the last release, or there could be something else. I haven't had time to check with all the mods in the list but i've checked everything i thought could cause a problem.

js38qmn.gif

59 minutes ago, King Something said:

Just one minor nitpick:

A "hanger" is a thing you hang a coat on. A "hangar" is a garage for airplanes and space planes.

I mean come one, where else is Bill going to hang his coat?

I don't mind nitpicks, i've added it to the list of things to fix before the next release. 

Cheers

Latest Release v0.1.7

v0.1.7 Change Log

  • Minor career fixes.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.