Nertea

[1.4.5] Near Future Technologies (NF aero bugfixes, Sept 21)

Recommended Posts

13 hours ago, Kiwi Kerman said:

Geeze response in 1 hour! just wish the OPT Space Planes thread was so responsive!

 

Deleting the engines folder for Mk IV worked for me, but really should be discussing that over in it's own thread.

 

Design problem/challenge I'm having, and looking for how everyone else has overcome this:

With the Mk4-1 Heavy Command Module, how do you guys set up ladders to get onto the ground when using it as a landing pod? I tried to bypass the little lip with an extendable ladder, but my kerbal just wanted to keep going on the underside. Any attempt I'm making to try to meet the bottom of the capsule with a ladder the kerbal just gets stuck. Any suggestions/ideas/tips?

Share this post


Link to post
Share on other sites

Is Near Future Launch Vehicles being called far future technologies in ksp-avc has been fixed in newer version yet? I cannot find any replies or changelog about it...

Edited by ssd21345

Share this post


Link to post
Share on other sites
3 hours ago, ssd21345 said:

Is Near Future Launch Vehicles being called far future technologies in ksp-avc has been fixed in newer version yet? I cannot find any replies or changelog about it...

Yes, known issue. It's a pointing issue in the .version file.

  • Like 1

Share this post


Link to post
Share on other sites

It's not even a pointing issue, it's just a label. Not worth a new release to fix that IMO.

  • Like 1

Share this post


Link to post
Share on other sites
On 7/12/2017 at 0:22 PM, Nertea said:

Are you sure there isn't something else doing this? There is no bespoke patch in Kerbal Atomics that does this, and the dynamic patch explicitly only affects LiquidFuel. Pinging @toric5 to see if he has any insight whether the dynamic patch would misbehave in said situations.

haven't actually been around since 1.3 dropped, so sorry about the late reply. the patch will only target things that use liquidfuel, but no oxidiser or intake air. they may do strange things to lf+intake atmo engines (not that i am aware of any). in 1.2, i used the nuculear thermal turbojets along side the patch while i was working on it, and had no issues. I will try to replicate on monday. (I work this weekend.)

Share this post


Link to post
Share on other sites

Hello.

I have a question about nuclear reactors and uranium. My engineers do not transfer uranium between the containers. It is written that an engineer of level one is needed. And nothing happens. What am I doing wrong?

Edited by Andriy

Share this post


Link to post
Share on other sites

Not sure if this is an issue here or with CTT, or possibly even Hide empty nodes, but I don't see the 7.5m drone core in my tech tree. I can see the 5m under the mechatronics category, but that is the end of that line for me. I'll remove hide empty nodes and see if that changes anything. Will report back. Also can post anything else you need that I have forgotten/didn't know about.

Share this post


Link to post
Share on other sites
8 minutes ago, HoveringKiller said:

Not sure if this is an issue here or with CTT, or possibly even Hide empty nodes, but I don't see the 7.5m drone core in my tech tree. I can see the 5m under the mechatronics category, but that is the end of that line for me. I'll remove hide empty nodes and see if that changes anything. Will report back. Also can post anything else you need that I have forgotten/didn't know about.

 

@Nertea This is a misspelling of artificialIntelligence in the CTT patch (I've put a pull request on GitHub for you)

  • Like 2

Share this post


Link to post
Share on other sites

Hey guys, I'm getting a lot of these when vessels go out of range:

ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
  at System.Collections.Generic.List`1[ResourceRatio].get_Item (Int32 index) [0x00000] in <filename unknown>:0 
  at DynamicBatteryStorage.ModuleDynamicBatteryStorage.VerifyInputs (.PartModule pm, Boolean isProducer) [0x00000] in <filename unknown>:0 
  at DynamicBatteryStorage.ModuleDynamicBatteryStorage.TrySetupProducer (.PartModule pm) [0x00000] in <filename unknown>:0 
  at DynamicBatteryStorage.ModuleDynamicBatteryStorage.RefreshVesselElectricalData () [0x00000] in <filename unknown>:0 
  at DynamicBatteryStorage.ModuleDynamicBatteryStorage.RefreshVesselElectricalData (.Vessel eventVessel) [0x00000] in <filename unknown>:0 
  at EventData`1[Vessel].Fire (.Vessel data) [0x00000] in <filename unknown>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
EventData`1:Fire(Vessel)
Vessel:OnDestroy()

 

Also, somehow, NFE overheats and damages my USI nuclear reactor pretty badly when I'm timewarping although I have sufficient cooling installed.

 

I will try to provide more details and log a github issue tomorrow, this is just a heads up.

Share this post


Link to post
Share on other sites
18 minutes ago, Kobymaru said:

Hey guys, I'm getting a lot of these when vessels go out of range:

Yeah... going to need a lot more than that. Full log of event, descriptions and screenshots of vessels involved, mods installed, etc. 

18 minutes ago, Kobymaru said:

Also, somehow, NFE overheats and damages my USI nuclear reactor pretty badly when I'm timewarping although I have sufficient cooling installed.

Again, lots more details needed, like what part, what radiators, screenshots, etc...

Share this post


Link to post
Share on other sites
11 minutes ago, Nertea said:

Yeah... going to need a lot more than that. Full log of event, descriptions and screenshots of vessels involved, mods installed, etc. 

Again, lots more details needed, like what part, what radiators, screenshots, etc...

Sorry about that, I was hoping you knew whats up looking at the exception. Happens sometimes. :wink:

But alas, more details are coming tomorrow.

Share this post


Link to post
Share on other sites

Oh my....   i dissapear for a short bit and in my abscence my favorite mod-umbrella-pack comes out with giant rocket parts???

 

cant wait to see what i blow up on the pad with these...

 

:)

17 hours ago, Kobymaru said:

Sorry about that, I was hoping you knew whats up looking at the exception. Happens sometimes. :wink:

But alas, more details are coming tomorrow.

In my experience ive always had to use stock radiators with USI reactors.  the heat control parts only worked for me with stock parts or NF reactors

Share this post


Link to post
Share on other sites
On 7/14/2017 at 7:38 AM, Aelfhe1m said:

 

@Nertea This is a misspelling of artificialIntelligence in the CTT patch (I've put a pull request on GitHub for you)

I've found it and corrected it on my game, I'll upload the fixed file here if anyone is interested in it.

Share this post


Link to post
Share on other sites
6 hours ago, TK421d said:

In my experience ive always had to use stock radiators with USI reactors.  the heat control parts only worked for me with stock parts or NF reactors

This would have been useful to mention, but I can't see how that would be a thing. HC has no plugin bits, it's purely configs.

On 7/14/2017 at 3:16 AM, Andriy said:

I have a question about nuclear reactors and uranium. My engineers do not transfer uranium between the containers. It is written that an engineer of level one is needed. And nothing happens. What am I doing wrong?

Sounds like a bug in the UI, that should say level 4. I'll look into it when I can. Can you transfer fuel with a level 4/5 engineer?

 

 

Share this post


Link to post
Share on other sites

Hey @Nertea,

i really love your mods. The art-style and models are perfect. Unfortunately there is a problem with your DXT compressed normal maps. All the normal maps are missing the X/U information, which is the R-channel in the standard (blue/purple) normal map. All RGBA-channels contain the same G-channel (Y/V information) of the standard normal map.

Your normal maps look like this: R'G'B'A' = GGGG

A DXTnm compressed normal map should look like this:  R'G'B'A' = XGXR  R-channel moved to the A-channel, R&B-channel need to be filled with the same arbitrary values, usually a copy of the G-channel or white.

My guess is that something went wrong with the DXTnm compression you used. I hope you still have the uncompressed source files. I can recommend GIMP with the DDS plugin. It has a DXT5nm compression option that works. It rearranges the channels like mentioned above and then compresses with DXT5. The resulting nm looks pink instead of grey because it fills the R&B-channel with white instead of a copy of the G-channel, which doesn't matter because they aren't used anyway.

Or you could use ImageMagick v7 to batch convert with the following command:

convert input.png -alpha Set -separate -swap 0,3 -combine -fill white -colorize 100,0,100,0 -define dds:compression=dxt5 output2.dds

 

Edited by eppima

Share this post


Link to post
Share on other sites
8 hours ago, Nertea said:

Sounds like a bug in the UI, that should say level 4. I'll look into it when I can. Can you transfer fuel with a level 4/5 engineer?

No, none of the engineers can do this.

I tried to change the file ___Kerbal Space Program\GameData\NearFutureElectrical\Parts\Utility\nuclear-recycler-25

{
		name = RadioactiveStorageContainer
		DangerousFuel = DepletedFuel
		SafeFuel = EnrichedUranium
		// What enginer level is needed to transfer the safe fuel
		EngineerLevelForSafe = 1
		// What enginer level is needed to transfer the dangerous fuel
		EngineerLevelForDangerous = 3
		// Max temp for transferring fuel into or out of the part
		MaxTempForTransfer = 400
		// kW of heat per unit of waste
		HeatFluxPerWasteUnit = 5
	}

Changing the number at the lines EngineerLevelForSafe = 1 and EngineerLevelForDangerous = 3 only changes the displayed text on the screen. In other reactor configuration files the same code.

Share this post


Link to post
Share on other sites

I seem to be getting more explosions than expected when using the NFLV radial decoupler. Using it for a 2.5m mainsail LRB stage, but the main tank of the booster (Ven's cryoXXL) keeps exploding when it's decoupled. I've tried turning down ejection force all the way to 0%, and with no autostruts or rigid attachment, and still explodes the tank. If I offset the tank to be further out from the core stage, so it's not visibly touching the top of the decoupler, it no longer explodes. So I guess I collider issue?

Share this post


Link to post
Share on other sites
6 hours ago, Andriy said:

No, none of the engineers can do this.

I tried to change the file ___Kerbal Space Program\GameData\NearFutureElectrical\Parts\Utility\nuclear-recycler-25


{
		name = RadioactiveStorageContainer
		DangerousFuel = DepletedFuel
		SafeFuel = EnrichedUranium
		// What enginer level is needed to transfer the safe fuel
		EngineerLevelForSafe = 1
		// What enginer level is needed to transfer the dangerous fuel
		EngineerLevelForDangerous = 3
		// Max temp for transferring fuel into or out of the part
		MaxTempForTransfer = 400
		// kW of heat per unit of waste
		HeatFluxPerWasteUnit = 5
	}

Changing the number at the lines EngineerLevelForSafe = 1 and EngineerLevelForDangerous = 3 only changes the displayed text on the screen. In other reactor configuration files the same code.

I'll investigate.

14 hours ago, eppima said:

Hey @Nertea,

i really love your mods. The art-style and models are perfect. Unfortunately there is a problem with your DXT compressed normal maps. All the normal maps are missing the X/U information, which is the R-channel in the standard (blue/purple) normal map. All RGBA-channels contain the same G-channel (Y/V information) of the standard normal map.

Your normal maps look like this: R'G'B'A' = GGGG

A DXTnm compressed normal map should look like this:  R'G'B'A' = XGXR  R-channel moved to the A-channel, R&B-channel need to be filled with the same arbitrary values, usually a copy of the G-channel or white.

My guess is that something went wrong with the DXTnm compression you used. I hope you still have the uncompressed source files. I can recommend GIMP with the DDS plugin. It has a DXT5nm compression option that works. It rearranges the channels like mentioned above and then compresses with DXT5. The resulting nm looks pink instead of grey because it fills the R&B-channel with white instead of a copy of the G-channel, which doesn't matter because they aren't used anyway.

Feh.... ok so here's what happened. The KSP PartTools exporter swizzles the channels already, and then tacking a DXT5nm conversion on top swizzles them again, losing the A channel in the process. Never thought to check. 

This is going to be a horrible pain in the ass to fix.

Share this post


Link to post
Share on other sites
18 hours ago, Nertea said:

This would have been useful to mention, but I can't see how that would be a thing. HC has no plugin bits, it's purely configs.

it HAS been a while since i used both, i recall it being a thing before stock heat was a thing.

 

Also:  i think i just fell in love with those engine mounts with the fairing nodes below...

Edited by TK421d

Share this post


Link to post
Share on other sites
On 7/15/2017 at 1:06 PM, TK421d said:

In my experience ive always had to use stock radiators with USI reactors.  the heat control parts only worked for me with stock parts or NF reactors

19 hours ago, Nertea said:

This would have been useful to mention, but I can't see how that would be a thing. HC has no plugin bits, it's purely configs.

This sounds like it may be referring to the bug where some parts allocate much more radiator capacity than they need, leaving other parts starved for cooling.  That's not specific to USI reactors, though; I think it's just a bug in the stock heat mechanics, possibly related to the part having a large "max cooling" value.  The workaround is to use "nearby-only" radiators placed such that the offending part(s) can't draw from them, but other parts can.  "Having to use stock radiators" is just because HC doesn't provide any nearby-only radiators.

There's an MKS drill that's known to cause the problem, which sparked some discussion in the MKS thread and a bug in the MKS tracker.  My example craft file attached to the bug has a USI reactor and stock TCS radiators, but I originally encountered the problem while using NFE's MX-0 reactor and HC's YF-75 radiators (together with those MKS drills).  (Note that this was in 1.2.2, though; I haven't tried it again in 1.3.)

Edited by Wyzard

Share this post


Link to post
Share on other sites
1 hour ago, TK421d said:

it HAS been a while since i used both, i recall it being a thing before stock heat was a thing.

 

But... if it was before stock heat, then how would stock radiators have worked instead of HC radiators? :wink:

25 minutes ago, Wyzard said:

This sounds like it may be referring to the bug where some parts allocate much more radiator capacity than they need, leaving other parts starved for cooling.  That's not specific to USI reactors, though; I think it's just a bug in the stock heat mechanics, possibly related to the part having a large "max cooling" value.  The workaround is to use "nearby-only" radiators placed such that the offending part(s) can't draw from them, but other parts can.  "Having to use stock radiators" is just because HC doesn't provide any nearby-only radiators.

 

Yay more stock heat bugs.

10 hours ago, Andriy said:

No, none of the engineers can do this.

 

I can't repro this at all. I tried transferring a bunch of fuel and waste from 2.5m reactors, recyclers and fuel containers (using a level 5 engineer) with no problems. Well, except a small localization bug...

Additionally I tried transferring with a level 1 engineer, could successfully transfer fuel but not waste, so everything seems to be working as planned. 

4 hours ago, Rodger said:

I seem to be getting more explosions than expected when using the NFLV radial decoupler. Using it for a 2.5m mainsail LRB stage, but the main tank of the booster (Ven's cryoXXL) keeps exploding when it's decoupled. I've tried turning down ejection force all the way to 0%, and with no autostruts or rigid attachment, and still explodes the tank. If I offset the tank to be further out from the core stage, so it's not visibly touching the top of the decoupler, it no longer explodes. So I guess I collider issue?

I tried a bunch of repros using many NFLV and stock tanks as both the host and the child and could no repro this on the launchpad or in flight. Can you  get me repro steps without Ven's tanks?

Share this post


Link to post
Share on other sites
1 hour ago, Nertea said:

I can't repro this at all. I tried transferring a bunch of fuel and waste from 2.5m reactors, recyclers and fuel containers (using a level 5 engineer) with no problems. Well, except a small localization bug...

Additionally I tried transferring with a level 1 engineer, could successfully transfer fuel but not waste, so everything seems to be working as planned. 

I realized what the problem is :-))) I'm using the russian version of the game. Switch to english, everything works correctly. Thank you

Share this post


Link to post
Share on other sites

@Nertea

Broken solar panel breaks.. but doesn't.. collider remains and can even move or cause impacts with other craft. Major correction needed:

Model is OKEB 78, have not checked other sails yet to see how they perform when broken. Also, cannot be repaired. Not sure if the repair part is WAD.

k2OFabf.png

Edited by Maelstrom Vortex

Share this post


Link to post
Share on other sites
12 hours ago, Maelstrom Vortex said:

@Nertea

Broken solar panel breaks.. but doesn't.. collider remains and can even move or cause impacts with other craft. Major correction needed:

Model is OKEB 78, have not checked other sails yet to see how they perform when broken. Also, cannot be repaired. Not sure if the repair part is WAD.

k2OFabf.png

i have had this issue too caused a probe that couldent be undocked, as for repairing them you cant repair solar panels.
 

but heres a random ship!

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now