Nertea

[1.7.x] Near Future Technologies (NF Electrical upgrades July 9th)

Recommended Posts

I think there seems to be a problem with NF Construction:
30ttkcw.png
I already reinstalled both B9 Switch and NF Construction, the issue remains. Any idea what's causing this?

Share this post


Link to post
Share on other sites
1 hour ago, KSPanier said:

I already reinstalled both B9 Switch and NF Construction, the issue remains. Any idea what's causing this?

Some of the B9 part switch configs have formatting errors that causes this error message. The mod still works fine, just ignore the message. Its just like driving a car with a check engine light that is lit up for no reason.

 

@Nertea, the new NF Solar parts are gorgeous! I've been busy updating some of my designs. Are any of them modeled after the ISS arrays?

Share this post


Link to post
Share on other sites
20 minutes ago, Nightside said:

Some of the B9 part switch configs have formatting errors that causes this error message. The mod still works fine, just ignore the message. Its just like driving a car with a check engine light that is lit up for no reason.

 

@Nertea, the new NF Solar parts are gorgeous! I've been busy updating some of my designs. Are any of them modeled after the ISS arrays?

Well, that check engine light just deleted my space station, caused a excrements ton of null.pointer.exceptions and bricks the game everytime I try to load an Ortho part launched from before the update and an Ortho part launched after the update into the same scene.

Share this post


Link to post
Share on other sites

Are the new solar panels tweakscale compatible?

Share this post


Link to post
Share on other sites
Posted (edited)
6 hours ago, KSPanier said:

Well, that check engine light just deleted my space station, caused a excrements ton of null.pointer.exceptions and bricks the game everytime I try to load an Ortho part launched from before the update and an Ortho part launched after the update into the same scene.

From what I can figure out, in order to dirty patch it you'd need to dig into the unity build of the part to see the exact transform names.  Its throwing those errors for me also, but I started a fresh career with 1.7 so its not effected anything in game (crosses fingers).

I was getting almost double the crazy warnings on load (5 fatal patch errors from MM) but with the solar panel update today it went from 5 to just 1 - assuming that's NF Construction.

Edited by PolecatEZ

Share this post


Link to post
Share on other sites
1 hour ago, PolecatEZ said:

From what I can figure out, in order to dirty patch it you'd need to dig into the unity build of the part to see the exact transform names.  Its throwing those errors for me also, but I started a fresh career with 1.7 so its not effected anything in game (crosses fingers).

I was getting almost double the crazy warnings on load (5 fatal patch errors from MM) but with the solar panel update today it went from 5 to just 1 - assuming that's NF Construction.

I get zero MM patch errors with NF Solar and Construction, however there could be an issue with one of the optional mod patches or in a patch from another mod.

the log should give you a clue to the source of the error.

Share this post


Link to post
Share on other sites

The problem started with the latest B9 plugin version.

Here's the relevant part of the log:

Spoiler

[LOG 23:47:29.924] PartLoader: Compiling Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-attach-01/truss-octo-attach-01'
[WRN 23:47:29.934] Warning on PartSubtype Angled on module ModuleB9PartSwitch (moduleID='meshSwitch') on part unknownPart: No transforms named 'COLLISION' found
[WRN 23:47:29.934] Warning on PartSubtype Angled Hollow on module ModuleB9PartSwitch (moduleID='meshSwitch') on part unknownPart: No transforms named 'COLLISION' found
[WRN 23:47:29.934] Warning on PartSubtype Ortho on module ModuleB9PartSwitch (moduleID='meshSwitch') on part unknownPart: No transforms named 'COLLISIONALT' found
[WRN 23:47:29.934] Warning on PartSubtype Ortho Hollow on module ModuleB9PartSwitch (moduleID='meshSwitch') on part unknownPart: No transforms named 'COLLISIONALT' found
[LOG 23:47:29.939] PartLoader: Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-attach-01/truss-octo-attach-01' has no database record. Creating.
[LOG 23:47:29.942] DragCubeSystem: Creating drag cubes for part 'truss-octo-attach-01'
[WRN 23:47:29.954] Warning on PartSubtype Angled on module ModuleB9PartSwitch (moduleID='meshSwitch') on part truss-octo-attach-01: No transforms named 'COLLISION' found
[WRN 23:47:29.960] DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.
[WRN 23:47:29.961] Warning on PartSubtype Angled Hollow on module ModuleB9PartSwitch (moduleID='meshSwitch') on part truss-octo-attach-01: No transforms named 'COLLISION' found
[WRN 23:47:29.962] DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.
[WRN 23:47:29.962] Warning on PartSubtype Ortho on module ModuleB9PartSwitch (moduleID='meshSwitch') on part truss-octo-attach-01: No transforms named 'COLLISIONALT' found
[WRN 23:47:29.963] DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.
[WRN 23:47:29.963] Warning on PartSubtype Ortho Hollow on module ModuleB9PartSwitch (moduleID='meshSwitch') on part truss-octo-attach-01: No transforms named 'COLLISIONALT' found
[WRN 23:47:29.964] DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.
[LOG 23:47:29.968] PartLoader: Compiling Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-crew-01/truss-octo-crew-01'
[WRN 23:47:29.980] Warning on PartSubtype Solid on module ModuleB9PartSwitch (moduleID='meshSwitch') on part unknownPart: No transforms named 'TubeLrg' found
[WRN 23:47:29.980] Warning on PartSubtype Hollow on module ModuleB9PartSwitch (moduleID='meshSwitch') on part unknownPart: No transforms named 'TubeLrg' found
[WRN 23:47:29.980] Warning on PartSubtype Dual on module ModuleB9PartSwitch (moduleID='meshSwitch') on part unknownPart: No transforms named 'TubeLrg' found
[LOG 23:47:29.985] PartLoader: Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-crew-01/truss-octo-crew-01' has no database record. Creating.
[LOG 23:47:29.989] DragCubeSystem: Creating drag cubes for part 'truss-octo-crew-01'
[WRN 23:47:30.013] Warning on PartSubtype Solid on module ModuleB9PartSwitch (moduleID='meshSwitch') on part truss-octo-crew-01: No transforms named 'TubeLrg' found
[WRN 23:47:30.015] DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.
[WRN 23:47:30.015] Warning on PartSubtype Hollow on module ModuleB9PartSwitch (moduleID='meshSwitch') on part truss-octo-crew-01: No transforms named 'TubeLrg' found
[WRN 23:47:30.015] DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.
[WRN 23:47:30.016] Warning on PartSubtype Dual on module ModuleB9PartSwitch (moduleID='meshSwitch') on part truss-octo-crew-01: No transforms named 'TubeLrg' found
[WRN 23:47:30.016] DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.
[LOG 23:47:30.021] PartLoader: Compiling Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-crew-02/truss-octo-crew-02'
[WRN 23:47:30.032] Warning on PartSubtype Solid on module ModuleB9PartSwitch (moduleID='meshSwitch') on part unknownPart: No transforms named 'TubeMedium' found
[WRN 23:47:30.032] Warning on PartSubtype Hollow on module ModuleB9PartSwitch (moduleID='meshSwitch') on part unknownPart: No transforms named 'TubeMedium' found
[WRN 23:47:30.032] Warning on PartSubtype Dual on module ModuleB9PartSwitch (moduleID='meshSwitch') on part unknownPart: No transforms named 'TubeMedium' found
[LOG 23:47:30.037] PartLoader: Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-crew-02/truss-octo-crew-02' has no database record. Creating.
[LOG 23:47:30.040] DragCubeSystem: Creating drag cubes for part 'truss-octo-crew-02'
[WRN 23:47:30.065] Warning on PartSubtype Solid on module ModuleB9PartSwitch (moduleID='meshSwitch') on part truss-octo-crew-02: No transforms named 'TubeMedium' found
[WRN 23:47:30.067] DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.
[WRN 23:47:30.067] Warning on PartSubtype Hollow on module ModuleB9PartSwitch (moduleID='meshSwitch') on part truss-octo-crew-02: No transforms named 'TubeMedium' found
[WRN 23:47:30.068] DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.
[WRN 23:47:30.068] Warning on PartSubtype Dual on module ModuleB9PartSwitch (moduleID='meshSwitch') on part truss-octo-crew-02: No transforms named 'TubeMedium' found
[WRN 23:47:30.069] DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.
[LOG 23:47:30.073] PartLoader: Compiling Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-crew-03/truss-octo-crew-03'
[WRN 23:47:30.084] Warning on PartSubtype Solid on module ModuleB9PartSwitch (moduleID='meshSwitch') on part unknownPart: No transforms named 'TubeSmall' found
[WRN 23:47:30.084] Warning on PartSubtype Hollow on module ModuleB9PartSwitch (moduleID='meshSwitch') on part unknownPart: No transforms named 'TubeSmall' found
[WRN 23:47:30.084] Warning on PartSubtype Dual on module ModuleB9PartSwitch (moduleID='meshSwitch') on part unknownPart: No transforms named 'TubeSmall' found
[LOG 23:47:30.089] PartLoader: Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-crew-03/truss-octo-crew-03' has no database record. Creating.
[LOG 23:47:30.093] DragCubeSystem: Creating drag cubes for part 'truss-octo-crew-03'
[WRN 23:47:30.114] Warning on PartSubtype Solid on module ModuleB9PartSwitch (moduleID='meshSwitch') on part truss-octo-crew-03: No transforms named 'TubeSmall' found
[ERR 23:47:30.114] [SeriousWarningHandler] Not displaying serious warning because too many warnings have already been added:

[ERR 23:47:30.115] Initialization errors on ModuleB9PartSwitch (moduleID='meshSwitch') on part truss-octo-crew-03 subtype 'Solid'
  No transforms named 'TubeSmall' found

[WRN 23:47:30.116] DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.
[WRN 23:47:30.116] Warning on PartSubtype Hollow on module ModuleB9PartSwitch (moduleID='meshSwitch') on part truss-octo-crew-03: No transforms named 'TubeSmall' found
[ERR 23:47:30.116] [SeriousWarningHandler] Not displaying serious warning because too many warnings have already been added:

[ERR 23:47:30.117] Initialization errors on ModuleB9PartSwitch (moduleID='meshSwitch') on part truss-octo-crew-03 subtype 'Hollow'
  No transforms named 'TubeSmall' found

[WRN 23:47:30.117] Warning on PartSubtype Dual on module ModuleB9PartSwitch (moduleID='meshSwitch') on part truss-octo-crew-03: No transforms named 'TubeSmall' found
[ERR 23:47:30.117] [SeriousWarningHandler] Not displaying serious warning because too many warnings have already been added:

[ERR 23:47:30.117] Initialization errors on ModuleB9PartSwitch (moduleID='meshSwitch') on part truss-octo-crew-03 subtype 'Dual'
  No transforms named 'TubeSmall' found

[LOG 23:47:30.122] PartLoader: Compiling Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-docking-125/truss-octo-docking-125'
[LOG 23:47:30.138] PartLoader: Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-docking-125/truss-octo-docking-125' has no database record. Creating.
[LOG 23:47:30.141] DragCubeSystem: Creating drag cubes for part 'truss-octo-docking-125'
[LOG 23:47:30.166] PartLoader: Compiling Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-docking-25/truss-octo-docking-25'
[LOG 23:47:30.183] PartLoader: Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-docking-25/truss-octo-docking-25' has no database record. Creating.
[LOG 23:47:30.185] DragCubeSystem: Creating drag cubes for part 'truss-octo-docking-25'
[LOG 23:47:30.203] PartLoader: Compiling Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-docking-octo/truss-octo-docking-octo'
[LOG 23:47:30.221] PartLoader: Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-docking-octo/truss-octo-docking-octo' has no database record. Creating.
[LOG 23:47:30.225] DragCubeSystem: Creating drag cubes for part 'truss-octo-docking-octo'
[LOG 23:47:30.242] PartLoader: Compiling Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-drone-01/truss-octo-drone-01'
[LOG 23:47:30.387] PartLoader: Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-drone-01/truss-octo-drone-01' has no database record. Creating.
[LOG 23:47:30.392] DragCubeSystem: Creating drag cubes for part 'truss-octo-drone-01'
[LOG 23:47:30.418] PartLoader: Compiling Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-hub-01/truss-octo-hub-01'
[LOG 23:47:30.431] PartLoader: Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-hub-01/truss-octo-hub-01' has no database record. Creating.
[LOG 23:47:30.432] DragCubeSystem: Creating drag cubes for part 'truss-octo-hub-01'
[LOG 23:47:30.457] PartLoader: Compiling Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-hub-crew-01/truss-octo-hub-crew-01'
[LOG 23:47:30.471] PartLoader: Part 'NearFutureConstruction/Parts/Truss/truss-octo/truss-octo-hub-crew-01/truss-octo-hub-crew-01' has no database record. Creating.
[LOG 23:47:30.473] DragCubeSystem: Creating drag cubes for part 'truss-octo-hub-crew-01'
[LOG 23:47:30.506] PartLoader: Compiling Part 'NearFutureConstruction/Parts/Truss/truss-spinal/truss-spinal-01/truss-spinal-01'
[LOG 23:47:30.524] PartLoader: Part 'NearFutureConstruction/Parts/Truss/truss-spinal/truss-spinal-01/truss-spinal-01' has no database record. Creating.
[LOG 23:47:30.529] DragCubeSystem: Creating drag cubes for part 'truss-spinal-01'
[LOG 23:47:30.552] PartLoader: Compiling Part 'NearFutureConstruction/Parts/Truss/truss-spinal/truss-spinal-02/truss-spinal-02'
[LOG 23:47:30.571] PartLoader: Part 'NearFutureConstruction/Parts/Truss/truss-spinal/truss-spinal-02/truss-spinal-02' has no database record. Creating.
[LOG 23:47:30.575] DragCubeSystem: Creating drag cubes for part 'truss-spinal-02'
[LOG 23:47:30.599] PartLoader: Compiling Part 'NearFutureConstruction/Parts/Truss/truss-spinal/truss-spinal-03/truss-spinal-03'
[LOG 23:47:30.617] PartLoader: Part 'NearFutureConstruction/Parts/Truss/truss-spinal/truss-spinal-03/truss-spinal-03' has no database record. Creating.
[LOG 23:47:30.622] DragCubeSystem: Creating drag cubes for part 'truss-spinal-03'
[LOG 23:47:30.643] PartLoader: Compiling Part 'NearFutureConstruction/Parts/Truss/truss-spinal/truss-spinal-adapter-01/truss-spinal-adapter-01'
[LOG 23:47:30.656] PartLoader: Part 'NearFutureConstruction/Parts/Truss/truss-spinal/truss-spinal-adapter-01/truss-spinal-adapter-01' has no database record. Creating.
[LOG 23:47:30.659] DragCubeSystem: Creating drag cubes for part 'truss-spinal-adapter-01'
[LOG 23:47:30.681] PartLoader: Compiling Part 'NearFutureConstruction/Parts/Truss/truss-spinal/truss-spinal-adapter-02/truss-spinal-adapter-02'
[LOG 23:47:30.695] PartLoader: Part 'NearFutureConstruction/Parts/Truss/truss-spinal/truss-spinal-adapter-02/truss-spinal-adapter-02' has no database record. Creating.

 

Share this post


Link to post
Share on other sites

I'm trying to provide battery backup for a station carrying a large amount of LH2 in inflatable tanks.  I thought maybe I'd try some of the new-fangled Lithium Air batteries and NFE Capacitors.

After some experimentation on the launchpad, I'm really confused.  Are these strictly manual devices?  It seems like capacitors only discharge when you press a button, and Lithium Air batteries only convert their KilowattHour resource to Electric Charge when a slider is moved to the correct position.  And both of them also require manual intervention to recharge?

 

I'm not clear what these are for, really.  Maybe some future tech that requires a lot of manual prep to charge up?  They don't seem to behave like real-world batteries and capacitors, that's for sure.

Share this post


Link to post
Share on other sites
5 hours ago, justspace103 said:

Are the new solar panels tweakscale compatible?

There is no official support, but there is no intentional barring of functionality either. Try and see if it works.

Pretty sure it'll work for the vast majority, if not all of them.

Share this post


Link to post
Share on other sites
1 hour ago, GDorn said:

I'm trying to provide battery backup for a station carrying a large amount of LH2 in inflatable tanks.  I thought maybe I'd try some of the new-fangled Lithium Air batteries and NFE Capacitors.

After some experimentation on the launchpad, I'm really confused.  Are these strictly manual devices?  It seems like capacitors only discharge when you press a button, and Lithium Air batteries only convert their KilowattHour resource to Electric Charge when a slider is moved to the correct position.  And both of them also require manual intervention to recharge?

 

I'm not clear what these are for, really.  Maybe some future tech that requires a lot of manual prep to charge up?  They don't seem to behave like real-world batteries and capacitors, that's for sure.

Main use is for electric engines like the hall thruster that need short but intense bursts of high power.  Capacitors are lighter than batteries so are useful in small craft such as probes.  They do discharge fairly quickly though.  You could use Smart Parts mod to trigger them on a given condition but for continuous charge to support things like cryo tanks you're better off using regular batteries I think.

Share this post


Link to post
Share on other sites

I wouldn't exactly call Hall thrusters something that needs "short" bursts. Several-minute-long burns aren't all too uncommon, particularly for long-range (e.g. Joolbound) probes.

Share this post


Link to post
Share on other sites

Well, capacitors are still very good for even several minute burns. And for the plasma engines, either you bring nuclear power or you take enough capacitors and some solar panels. Ideally both :P I'm using them on a lot of ships, from small probes to SSTO spaceplanes (with plasma engines instead of nukes). Micro-management is not that complex thanks to the capacitors panel. Combined with the betterTimeWarp mod, it makes electric engines very nice to use compared to stock. Thanks for that Nertea ! And for the very nice looking solar panels. And all the other mods !

Share this post


Link to post
Share on other sites
Posted (edited)

The key consideration is mass.

An electric engine doesn't only have its own mass to factor in, but also the mass of its power source. In contrast to fuel, this is all dry mass. So it reduces your dV and your TWR and increases your launch mass. You have a vested reason to bring the most lightweight power source that does the job for you.

The figure describing this property is called "specific power", and is measured (in the case of this mod) in electric charge per second per ton (Ec/s/ton). On one end of the scale we have RTGs, which post something like a little below 10 Ec/s/ton at stock stats (your experience with NF Electrical may vary). Solar power begins around 50 to 60 Ec/s/ton in stock, and in case of NF Solar, tops out at around 120 Ec/s/ton on the very high end. NF's nuclear reactors, you might find those anywhere between 100 and 250 Ec/s/ton; larger reactors have better specific power.

But with capacitors and a trickle charge source? You can pull off in excess of 400 Ec/s/ton easily. Your burn duration is hard limited, true - but if you can cover the duration you need, and waiting a while for the recharge isn't a problem for your application, then this is the single most mass-efficient power source you can possibly employ.

For this reason, capacitors intentionally force you to control them by hand. If they were automated, they'd be broken beyond belief.

Edited by Streetwind

Share this post


Link to post
Share on other sites
Posted (edited)

I'm running into a weird problem. When I try to launch any craft with an inflatable craft (or something like the centrifuge rings), then I leave the craft to the space center or load back into the game, it gives me this error:

2iVdEPT.png

This particular test was simply a centrifuge ring. Same result if I put an inflatable hab section or a different ring.

I tried clearing out all my addons and reinstalling them, and rebooting the computer. Keeps giving me this. Happens with any of the deployable parts in the Station part expansion redux. I haven't seen it with any other part. It just started a few days ago. I  tried removing any new addons, but that didn't change anything either. Anyone else getting this? I can upload logs if it'll help. Is it related to the B9Partswitch errors?

Edit: Just to be clear, the craft was one part: the Coriolis Inflatable Centrifuge Module, nothing else.

Edited by AmpCat

Share this post


Link to post
Share on other sites
2 hours ago, AmpCat said:

I'm running into a weird problem. When I try to launch any craft with an inflatable craft (or something like the centrifuge rings), then I leave the craft to the space center or load back into the game, it gives me this error:

2iVdEPT.png

This particular test was simply a centrifuge ring. Same result if I put an inflatable hab section or a different ring.

I tried clearing out all my addons and reinstalling them, and rebooting the computer. Keeps giving me this. Happens with any of the deployable parts in the Station part expansion redux. I haven't seen it with any other part. It just started a few days ago. I  tried removing any new addons, but that didn't change anything either. Anyone else getting this? I can upload logs if it'll help. Is it related to the B9Partswitch errors?

Edit: Just to be clear, the craft was one part: the Coriolis Inflatable Centrifuge Module, nothing else.

Weirdly, I get this same issue with flags I have planted - once I change scenes back to KSC, the message pops up with "Vessel NameOfFlagIJustPlanted was not..." etc.

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, AccidentalDisassembly said:

Weirdly, I get this same issue with flags I have planted - once I change scenes back to KSC, the message pops up with "Vessel NameOfFlagIJustPlanted was not..." etc.

Huh. I should check the flags I've planted. Took me a few days to narrow down the problem. I noticed it first when my space station just poofed, but only (or so I thought) after undocking its engine section for recovery and replacement. It could have been just coincidence, but the remaining station (the part that vanished) did have that part I mentioned above.

After checking, nope, all my flags are intact.

Edited by AmpCat

Share this post


Link to post
Share on other sites

Got the newest NFS and it's amazing. Really cool stuff, looks better than ever.

Share this post


Link to post
Share on other sites
Posted (edited)

Love this update to NFS too.

@Nertea, noticed one potential bug; the Ares and Titan solar blankets both produce the same amount of EC (500), even though the Titan is pretty clearly over twice the area. (not to mention, twice the mass). I'm guessing the Ares should be 250.

Edit: Also, several of the solar blankets in the description claim they are not retractable, but the stats don't say they're not retractable, and is indeed retractable in space. The specific one I tested was the Nautilus

Edited by AmpCat

Share this post


Link to post
Share on other sites
Posted (edited)

When I downloaded and installed NFE for 1.7, opening my save gave several error messages saying that my nuclear fuel drums on my Argotech Deep Space Probes were not useable. Were some parts deprecated or what? Another issue is that I have 3 copies of the RTG one with the black texture and two without.Im currently using 1.6 NFE with the others being updated.

PS I really love the Argon Hall Effect Thrusters. Really power efficient and I can run a bunch off the Garnet reactor. I can easily make a light interplanetary probe that can not only get to the outer reaches of OPM, but also enter orbit around every body and have a lot of DV left over.

Edited by Xurkitree

Share this post


Link to post
Share on other sites
Posted (edited)

can you make it's latest version work with KSP 1.4.5 please? i want to use it with RSS/RO. is it gonna be hard?

Edited by VaNnadin

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, VaNnadin said:

can you make it's latest version work with KSP 1.4.5 please? i want to use it with RSS/RO. is it gonna be hard?

I suggest you use a version that is for 1.4.5, check through CurseForge or SpaceDock.

14 hours ago, Xurkitree said:

When I downloaded and installed NFE for 1.7, opening my save gave several error messages saying that my nuclear fuel drums on my Argotech Deep Space Probes were not useable. Were some parts deprecated or what? Another issue is that I have 3 copies of the RTG one with the black texture and two without.Im currently using 1.6 NFE with the others being updated.

 

No such issues have been reported. It's really worth noting the following from the changelog:

- Some restructuring of files and assets, ensure you delete old NFE installations

Make sure you did this. 

On 5/16/2019 at 12:14 PM, AmpCat said:

I tried clearing out all my addons and reinstalling them, and rebooting the computer. Keeps giving me this. Happens with any of the deployable parts in the Station part expansion redux. I haven't seen it with any other part. It just started a few days ago. I  tried removing any new addons, but that didn't change anything either. Anyone else getting this? I can upload logs if it'll help. Is it related to the B9Partswitch errors?

I cannot reproduce this, can you provide exact steps?

Edited by Nertea

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, Nertea said:

I suggest you use a version that is for 1.4.5, check through CurseForge or SpaceDock.

i know and i can do it right now but new design is so cool to me;  If my request is difficult to work on can you tell me about difference between 1.4.5 and 1.7.0 parts? i'll try to make newest version fit with 1.4.5 myself if you allow it.

Edited by VaNnadin

Share this post


Link to post
Share on other sites
1 hour ago, VaNnadin said:

i know and i can do it right now but new design is so cool to me;  If my request is difficult to work on can you tell me about difference between 1.4.5 and 1.7.0 parts? i'll try to make newest version fit with 1.4.5 myself if you allow it.

Any of the mods with parts that use the new shaders will be pretty broken pre 1.6 as those versions do not package the appropriate shaders.

Share this post


Link to post
Share on other sites
Posted (edited)

@Nerteasorry i tried to edit .mu file with blender&.mu file import plugin but i couldn't. i could open file but i failed to edit it. I understand what is problem but have no idea which part of mod should to touch. i'm sorry to bother you but can you give me a favor? 

Edited by VaNnadin

Share this post


Link to post
Share on other sites
2 hours ago, VaNnadin said:

@Nerteasorry i tried to edit .mu file with blender&.mu file import plugin but i couldn't. i could open file but i failed to edit it. I understand what is problem but have no idea which part of mod should to touch. i'm sorry to bother you but can you give me a favor? 

It won't work. You would have to go through every file, import it, change the shader, build the exports and re-export them again. This will involve very complex rigging.

Your best bet is to hex edit the files to change the shader there. Don't really know where to start with that though. Good luck.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.