blowfish

[1.8.x] B9 Aerospace | Release 6.6.0 (Feb 5 2020)

Recommended Posts

20 minutes ago, Stikkychaos said:

what timezone do you mean? 
Also, even with all dependencies updated to 1.3 i still cant use core b9 module so i'm waiting eagerly :>

Have fun whatever you're doing!

Sorry, I'm not going to commit to anything that precise.  That's just silly.  And if something is not working with updated dependencies it's probably not B9.  Needless to say, I have no way of knowing exactly what without logs.

Share this post


Link to post
Share on other sites

You're joking! Can I finally build nice looking space ships? Wooohoooo!

Do I need to start a new career game? Or can I just use these parts in my current one?

Share this post


Link to post
Share on other sites
24 minutes ago, ArmchairPhysicist said:

You're joking! Can I finally build nice looking space ships? Wooohoooo!

Do I need to start a new career game? Or can I just use these parts in my current one?

Should be fine to add to an existing career game.  It's just parts after all (and none of the dependent plugins really affect career)

Share this post


Link to post
Share on other sites

Hello, it's nice to see you updated this mod,I extract the ships file from the latest version zip,but I encountered a little problem:

All works fine except two parts.

Utility,landing.gear.HDG1A.

Utility.landing.gear.HDG2A.

can you help me with the pylon issue or send me a new version of the ships Archive with out error

my email is edit: email removed by moderator

thankyou very much:):wink:

 

Edited by Kerbal101
removing personal information

Share this post


Link to post
Share on other sites

@liutx23ban Hello and welcome to the forums, liutx23ban! :)

While this is not against the rules, I have took the liberty to edit out the email you publicly shared to protect you from possible armada of spam from the spam bots, which can easily pick it up.
I can hardly imagine that it was your goal. :)

You can upload the craft you have to craft-sharing site like kerbalx.com - and share the download link here, or/and post the pictures of the problems you had.
You can also, of course, ask to send any craft via PM, but sharing email or any contact info publicly could lead to very undesirable side-effects. :)

Best regards!

Share this post


Link to post
Share on other sites

Hello,

I would like to ask a question. I tried to understand how the internal cockpits work. They use the RPM. And they have an own RPM-Screen, the B9-Display. I like this better than the normal RPM-Display. I think the use of the buttons is much better. And (!!!) they have the Syntneticvision. APFD with the SyntneticVision.

What I would like to know is, how do you handle the internal cameras, the B9ForwardCamera and the B9LandingCamera?

I know, that some of the Displays are able to use the ExtCam (1-8). And some don't. That's okay. I can alter that, but I woulkdn't.

But where do I find the definition of the B9ForwardCamera and the B9LandingCamera? Position and FOV and the like. 

 

Thank you in advance,

- Isabelle

Share this post


Link to post
Share on other sites
5 hours ago, liutx23ban said:

All works fine except two parts.

Utility,landing.gear.HDG1A.

Utility.landing.gear.HDG2A.

My guess is that you don't have Kerbal Foundries. That mod has the magic sufficiently advanced technology necessary to make pre-1.1.0 wheels, landing gear and landing legs work properly.

 

There's a small but non-zero chance that something else is causing your problem. Follow the instructions in the link in Blowfish's signature, and post your log, and he or another modder will take a look at the log to diagnose the problem.

Share this post


Link to post
Share on other sites

 

6 hours ago, liutx23ban said:

Hello, it's nice to see you updated this mod,I extract the ships file from the latest version zip,but I encountered a little problem:

All works fine except two parts.

Utility,landing.gear.HDG1A.

Utility.landing.gear.HDG2A.

can you help me with the pylon issue or send me a new version of the ships Archive with out error

23 minutes ago, King Something said:

My guess is that you don't have Kerbal Foundries. That mod has the magic sufficiently advanced technology necessary to make pre-1.1.0 wheels, landing gear and landing legs work properly.

There's a small but non-zero chance that something else is causing your problem. Follow the instructions in the link in Blowfish's signature, and post your log, and he or another modder will take a look at the log to diagnose the problem.

Specifically you need KSPWheel for the landing gear to show up.

The pylons I meant to address but didn't get to in this release.

But I wouldn't trust the ships too much.  They haven't been updated in years, and even if they load in the editor there's no guarantee that they will actually work (e.g. CoM vs CoL might be off, engines might now be underpowered or overpowered).  There is a reason I stopped including them in the official downloads.  If someone wants to take the time to update them I will gladly start supporting them again but until that happens I'm going to have to say that they are just unsupported.

2 hours ago, Isabelle.V.Fuchs said:

Hello,

I would like to ask a question. I tried to understand how the internal cockpits work. They use the RPM. And they have an own RPM-Screen, the B9-Display. I like this better than the normal RPM-Display. I think the use of the buttons is much better. And (!!!) they have the Syntneticvision. APFD with the SyntneticVision.

What I would like to know is, how do you handle the internal cameras, the B9ForwardCamera and the B9LandingCamera?

I know, that some of the Displays are able to use the ExtCam (1-8). And some don't. That's okay. I can alter that, but I woulkdn't.

But where do I find the definition of the B9ForwardCamera and the B9LandingCamera? Position and FOV and the like. 

 

Thank you in advance,

- Isabelle

The camera transforms are actually defined in the model itself.  The screen looks for those transforms specifically.  I don't think there's a a way to add them into an existing model without re-exporting unfortunately.

Share this post


Link to post
Share on other sites

Hello blowfish,

thank you for your quick response.
I understand. The only way to use the APFD then would be to change the cfg-file:

from:
    cameraTransform = B9ForwardCamera
to:
    cameraTransform = ExtCam1

Then it would use one external camera (with index 1) instead of the internal.
is that right?


Best wishes,
- Isabelle

 

Edited by Isabelle.V.Fuchs

Share this post


Link to post
Share on other sites
4 minutes ago, Isabelle.V.Fuchs said:

Hello blowfish,

thank you for your quick response.
I understand. The only way to use the APFD then would be to change the cfg-file:

from:
    cameraTransform = B9ForwardCamera
to:
    cameraTransform = ExtCam1

Then it would use one external camera (with index 1) instead of the internal.
is that right?


Best wishes,
- Isabelle

 

Yes, but it would change across every part that uses that prop.  So what you'd probably want to do is duplicate the prop definition with a new name and then change the camera transform name.

Share this post


Link to post
Share on other sites
1 minute ago, blowfish said:

Yes, but it would change across every part that uses that prop.  So what you'd probably want to do is duplicate the prop definition with a new name and then change the camera transform name.

Ah. Good idea!

 

Thank you :)

Share this post


Link to post
Share on other sites

When you realize that @blowfish was sneaky and  squeezed a B9 update in 3 days ago and you totally missed it because you've been combing over a LOT of mods for a Twitch Live Stream Series, and only notice it seconds ago because KSP-AVC smacks you in the face with a notice... Needless to say I am off to GitHub and changing my versions... Thanks for the new versions, much love <3 have a good week.

Share this post


Link to post
Share on other sites

Is there any way to disable the requirements for a precooler after an intake? Thanks.

Share this post


Link to post
Share on other sites
6 minutes ago, Lemcal Kerman said:

Is there any way to disable the requirements for a precooler after an intake? Thanks.

There is no such requirement

Share this post


Link to post
Share on other sites
7 hours ago, blowfish said:

There is no such requirement

maybe the req for precooler being attached to intakes...

Edited by Acvila

Share this post


Link to post
Share on other sites

There is norequirement for the precoolers to be anywhere.  As it stands they're purely aesthetic

Share this post


Link to post
Share on other sites
1 hour ago, blowfish said:

There is norequirement for the precoolers to be anywhere.  As it stands they're purely aesthetic

So, no matter if you attach it to an intake or not,it will function the same?

Share this post


Link to post
Share on other sites

There is some piece of config files for B9 precooler, buried somewhere on forums when I messed with those several KSP versions ago.

You can try to make comparison with stock precooler parts and make it to have some functions beside aesthetic.
Take following with grain of salt, it was long time ago and I writting this from top of my head, but as much as I can recall, stock part can conduct heat from nearby parts slightly better than other craft parts of similar volume (fuel tank, structural). That way it helps cooling engine.

For B9 part I was using electricity as required resource (simulating pumps and other cooling equipment) and option to switch it on/off.
It can help if you put it just behind air intake or next to engine to cool those if you have overheating issues. Don't longer know if some custom edit of B9 precooler is still required for this effect or not.

It is not much, but it can help slightly on some craft design if additional weight is not issue. Beside that it can also hold some fuel, so it does not have to be only aesthetic.

Share this post


Link to post
Share on other sites

This mod or Mods work fine but some of the fuel tanks and the adapters have a texture issue where it looks like a double texture of the fuel tank and the adapters and it looks like the textures are also overlaping. If you can fix the issue as soon as you can or give a fixed link then thanks very much. Ps I installed all the dependent mods. 

Edited by Trekkie148

Share this post


Link to post
Share on other sites
4 hours ago, Trekkie148 said:

This mod or Mods work fine but some of the fuel tanks and the adapters have a texture issue where it looks like a double texture of the fuel tank and the adapters and it looks like the textures are also overlaping. If you can fix the issue as soon as you can or give a fixed link then thanks very much. Ps I installed all the dependent mods. 

It sounds very much like you have an incompatible version of B9 Part Switch.  What version of KSP are you on, and what version of B9 Part Switch is installed (you can look at GameData/B9PartSwitch/B9PartSwitch.version).  Do the fuel switch options show up?

Share this post


Link to post
Share on other sites
2 hours ago, blowfish said:

It sounds very much like you have an incompatible version of B9 Part Switch.  What version of KSP are you on, and what version of B9 Part Switch is installed (you can look at GameData/B9PartSwitch/B9PartSwitch.version).  Do the fuel switch options show up?

Then can you give me a compatible version of B9 parts switch plz for 1.3 Plus this is what almost every part looks like :(EPUrLXp.png

Just now, Trekkie148 said:

Then can you give me a compatible version of B9 parts switch plz for 1.3 Plus this is what almost every part looks like :(EPUrLXp.png

Plus the fuel tank options don't appear. Please help

Share this post


Link to post
Share on other sites
7 minutes ago, Trekkie148 said:

Then can you give me a compatible version of B9 parts switch plz for 1.3 Plus this is what almost every part looks like :(

Plus the fuel tank options don't appear. Please help

The version included in the B9 v6.3.2 download is compatible.  All the dependencies have links in the first post of this thread.  Here is the list of releases for B9 Part Switch for convenience, they are all clearly labeled with the version of KSP they support.

If you reinstall B9 Part Switch and still have issues, I will need to see your logs (usually no way to debug these sorts of errors without them).  Instructions on how to find and upload them are in the "how to get support" link in my signature.

Share this post


Link to post
Share on other sites
9 minutes ago, blowfish said:

The version included in the B9 v6.3.2 download is compatible.  All the dependencies have links in the first post of this thread.  Here is the list of releases for B9 Part Switch for convenience, they are all clearly labeled with the version of KSP they support.

If you reinstall B9 Part Switch and still have issues, I will need to see your logs (usually no way to debug these sorts of errors without them).  Instructions on how to find and upload them are in the "how to get support" link in my signature.

Is the texture issue fixed?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.