Jump to content

[1.10.1] Realism Overhaul [27 Jul 2021]


Theysen
 Share

Recommended Posts

1 hour ago, DaOPCreeper said:

tell them to hurry up and update, i just started playing and im waiting on this mod 

Mod makers are volunteers who work on their mods when they have time and when they feel like it, and then offer their work to help others enjoy the game. Telling them to hurry up is likely to simply discourage them from doing this volunteer work at all. 

Link to comment
Share on other sites

2 hours ago, raidernick said:

RO is ready to release. I plan to put a release out as soon as Deadly Reentry and Real Fuels are officially updated for 1.9.x. They currently work but give version warnings on load and won't show up in CKAN so I want them marked as compatible first. As for 1.10.x that is completely on Kopernicus and the 10 or so other mods that aren't updated for it yet.

Sounds good! Thanks or the update and all the hard work!

Link to comment
Share on other sites

On 12/6/2020 at 10:27 AM, raidernick said:

RO is ready to release. I plan to put a release out as soon as Deadly Reentry and Real Fuels are officially updated for 1.9.x. They currently work but give version warnings on load and won't show up in CKAN so I want them marked as compatible first. As for 1.10.x that is completely on Kopernicus and the 10 or so other mods that aren't updated for it yet.

Amazing! As for 1.10.x, I suggest not updating to it anymore, as it is about to become outdated. If you (or your dependent mods) wish for an update to a modern KSP version, I propose that you just update to 1.11.x.

P.S. Keep up the good work!

Link to comment
Share on other sites

  • 2 weeks later...

Edit: problem fixed. The text below dont matter anymore

 

So, i am actually having a big error.  yestarday i made a new vassel  (the third one) and i started to build it using ktc of course.  Today (half hour ago) i load my game and my craft just disappear (i saved it for sure) but KCT is still building it. besides two of my crafts just changed their color to the same one for no reason.

Here is my log.

https://drive.google.com/file/d/1yfeu-l_5_kZEnd1uKkuqYwE-Y-ZXdJnw/view?usp=sharing

Also my saves:

https://drive.google.com/file/d/1L_WCJ6J9OcIJIPLAnmSQrwxSOwOtWEks/view?usp=sharing

i really don't know if i shoud be post my problem here since i don't know what mod is causing this problem

Sorry for my english and thanks in advance.

Edited by OwariTY
Link to comment
Share on other sites

On 12/2/2020 at 4:15 AM, AVaughan said:

Have you followed the install directions?  https://github.com/KSP-RO/RP-0/wiki/RO-&-RP-1-Installation-for-1.8.1

Hello, thanks for responding. I already solved that problem (by installing a older version of CKAN). But i encountered another problem. My textures didn't load (i checked my gamedata folder and i had all the mod folders).  I know how to install it but i have a slow internet connection (specially during this year due to the lockdown) and the last time i installed it took me some hours. Is there another way of downloading this with the ckan?

EDIT: I readed the article and did all the steps (except creating because i got the kerbin planet in the home screen).

Edited by anothernormalplayer
I missed something that i think it would be usefull to understand this post.
Link to comment
Share on other sites

Hi guys, I am having an issue with KSP-RO installation on 1.8.1. I get these really weird shadows in KSC, they are flickering when I rotate the view.

Jj5yvah.pngpBQjhC2.png

 

Additionally, it is very difficult to select VAB, SPH and other facilities, the mouse target zone is way off.

I have followed this guide to install KSP-RO on a fresh KSP 1.8.1 installation. I installed all the required mods exactly like described in the guide. Additionally, I have installed these visual enhancements:

EVE v1.8.0-2

RSSVE v1.8.1-RC1

Scatterer v0.0621 (also tried 0.0610)

Distant Object Enhancement v2.0.0.2

 

It does look like Scatterer issue to me, but I have tried both version suggested in the guide, and also every possible setting in Scatterer (with game restarts, of course).

 

Has anyone had this kind of an issue? My graphics drivers are up to date, and as far as I can see, I did everything per the guide.

Link to comment
Share on other sites

30 minutes ago, aluc24 said:

Hi guys, I am having an issue with KSP-RO installation on 1.8.1. I get these really weird shadows in KSC, they are flickering when I rotate the view.

 

Additionally, it is very difficult to select VAB, SPH and other facilities, the mouse target zone is way off.

I have followed this guide to install KSP-RO on a fresh KSP 1.8.1 installation. I installed all the required mods exactly like described in the guide. Additionally, I have installed these visual enhancements:

EVE v1.8.0-2

RSSVE v1.8.1-RC1

Scatterer v0.0621 (also tried 0.0610)

Distant Object Enhancement v2.0.0.2

 

It does look like Scatterer issue to me, but I have tried both version suggested in the guide, and also every possible setting in Scatterer (with game restarts, of course).

 

Has anyone had this kind of an issue? My graphics drivers are up to date, and as far as I can see, I did everything per the guide.

You need to provide a log file, see my sig for info

Link to comment
Share on other sites

Hello, its been a while, hope all are well.  Happy holidays to all!

Considering all the spacex vertical landings (including Starship!!!), I have been concentrating on the mechjeb landing guidance.  

My issues are as follows:

  1.  It doesn't account for atmosphere when doing sub-orbital hops around the earth.  Therefore doing a targeted auto-land is not possible.  Any ways around this?
  2. The suicide burn ignition doesn't account for engine startup time.  It should be lighting the engines ~ 2 seconds before the suicide burn countdown goes to zero.   However it starts the ignition process right at 0, and 2 seconds later when engines come to full thrust the ship is in the ground.
  3.  Recently updated a bunch of mods and now my suicide burn countdown is WAY off.  Showing 1 hour when it should actually be seconds.  Mods updated were as follows:  (ProceduralParts, CommunityResourcePack ,RealFuels-Stock,RealFuels, FerramAerospaceResearch ,KerbalJointReinforcement ,EngineGroupController ,RealismOverhaul ,RealPlume ,AJE  ,KSP-AVC  ,SolverEngines ,SmokeScreen ,RealHeat  ,RealChute ,ModularFlightIntegrator  ,REPOSoftTech ,MechJeb2).

Any help would be appreciated , making my rockets re-usable is key to greater space access for my kerbins :)

 

 

 

 

Link to comment
Share on other sites

My solar panels seem to all be producing double the energy the claim to be. Resource panel versus Part properties. Screeny  I thought it might be related to NearFuture Solar, but I removed all of the NearFuture mods and still have double charge.

Also, almost all of the stock vessels show locked or missing parts. Screeny

Everything installed via CKAN.

Link to comment
Share on other sites

On 12/6/2020 at 10:27 AM, raidernick said:

RO is ready to release. I plan to put a release out as soon as Deadly Reentry and Real Fuels are officially updated for 1.9.x. They currently work but give version warnings on load and won't show up in CKAN so I want them marked as compatible first. As for 1.10.x that is completely on Kopernicus and the 10 or so other mods that aren't updated for it yet.

So the new version to be released will not support both 1.9.X and 1.10.XMaybe I should be ready for  update to 1.9.1 :sticktongue:

Link to comment
Share on other sites

Hey guys. I'm trying to get BonVoyage mod to work with Realism Overhaul. The mod itself loads fine (the menu is there in KSC view), but the part is missing from VAB/R&D. I have NoNonRO and NoNonRP0 folders in my Gamedata, so I have created a .cfg patch in Gamedata as well, like this:
 

@PART[BonVoyageModule]:FOR[BonVoyage]:NEEDS[RealismOverhaul]
{
	%RSSROConfig = True
	%title = BonVoyageModule
	%description = BonVoyageModule
	%TechRequired = stability
}

 

But the part is still not showing up. The "stability" tech node is definitely there, and it is unlocked. But it doesn't have the BonVoyage module part. This is my first time messing with configs like this. Can anyone help?

Link to comment
Share on other sites

7 hours ago, aluc24 said:

Hey guys. I'm trying to get BonVoyage mod to work with Realism Overhaul. The mod itself loads fine (the menu is there in KSC view), but the part is missing from VAB/R&D. I have NoNonRO and NoNonRP0 folders in my Gamedata, so I have created a .cfg patch in Gamedata as well, like this:
 

@PART[BonVoyageModule]:FOR[BonVoyage]:NEEDS[RealismOverhaul]
{
	%RSSROConfig = True
	%title = BonVoyageModule
	%description = BonVoyageModule
	%TechRequired = stability
}

 

But the part is still not showing up. The "stability" tech node is definitely there, and it is unlocked. But it doesn't have the BonVoyage module part. This is my first time messing with configs like this. Can anyone help?

Try %TechRequired = stabilityRP0. 

Link to comment
Share on other sites

6 hours ago, Pehvbot said:

Try %TechRequired = stabilityRP0. 


Thanks for the suggestion... But it didn't work :( What's the normal procedure to register parts to work with RO? Perhaps I missed some vital step?

Link to comment
Share on other sites

  • 2 weeks later...

Hi,

So I tried launching my first sounding rocket from Lelystad, but can;t get a VHF connection to the rocket. After moving to FR Kourou this still didn't work on the telemetry unit. Do I need to go to Florida or am I missing something?

Link to comment
Share on other sites

Gameplay question, though I might be in the wrong topic for play tips here: my first sounding rocket had a thermometer but I cant transmit the science due to "no hard drive space available" am I missing something? I have a link now and a science core in the procedural thingy. I followed the wiki for the first rocket but am  not getting any science from my fruits of labor ;-)

Link to comment
Share on other sites

Something is fishy in my install, I get the contracts completed but I am not getting any science points. According to the tutorials I should have a couple of points after reaching the Karman line. The cfg file for the contract says no... perhaps its not all up to date?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...