Theysen

[1.6.1] Realism Overhaul v12.7.1 [16 June 2019]

Recommended Posts

Not sure if there is any interest in this beyond plebs like me but figure I might throw it out there.

Would it be beneficial to throw some instructions in the first page on "de-real" this mod with some regular expression config edits to take away the really difficult parts and prevent people from having to rely on other simplification mods that may or may not stay updated. Namely ullage, ignitions, and throttleability are what I find really sucks the playability out of this mod for me.

Find/Replace in files in the realism overhaul folder with notepad++:

Remove ullage requirement for all engines:
ullage = .*
ullage = False

Remove ignition limit for all engines:
ignitions = .*
ignitions = 100

Allow full throttle-ability for all engines:
minthrottle = .*
minthrottle = 0

I really appreciate and enjoy all the work that went into this mod but I find the supreme realism really frustrating in certain respects and turns my play sessions into long periods of success followed by a sudden outburst of rage and failure when I put myself in an unforeseen situation or mess up in some way. The above three changes really make this mod much more forgiving in-line with the stock game while retaining the other more interesting (to me) aspects of a realism overhaul.

 

Edited by li7in6

Share this post


Link to post
Share on other sites

OK, so haven't played with this suite before and want to check it out. What's the bestest, mostest straight forward way of deploying it? I have the Steam version which is currently 1.3.1, but I can access previous version using the beta system (at least I think that's what it's for). 

My thoughts are that I revert to 1.2.2, copy the 1.2.2 KSP folder to another location, then use CKAN to install RO and RP-0 (or is RP-0 included with RO?). Does that make some sort of sense to get a running game?

I take it the suggested mods will be presented as an option to install during the CKAN installation?

Also, is it necessary to be a space history buff to enjoy playing this? I don't know much about real fuels and what rockets were from where for which space program. Can I design rockets just using their part stats without running into obstacles? I'm not a great KSP player, but I like the idea of playing realistically, at least just as a side project for a bit of fun.

Thanks

Share this post


Link to post
Share on other sites
20 hours ago, strudo76 said:

OK, so haven't played with this suite before and want to check it out. What's the bestest, mostest straight forward way of deploying it? I have the Steam version which is currently 1.3.1, but I can access previous version using the beta system (at least I think that's what it's for). 

My thoughts are that I revert to 1.2.2, copy the 1.2.2 KSP folder to another location, then use CKAN to install RO and RP-0 (or is RP-0 included with RO?). Does that make some sort of sense to get a running game?

I take it the suggested mods will be presented as an option to install during the CKAN installation?

Also, is it necessary to be a space history buff to enjoy playing this? I don't know much about real fuels and what rockets were from where for which space program. Can I design rockets just using their part stats without running into obstacles? I'm not a great KSP player, but I like the idea of playing realistically, at least just as a side project for a bit of fun.

Thanks

NathanKell has a nice tutorial series, where you can learn and see if RO and RP-0 are something for you.

I only play RO and i must say, once you go RO you never go back :D

If you start as a beginner you will sit like 90% of your time in the VAB and try to get the numbers, ullage of engines, fuels, masses, avionics and so on, to get your rockets right. ( I did).

 

Edited by JohnMcLane

Share this post


Link to post
Share on other sites

Thanks, I'll definitely give that a look.

Ended up just installing it anyway. Built a rocket, which pretty much just fell over :blush: 

Gonna need that tutorial series for sure! :D

Share this post


Link to post
Share on other sites
2 hours ago, strudo76 said:

Thanks, I'll definitely give that a look.

Ended up just installing it anyway. Built a rocket, which pretty much just fell over :blush: 

Gonna need that tutorial series for sure! :D

It's an incredibly informative tutorial series!  Also, check out the wiki on the RP-0 github [ https://github.com/KSP-RO/RP-0/wiki/Tutorial:-Getting-Started ] which includes more detailed installation instructions and a guide for the first couple rockets.

Feel free to mix and match parts from the differing space programs.  For the most part, the tech tree isn't program specific.

Different engines/engine subtypes [and thus fuel types &  mixtures] become available as you increase tech level, but boiled down to a game mechanics perspective, you end up selecting for the engine+tank stats, mainly ISP and fuel density.  It's neat to know some of the history or space program preferences and/or why that was the case, but your rocket will fly the same regardless!

Share this post


Link to post
Share on other sites

Hey guys, I was wondering: are there RO and RP-0 balanced configs for the Stock antenna system? I think it's mostly about the antenna ranges, masses and e/c consumption.

I'm coming to realize (once again) that RemoteTech just isn't fun for me, and back when I played stock, the antenna system gave a good enough challange.

ps.: How do you do ullage with RemoteTech?

Share this post


Link to post
Share on other sites

@Kobymaru Some parts are supported (IIRC Coatl Aerospace and VSR) but there are still many parts left to be configured. For now it is not possible to fully replace RT with CommNet, since you will be lacking all the useful tracking stations.

Ullage with RT: that's...difficult, not without MJ configured to use RCS for ullage. RT does not have an option to explicitly use RCS as engine(s) but i am sure others will have some workarounds for that.

Share this post


Link to post
Share on other sites

The Mod SSTU seems to have an issue with it's RCS on the Apollo Service module, changes in attitude causes unnecessary translation due unnecessary thruster firing does anyone know how to fix this?

Share this post


Link to post
Share on other sites
2 hours ago, Phineas Freak said:

@Kobymaru Some parts are supported (IIRC Coatl Aerospace and VSR) but there are still many parts left to be configured. For now it is not possible to fully replace RT with CommNet, since you will be lacking all the useful tracking stations.

That's a shame, is there ongoing work or plans to do this? Or are people perfectly happy with RT?

I tried RT 2 years ago on my stock game, and it sucked the fun right out of playing (especially the limited Flight computer functionality), and the lockdown is far from complete. Unfortunately, not much has changed since. I think RT could even habe a place nowadays if they would integrate some of the KSP features instead of working against them.

 

2 hours ago, Phineas Freak said:

Ullage with RT: that's...difficult, not without MJ configured to use RCS for ullage. RT does not have an option to explicitly use RCS as engine(s) but i am sure others will have some workarounds for that.

OK, and what's the technique with MechJeb?

Share this post


Link to post
Share on other sites
20 hours ago, Kobymaru said:

OK, and what's the technique with MechJeb?

There is an option to "Use RCS for ullage" under the MJ settings. Enabling that will ensure that MJ will check the propellant stability before trying to ignite an engine. So, you can program a maneuver node via RT and MJ (theoretically) will cover everything else.

Share this post


Link to post
Share on other sites
8 hours ago, Phineas Freak said:

There is an option to "Use RCS for ullage" under the MJ settings. Enabling that will ensure that MJ will check the propellant stability before trying to ignite an engine. So, you can program a maneuver node via RT and MJ (theoretically) will cover everything else.

Sorry for being daft, but where can I find that? I can't find that option in the Settings and not even in the custom window editor.

Share this post


Link to post
Share on other sites
1 hour ago, Kobymaru said:

Sorry for being daft, but where can I find that? I can't find that option in the Settings and not even in the custom window editor.

I think it was called "Prevent unstable ignition" or something like that. I also kind of remember it being enabled by default though.

Share this post


Link to post
Share on other sites

Hello,

Can you explain to me this spreadsheet ?
https://docs.google.com/spreadsheets/d/1A7gQkIiQKi0VtRecE6p86KCKuoawZPdzk7NlaxssRJ4/edit#gid=0

I suppose when all is green RO will become compatible with the target versions of KSP 3.0 and 3.1.

Today for example, is only Persistant Rotation make RO uncompatible with KSP 3.0 ? And what about RSS Date Time Formatter, why isn't YES in Load column ?

Thank you very much

Share this post


Link to post
Share on other sites
On 19.1.2018 at 9:26 PM, siimav said:

I think it was called "Prevent unstable ignition" or something like that. I also kind of remember it being enabled by default though.

Thanks, I found the setting and it was indeed enabled by default.

Unfortunately, it does not seem to apply when the RemoteTech flight computer itself jacks up the the throttle: I get a failed ignition every single time and no attempt to perform ullage automatically.

I also tried to program it into the flight computer by throttling up with main engines disabled and RCS enabled, but even then, the RCS blocks don't fire (they do when I put the throttle up manually).

Do I understand correctly that my only option now is to CHEAT and manually perform ullage using the RCS controls that magically aren't locked down and have no signal delay?

Share this post


Link to post
Share on other sites

How can I downgrade my install to 1.2.2 so I can use Realism Overhaul?

Share this post


Link to post
Share on other sites
5 hours ago, ILikeIke said:

How can I downgrade my install to 1.2.2 so I can use Realism Overhaul?

In steam, right clic on ksp and go to properties, then betas and there you'll be able to choose 1.2.2. Or something like that :) 

Share this post


Link to post
Share on other sites
On 24.1.2018 at 7:26 AM, Alex38 said:

In steam, right clic on ksp and go to properties, then betas and there you'll be able to choose 1.2.2. Or something like that :) 

@ILikeIke To add to that, after downgrading you should copy the whole install to a different location. KSP doesn not have DRM, so it's no problem, on the other hand you avoid problems whenever there is an update.

Share this post


Link to post
Share on other sites

OK, I recently (after a slightly failed effort with 6.4K and Sigma Dimensions) decided to give Realism Overhaul another go. It's been a year or so since I last tried it (I think...) Everything seems to have worked, using KSP 1.2.2, using CKAN for almost everything, except KAS which for some reason wouldn't install. I put that in manually (I had an older version; 6.2, which seems valid) However, though the game seems to run fine I have next to no capsules. In my initial install I had one in the entire tree! Quite a few Kerbal carrying devices, but nothing with avionics but one (The TKS VA module if I remember right). I've gone through attempting to install various other mods, FASA and Soviet Spacecraft, but still am severely lacking in early capsules. The few RP0 compatible capsules seem to be all in 'Mature Capsules' with maybe one elsewhere. Not sure if CKAN messed up, or I did when selecting options (I think the only thing I opted out of was Persistent Rotation)

 

Here is the huge list of mods I have in my current build, if this helps.

 

SNFDpdi.jpg

Share this post


Link to post
Share on other sites

Not quite, I think, but hopefully they are getting close.  I too have been waiting a while for RO to update.  I just checked several prerequisite mods for updates, and attempted to launch KSP.  It is still not able to reach the loading screen, and is also giving me an incompatibility warning for RealFuels in addition to RealismOverhaul, despite the most recent version of RF indicating that it is intended for 1.3.1 (so likely a false warning).  Real Heat has not officially updated (there would be a new .zip on GitHub if it had), but the .dll file for the new version exists and can be downloaded, so the RO team should be able to bypass that prerequisite issue.  We will know when RealismOverhaul is ready because the name of this topic will change to reflect the changes.  The KSP version number in square brackets will be the key indication that a change has occurred.  When it reads either [1.3] or [1.3.1]. we will know it is time to download a new version and try it.  The RO version number will also change.

It sure has been a long wait.  I am hoping they will get an updated version of RO released soon, as I was planning to do a new campaign in Real Solar System, for which RO is still effectively a  prerequisite (someone did recently make a new mod which technically does allow this dependency to be bypassed, but said new mod is not intended for use with many of the other mods utilized/supported by RSS and RO, such as Real Fuels)).

Edit: I just noticed something on the spreadsheet row for RH indicating a problem with the new .dll file for that mod.  That could be what is holding us up.  I thought RH was ready because the incompatibility warning for it had been eliminated, but the new version may have a critical error in it.

Edited by cgwhite4
New information

Share this post


Link to post
Share on other sites

Can't wait to play KSP/RO again. :D I switched to linux a few months ago and unfortunately 1.2.2 has an issue witch lets most of the available window manager crash, since then I didn't play it anymore. But in 1.3.x it is supposed to be fixed.

Share this post


Link to post
Share on other sites

How does RO deal with part volumes for KIS? I've found they're absurdly large. The FASA ALSEP parts can't fit in a 400L KIS container because it says they are something like 10,000 liters which is obviously absurd. Even the wrench is something like 3L. Is there a way to change this?

Share this post


Link to post
Share on other sites
22 hours ago, hargn said:

Hi @Patupi,

AmpYear conflicts with RO/RP-0. I believe it breaks the avionic node of probe/capsule elements.
So remove it.

If you want some help/tutorial to start with RO/RP-0, look at the wiki https://github.com/KSP-RO/RealismOverhaul/wiki and https://github.com/KSP-RO/RP-0/wiki.

You can also look at some Youtube channels : NathanKell for example.

Thank you! That will help a lot. I'm already a short ways into the play, but at least it wasn't a critical mod for me to remove. Much appreciated.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.