Theysen

[1.6.1] Realism Overhaul v12.7.2 [17 July 2019]

Recommended Posts

On 3/31/2018 at 8:54 PM, Bornholio said:

.cacklingLaughter

also i'm going around pestering folks  come over to the testing camp

Remaining Mods for release holding up RO/.RP0
NONE
  And Now RO is released

If you have RF Stock configs installed you will get 2 errors in Ro_RCS_Config.cfg and MM cache will not save.



Please if possible comment on issues and
add new issues to relavent GIT hubs
if you see problems with any mod or RO/RP0

:o 1.3.1 RPO release soon? how stable is the DEV branch?
awesome work guys!

Share this post


Link to post
Share on other sites
10 minutes ago, Ventzi said:

:o 1.3.1 RPO release soon? how stable is the DEV branch?
 

Dev is very playable, but it can be a chore to make sure you have the right .dlls in place. As for it releasing Soon(tm) is still the best answer.  RP0 could release at any time given master is compiled for 1.3.1. and the fixit PR's are down to one or two.

Share this post


Link to post
Share on other sites
On 4/3/2018 at 5:34 PM, Theysen said:

[1.3.1] Realism Overhaul v12.0.0 [03 Apr 2018]

Update available to make Realism Overhaul compatible to Kerbal Space Program version 1.3.1. Do note that also Real Solar System is now compatible to 1.3.1.

 

Changelog

  • Tweak WAC/Aerobee, RL10 config costs
  • Add the LR87/91 configs as sepculative
  • Update X-405 config to match specs in Vanguard Engineering Summary
  • Tweak Russian Engine reliability and config costs
  • Various craft fixes for Raidernick model changes
  • Update Raidernick configs for proton changes
  • Move entryCost from S-3 to S-3D
  • Global engine config changes
  • Fix testflight configs of various engines
  • Added RealEngines support
  • Fix mass of several avionics packages
  • Fixed some part tags
  • Fixed various BDB and FASA configs
  • Added missing brackets to resource configs
  • Added new part module AdjustableCoMShifter
  • Fixed trailing whitespace/newlines in many files
  • Turn off relaying for all SPUs
  • Fix X-405 verniers using the wrong HTP mixture
  • Updated CMES for KSP 1.3.1
  • Added new Bluedog parts
  • Add generic engine config for BDB X-405H
  • Fix generic RCS thruster mass and scale
  • Various SSTU config fixes
  • SXT updates including mass fix for sputnik
  • Update netkan to remove dead mods and add a few new ones

Thanks to NathanKell, Raidernick, eggrobin, pap1723, PhineasFreak, ctiberious, blowfishpro, AnticlockwisePropeller, Bornholio, smartdummies, aw1621107, AlphaMike741, Ash19256, ahmedcharles, MikeOnTea, m4gus88, DocRockwell, Schnobs and glilienthal for their contributions to this release!

Special thanks to Eggrobin, Ferram and blowfishpro for getting all the dependencies updated.

Spoiler

GRAZIE RAGAZZI!!!!!!!!!

 

Share this post


Link to post
Share on other sites

[snip]

its best not to rush mod makers as they are not payed and can do what they want to do... someone correct me if i'm wrong

Edited by Vanamonde

Share this post


Link to post
Share on other sites
On 3/29/2018 at 11:56 AM, Theysen said:

Simply put - the mariner probe is not configured for RP-0 mechanics which involve avionics. Think of avionics as mass limit a probe core can deal with. As soon as it gets above the mass limit you can’t control your rocket / craft at all until you add a sufficient probe core to it (most preferably to the next stage). Think of it like the real life equivalent in a Atlas V for example, the probe itself won’t steer the whole booster but rely on the rockets internal guidance computers until separation. That’s what avionics try to incorporate. If a probe core isn’t configured for the avionics this mechanic is neglected and you  mariner could steer the whole launcher on its own. 

Thanks for the explanation. BTW did you know that the link in the first line of the OP is broken?

Does anyone know (even roughly) what speed the lunar return rated heatshields will protect against?

 

Again, I am using all the mods suggested by RO - I think it is better to ask here than in say deadly reentry thread or whichever, since people here must be using this suite of mods together.

 

I decided not to install Cheaty Mccheater hyperedit this game so that if something goes wrong I am not tempted to just undo it. But this means that I have no idea if i can go directly from a Hohmann transfer to Venus into the Venusian atmosphere, to aerocapture and descend to the surface? And no real way to test this short of trying it and probably failing the contract.

 

Edited by Antstar
something went really wrong!!!

Share this post


Link to post
Share on other sites

Good job guys! I am checking github repo everyday and there is always PR's open, people are working hard for this. Please appreciate the people that working on this project.

Share this post


Link to post
Share on other sites

[snip]

No not yet and the compatibility update is undetermined. 

Also please consider reading the last few posts as well next time, we already covered the question.

For a general statement, as long this thread title does not cover [1.4.X] in it, it won't work with those versions. :)

Share this post


Link to post
Share on other sites

Some posts have been removed from this thread. Please remember that it may seem like encouragement for you to ask a modmaker to update, but to the modmaker, a succession of these posts can start to feel like harassment, especially if it's clear the asker has not read information already in the thread.

However, some posts mocking those asking for updates have also been removed. All that kind of thing does is add to the off-topic clutter in the thread and make the forum seem unfriendly to new members. If you see a post which you believe may be troublesome, please just hit the report button on it and leave it to the moderators rather than reply yourself. 

Share this post


Link to post
Share on other sites
23 hours ago, Gordon Dry said:

@Theysen In OP under Dependencies the link to ModuleManager points to 3.0.6 for KSP 1.4.x: https://ksp.sarbian.com/jenkins/job/ModuleManager/141/artifact/ModuleManager-3.0.6.zip

And yet it works fine, iirc the version compatibility was aimed to be mostly preserved. I got no issues with the latest ModuleManager in 1.3.1 and RO. :)

Share this post


Link to post
Share on other sites
1 hour ago, Theysen said:

I got no issues with the latest ModuleManager in 1.3.1 and RO.

This is very interesting - it never came to my mind (and I never read someone saying so) that MM versions are backwards-compatible...

Share this post


Link to post
Share on other sites

Nuclear Rockets

Hi all,  I am thinking of finally adding nuclear rockets to my crafts. However, I don't know how to actually us them. The only thing they use as propellant is LqdHyrogen, and this boils off rather quickly. So it looks like NERVA etc is useless for interplanetary travel, which would be the exact thing I'd want them to use for.

How are you guys dealing with that? Is there acceptable heat control? Or do you just use them to start from LEO?

Thanks!

Gustav

 

Share this post


Link to post
Share on other sites
On 4/9/2018 at 3:26 PM, Lilienthal said:

Nuclear Rockets

Hi all,  I am thinking of finally adding nuclear rockets to my crafts. However, I don't know how to actually us them. The only thing they use as propellant is LqdHyrogen, and this boils off rather quickly. So it looks like NERVA etc is useless for interplanetary travel, which would be the exact thing I'd want them to use for.

How are you guys dealing with that? Is there acceptable heat control? Or do you just use them to start from LEO?

Thanks!

Gustav

 

You are correct. Without boiloff mitigation they are only useful for Injection burns outbound and upper stage ascent to orbit.  Historically the one tested were expected to do just that (Rover, RD-0410 and SNTP Programs)  DRA 5.0 posits that hydrogen re-compression would be used in tandem with Bi-modal (power generation mode) NTR's.  They can easily get either much higher payloads or much faster transits.  With the new cryo RF branch you can increase the insulation.  There are also ways of using heatsinks and cryopumps to keep the tank temp at 20K thus not having boiloff.  one very common alternate for mars return at least is to depend on Liquid Methane which has a much higher boiloff temp and greater tank density.

Share this post


Link to post
Share on other sites

I'm still running on 1.2.2 so this could have changed; if so I''ll take the plunge and upgrade immediately and ignore what follows.

As far as I know there are no ICBM contracts, and no mods that add this feature for RO either. Seeing as that was the prime reason for rockets being funded in the first place it seems odd that there are no in-game suborbital contracts to impact 7000miles downrange or something similar. Instead we start with reaching altitudes  or orbiting.

The main reason this would be awesome is that unlike in real life, there are no in-game benefits to using high-boiling/storeable propellants in launch vehicle first and second stages. ICBM contracts could begin by only requiring range, like atlas or R-7, then have to be storeable, a la Titan or proton, and then finally solid only like most modern ones. This could provide a nice way for Titan style manned launchers to come about naturally.

As it is I never make my kerbals get on towers of toxic hypergols when they could use the comparably safer and also more efficient kerosene versions instead. If, however, I had a tried and tested ICBM that happened to use UDMH, I wouldn't feel too guilty putting Vadim on it, 'in the name of science'.

If this is already a thing, let me know, otherwise is there any way this could become a thing?

 

Finally, I don't have any particular love of either nukes or missiles. This is just about history not weapons.

Share this post


Link to post
Share on other sites
2 hours ago, walterdunst said:

I'm still running on 1.2.2 so this could have changed; if so I''ll take the plunge and upgrade immediately and ignore what follows.

As far as I know there are no ICBM contracts, and no mods that add this feature for RO either. Seeing as that was the prime reason for rockets being funded in the first place it seems odd that there are no in-game suborbital contracts to impact 7000miles downrange or something similar. Instead we start with reaching altitudes  or orbiting.

The main reason this would be awesome is that unlike in real life, there are no in-game benefits to using high-boiling/storeable propellants in launch vehicle first and second stages. ICBM contracts could begin by only requiring range, like atlas or R-7, then have to be storeable, a la Titan or proton, and then finally solid only like most modern ones. This could provide a nice way for Titan style manned launchers to come about naturally.

As it is I never make my kerbals get on towers of toxic hypergols when they could use the comparably safer and also more efficient kerosene versions instead. If, however, I had a tried and tested ICBM that happened to use UDMH, I wouldn't feel too guilty putting Vadim on it, 'in the name of science'.

If this is already a thing, let me know, otherwise is there any way this could become a thing?

 

Finally, I don't have any particular love of either nukes or missiles. This is just about history not weapons.

You should be posting this in the rp0/rp1 thread or github. RO never has and never will add anything career related to the game.

Share this post


Link to post
Share on other sites
10 hours ago, walterdunst said:

I'm still running on 1.2.2 so this could have changed; if so I''ll take the plunge and upgrade immediately and ignore what follows.

As far as I know there are no ICBM contracts, and no mods that add this feature for RO either. Seeing as that was the prime reason for rockets being funded in the first place it seems odd that there are no in-game suborbital contracts to impact 7000miles downrange or something similar. Instead we start with reaching altitudes  or orbiting.

The main reason this would be awesome is that unlike in real life, there are no in-game benefits to using high-boiling/storeable propellants in launch vehicle first and second stages. ICBM contracts could begin by only requiring range, like atlas or R-7, then have to be storeable, a la Titan or proton, and then finally solid only like most modern ones. This could provide a nice way for Titan style manned launchers to come about naturally.

As it is I never make my kerbals get on towers of toxic hypergols when they could use the comparably safer and also more efficient kerosene versions instead. If, however, I had a tried and tested ICBM that happened to use UDMH, I wouldn't feel too guilty putting Vadim on it, 'in the name of science'.

If this is already a thing, let me know, otherwise is there any way this could become a thing?

 

Finally, I don't have any particular love of either nukes or missiles. This is just about history not weapons.

You should really try the dev version of rp-0 .  It adds things like sounding rocket contracts.

See the 1.3.1 section of https://github.com/KSP-RO/RP-0/wiki/Setting-up-for-Development-Install-:Temp-Page:

Share this post


Link to post
Share on other sites

RO makes my engines produce no thrust, they aren't even showing up at stages, it's unplayable for me in 1.4 and 1.3. When I put solver engines, all engines disappear from parts.

Share this post


Link to post
Share on other sites
7 hours ago, Capt.gelo said:

RO makes my engines produce no thrust, they aren't even showing up at stages, it's unplayable for me in 1.4 and 1.3. When I put solver engines, all engines disappear from parts.

First of all it doesn't work in 1.4 at all so don't even mention that because you won't get help with it. Second, you are not installing the mod and it's dependencies correctly, or at all, or you are installing the wrong versions. Go back, read the OP, install everything again from scratch on a clean 1.3.1 install. If you can't do that try using ckan it will do it automatically.

Edited by raidernick

Share this post


Link to post
Share on other sites
10 minutes ago, raidernick said:

First of all it doesn't work in 1.4 at all so don't even mention that because you won't get help with it. Second, you are not installing the mod and it's dependencies correctly, or at all, or you are installing the wrong versions. Go back, read the OP, install everything again from scratch on a clean 1.3.1 install. If you can't do that try using ckan it will do it automatically.

well RO doesn't show up in CKAN, sorry for being a noob

Share this post


Link to post
Share on other sites
2 minutes ago, Capt.gelo said:

well RO doesn't show up in CKAN, sorry for being a noob

It does if you are using the right ksp version. I can assure you 100% it shows up for ksp 1.3.1, I tested it, so did many others and people have been installing it that way since. It won't show up in 1.4 versions but like I said it's not updated for 1.4 and neither are most of the dependencies. 

Edited by raidernick

Share this post


Link to post
Share on other sites
1 minute ago, raidernick said:

It does if you are using the right ksp version. I can assure you 100% it shows up for ksp 1.3.1, I tested it, so did many others and people have been installing it that way since. It won't show up in 1.4 versions but like I said it's not updated for 1.4 and neither are most of the dependencies. 

Thanks! It's my first time using CKAN, I changed some things in the settings and now I can use RO in 1.3, thanks a lot!

Share this post


Link to post
Share on other sites

Thanks to anyone involved in the update and hope you guys find time in the future to carry on! 

I have a strange thing occurring.  I do have a virgin 1.31. When I attempt to install via ckan it gets so far then it caps out saying ferram is already installed  bla bla bla and quits.  Think it might have been another mod showing up once. Any ideas how to fix. Ckan would be nice but can do install by hand if worse case but ckan would definitely  be nice lol.

Share this post


Link to post
Share on other sites
19 minutes ago, Wragie said:

Thanks to anyone involved in the update and hope you guys find time in the future to carry on! 

I have a strange thing occurring.  I do have a virgin 1.31. When I attempt to install via ckan it gets so far then it caps out saying ferram is already installed  bla bla bla and quits.  Think it might have been another mod showing up once. Any ideas how to fix. Ckan would be nice but can do install by hand if worse case but ckan would definitely  be nice lol.

you most likely have FAR craft files in the KSP/ships thumbs, vab and sph folders. Try to manually delete them and CKAN won't cry about them.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.