Theysen

[1.6.1] Realism Overhaul v12.7.2 [17 July 2019]

Recommended Posts

Thanks a lot JohnMcLane. Then everything will be alright I guess? I won't lose a lot of features if I downgrade?

Share this post


Link to post
Share on other sites

If you're going to use RO, I reccomend copying the install elsewhere since Steam automatic update will mess with your install a LOT.

Share this post


Link to post
Share on other sites
On 9/12/2018 at 11:04 AM, Cousnouf said:

Thanks a lot JohnMcLane. Then everything will be alright I guess? I won't lose a lot of features if I downgrade?

WIth RO you only gain a lot of features that the standard game (RSS, RealFuels/engineUllage, limitedIgnitions and and and) cant give you! Much higher immersion into rockets and spaceflight. I also recommend using Realistic Progression 0 the developmental version (which is for 1.3.1), that makes it even more real and gives you contracts and avionics and stuff (https://github.com/KSP-RO/RP-0/tree/Developmental green button: "clone or download"). If you never played Realism Overhaul it can be it little bit overwhelming, it has a high learning curve, but:

RO/RP0 are the BEST :D

Share this post


Link to post
Share on other sites
15 minutes ago, JohnMcLane said:

If you never played Realism Overhaul it can be it little bit overwhelming, it has a high learning curve, but:

RO/RP0 are the BEST :D

To put it into perspective... KSP has a steep learning curve, adding RO + RP0 or RP1 makes that curve go vertical, like a sounding rocket ;) but it’s well worth it.

Share this post


Link to post
Share on other sites

If you have completely mastered stock KSP, the learning curve for RSS/RO/RP-0 is similar to the learning curve that got you from Day 1 of stock KSP to where you are now.  

It's really a whole new game.

Share this post


Link to post
Share on other sites

I'm getting a crash on loading screen, while trying to Install RO and the recommended mods. I went mod by mod, and the problem seems to arise when I try to load RO and TestFlight together. The setting works fine with only one of them, but not both.

Using TestFlightCore-v1.8.0.1 and RealismOverhaul-v12.1.0 as linked in the OP. I also tried the respective master versions that are linked in the RP-0 1.3.1 spreadsheet. I uploaded a crash folder under that link:

https://www.dropbox.com/s/r4hbjcnpe3vdo63/2018-09-18_220936.zip?dl=0

Share this post


Link to post
Share on other sites

Hi everyone!

Now that all the essential mods, including RSS seem to be updated, what are the plans, regarding Realism overhaul? :) :)

Looking forward and really can not play without it

Thank you!

Share this post


Link to post
Share on other sites
8 minutes ago, Iguas said:

Hey, how do you guys roll back to 1.3.1 ?

Not sure how to do it if you got KSP from the Squad store.  But in Steam you look under Betas and they offer many KSP versions: 1.0.5, 1.1.3, 1.2.2, 1.3.1, and all from 1.4.1 to 1.4.4.  So you can select 1.3.1, let Steam download, then copy out of the Steam install directory (usually "<Steam root>/SteamApps/common/Kerbal Space Program/") to one you maintain (I use "C:/Prog/KSP/v1.3.1" for a pristine copy and "C:/Prog/KSP/v1.3.1+mods/" for the modded install where I ran KSP 1.3.1).

Edited by Jacke

Share this post


Link to post
Share on other sites
6 hours ago, DanielBR401 said:

CKAN doesn't work with this anymore?

At a guess because you are trying to install into a 1.4.x version of KSP.   RO and some of its dependencies haven't released 1.4 compatible versions yet, so there are no 1.4 compatible versions for ckan to install.  In the meantime you should be able to install Ro in KSP 1.3.1.  If you use Steam instructions on how to get a copy of 1.3.1 are a couple of posts up.

Share this post


Link to post
Share on other sites
10 hours ago, DanielBR401 said:

CKAN doesn't work with this anymore?

 

3 hours ago, AVaughan said:

At a guess because you are trying to install into a 1.4.x version of KSP.   RO and some of its dependencies haven't released 1.4 compatible versions yet, so there are no 1.4 compatible versions for ckan to install.  In the meantime you should be able to install Ro in KSP 1.3.1.  If you use Steam instructions on how to get a copy of 1.3.1 are a couple of posts up.

If you use GOG, then write support and have them make the install files available to you. It might take a couple of days before they reply, but in my experience, they upload it to an FTP-server pretty soon. If enough of us requests older versions of KSP, they might end up having a better backlog of versions available on their homepage or the GOG Galaxy application. :)

Share this post


Link to post
Share on other sites

I wanted to play career in RSS but didn't want to go full Realism (I like Kerbal parts and don't want to mess with fuel types, ullage, restarts, etc.   I also wanted to use 1.4.x).  I installed the ROMini.cfg patch to rescale and real-size the Kerbal parts.  It seems to work well, mostly.  Some of the Making History parts are glitchy but nothing you can't work around.

The thing I was wondering is this:  Does anyone know if there's an in game reason to have fuel tanks nearly double their  fuel-to-mass ratio compared to similar real world tanks?  A script modified LT-45 engine for example is a very close analog for an early Merlin 1 (very similar thrust and ISP), but it needs half the fuel mass to get the same burn time, thus giving it a huge boost in dV.  It means you can get away with much lighter (and shorter!) rockets.

Before I start messing around with the cfg file to get more realistic(ish) numbers I figured I would ask in case I'm missing some important point or my math is just crap and I'm wrong about the fuel/mass thing.

 

Share this post


Link to post
Share on other sites

The fuel/mass ratios were adjusted along with a bunch of other things to adapt to the 1/10th sized solar system. If you used RL ratios it would be too easy. There's a mod called SMURFF that tweaks them for you

Share this post


Link to post
Share on other sites
6 hours ago, Tyko said:

The fuel/mass ratios were adjusted along with a bunch of other things to adapt to the 1/10th sized solar system. If you used RL ratios it would be too easy. There's a mod called SMURFF that tweaks them for you

Thanks!

Share this post


Link to post
Share on other sites

KSP 1.3.1/RO 12.1.0/all required dependencies specified in the OP

I'm unable to get RCS to work.  I'm mounting thrusters directly on the fuel tank and have configured the fuel to match the thruster requirements.  I've tried many combinations of thrusters and RCS tanks, but the engineering report in the VAB always indicates "consumers not receiving mono-propellant".  If I uninstall RO/Real Fuels/Real Plume, RCS seems to work fine.  Thanks for any help.

Share this post


Link to post
Share on other sites

I'd like to report a bug. I'm not sure if it's RO doing this so sorry if this is the wrong thread.

Basically, patches of the ground start floating up as I approach the ground. I haven't noticed it when I'm ascending, but definitely when I'm descending. You can also crash into these ground patches, and I've observed them to be as high as 40km in altitude. They're not just stationary, either. You can see them moving upwards as you get closer.

Logs: https://www.dropbox.com/s/i0vleh0p582wgqs/output_log.txt?dl=0

Pics: https://imgur.com/a/OcI3tEB

It's actually kind of funny sometimes, until I end up crashing into one

EDIT: I know the screenshots only show the moon, but it happens on Earth too. 

EDIT2: Narrowed it down to scatterer. 

Edited by dafidge9898

Share this post


Link to post
Share on other sites

Atlas V Common Core Booster

Eight STAR 5F solid rocket motors (6 kN each) to aid the separation of the Centaur upper stage.

The engines are not working?? (realism overhaul)

Share this post


Link to post
Share on other sites

[Deleted, but the "Delete Post" button was pointlessly removed a couple of years ago and now we can't delete pointless posts.]

Edited by RoboRay

Share this post


Link to post
Share on other sites
23 hours ago, RoboRay said:

[Deleted, but the "Delete Post" button was pointlessly removed a couple of years ago and now we can't delete pointless posts.]

Atlas V Common Core Booster

Eight STAR 5F solid rocket motors (6 kN each) to aid the separation of the Centaur upper stage.

The engines are not working?? (realism overhaul)

Share this post


Link to post
Share on other sites
On 9/14/2018 at 1:44 AM, Jaeleth said:

To put it into perspective... KSP has a steep learning curve, adding RO + RP0 or RP1 makes that curve go vertical, like a sounding rocket ;) but it’s well worth it.

Your RO sounding rockets work better than mine :wacko:

Share this post


Link to post
Share on other sites
On 9/12/2018 at 4:19 AM, AVaughan said:

That is stock behaviour.  It's called show activation toggles.  If you don't see something like that, then open settings and check you have advanced tweakables turned on.

 

Sorry for the late reply, but thank you. Thats going to really help, when I come to think about it I was also missing the fuel priority so that make sense. I simply hadn't really needed it yet however as default generally works out. tbh that should be on by defualt as it's super handy.

Edited by etheoma

Share this post


Link to post
Share on other sites

It's a pity that there are no full blown configs for Bluedog_DB existing yet ...

I tried to find some in repos but no avail ...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.