Theysen

[1.6.1] Realism Overhaul v12.7.2 [17 July 2019]

Recommended Posts

1 hour ago, AVaughan said:

THe most recent release is meant for KSP 1.6.1.  The current version probably wont work properly with 1.7.x. 

When can we use it with 1.7.x?

Share this post


Link to post
Share on other sites
Posted (edited)

Perhaps.First of all, I don’t want to find some Bugs.

Edited by Peter JY

Share this post


Link to post
Share on other sites
11 hours ago, Peter JY said:

Perhaps.First of all, I don’t want to find some Bugs.

You can try it, but you might find bugs.  If you don't want bugs then just use 1.6.1.

(looks like you may speak Mandarin so hopefully google doesn't let me down with this.)

你可以试试,但你可能会发现错误。如果您不想要错误,那么只需使用1.6.1。

Share this post


Link to post
Share on other sites

Are there any plans to add SSTU's modular SRBs to ROEngines? I'm asking here because there isn't a dedicated ROEngines forum topic. 

Share this post


Link to post
Share on other sites
Posted (edited)

My Realism Overhaul has no Avionics Tonnage Limits.  Is that wrong?

[Edit - most of post removed]

I finally figured out by searching the github source code that RO doesn't have the avionics tonnage limit, it's RP that controls that.  I had previously played with both installed before I fired up the game so I misunderstood which mod caused which feature.  (I had assumed RP was limited to just the career aspects of the game like contracts and tech tree, and that RO did all the actual physical rules like avionics limitations.  In other words, I thought that RP was about progression, hence the name, and therefore was irrelevant if you are playing sandbox mode.  I didn't realize I needed it to get some of the base code that runs actual realism rules like avionics tonnage.)

Edited by Steven Mading

Share this post


Link to post
Share on other sites

I don't have an RO install, but my 1.6.1 rp-1 install is working fine, including avionics limits.  Maybe just try installing rp-1?

Share this post


Link to post
Share on other sites
12 hours ago, AVaughan said:

I don't have an RO install, but my 1.6.1 rp-1 install is working fine, including avionics limits.  Maybe just try installing rp-1?

The problem was that I thought the avionics limits were part of the core RO mod when they're not.  They're implemented by RP-1 as it turns out, which is confusing since those are a core game mechanic about the parts, rather than a thing about "progression". (i.e. it's about how the part itself works, not about the tech tree or the contracts, and therefore is needed even in a sandbox game, and thus feels out of place in the mod that's there for the progression instead of for the sandbox mode.

Share this post


Link to post
Share on other sites
On 6/2/2019 at 11:53 AM, jdub3350 said:

Is there anything in this log file that might indicate why my rockets are getting stuck to the pad?  Even with a 1.5 TWR they seem like they are stuck on something.  Thanks for any and all help. 

 

https://drive.google.com/file/d/1WonAiywyX-nkFPYq9k1hUAjms8XrqHM9/view?usp=sharing

I found what follows on your log:

[EXC 07:40:32.161] NullReferenceException: Object reference not set to an instance of an object
        SaturableRW.SaturableRW.UpdateMomentum ()
        SaturableRW.SaturableRW.FixedUpdate ()
[EXC 07:40:32.161] NullReferenceException: Object reference not set to an instance of an object
        SaturableRW.SaturableRW.UpdateMomentum ()
        SaturableRW.SaturableRW.FixedUpdate ()
[EXC 07:40:32.175] NullReferenceException: Object reference not set to an instance of an object
        SaturableRW.SaturableRW.UpdateMomentum ()
        SaturableRW.SaturableRW.FixedUpdate ()
[EXC 07:40:32.175] NullReferenceException: Object reference not set to an instance of an object
        SaturableRW.SaturableRW.UpdateMomentum ()
        SaturableRW.SaturableRW.FixedUpdate ()
[EXC 07:40:32.188] NullReferenceException: Object reference not set to an instance of an object
        SaturableRW.SaturableRW.UpdateMomentum ()
        SaturableRW.SaturableRW.FixedUpdate ()
[EXC 07:40:32.189] NullReferenceException: Object reference not set to an instance of an object
        SaturableRW.SaturableRW.UpdateMomentum ()
        SaturableRW.SaturableRW.FixedUpdate ()
[ERR 07:40:32.205] Module tjs_DecouplerLight threw during OnUpdate: System.TypeLoadException: Could not load type 'ModuleDecouplerBase' from assembly 'EngineLightRelit'.
  at Part.ModulesOnUpdate () [0x00000] in <filename unknown>:0

What hints me a problem with SaturableRW and EngineLightRelit, whatever these things are.

I also found:

[LOG 07:10:35.533] PartLoader: Compiling Part 'StationPartsExpansionRedux/Parts/Extendable/extendable-125/sspx-inflatable-centrifuge-125-1/sspx-inflatable-centrifuge-125-1'
[ERR 07:10:35.616] Module ModuleFuelTanks threw during OnLoad: System.ArgumentNullException: Argument cannot be null.
Parameter name: key
  at System.Collections.Generic.Dictionary`2[System.String,RealFuels.Tanks.TankDefinition].ContainsKey (System.String key) [0x00000] in <filename unknown>:0
  at System.Collections.ObjectModel.KeyedCollection`2[TKey,TItem].Contains (.TKey key) [0x00000] in <filename unknown>:0
  at RealFuels.Tanks.ModuleFuelTanks.RecordTankTypeResources (System.Collections.Generic.HashSet`1 resources, System.String type) [0x00000] in <filename unknown>:0
  at RealFuels.Tanks.ModuleFuelTanks.RecordManagedResources () [0x00000] in <filename unknown>:0
  at RealFuels.Tanks.ModuleFuelTanks.OnLoad (.ConfigNode node) [0x00000] in <filename unknown>:0
  at PartModule.Load (.ConfigNode node) [0x00000] in <filename unknown>:0

What hints me this can be the source of the problem. What you describes happens when Fuel Switches have problems while they are computing the resulting mass of a part, and we have evidences that something (usually a problematic patch!) is inducing RealFuels to a exception.

 

On 6/4/2019 at 1:12 PM, MadArkael said:

Not sure by your comments if you sorted it, but KSP also does not like negative mass objects. Sometimes TweakScale works funny with specific parts.

Except that the guy DOES NOT have TweakScale installed. TweakScale is, usually, the Screaming Victim of that occurrences. Most of the time, it's a Fuel Switch problem that TweakScale gets involved because TweakScale are installed in all the parts of a system - and so, they are always involved on the mess because every part have it, as well the problematic third party Add'On.

Share this post


Link to post
Share on other sites
Posted (edited)

@jdub3350

If you have SSTU tanks on that craft then certain tanks can trigger a conflict with Real Fuels under certain conditions.The conflict is that both SSTU and Real Fuels try to cancel out the mass on the tank prior to modifying it on the expectation that it will be offset by their respective resource switchers. Unfortunately the part has then lost twice as much mass as it should have which can push it negative. If there is not enough resource mass on the part to make the net mass positive then the Unity RigidBody will have negative mass and no forces can affect it.

The Orion Service Module is a candidate for that issue as is the lander tanks. Spawn them each by themselves in the VAB with the same resources they had on the craft and then look at their mass in the engineer report. A more complicated method would be to look at the craft file and compare each part's modMass field against the part's original mass. If mass + modMass  <= 0 then that's a problem.

 

Edit: There has been a fix created for the SSTU issue but I don't think he's released an update with it yet. A verified workaround would be to identify affected parts and patch their mass to 0 with a ModuleManager patch.

Edited by Starwaster

Share this post


Link to post
Share on other sites

@Theysen Good day, I'd like to know the number of restarts an ion engine has in RO, it's for something non ksp related I'm working on and can't find much regarding them online

Share this post


Link to post
Share on other sites

The Saturn V craft file in the the "Realism Overhaul Craft Files" mod pack does not have enough delta v for TLI. I've tried many times to make orbit with enough delta-v to make TLI, but it's never worked out. A simple calculation shows that there is not enough delta-v (3,000 m/s) after orbital insertion (9,400 m/s) to make TLI. Wondering if this is just an issue with my setup or not.

Share this post


Link to post
Share on other sites
4 hours ago, 63Hayden said:

The Saturn V craft file in the the "Realism Overhaul Craft Files" mod pack does not have enough delta v for TLI. I've tried many times to make orbit with enough delta-v to make TLI, but it's never worked out. A simple calculation shows that there is not enough delta-v (3,000 m/s) after orbital insertion (9,400 m/s) to make TLI. Wondering if this is just an issue with my setup or not.

What kind of orbit are you starting from? What altitude and what is your inclination compared to the moon’s inclination?

Share this post


Link to post
Share on other sites

@63Hayden

Are these the FASA parts you're talking about? If so, I was just looking at those and there's some noticeable issues IF you loaded the Saturn V craft file that uses those parts. 

The issue is that the J2 engines are not properly configured. Issue only applies if loaded the craft file. If so, remove the J2 engines from the rocket and replace them with with fresh copy from the inventory list. Place them and then configure them using the engine GUI button. Change their configuration to 230K 

(as loaded from the craft file they are the default J2 with 800 kN of thrust and cannot be reconfigured from the GUI because of exceptions being thrown. That's why, replace them with fresh copies)

Share this post


Link to post
Share on other sites
13 hours ago, Starwaster said:

@63Hayden

Are these the FASA parts you're talking about? If so, I was just looking at those and there's some noticeable issues IF you loaded the Saturn V craft file that uses those parts. 

The issue is that the J2 engines are not properly configured. Issue only applies if loaded the craft file. If so, remove the J2 engines from the rocket and replace them with with fresh copy from the inventory list. Place them and then configure them using the engine GUI button. Change their configuration to 230K 

(as loaded from the craft file they are the default J2 with 800 kN of thrust and cannot be reconfigured from the GUI because of exceptions being thrown. That's why, replace them with fresh copies)

I loaded the Saturn V from the craft files, and yeah the J2's seem very underpowered. I always launch into an orbit with a zero relative inclination to the moon, or as near to zero as possible. I'll do as you suggest here and see if it works.

Share this post


Link to post
Share on other sites

Can you install this in the middle of a savegame, and is this compatible with SMURFF?

Edited by KingKerb

Share this post


Link to post
Share on other sites
4 hours ago, KingKerb said:

Can you install this in the middle of a savegame, and is this compatible with SMURFF?

SMURFF is what you use if you're not brave enough for RO. If you  have RO you don't want SMURFF.

Installing it in the middle of a save game... sure, why not? What could possibly go wrong? I mean it's not like any engines you have in flight are going to stop working because they just got reconfigured to use a different set of propellants and possibly a different mix ratio of said propellants.... right?

RIGHT?!??

Ehhh. Don't do it. Sounds like a really bad idea to me. ;) 

Share this post


Link to post
Share on other sites
5 hours ago, Starwaster said:

Installing it in the middle of a save game... sure, why not? What could possibly go wrong? I mean it's not like any engines you have in flight are going to stop working because they just got reconfigured to use a different set of propellants and possibly a different mix ratio of said propellants.... right?

RIGHT?!??

TLdr; version

dgzvIi2l.jpg

Share this post


Link to post
Share on other sites
6 hours ago, Starwaster said:

SMURFF is what you use if you're not brave enough for RO. If you  have RO you don't want SMURFF.

Installing it in the middle of a save game... sure, why not? What could possibly go wrong? I mean it's not like any engines you have in flight are going to stop working because they just got reconfigured to use a different set of propellants and possibly a different mix ratio of said propellants.... right?

RIGHT?!??

Ehhh. Don't do it. Sounds like a really bad idea to me. ;) 

Ok, I was expecting it to not be compatible with SMURFF, but I wasn't sure.

Edited by KingKerb

Share this post


Link to post
Share on other sites

No rocket engines are loading in the VAB and the parachutes don't have any staging for them. . I installed realism overhaul and its dependencies, uninstalled SMURFF, and started a new savegame, but it still isn't working. What am I doing wrong? I think I know how to solve the parachute problem, but will ro work without realchute?

Edited by KingKerb

Share this post


Link to post
Share on other sites

Is there a general consensus here as to the best version of KSP to use with realism overhaul, and all the recommended mods? I find that if I use a more recent version of the KSP, a lot of recommended mods just aren't updated to be compatible. I'm currently using 1.6.1, but a lot of the mods I want just aren't updated. For instance, the ALCOR lander was made for version 0.9 I believe - Very outdated.

Also, as a side question, is there a way to reduce the part count, or at least "hide" some of the parts you don't want to use in the editor or when you are loading the game? With a fully modded RO install, my game can take upwards of 15 minutes to start. Any help appreciated, thanks.

Edited by 63Hayden
extra

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.