Theysen

[1.6.1] Realism Overhaul v12.7.2 [17 July 2019]

Recommended Posts

Well my loading problem is solved i manualy downloaded the 1.2.2 versions of Community rescource pack, firespitter and semi-saturable reaction wheels and now it works so to the people that don't find there problem this might solve it.

And wow do i love al the new engine and part textures <3 Thank you to the whole rss community/contributers

Edited by kerboman25

Share this post


Link to post
Share on other sites

installed RO from CKAN everything looking okey. Good job to the release team!

Edited by AlimOncul

Share this post


Link to post
Share on other sites

Now that the loading problem is fixed i've got a problem with my rcs they don't work when i select the right fuel :/

Share this post


Link to post
Share on other sites
2 hours ago, kerboman25 said:

Now that the loading problem is fixed i've got a problem with my rcs they don't work when i select the right fuel :/

1) Fuel tank is pressurized? 

2) They are staged or enabled via Right-Click-Menu in the flight scene?

3) What kind of fuel tank are you using? Some need to have crossfeed enabled in the VAB

 

Cheers

Share this post


Link to post
Share on other sites
2 hours ago, kerboman25 said:

Now that the loading problem is fixed i've got a problem with my rcs they don't work when i select the right fuel

IMHO it seems that several mods don't "accept" or recognize RCSFX but "good old default RCS" does well.
Perhaps it has something to do with that.
Two days ago I also had quirks using RCS on gravity turn with "Fore on throttle" activated as an ullage helper, some exceptions were thrown about RO ...

But because people decided to be annoyed by me and ignore me I just didn't post another "complain"...

Share this post


Link to post
Share on other sites
6 hours ago, Theysen said:

1) Fuel tank is pressurized? 

2) They are staged or enabled via Right-Click-Menu in the flight scene?

3) What kind of fuel tank are you using? Some need to have crossfeed enabled in the VAB

The tanks that i'm using are proceduraltanks and are presurized these are connected via fuel ducts to the ship. They are also ennabled via staging so i don't know what im doing wrong but there might be something odd if you look in the link i have a picture of it i don't know if it's normal.

https://drive.google.com/open?id=0Bw904_cO3bhvRFE2N1Y4UnNHMVE

 

Share this post


Link to post
Share on other sites
6 minutes ago, kerboman25 said:

The tanks that i'm using are proceduraltanks and are presurized these are connected via fuel ducts to the ship. They are also ennabled via staging so i don't know what im doing wrong but there might be something odd if you look in the link i have a picture of it i don't know if it's normal.

https://drive.google.com/open?id=0Bw904_cO3bhvRFE2N1Y4UnNHMVE

 

Then the usual please,

 

output log, module manager cache and a screenshot of your GameData folder please. :)

Share this post


Link to post
Share on other sites

Thank you ALL for your great work!!! Good time to update to ksp 1.2.2 now! :D

Share this post


Link to post
Share on other sites

@KAO yes but you need to recompile/update most of the dependencies installed manually:

  • EngineGroupController
  • Real Fuels
  • RealismOverhaul
  • RealSolarSystem
  • SolverEngines

Also, you are missing the rest of the dependencies:

  • Advanced Jet Engine
  • Community Resource Pack
  • FAR
  • Real Heat
  • Real Plume
  • SmokeScreen

And remove mods that are conflicting with other mods:

  • Modular Fuel Tanks

Share this post


Link to post
Share on other sites

Just did a complete install from scratch.

Unzip KSP 1.2.2

CKAN Realism Overhaul and all recommended mods

Add RSS and RSSVE and Scatterer

EVA kerbal on launchpad and he explodes due to overheating?

Share this post


Link to post
Share on other sites
3 minutes ago, Phineas Freak said:

 

You da man! Confirmed fix. Jut out of curiosity, is it because I added RSS or "stock RO" bug?

Share this post


Link to post
Share on other sites

@g00bd0g no, DRE changes a lot of the thermal functionality and requires some patching to work as expected. KerbalEVA is a "part" now and so changes are required in order to interoperate with DRE.

Read the contents of the post that i linked to get a better idea.

Share this post


Link to post
Share on other sites

Hi!

I'm having issues with antenna modules on most of Raidernick's probes, both US and Soviet ones.

They either extend their antennae immediately after placing, with no option to retract them, or they cannot be extended. In both cases, the contect menu lacks any extend or retract buttons.

Anyone else encountered such behaviour?

 

Not sure if its a general config error or something borked out on my end.

 

Running a whole RO 1.2.2 kit. The stuff that's available and officially advertized as 'working'.

 

 

 

 

Share this post


Link to post
Share on other sites
42 minutes ago, h0yer said:

The stuff that's available and officially advertized as 'working'

Can you provide us some KSP logs?

Share this post


Link to post
Share on other sites
Just now, Phineas Freak said:

Can you provide us some KSP logs?

Sure, will provide theese after getting back home...

Share this post


Link to post
Share on other sites

Does anyone have a Remote tech config file with the RO settings and all the ground stations the links i am finding are bad.

thanks,

gene

Share this post


Link to post
Share on other sites

@Phineas Freak

Here the log: (~12MB!)

https://drive.google.com/file/d/0B6QoFtOsM0n-bWV3bTdyWEVBcGM/view?usp=sharing

What I did:

I started the game, loaded the savegame, went into the VAB and picked and placed a Molniya-1, which immediately extended its solar panels and antennae and I opened its context menu.

Then I deleted it, exited the VAB, left the game and closed KSP.

Share this post


Link to post
Share on other sites

What is really the issue is that I just installed RO with CKAN and all dependencies and I cannot get a connection. I have used RO for many years just took a 6 month break and after installations with the latest version I am having this issue just looking for a RT config file

Share this post


Link to post
Share on other sites

@h0yer So, there are some things going wrong here:

Critical Stuff:

D:\Steam\steamapps\common\Kerbal Space Program\...

First rule when you are modding KSP: you never mod a Steam installation. Instead, you copy the KSP folder somewhere outside the SteamApps folder and run KSP from there. If you don't then:

[ERR 15:30:00.862] ADDON BINDER: Cannot resolve assembly: KSPUtil, Culture=neutral, PublicKeyToken=null

[ERR 15:30:00.863] ADDON BINDER: Cannot resolve assembly: KSPUtil, Culture=neutral, PublicKeyToken=null

[ERR 15:30:00.867] AssemblyLoader: Exception loading 'DeadlyReentry': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

You will end up with deprecated and/or conflicting files/assemblies, much like the KSPUtil.dll above (was merged with other assemblies in KSP 1.2). This will break a ton of stuff.

Not So Critical Stuff:

Then, we have old and incompatible assemblies:

[ERR 15:30:00.867] AssemblyLoader: Exception loading 'DeadlyReentry': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

Additional information about this exception:

 System.TypeLoadException: Could not load type 'DeadlyReentry.ModuleAeroReentry' from assembly 'DeadlyReentry, Version=7.4.7.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'DeadlyReentry.DeadlyReentryScenario' from assembly 'DeadlyReentry, Version=7.4.7.0, Culture=neutral, PublicKeyToken=null'.

The 7.4.7.0 version of DRE is only compatible with KSP 1.1.3. There is an updated version (7.5.0.0) for KSP 1.2(.2) here: https://github.com/Starwaster/DeadlyReentry/releases

The rest of the log is clean. I guess that if you recreate your installation with a clean install of KSP 1.2.2 everything will be fine.

Share this post


Link to post
Share on other sites

@Phineas Freak

Thanks for taking the time!

I really had no idea about the KSP-Steamfolder issue, but I will switch to using an external non-steam folder in the future...

The wrong DRE version obviously is my error, since I manually downloaded it, shame on me^^ (thx for linking it)

 

Well, I guess I'll reinstall KSP, move it away from steam, move the mods as well and report back...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.