Jump to content

[1.7.3-1.8.1] Realism Overhaul v12.8.1 [17 April 2020]


Recommended Posts

Hi

Wondering if anyone can help with Engine stats for SSTU! :)

Basically, the Interim Cryogenic Propulsion Stage (ICPS), which uses an RL10B-2, hasn't updated its engine stats in game. It still has the stock stats:

Spoiler

2q821zq.jpg

The Actual RL10B-2 where it appears by itself has the correct RO stats:

Spoiler

xgfjbb.jpg

I'm trying to track down the route by which this should work via the cfg files:

GameData\SSTU\Parts\ShipCore\Series-C\SC-C-ICPS.cfg - this has the stock config for the part

Spoiler
PART
{
module = Part
name = SSTU-SC-C-ICPS
author = Shadowmage
 
...
 
MODULE
{
    name = ModuleEnginesFX
    engineID = RL10B-2
    runningEffectName = running_closed
    thrustVectorTransformName = RL10B-2-ThrustTransform
    exhaustDamage = True
    ignitionThreshold = 0.1
    minThrust = 0
    maxThrust = 45
    heatProduction = 35
    PROPELLANT
    {
        name = LqdHydrogen
        ratio = 15
        DrawGauge = True
        resourceFlowMode = NO_FLOW
    }
    PROPELLANT
    {
        name = Oxidizer
        ratio = 1
        resourceFlowMode = NO_FLOW
    }
    atmosphereCurve
    {
        key = 0 465.5 0 -1513
        key = 0.075 352 -1513 -342000
        key = 0.076 10 -342000 0
    }
}
 

GameData\RealismOverhaul\RO_SuggestedMods\SSTU\SSTU_Orion.cfg - this RO cfg file covers the ICPS and links it to the RL10B-2. The text from this file appears in the description, so I know this one is being applied

Spoiler
@PART[SSTU-SC-C-ICPS]:AFTER[RealismOverhaulEngines]
{
    @title = Interim Cryogenic Propulsion Stage (ICPS)
    %manufacturer = Boeing
    %description = The Interim Cryogenic Propulsion Stage (ICPS) consists of a modified Delta IV 5 m upper stage. Its structure has been strengthened to support SLS flight loads and the hydrogen tank has been stretched by 46 cm to account for on-orbit boiloff. //http://forum.nasaspaceflight.com/index.php?topic=35528.320
    
    @MODULE[ModuleEngineConfigs]
    {
        !CONFIG,*:HAS[~name[RL10B-2]] {}
    }
}

GameData\RealismOverhaul\Engine_Configs\RL10_Config.cfg - This has the (correct) stats for the RL10B-2 and these are obviously applied to the engine where it appears by itself, but apparently not in the ICPS

Spoiler
        CONFIG //(9)
        {
            name = RL10B-2
            minThrust = 110.1
            maxThrust = 110.1
            heatProduction = 100
            PROPELLANT
            {
                name = LqdHydrogen
                ratio = 0.7325
                DrawGauge = True
            }
            PROPELLANT
            {
                name = LqdOxygen
                ratio = 0.2675 //5.88
            }
            atmosphereCurve
            {
                key = 0 465.5
                key = 1 235
            }
            massMult = 1.659
            
            %ullage = True
            %ignitions = 15
            %IGNITOR_RESOURCE
            {
                %name = ElectricCharge
                %amount = 0.5
            }
        }
 

Can anyone with more experience of the cfg files figure out where the issue is?

Always grateful! :)

Link to post
Share on other sites
On 7/26/2018 at 11:24 AM, RealTimeShepherd said:

Hi

Wondering if anyone can help with Engine stats for SSTU! :)

Basically, the Interim Cryogenic Propulsion Stage (ICPS), which uses an RL10B-2, hasn't updated its engine stats in game. It still has the stock stats:

  Reveal hidden contents

2q821zq.jpg

The Actual RL10B-2 where it appears by itself has the correct RO stats:

  Reveal hidden contents

xgfjbb.jpg

I'm trying to track down the route by which this should work via the cfg files:

GameData\SSTU\Parts\ShipCore\Series-C\SC-C-ICPS.cfg - this has the stock config for the part

  Reveal hidden contents
PART
{
module = Part
name = SSTU-SC-C-ICPS
author = Shadowmage
 
...
 
MODULE
{
    name = ModuleEnginesFX
    engineID = RL10B-2
    runningEffectName = running_closed
    thrustVectorTransformName = RL10B-2-ThrustTransform
    exhaustDamage = True
    ignitionThreshold = 0.1
    minThrust = 0
    maxThrust = 45
    heatProduction = 35
    PROPELLANT
    {
        name = LqdHydrogen
        ratio = 15
        DrawGauge = True
        resourceFlowMode = NO_FLOW
    }
    PROPELLANT
    {
        name = Oxidizer
        ratio = 1
        resourceFlowMode = NO_FLOW
    }
    atmosphereCurve
    {
        key = 0 465.5 0 -1513
        key = 0.075 352 -1513 -342000
        key = 0.076 10 -342000 0
    }
}
 

GameData\RealismOverhaul\RO_SuggestedMods\SSTU\SSTU_Orion.cfg - this RO cfg file covers the ICPS and links it to the RL10B-2. The text from this file appears in the description, so I know this one is being applied

  Reveal hidden contents
@PART[SSTU-SC-C-ICPS]:AFTER[RealismOverhaulEngines]
{
    @title = Interim Cryogenic Propulsion Stage (ICPS)
    %manufacturer = Boeing
    %description = The Interim Cryogenic Propulsion Stage (ICPS) consists of a modified Delta IV 5 m upper stage. Its structure has been strengthened to support SLS flight loads and the hydrogen tank has been stretched by 46 cm to account for on-orbit boiloff. //http://forum.nasaspaceflight.com/index.php?topic=35528.320
    
    @MODULE[ModuleEngineConfigs]
    {
        !CONFIG,*:HAS[~name[RL10B-2]] {}
    }
}

GameData\RealismOverhaul\Engine_Configs\RL10_Config.cfg - This has the (correct) stats for the RL10B-2 and these are obviously applied to the engine where it appears by itself, but apparently not in the ICPS

  Reveal hidden contents
        CONFIG //(9)
        {
            name = RL10B-2
            minThrust = 110.1
            maxThrust = 110.1
            heatProduction = 100
            PROPELLANT
            {
                name = LqdHydrogen
                ratio = 0.7325
                DrawGauge = True
            }
            PROPELLANT
            {
                name = LqdOxygen
                ratio = 0.2675 //5.88
            }
            atmosphereCurve
            {
                key = 0 465.5
                key = 1 235
            }
            massMult = 1.659
            
            %ullage = True
            %ignitions = 15
            %IGNITOR_RESOURCE
            {
                %name = ElectricCharge
                %amount = 0.5
            }
        }
 

Can anyone with more experience of the cfg files figure out where the issue is?

Always grateful! :)

SSTU is a really great mod, however it is a work-in-progress and contains many custom modules that the author changes from time to time. What this means is that configs like these may break, and need to be rewritten when something in the mod changes.

If no one else has working configs, your best bet is to learn how to do it yourself (and then share with the community). 

Link to post
Share on other sites
On 6/21/2018 at 2:31 AM, raidernick said:

RO is entirely config based. The dll file is not actually required and only contains 2 classes which only affect com moving. What NEEDS to be updated is FAR, not RO.

Hi all,

I am wondering, how much would change to run RO without FAR, using the stock aero system? Would that be an option or blasphemy that'll get me a harsh reaction from @raidernick and others?

Best,

Gustav

 

Link to post
Share on other sites
2 hours ago, Lilienthal said:

Hi all,

I am wondering, how much would change to run RO without FAR, using the stock aero system? Would that be an option or blasphemy that'll get me a harsh reaction from @raidernick and others?

Best,

Gustav

 

Probably blasphemy, but I definitely see the point of the question.  There are a couple PRs in FAR with recompiles for 1.4.x that haven't been merged in for quite a while.  RO updates have lagged because of dependencies, which makes sense but there's also something to be said for RO itself to be a forcing function / show desire for those dependencies.  An argument for just playing older versions doesn't work very well since bug fixes on many systems [that are RO dependencies] often don't get older versions re-released.  This also ignores that players might want new features from base game upgrades and other mod updates [required or otherwise for RO], and also that it becomes a much bigger lift to catch up multiple significant releases later.  After the last long hiatus from releasing, I think the RO team wanted to move to something more spiral-development with smaller monthly releases. But... RO's last release was 90 days ago, and is 30+ commits behind the master branch at this time.

With FAR, I assume [speculation] that nobody else has privileges to merge into master.

Link to post
Share on other sites
On 7/19/2018 at 2:34 AM, MaltYebisu said:

@Speedbird52

I'm not sure when RO will be updated for 1.4.4, but it is already ready for use with 1.3.1. You can find it on CKAN.

If you want to track some of the mods used in RO and RP-0, you can look at the KSP 1.4 Golden Spreadsheet.

If you want help installing mods for RP-0, you can use the KSP 1.3.1 Golden Spreadsheet.

Unfortunately I do not have access to 1.31

Link to post
Share on other sites

@Speedbird52  If you have the Steam version of ksp then you can access 1.3.1 from the betas tab.  (Right click on KSP in steam, select properties then betas tab then select 1.3.1 from the drop down box).  There is also probably a way to download old version from the ksp store or from GOG, but I don't have those versions.

Link to post
Share on other sites
18 hours ago, AVaughan said:

@Speedbird52  If you have the Steam version of ksp then you can access 1.3.1 from the betas tab.  (Right click on KSP in steam, select properties then betas tab then select 1.3.1 from the drop down box).  There is also probably a way to download old version from the ksp store or from GOG, but I don't have those versions.

Awesome! TYSM :)

 

Does anyone know of a Realism Overhaul compatible Space X pack? So far all I found was the BFR

Link to post
Share on other sites

I have a problem for which I couldn´t find a solution yet. I have RO for 1.3.1 and the KK Launchers pack for 1.3.0. Yet the configs provided by RO just seem to cover the configs for Falcon 1. Did I miss something?

I was wondering if there are configs for all the Space X rockets included in the pack, since I have seen other people use them with RO.

Link to post
Share on other sites
On 7/31/2018 at 6:45 AM, Lilienthal said:

Hi all,

I am wondering, how much would change to run RO without FAR, using the stock aero system? Would that be an option or blasphemy that'll get me a harsh reaction from @raidernick and others?

Best,

Gustav

 

I can confidently say that this is never going to happen. The entire point of RO is to meet real life standards for parts, if you are then re-balancing them for stock you might as well just be playing stock and not install RO at all.

Link to post
Share on other sites
On 7/28/2018 at 11:18 PM, Nightside said:

SSTU is a really great mod, however it is a work-in-progress and contains many custom modules that the author changes from time to time. What this means is that configs like these may break, and need to be rewritten when something in the mod changes.

If no one else has working configs, your best bet is to learn how to do it yourself (and then share with the community). 

Thanks Nightside. I have tried this and made some progress. I now have the ICPS working with the correct stats

Funny enough, I then tried the same thing with the SSTU Exploration Upper Stage (EUS) but something weird is happening, basically when the engines fire up, it reports the production of 440kN of force and the fuel is consumed at the expected rate, but Gforce remains at zero and AP and PE remain utterly unchanged. After a short while, the engine tends to flameout due to vapour in the feed lines. So it looks like no propulsive force is being generated at all, even though the right-click interface shows 440 kN and the fuel is being consumed

Does anyone with experience with the cfg files know what stupid thing I have forgotten to do?

Many thanks!

Link to post
Share on other sites

Having a weird ullage problem. I can achieve ullage on the RCS and fire the engines (multiple Astris on a big station) but the engines won't maintain their own ullage. As long as I hold down 'h' they will keep going but once I let go, the engines flame out 'vapor in feedlines' within a few seconds. They're pushing almost 1m/s² so I would think that's enough acceleration.

I could just disable ullage for those motors entirely, but if there's a way to just decrease the ullage threshold in a MM patch, that would be ideal. I already have several of my own MM patches. Can't find documentation for the ullage keys though. Is the GitHub wiki the best place for reference?

Still 1.2.2, hopefully that's still OK.

 

Edit: Wow, creating a new engine is a lot more difficult than changing the cost of lights. Maybe I can't just do this in ModuleManager. Seems like my changes aren't actually changing.

Edited by ShakeNBake
Link to post
Share on other sites

I keep lurking around Bornholio's Golden Spreadsheet for 1.4.x (https://docs.google.com/spreadsheets/d/1jqFjaHCo0gdIj5mX61V8D02Ma6v1WfH2Zuv0ddXgG5M/edit#gid=0) and appreciate all of the updates he and a few other anonymous contributors make to it.  It attempts to track the compatibility of various mods required for the RO and RP0/RP1 mod suites.

So practically speaking, what -is- delaying release of a newer version of ROFAR & KJR are both Ferram's.  Starwaster's DRE.  Real Solar System + textures (tho textures shouldn't have any dependency on the version of KSP).  Testflight has a PR waiting.  What else is an actual dependency that would halt release?

Link to post
Share on other sites
11 hours ago, DRVeyl said:

I keep lurking around Bornholio's Golden Spreadsheet for 1.4.x (https://docs.google.com/spreadsheets/d/1jqFjaHCo0gdIj5mX61V8D02Ma6v1WfH2Zuv0ddXgG5M/edit#gid=0) and appreciate all of the updates he and a few other anonymous contributors make to it.  It attempts to track the compatibility of various mods required for the RO and RP0/RP1 mod suites.

So practically speaking, what -is- delaying release of a newer version of ROFAR & KJR are both Ferram's.  Starwaster's DRE.  Real Solar System + textures (tho textures shouldn't have any dependency on the version of KSP).  Testflight has a PR waiting.  What else is an actual dependency that would halt release?

The three mods you listed are fundamental for RO / RSS.
And to be honest, it wouldn't consider it "halting" a release, just view 1.3.1 as the base version for RO to remain on until we eventually someday update it to 1.4.X whatever the version of KSP is current. Are there actually features absolutely needed for RO? I didn't bother to check but saw the many bugs, fixes and issues still remaining with the current version of KSP. 1.3.1 is nice and stable. If FAR and other mods remain on 1.3.1, we will too.

 

I think the big update will happen once RP-1 *might* be released, otherwise there is no rush whatsoever. :) 

Link to post
Share on other sites
5 hours ago, Theysen said:

And to be honest, it wouldn't consider it "halting" a release, just view 1.3.1 as the base version for RO to remain on until we eventually someday update it to 1.4.X whatever the version of KSP is current. Are there actually features absolutely needed for RO? I didn't bother to check but saw the many bugs, fixes and issues still remaining with the current version of KSP. 1.3.1 is nice and stable. If FAR and other mods remain on 1.3.1, we will too.

I think the big update will happen once RP-1 *might* be released, otherwise there is no rush whatsoever. :)

I suppose I outlined my objection to this in my earlier post.  It's not about the features that the base KSP provides that are absolutely necessary.  It's not even about the features within RO itself (or its dependencies).  It's about all the ongoing development in other mods that become inaccessible to the RO player because RO does not upgrade, and it's questionable that other mod developers should be expected to maintain development and release for older versions of KSP.  As an example, RemoteTech fixed a breaking bug w/RO compatibility in March with its 1.8.10 release and update to 1.4.1.  It had to re-release in JUNE with 1.8.11(.131) for RO.

It's fair that a mod suite with external dependencies like RO is slower to update.  I think it is harmful to development to argue that new features in the core system aren't necessary, so no update should happen.  And its a flaw in the development cycle if an individual external mod is holding up your compatibility, for apparent lack of activity in that mod.  [I have no insight into Ferram's situation or why FAR appears to be going without development.  I love FAR as a mod.  But from a programmatics standpoint, losing supply of a required component is a program risk, and there doesn't appear to be any mitigation.]

 

Link to post
Share on other sites

About the new engines added by RO (the turbofans, Vernier thrusters, etc.): they seem to share the same stock models, which makes the engine section look kinda ugly :P

Is there a mod that adds unique models for those parts?

Link to post
Share on other sites

Hello, I have a loading issue on MAC OSX, The game freezes while loading the "GameData/Squad/Parts/Engine" parts, it gets stuck on SIZE2LFB and if I delete it it gets stuck on another engine part, this is around the 90% loading mark. It seems to load everything just fine. I have all the dependancies and recommendations, but zero suggested mods.

Link to post
Share on other sites

Hello.
Just tried to test DEV RP-0(RP-1)
KSP 1.3(lastest 1.3 from STEAM library).
Installed via CKAN RSS+RO and it worked fine.
today tried to install RP-0 
From git (installed all except B9 procwings, made it from CKAN (B9 aerospace procedural wings - Fork 0.40.13)
replaced DLLs, but did not find KRASH.dll in game folder, only KRASH.cfg. Placed dll next to it in RP-0 folder.
ANd after lauch i have crash with "Cannot find a PartModule of typename 'ModuleTagHydrolox'"

https://drive.google.com/open?id=1i3mPDkrWlyeadQh-5s5M_qJD2QL2orgK
output_log.txt

Last lines, i think useful info is here.

any idea what i did wrong?

Spoiler



PartLoader: Part 'B9_Aerospace_ProceduralWings/Parts/Aero_Wing_Procedural/wing_procedural_typeC/RO-B9ProcAMWing-Early' has no database record. Creating.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

DragCubeSystem: Creating drag cubes for part 'RO-B9ProcAMWing-Early'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

PartLoader: Compiling Part 'CryoEngines/Parts/Engine/cryoengine-125/cryoengine-125-1/cryoengine-125-1'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

*RF* Loading RFSETTINGS global settings
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

*U* Ullage constructor called on cryoengine-125-1
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Generating field configuration for type B9PartSwitch.ModuleB9PartSwitch
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Generating field configuration for type B9PartSwitch.PartSubtype
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Cannot find a PartModule of typename 'ModuleTagHydrolox'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

PartLoader: Part 'CryoEngines/Parts/Engine/cryoengine-125/cryoengine-125-1/cryoengine-125-1' has no database record. Creating.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

DragCubeSystem: Creating drag cubes for part 'cryoengine-125-1'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

PartLoader: Compiling Part 'CryoEngines/Parts/Engine/cryoengine-125/cryoengine-125-2/cryoengine-125-2'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

*U* Ullage constructor called on cryoengine-125-2
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

*RFMEC* ERROR Can't find configuration RL10A-1, falling back to first tech-available config.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Cannot find a PartModule of typename 'ModuleTagHydrolox'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Crash!!!
SymInit: Symbol-SearchPath: '.;D:\Games\Steam\steamapps\common\Kerbal Space Program;D:\Games\Steam\steamapps\common\Kerbal Space Program;C:\WINDOWS;C:\WINDOWS\system32;SRV*C:\websymbols*http://msdl.microsoft.com/download/symbols;', symOptions: 530, UserName: 'MWG'
OS-Version: 10.0.17134 () 0x100-0x1


 

Small update.
As i can see - there is some kind of problem with engines.
First, as you see, there is problem with cryoengines.
I deleted it.
Next was with forgotten real engines 

Spoiler



PartLoader: Compiling Part 'RealEngines/NK33/NK33engine'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

*U* Ullage constructor called on NK33engine
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Crash!!!


 

then i deleted forgottenrealengines, sovietengines, realengines.

and finally i get crash on Squad's engine config

Spoiler



PartLoader: Compiling Part 'Squad/Parts/Engine/liquidEngine24-77/liquidEngine24-77/smallRadialEngine'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

*U* Ullage constructor called on smallRadialEngine
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

smallRadialEngine.pressureFed = False
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

smallRadialEngine.pressureFed = False
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Crash!!!


 

So what is wrong?
 

Edited by mwg_test
Link to post
Share on other sites
On 8/18/2018 at 7:29 PM, mwg_test said:

Hello.
Just tried to test DEV RP-0(RP-1)
KSP 1.3(lastest 1.3 from STEAM library).
Installed via CKAN RSS+RO and it worked fine.
today tried to install RP-0 
From git (installed all except B9 procwings, made it from CKAN (B9 aerospace procedural wings - Fork 0.40.13)
replaced DLLs, but did not find KRASH.dll in game folder, only KRASH.cfg. Placed dll next to it in RP-0 folder.
ANd after lauch i have crash with "Cannot find a PartModule of typename 'ModuleTagHydrolox'"

So what is wrong?
 

Have you installed the dev version of TestFlight? The master version will cause issues like this as it isn't compatible with 1.3. When the crashes occurred for me they were at similar points as you describe.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...