Jump to content

[1.7.3-1.8.1] Realism Overhaul v12.8.1 [17 April 2020]


Recommended Posts

On 11/1/2019 at 6:43 AM, Lilienthal said:

Oops. I confused RP-1 and RO. - So I am very happy that RO has been out for months and look forward to RP-1 in 1.6.1 soon. ;)

well today's your lucky day isnt it @Lilienthal???? because there is indeed a working RP-1 version for KSP 1.6.1 - see the following link for installation instructions:

https://github.com/KSP-RO/RP-0/wiki/RO-&-RP-1-Installation-for-1.6.1

Edited by hypervelocity
Link to post
Share on other sites

Update Time!

@raidernick raidernick released this 11 hours ago

  • Add STME Engine Config with Testflight configs
  • Fix incorrect Engine Type Names
  • Better Internal Overlay scaling for SXT Ju87 cockpit
  • Scale Bonanza IVA to match the RO model size
  • Fix Conic Cockpit IVA Overlay offset
  • Update RO FASA Saturn V Apollo Lunar.craft
  • Update SSTU tanks configs
  • Create unified procedural tanks for RP-1
  • Remove duplicate converters from SNAP-9, SNAP-19 and MMRTG
  • Changed default engine config from NK-43 to NK-15V to prevent RF from selecting locked configs
  • Update Raptor Engine Config with new infos from SpaceX
  • Fix Mk1 Pod Kerbal scaling
  • Add KSPWheel configs to all Stock landing gear/legs if KSPWheel is installed
  • Comment out landing leg which is not working
  • Add support for integrated RCS in B9 HL and S2 cockpits
  • Compatability with DECQ's Space Shuttle System
  • Correct RealEngines Raptor node position
  • Add new Methalox plume to RealEngines Raptor
  • Updated RD-170,RD-180,RD-190 rescale factors
  • Various Raidernick fixes:
    • Fix N1 fuel flow priorities
    • Fix RCS ports on various command pods
    • R7 overhaul to engines and tanks to use HTP
    • Various vernier plume fixes
    • Update fairing and les configs for changes to abort system in parent mods
    • Fix Salyut CoM and iva locations
    • Fix Salyut and Soyuz EC usage to be more realistic
    • Add new configs for Titan 34D and transtage parts
    • Fix some issues with missing action groups in craft files

Thanks to @vader111, @raidernick, @pap1723, @lpgagnon, @Starwaster, @lukecologne, @whale2, @IronKerbal and @siimav for work on this latest update!

 

Link to post
Share on other sites

Thanks for the work on the new release and the hard work. I've been experienced an annoying issue, though (not sure if it's RO related, but I think it is). Fuel value in tanks upon craft loading in the VAB do not hold their values. E.g.: if a tank has a starting value of 86% use and I move it up to 97% (so full capacity depending on tank type), loading the craft file back again will cause it to go back to its default value of 86%. Similarly, if I drop a tank's value down from 86 to 50%, again, it will default back to its 86% value. 

Logs: https://www.dropbox.com/sh/fkrbiavx1c3g8u0/AABvgUGRlOCNWEzt5vZUNJ_4a?dl=0

KSP 1.6.1, RP-1... 

Thanks,

Link to post
Share on other sites

For most of them, you turn them on and off just like in the real world.

Very few rocket engines can be throttled up and down.  Unless you're using the engine to land, it's really not needed and would make the engine far more complex/heavy/expensive to design and build.

Edited by RoboRay
Link to post
Share on other sites
1 hour ago, Starwaster said:

@Hungry_Dragon265 they work exactly the same as in stock except that they have limited ignitions and have throttle limitations. (can't be throttled or can't be throttled below a certain point). How are you having problems with them? You stage them and you throttle up. Or you use the PAW to activate/deactivate them.

But I have the RO but it says that there aren't any engines at all, I'll try PAW and then I will continue 

Link to post
Share on other sites
21 hours ago, Hungry_Dragon265 said:

With RO installed how do you controle a rocket engine

 

You haven't provided enough information for us to do anything more than guess at the cause of your problem.

So some possible guesses.

Wrong fuel for the engine.

Pressurise fed engine without a highly pressurised tank.

No control possible because you have no comms, or lack a suitable command module.  

Improperly installed mods, or mods that aren't compatible with your ksp version, or mods that aren't compatible with your RO install.

If you still need help please provide a screenshot of your gamedata folder, plus a screenshot of your vessel on the runway/launchpad with the engine, tank and command module Part Action Windows visible.

 

 

 

 

 

Link to post
Share on other sites
Just now, AVaughan said:

You haven't provided enough information for us to do anything more than guess at the cause of your problem.

So some possible guesses.

Wrong fuel for the engine.

Pressurise fed engine without a highly pressurised tank.

No control possible because you have no comms, or lack a suitable command module.  

Improperly installed mods, or mods that aren't compatible with your ksp version, or mods that aren't compatible with your RO install.

If you still need help please provide a screenshot of your gamedata folder, plus a screenshot of your vessel on the runway/launchpad with the engine, tank and command module Part Action Windows visible.

 

 

 

 

 

For activating a engine and throttle an engine

oh i tried installing PAW and it didn't work at all

Link to post
Share on other sites

The PAWs are built into KSP.  They don't need to be installed.  They are the little windows that open when you right click a part.  Please provide screenshots of your vessel on the launchpad with the engine, fuel tank and command module PAWs open.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...