Jump to content

[1.4.3] Gameslinx's Planet Overhaul v3.4.0 [UPDATE IN PROGRESS]


Recommended Posts

7 hours ago, TheWanderer05 said:

I didn't really notice this until I exited Nievis' SOI, but there's a graphical bug that seems to take place below the surface - not sure what the object at the center looks like either. 

Edit: This update is also causing my ksp to crash and have loading times over ten times as long as the previous update.

Sorry about sending so many reports, I feel like I'm spamming. 

It's useful - you're not spamming

The update included a lot more 8k textures, so the game will take longer to load. You might also be out of RAM, causing it to crash 

I'm gonna use 4k textures for thelai, quarta and fume as they are quite small and to be frank, you can't actually see the surface of fume - that will decrease load times again :)

Nievis' graphical bug is caused by ScaledVersion not loading before you're out of its SOI. I'm either going to slightly increase its SOI or fiddle with its scaled version

Edited by Gameslinx
Link to post
Share on other sites

Hey all! Hotfix incoming in 30 minutes which will attempt to fix the excessive 10GB RAM usage ingame. A few textures are 8k when they don't need to be, especially Niebos_normal.png, which is 30MB on its own!

Link to post
Share on other sites
26 minutes ago, ModerndayLink64 said:

How come niebietos' name was changed to Nievis?

I don't like having to pronounce Niebietos :P

 

___________________________________________

In other news, the RAM usages have been reduced from 10GB to just above 7GB (in the main menu), now people with 8GB of RAM can use it :D

(UPDATE COMING TOMORROW)

Edited by Gameslinx
Link to post
Share on other sites
On 2017-5-21 at 11:11 PM, TheWanderer05 said:

Edit: This update is also causing my ksp to crash and have loading times over ten times as long as the previous update.

Update released fixing this. Lowered the file size to 500MB from 1GB, and the RAM usages have been reduced from 9GB to 6 GB. You won't crash anymore. 

 

As for the 10x longer loading times, that's an issue on your end.

Link to post
Share on other sites
11 minutes ago, KerbolExplorer said:

one thing since the apdate that makes Gaias atmosfere brethable were they more apdates.I ask this because i wasnt using this pack for a wile and i whant to know if there were any new updates

There have been many, many updates in the last week. 

To update, please delete the entire mod before updating as many things were changed.

There's a whole bunch of new stuff and many planets were improved and changed :) performance has also improved drastically.

Link to post
Share on other sites
18 minutes ago, Gameslinx said:

There have been many, many updates in the last week. 

To update, please delete the entire mod before updating as many things were changed.

There's a whole bunch of new stuff and many planets were improved and changed :) performance has also improved drastically.

wow:D i better find out now

Link to post
Share on other sites

Related image

Before anyone asks, this mod is not compatible with version 1.3 as of 26 May, 2017.

Yes, I hate the update too, and I have too much to say to dump it here under this notice but 1.3, simply put, is horrible. When Kopernicus updates to the new KSP version, I will release an update and work towards 1.3 support. Thanks for understanding and thank you for reading. 

- Linx.

Link to post
Share on other sites

Hey all! I have some more information regarding the 1.3 update.

I need to wait for seven dependencies to update:

  1. Kopernicus
  2. ModularFlightIntegrator
  3. Instantiator
  4. Scatterer
  5. Environmental Visual Enhancements
  6. TextureReplacer
  7. ModuleManager

It may take weeks if not months for these dependencies to fully update. I'm a bit sceptical whether Instantiator will update for 1.3, as Kargantua has not been recently updated, nor has the developer of that mod and its plugin. Hopefully, Instantiator should already work with 1.3 as it requires no dependency and injects its own code using seemingly solid foundation code from KSP as its base, so it shouldn't be so much of a problem. In the likely case it does not work and does not update, I will have to revert to the older version of Olu'um's rings.

Link to post
Share on other sites

Hey there! I rolled back to 1.2.2 to give this a shot, screenshots look awesome.  Unfortunately I'm just getting a black screen when I try to load the Space Center, can't click on VAB or do anything.  I installed the mod direct from the spacedock download in a clean install, no other mods.  Running linux 64 bit

 

I'm going to go play around with the new 1.3 for a bit until I hear back, but I would love to give this one a shot

Edited by Jetski
Link to post
Share on other sites
10 minutes ago, Jetski said:

Hey there! I rolled back to 1.2.2 to give this a shot, screenshots look awesome.  Unfortunately I'm just getting a black screen when I try to load the Space Center, can't click on VAB or do anything.  I installed the mod direct from the spacedock download in a clean install, no other mods.  Running linux 64 bit

 

I'm going to go play around with the new 1.3 for a bit until I hear back, but I would love to give this one a shot

Could you send me the following files:

  • Kerbal Space Program > Logs > Kopernicus > Kopernicus.log
  • screenshot of you GameData folder

And do you know how much RAM you have on your computer?

Thanks :)

Link to post
Share on other sites
12 minutes ago, Jetski said:

Wow quick response! 

https://www.dropbox.com/s/jfolbdx2w06wc0b/Screenshot from 2017-05-27 11-08-39.png?dl=0

https://www.dropbox.com/s/fycjgyydijx3rf1/Kopernicus.log?dl=0

 

I'm not sure on RAM, but I've run planet packs before without trouble.  Maybe 8GB?  new solid state HD so was hoping for good speed :)

Can you send Dread.Body.Log (KSP > Logs > Kopernicus)? This should help me gauge where kopernicus goes poof. It likely encountered an exception or couldn't parse a node in one of the configs for whatever reason.

 

I'm unsure of what's happening here. I assume you're running 1.2.2 and the kopernicus I provided in the ZIP 

 

Edited by Gameslinx
Link to post
Share on other sites
10 minutes ago, Jetski said:

https://www.dropbox.com/s/22ar1o78l3x9xwq/Dread.Body.log?dl=0

Yep, fresh KSP install from the 1.22 zip file, the only mod files going into the GameData are the contents of your zip file from Spacedock

Could you also send over Dread.cfg? It's found in Gamedata > Olei > configs > Dread.cfg.

I have a feeling I think I know what the problem is, but I haven't touched Dread's config in a long time, so ours should be identical. Kopernicus is having trouble parsing whatever comes after the biome map. I'm not sure whether running Linux would affect this because, as you said, you have run other planet packs before. Thanks :D

Link to post
Share on other sites
16 minutes ago, Jetski said:

https://www.dropbox.com/s/6ju6w85ca4g1mlm/Dread.cfg?dl=0

Here's as far as I get.  Just for fun I redownloaded the zip from spacedock, but same results

 

88WhTYg.png

Hmmm... that looks more like a KSP error than the mod doing that. I haven't encountered that before, and you're the first one to come to me about it. I'll continue looking, but after looking at the CFG files and your logs, there's no reason why some bodies didn't load - even since you were playing in 64 bit.

If you use steam, you can redownload the KSP 1.2.2 by selecting it from Properties > Betas.

Something is definitely amiss here. I downloaded the mod from SpaceDock and installed it the same as you have and it's working fine, meaning I'm inclined to think it's KSP that's gone wrong somewhere. Sorry that I can't help much - this is a new problem you've found. I don't think you're out of RAM since you made it past the loading screen, so don't worry about that.

If I come up with something, I'll let you know. I'll tag @The White Guardian as he is online whether he has seen this before.

Edited by Gameslinx
Link to post
Share on other sites

After deleting all the planet stuff, same install but only the Squad folder in GameData it loads OK, so install is not borked.  Is it worth deleting individual folders from your mod to see which it is, or are they all interconnected?

14Oh6KT.png

Link to post
Share on other sites
8 minutes ago, Jetski said:

After deleting all the planet stuff, same install but only the Squad folder in GameData it loads OK, so install is not borked.  Is it worth deleting individual folders from your mod to see which it is, or are they all interconnected?

14Oh6KT.png

They're mostly interconnected, however you can remove Scatterer , TWG and Environmental Visual Enhancements and see if that works :)

Link to post
Share on other sites
8 minutes ago, Jetski said:

dang.  removed those 3 and same thing happens, black screen at KSC.  Ah well, let me know if you have any ideas, mod looks really cool

Yeah...

Again, i'm sorry I'm unable to help. I don't want to blame Linux but something in the mod might not like it so much.

I'll let you know.

Link to post
Share on other sites

@Gameslinx @Jetski

KLE is a c# plugin built on top of Kopernicus. It is impossible for it to cause any kind of issue unless something is up with Kopernicus. Plus, if GPO uses KLE, then deleting it will break planet terrain. This is because KLE PQSMods used by GPO cannot be found thus the code is declared invalid and skipped, meaning that the terrain differs.

I personally think it could be because @Jetski is playing on Mac OS (Or Linux, becuase tbh I don't know the layout of either...). While Windows is lazy, Mac and Linux go the extra mile and check if cases also match (case-sensitivity is a thing for Mac OS and Linux players)

So @Gameslinx if a texture filepath is invalid when it comes to case sensitivity, then a texture cannot be found.

Either way, @Jetski this kind of problem (black KSC screen) usually occurs when there is a problem with Kerbin itself. Try deleting the Olei-Gaia folder.

 

Other possibilities:

KSP-Kopernicus version mismatch

Invalid ModularFlightIntegrator version

On 5/23/2017 at 3:03 AM, electricpants said:

I would use this mod, but I'm too addicted to Uncharted Lands.

Sorry, @GameslinxnTTYEdB.png 

AFAIK it should be compatible with UL save for the Kerbin-changing part of the mod.

In fact, please give it a try! I'm sure @Gameslinx could use compatibility data (GPO vs. UL orbit locations) so, if necessary, a compatibility patch can be included (which I'm happy to create).

Edited by The White Guardian
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...