Gameslinx

[1.4.3] Gameslinx's Planet Overhaul v3.4.0 [UPDATE IN PROGRESS]

Recommended Posts

10 hours ago, Shad_The_Knight said:

I am curious about this, but I noticed that there is a smaller rock orbiting vulcan (had to use hyperedit to figure out its called vulcanoid). I can't lock onto it or see its orbit line. The lack of orbit line makes sense as I read the info, but was it meant to not be targeted? 

It's meant to be a little more challenging if it helps, I'll make it targetable but without the orbit line in an update.

If you want to change this yourself, go to GPO/Configs/Vulcanoid.cfg and change Selectable to True 

Share this post


Link to post
Share on other sites

MERIDIAN,

I found that while trying to find a way to fix a bug where ksp crashes when changing SOI to any object other than Gaia. I have looked at the comment chain from GPP about the same issue but unfortunatley could not find a solution. Incase you need my mod list here it is.

Thanks for helping in advance.

Share this post


Link to post
Share on other sites
1 hour ago, HZDeadmeat said:

MERIDIAN,

I found that while trying to find a way to fix a bug where ksp crashes when changing SOI to any object other than Gaia. I have looked at the comment chain from GPP about the same issue but unfortunatley could not find a solution. Incase you need my mod list here it is.

Thanks for helping in advance.

That's an awful lot of mods.

Would you be able to test this again by removing all the mods and doing a clean install of GPO? I understand that might be difficult, but you can back up your gamedata folder first. Let me know if it still persists!

Share this post


Link to post
Share on other sites
2 hours ago, Gameslinx said:

That's an awful lot of mods.

Would you be able to test this again by removing all the mods and doing a clean install of GPO? I understand that might be difficult, but you can back up your gamedata folder first. Let me know if it still persists!

Clean install works fine must be a conflict with one of my other mods.

Share this post


Link to post
Share on other sites

Finally found the cause of the problem, Physics Range extender which was added by BDArmorycontinued causes the bug. Gameslinx keep up the awesome work on your planet packs and I cannot wait for Beyond Home.

Share this post


Link to post
Share on other sites
16 minutes ago, HZDeadmeat said:

Finally found the cause of the problem, Physics Range extender which was added by BDArmorycontinued causes the bug. Gameslinx keep up the awesome work on your planet packs and I cannot wait for Beyond Home.

Glad you found out what the issue was!

I'll make sure to remember that if I see anyone else having the problem.

One Beyond Home is released, I'll make sure to properly update all my other mods to 1.6.

Share this post


Link to post
Share on other sites

Love to see how that turns out! Good luck! I’m currently taking a KSP hiatus until this gets updated. Maybe give us some status updates once major landmarks are passed?

Share this post


Link to post
Share on other sites
4 hours ago, XeNoCaTZ said:

Does it work with 1.6.1 ?

If you update the dependencies, yes

Share this post


Link to post
Share on other sites

Is Scatterer really 100% necessary? because I tried downloading it before EVE was available for 1.5 and it crashed my game SO hard. So will GPO work without it?

I'd also like to see these mods bundled with GPO, it would have made my life 934937034759387503957309857 times easier.

 

Still this mod looks GORGEOUS. Can't wait to play it!

Share this post


Link to post
Share on other sites

Guys, does need 1.3 as well? I really hope I can play it in 1.4/5/6 (they're basically all compatible with each other)

Some of these dependencies are starting to tick me off, even if this is one of the most beautiful planet packs I've ever seen...

Share this post


Link to post
Share on other sites
1 hour ago, Spacenerd Kerman said:

Is Scatterer really 100% necessary? because I tried downloading it before EVE was available for 1.5 and it crashed my game SO hard. So will GPO work without it?

I'd also like to see these mods bundled with GPO, it would have made my life 934937034759387503957309857 times easier.

 

Still this mod looks GORGEOUS. Can't wait to play it!

Scatterer is not required. Scatterer works on 1.3.1, 1.4.2, 1.5.1 and 1.6+ so you should not be experiencing crashes.

34 minutes ago, Spacenerd Kerman said:

Guys, does need 1.3 as well

As long as you get the updated versions of Kopernicus and the mod's other dependencies. Instantiator is not updated but still works.

Share this post


Link to post
Share on other sites
1 hour ago, Spacenerd Kerman said:

Is Scatterer really 100% necessary? because I tried downloading it before EVE was available for 1.5 and it crashed my game SO hard. So will GPO work without it?

I'd also like to see these mods bundled with GPO, it would have made my life 934937034759387503957309857 times easier.

 

Still this mod looks GORGEOUS. Can't wait to play it!

 

34 minutes ago, Spacenerd Kerman said:

Guys, does need 1.3 as well? I really hope I can play it in 1.4/5/6 (they're basically all compatible with each other)

Some of these dependencies are starting to tick me off, even if this is one of the most beautiful planet packs I've ever seen...

No, the only dependencies necessary to play are Kopernicus and CTTP. In fact, you can get GPO looking beautiful with just EVE.

Share this post


Link to post
Share on other sites
On 1/29/2019 at 5:30 PM, Gameslinx said:

If you update the dependencies, yes

What dependencies ?

Share this post


Link to post
Share on other sites
1 hour ago, XeNoCaTZ said:

What dependencies ?

Listed on the GitHub when you go to download the mod

(Stuff like Kopernicus)

Share this post


Link to post
Share on other sites
5 hours ago, Gameslinx said:

Listed on the GitHub when you go to download the mod

(Stuff like Kopernicus)

And how I update it ?

Share this post


Link to post
Share on other sites
1 hour ago, XeNoCaTZ said:

And how I update it ?

Search the mod name, then get the newer version.

If you don't know how, just wait for the 1.6 release.

Share this post


Link to post
Share on other sites
15 hours ago, Gameslinx said:

Search the mod name, then get the newer version.

If you don't know how, just wait for the 1.6 release.

dependencies ?

Share this post


Link to post
Share on other sites

That said gamelinx doesn't support this kip version please use 1.3.1

 

 

Edited by XeNoCaTZ
wrong name of mod

Share this post


Link to post
Share on other sites
36 minutes ago, XeNoCaTZ said:

That said gamelinx doesn't support this kip version please use 1.3.1

 

 

I know I don't support KSP 1.6 but if you know what you're doing you can manually update it without much difficulty.

If you're not sure where to start, just wait for the update.

 

Share this post


Link to post
Share on other sites

but I want Kerbin not Gaia

What I need to do ?

Edited by XeNoCaTZ

Share this post


Link to post
Share on other sites
2 minutes ago, XeNoCaTZ said:

but I want Kerbin not Gaia

What I need to do ?

You could remove the Gaia config and then in the removePlanetaryBodies.cfg you could remove the "!Body[Kerbin] {}" but again, if you don't know how, don't try otherwise you will break the mod.

I won't help further with tampering with the mod, as this is really something you should do yourself.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.