ufindbatman

[1.2.2] E.T. - Extreme Textures (RSS)

Recommended Posts

@KGas- Inc Depends. For example, RSS itself has the provisions for adjusting things like that via a custom REALSOLARSYSTEM config node. There are some examples presented in the RSS GitHub Wiki page for that.

Share this post


Link to post
Share on other sites

Does the 1.1.3 version not work in 1.2.2, or am I doing something wrong? 

Thank you

Edit: I was doing something wrong. Ignore this post

Edited by dafidge9898
Was doing something wrong

Share this post


Link to post
Share on other sites

Have some problems:

https://yadi.sk/i/fZf4UtMr3MQSZB
https://yadi.sk/i/Q-DvuQzL3MQWhK

The same happens with fresh install (only Squad folder + mod)

I suppose there is a problem with the clouds: I've tried to combine RSSVE and some of new textures, and when I install the clouds (modified cfg + cloud dds texture)  the Earth looks the same.

But even with EarthColor.dds and lower cloud layer only it looks fantastic without significant impact on perfomance, like th RSSVE clouds, thank you :)

https://yadi.sk/i/GYxFX0Rm3MRqY8
https://yadi.sk/i/Og9Xwh9_3MRqiA

 

 

Edited by MaxP

Share this post


Link to post
Share on other sites

Has anybody tried this in Linux with openGL ? I have a pretty hefty gaming PC with 16Gb of RAM and an nvidia GTX1050.

 

Second question - will this 1.2.2 build run on 1.3.0 ? RSSVE is basically unusable on 1.3 so this may be a nice(r) alternative if it works well. 

Share this post


Link to post
Share on other sites
13 minutes ago, metalpoetza said:

Has anybody tried this in Linux with openGL ? I have a pretty hefty gaming PC with 16Gb of RAM and an nvidia GTX1050.

 

Second question - will this 1.2.2 build run on 1.3.0 ? RSSVE is basically unusable on 1.3 so this may be a nice(r) alternative if it works well. 

No it won't work on 1.3.

It might if you use scatterer v0.0300 and turn off the ocean shaders.

RSSVE has a 1.3 build available I thought?

Share this post


Link to post
Share on other sites
23 minutes ago, Galileo said:

No it won't work on 1.3.

It might if you use scatterer v0.0300 and turn off the ocean shaders.

RSSVE has a 1.3 build available I thought?

No build I could find. There is a branch - in the github repo - but I've not seen any build. I have no  idea what would happen if I self-compile that branch as I can't easily tell from  looking at the commit history how much work has actually happened in that branch yet.  It seems RSS introduces some real difficulties for visual mods - considering how 1.3 stock has at least 3 great ones now (AVP, SVE and Spectra) while RSSVE is still in RC status for 1.2.2. I suspect something makes it more difficult ?

Share this post


Link to post
Share on other sites
9 minutes ago, metalpoetza said:

No build I could find. There is a branch - in the github repo - but I've not seen any build. I have no  idea what would happen if I self-compile that branch as I can't easily tell from  looking at the commit history how much work has actually happened in that branch yet.  It seems RSS introduces some real difficulties for visual mods - considering how 1.3 stock has at least 3 great ones now (AVP, SVE and Spectra) while RSSVE is still in RC status for 1.2.2. I suspect something makes it more difficult ?

If you use the patch for RSS I posted in the thread, there are no issues with visual packs so long as you use the required dependencies of the visual pack. 

@Phineas Freak has posted a few times recently in the RSSVE thread about a version that works in 1.3. I would go looking for those comments and see where they get you.

Share this post


Link to post
Share on other sites
1 hour ago, Galileo said:

If you use the patch for RSS I posted in the thread, there are no issues with visual packs so long as you use the required dependencies of the visual pack. 

@Phineas Freak has posted a few times recently in the RSSVE thread about a version that works in 1.3. I would go looking for those comments and see where they get you.

It took some digging but I found the post with your patch link... unfortunately when I hit the download link dropbox gave me a 404 error. I would be happy to try it out tonight - but I need to get my hands on it first lol :P

Share this post


Link to post
Share on other sites
21 hours ago, metalpoetza said:

There is a branch - in the github repo - but I've not seen any build.

That branch is the one that it is compatible with KSP 1.3. All you have to do is to replace the .dll file of the RC4 release with the one from the repository. I also have a small table in the RSSVE OP that lists the proper versions of the dependencies and it includes a KSP 1.3 section.

22 hours ago, metalpoetza said:

 It seems RSS introduces some real difficulties for visual mods

There is no inherent "difficulty" regarding RSS visuals, it is just that i prefer to spend the extra time to get it right the first time. I could have easily released what i had 3 or 4 months ago and/or mark the latest version as an official one but:

  • I would not have included everything that I wanted from the release to have (still the Uranus rings did not make it)
  • I added some new things that required testing and would need some feedback from the users before making them part of the official releases (simple terrain textures, rings, DX11/OpenGL patchers, proper/accurate Scatterer configs - i had to write a custom external program for the Scatterer configs and that also took some time)
  • I opted to wait for the official KSP 1.3 RSS/RO/RP-0 releases to get it out of it's "dev" cycle (as i have noted in the RSSVE thread)

Share this post


Link to post
Share on other sites
41 minutes ago, Phineas Freak said:

That branch is the one that it is compatible with KSP 1.3. All you have to do is to replace the .dll file of the RC4 release with the one from the repository. I also have a small table in the RSSVE OP that lists the proper versions of the dependencies and it includes a KSP 1.3 section.

There is no inherent "difficulty" regarding RSS visuals, it is just that i prefer to spend the extra time to get it right the first time. I could have easily released what i had 3 or 4 months ago and/or mark the latest version as an official one but:

  • I would not have included everything that I wanted from the release to have (still the Uranus rings did not make it)
  • I added some new things that required testing and would need some feedback from the users before making them part of the official releases (simple terrain textures, rings, DX11/OpenGL patchers, proper/accurate Scatterer configs - i had to write a custom external program for the Scatterer configs and that also took some time)
  • I opted to wait for the official KSP 1.3 RSS/RO/RP-0 releases to get it out of it's "dev" cycle (as i have noted in the RSSVE thread)

Thanks for the response - I managed to get it working after I discovered a copy of the temp patch inside a post (the download appears to be gone), and edited the pqs_terain file in the RC4 release. I haven't got a working monodevelop setup right now, so can't actually recompile -though I may try to do so in the near future and see if I can offer any help.

I wasn't judging on the timelines - I fully understand we're talking about support for a version on which your key dependency isn't even fully released, and I really understand the idea of "not really having everything you want in it yet". Heck I'd be the greatest hypocrite on earth if I complained about release times, I've been failing to find time to write the next version of pyKAN for over a year now ! 

I just found it curious that the stock ones were proceeding so much faster than the RSS ones I know about - and wondered if there was a technical reason behind it. For the moment it's working okayish for me. I did have one landing where apparently every longitude had become an narrow ocean (cutting right through continents) but it appears to have been a one-time glitch. Unfortunately I didn't think to take a screenshot and it seems a bit nasty to be reporting bugs on an unreleased hack :P

Share this post


Link to post
Share on other sites

@metalpoetza There is no need to recompile the source code, the code changes required for the KSP 1.3 release are already compiled. If you download the "KSP-1.3-Update" branch in the form of a .zip file you will have a ready to go RSSVE installation for KSP 1.3 (same installation instructions as with the previous ones). In fact, since it is a dev version you do not actually need the RSSVE assembly. But, do not expect any kind of user support.

We are also getting off-topic so if you have any questions or suggestions it would be better to continue the discussion about RSSVE to the main RSSVE thread.

Share this post


Link to post
Share on other sites

 Good morning, i have 3 questions: Works on 1.3.0 ? Or visual mods works on any version ? Or work only in the same version 1.2.2 ? =), Already been answered in the previous post, ignore this post! Sorry for the inconvenience.

Edited by Catatau_27
My Fault

Share this post


Link to post
Share on other sites
2 hours ago, Catatau_27 said:

 Good morning, i have 3 questions: Works on 1.3.0 ? Or visual mods works on any version ? Or work only in the same version 1.2.2 ? =), Already been answered in the previous post, ignore this post! Sorry for the inconvenience.

Why why would anyone try to read this? The inconvenience with your post is trying to read it without getting a migraine. 

Change your font. 

Share this post


Link to post
Share on other sites
2 hours ago, Galileo said:

Por que alguém tentaria ler isso? O inconveniente com a sua publicação é tentar lê-lo sem ter enxaqueca. 

Mude sua fonte. 

Thanks for the tip, but be less arrogant and be more polite to people, because no one is to blame for your frustrations.

Share this post


Link to post
Share on other sites
10 minutes ago, Catatau_27 said:

Thanks for the tip, but be less arrogant and be more polite to people, because no one is to blame for your frustrations.

Ok, whatever you say lol

Share this post


Link to post
Share on other sites
2 minutes ago, Catatau_27 said:

The way you said it sounded rude. 

I was blunt, to the point, not rude. The way it come across depends on how you read it. It's easy to take typed words out of context. Enjoy your day :) 

Share this post


Link to post
Share on other sites

When I get above a certain height, (150km ish) all the land mass disappears and all I see is blue and clouds, Same in map view. 

Share this post


Link to post
Share on other sites

hello ive been using this mod for a while now (I LOVE IT) and i was recently making a new install of ksp for 1.2.2 during the making and testing i got this mod working and i loaded up the game everything was fine i put a satellite in orbit i hyper edited it so i could see the visuals but i installed wrong so it didn't look like what it was supposed to look like so i changed my graphics mods but now realizing i installed wrong i have attempted to put it in my install and it loads up fine but when i load up or create a new the frame rate is terrible i used the 1.1.3 version of this on my old install and i had even more mods and it worked fine but on hear once you load up a save it lags really badly i went to one of my satellites in orbit it looks great but it must be a mod conflicting ill try and give you some files and stuff here i hope they can help im currently trying to isolate the problem. i have the same problem as Seanksp 

Share this post


Link to post
Share on other sites

nvm i found out apparently we should had have dx11 but apparently the best buy people didn't do it my problem sorry 

Share this post


Link to post
Share on other sites

wait a minute i mess read it i have dx 12 do i need dx 11 or is it just a mod conflict (currently trying to locate the conflicting mod i have no other graphic mods except for planetshine and distant object)

Share this post


Link to post
Share on other sites

Hi folks,

Attempting to get this to work via the d3d11 shortcut.   Currently, I get the blue sphere problem.  

I've downloaded PhineasFreak's config used for RSSVE, and changed the Before/After texts from RSSVE to E.T.O, which is what MM uses as an ID for it.  However - I'm wondering - where do I place the config, if it were to work?  

I currently have it the Scatterer/Configs folder.  Is that correct?  
Also - has anyone else been working on the problem lately? 
Cheers,

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.