• 0
sp1989

KSP Just Doesn't Run Like it Use to

Question

I have been playing KSP SINCE .21. It wasn't until .23 I started modding my game. Now there are alot of nice fancy features included in ksp now but honestly it just doesn't run like it used to run. Even when I run a moderately modded game it lags and is almost unplayable. I really want play ksp like i used to but I just can't anymore because the game runs so poorly. Now I know people will undoubtedly comment about settings but I swear to you that I used to run almost 40 mods and the game performed flawlessly. Hundreds of hours of play time. As every update came my mod list got shorter and shorter because the game would crash. I figured maybe it was computer? Nope even though it wasn't I added 4 more gigs to my computer still the game just doesn't run like it used to. Now I admit I have a MacBook but again I used to play with ALOT of mods. BIG mods all together like the Soviet Pack, FASA, KW, and NOVA Punch, ASET ALCOR, laztek spacex mod, kethane, kso shuttle, chaka monkey, better atmospheres and or ksprc,  for anyone who remembers the good old days. I once over the course of a few weeks launched everything from sputnik to the space shuttle in order. Way before Bob Fitch using the soviet pack, skylab, american and soviet prob packs, fasa, iss pack, compent space shuttle and an atmosphere and texture pack. I once launched the KSO on top of the FASA Saturn V....honest... 

What I am saying is that these were REALLY big packs. All used together and honestly I can't imagine using any of them simultaneously anymore. My interest over the last say 3 months has diminished greatly and it was diminishing before that. It makes me sad but I just can't play the game like I used too. I know I can get a better computer but honestly why should I  since I have played the game the way I wanted even when the game was inefficient. Plus I can't afford a new computer. I just don't understand I can play it on 64 bit with 8gb ram and it just doesn't run right. I tried playing with just BDB and the game just runs really slow. Is there a mod like Active Texture Management out there because thats was what made me able to play with so many mods. Any way just wondering if there were any old dogs out there like me experiencing this same feeling and experience. I love the community and seeing all the wonderful creations but it makes me sad I can't use them like I would like to. 

Sincerely, 

A KSP Veteran who learned to fly with prop planes (firespitter) and learned to dock blind

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0

Try enabling the unsupported legacy terrain shader in your settings.cfg, that helped me with performance when I was playing on my Linux box with an onboard Intel 4K GPU. You really need a graphics card to be running the newest KSP.

If that's not the case then I don't know how to help you, performance has been pretty rock solid on both my machines (after fixing the terrain shader on one).

Share this post


Link to post
Share on other sites
  • 0

Most players are finding recent versions to be an improvement, so your question has been moved to the support section, since it seems to be something specific about your situation. How about more diagnostic details? System specs? 

Share this post


Link to post
Share on other sites
  • 0

Uninstall CraftImport if you've got it. It re-subscribes to an event every frame, causing runaway memory usage and garbage collection grinding. (Fix patch pending review.)

Share this post


Link to post
Share on other sites
  • 0
12 hours ago, HebaruSan said:

Uninstall CraftImport if you've got it. It re-subscribes to an event every frame, causing runaway memory usage and garbage collection grinding. (Fix patch pending review.)

Craft import was updated last night to fix that problem

Share this post


Link to post
Share on other sites
  • 0
13 hours ago, Vanamonde said:

Most players are finding recent versions to be an improvement, so your question has been moved to the support section, since it seems to be something specific about your situation. How about more diagnostic details? System specs? 

qGaLmPr.png

These are all the specs i know about my computer. Again I am aware my computer is not optimized to play KSP. I am aware I have an older computer. Im even aware the game has grown and evolved. But even when the game was at its most inefficient and ran on 32 bit only I sill could run dozens of mods with very limited lag and played for hours!

Share this post


Link to post
Share on other sites
  • 0

Your Mac is more than able to run the game, no worry on that side.

I'm not sure it will help you, but have a look on this thread:

 

Try the graphical settings changes at the beginning of the thread. Your game lagging makes me think it could be a solution (without too much hopes...)

Share this post


Link to post
Share on other sites
  • 0
On 31.1.2017 at 7:52 PM, sp1989 said:

These are all the specs i know about my computer. Again I am aware my computer is not optimized to play KSP. I am aware I have an older computer. Im even aware the game has grown and evolved. But even when the game was at its most inefficient and ran on 32 bit only I sill could run dozens of mods with very limited lag and played for hours!

While the HD 3000 and 4000 were much stronger compared to the older GMA family of onboard graphics chips they were still mostly meant to have some nice 3d effects on your desktop and window managers and for hardware developers to have a built in cheap and energy efficient video card. They were never meant for any heavy gaming. The fact that you could play the game for such a long time without any major problems is much more astounding than the fact that you are facing performance issues now.

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, Harry Rhodan said:

While the HD 3000 and 4000 were much stronger compared to the older GMA family of onboard graphics chips they were still mostly meant to have some nice 3d effects on your desktop and window managers and for hardware developers to have a built in cheap and energy efficient video card. They were never meant for any heavy gaming. The fact that you could play the game for such a long time without any major problems is much more astounding than the fact that you are facing performance issues now.

Not really astounding at all. The legacy terrain shaders were much easier on the on-board graphics card. I played KSP for several years (generally heavily modded, even a 4K RSS+RO setup with an 8K Earth texture) on a Linux-based i7 machine with Intel 4K graphics, very similar to the one shown above; it ran just fine, even with large ships. Certainly there were performance issues but nothing serious; the game was eminently playable. Once KSP deprecated those terrain shaders and hid the option in the menu I noticed a major dip in performance, especially during launch and looking at a planet. Those can be re-enabled in the settings.cfg file and should restore some performance.

UNSUPPORTED_LEGACY_SHADER_TERRAIN = True

 

Share this post


Link to post
Share on other sites
  • 0
11 hours ago, regex said:

Not really astounding at all. The legacy terrain shaders were much easier on the on-board graphics card. I played KSP for several years (generally heavily modded, even a 4K RSS+RO setup with an 8K Earth texture) on a Linux-based i7 machine with Intel 4K graphics, very similar to the one shown above; it ran just fine, even with large ships. Certainly there were performance issues but nothing serious; the game was eminently playable. Once KSP deprecated those terrain shaders and hid the option in the menu I noticed a major dip in performance, especially during launch and looking at a planet. Those can be re-enabled in the settings.cfg file and should restore some performance.


UNSUPPORTED_LEGACY_SHADER_TERRAIN = True

 

Interesting. Some quick questions:

-what exact differences you get "on screen" by doing this? Does anything look significantly different?

-would you gain any performance by doing that on a system where none of the components is a bottleneck? (i.e. KSP itself the limiting factor)

-and does this have an impact on the flickering shadow bug?

Thanks in advance

-Daf

 

Share this post


Link to post
Share on other sites
  • 0
Just now, Dafni said:

-what exact differences you get "on screen" by doing this? Does anything look significantly different?

Terrain seems darker. Check my posting history, I made a Kopernicus script a while back that somewhat addressed it.

Just now, Dafni said:

-would you gain any performance by doing that on a system where none of the components is a bottleneck? (i.e. KSP itself the limiting factor)

Potentially, I haven't checked. My current gaming machine is an Alienware 15 R2 I bought last June so I've had no real reason to try.

Just now, Dafni said:

-and does this have an impact on the flickering shadow bug?

Not that I know of.

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, regex said:

Terrain seems darker. Check my posting history, I made a Kopernicus script a while back that somewhat addressed it.

Potentially, I haven't checked. My current gaming machine is an Alienware 15 R2 I bought last June so I've had no real reason to try.

Not that I know of.

Thank you for that swift reply! I'll have a look.

My gaming machine is also quite decent, no component runs even close to its limit. Still the visual mods plus bigger ships can slow the game down somewhat. Not as bad as back in 1.0.5, but still irksome enough to maybe try the shader trick over the weekend.

Thanks again for pointing it out.

o7

Share this post


Link to post
Share on other sites
  • 0

Getting 8 fps on a pretty decent rig myself, looking at an 80 part ship, Im not sure where I should be looking. Ill try the legacy shaders and see if that helps at all.

Edited by blu3wolf

Share this post


Link to post
Share on other sites
  • 0
On 2/3/2017 at 2:19 AM, regex said:

Terrain seems darker. Check my posting history, I made a Kopernicus script a while back that somewhat addressed it.

Potentially, I haven't checked. My current gaming machine is an Alienware 15 R2 I bought last June so I've had no real reason to try.

Not that I know of.

legacy shaders helped. Still not the way it used to be but I will take it for now. I also don't like the colors but i don't spend much time on kerbin lol. 

Share this post


Link to post
Share on other sites
  • 0

Does anyone know if there is a Mod like ATM that works in 1.2? I feel that had alot to do with me being able to play with alot of mods in the past. 

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.