Gaarst

Community Mods and Plugins Library continued for 1.2.2 & 1.3

Recommended Posts

Posted (edited)
On 31/07/2017 at 1:06 AM, Gaarst said:

To-do:

  1. Check for updates in the Outdated section; DONE!
  2. Add the mods that were released after April since that's when we stopped massively adding mods to the library; DONE!
  3. Move 1.2 compatible mods to the Outdated section;
  4. Maybe sort a few categories and re-order mods (the more I'm going through these mods the more I realise our classification can be inconsistent);
  5. The spreadsheet thing for translations and getting rid of the dependence to the forum software. (I'll probably do 4. and 5. at the same time).

Just finished doing 2., now the list contains all the mods released since April!

As for 3. (moving the 1.2 mods to the Outdated section) I've made a poll so that you can choose when you want it to be done. Vote here:

 

Edited by Gaarst

Share this post


Link to post
Share on other sites

@Gaarst UPDATE! (OptionalAtmospheres)

Spoiler
  • [1.3.0] OptionalAtmosphere, by SamBelanger - This mod adds atmospheres to planets and moons which don't have any.
Spoiler
  • [1.3.0] OptionalAtmospheres, by SamBelanger and DeldaDizzy - This mod adds atmospheres to planets and moons which don't have any.

 

Share this post


Link to post
Share on other sites
10 hours ago, SamBelanger said:

@Gaarst UPDATE! (OptionalAtmospheres)

  Reveal hidden contents
  • [1.3.0] OptionalAtmosphere, by SamBelanger - This mod adds atmospheres to planets and moons which don't have any.
  Reveal hidden contents
  • [1.3.0] OptionalAtmospheres, by SamBelanger and DeldaDizzy - This mod adds atmospheres to planets and moons which don't have any.

 

 

6 hours ago, ModerndayLink said:

My mod has been updated to 1.3 

Thanks!

 

Thanks to both of you for the updates. However I don't have access to my laptop for a bit and there's no way I'll edit this list on mobile; so it might take a while for the library to be updated.

Share this post


Link to post
Share on other sites

@Gaarst - So a few weeks ago I moved DCK to the releases section and I was wondering if you could list DCK as a released mod

I have notified @CarnageINC that this is the case and asked to have DCK removed from the add-on development library, however he hasn't been online since August 5th so has yet to recieve my message

 

Share this post


Link to post
Share on other sites
55 minutes ago, DoctorDavinci said:

@Gaarst - So a few weeks ago I moved DCK to the releases section and I was wondering if you could list DCK as a released mod

I have notified @CarnageINC that this is the case and asked to have DCK removed from the add-on development library, however he hasn't been online since August 5th so has yet to recieve my message

 

I saw your message back then (I dont remember if Carnage told me or if it was in the thread), and I did add DCK to this library, I forgot to notify you that I did though. OTOH it is probably still in the Dev library if Carnage hasn't replied.

Share this post


Link to post
Share on other sites
33 minutes ago, Gaarst said:

I saw your message back then (I dont remember if Carnage told me or if it was in the thread), and I did add DCK to this library, I forgot to notify you that I did though. OTOH it is probably still in the Dev library if Carnage hasn't replied.

Thank you muchly :)

Share this post


Link to post
Share on other sites

There is some sort of API update in 1.3.1 which will basically require almost all mods/apps to recompile for compatibility and perhaps functionality.  This applies even to 1.3.0 -> 1.3.1 (apparently Squad devs missed this incompatibility until it was too late to change it).  It appears that game simply crashes whilst loading with any of the affected apps/mods

So perhaps now is the time to push the 1.2 apps to the outdated section, and put the 1.3.0 and 1.3.1 as the two primary active selections, since there are now even larger incompatibilities in the system.

Share this post


Link to post
Share on other sites
11 hours ago, i like pizza said:

Can you update the mods? It's been more than 26 days.

 

On 17/09/2017 at 1:11 PM, Gaarst said:

 

 

Thanks to both of you for the updates. However I don't have access to my laptop for a bit and there's no way I'll edit this list on mobile; so it might take a while for the library to be updated.

 

Share this post


Link to post
Share on other sites

I can confirm that the Warp, Drives mod Alcubierre warp drive by Rover Dude works in 1.3.1 as well as KW Rocketry and Modular Pods/Modular Rockets.

Share this post


Link to post
Share on other sites
On 17/09/2017 at 2:42 AM, SamBelanger said:

@Gaarst UPDATE! (OptionalAtmospheres)

  Hide contents
  • [1.3.0] OptionalAtmosphere, by SamBelanger - This mod adds atmospheres to planets and moons which don't have any.
  Hide contents
  • [1.3.0] OptionalAtmospheres, by SamBelanger and DeldaDizzy - This mod adds atmospheres to planets and moons which don't have any.

 

Updated!

 

On 17/09/2017 at 6:12 AM, ModerndayLink said:

My mod has been updated to 1.3 

Thanks!

Updated!

 

On 18/09/2017 at 7:12 PM, linuxgurugamer said:

Kaptain's Log:

 

Added!

 

On 07/10/2017 at 4:03 AM, Murdabenne said:

There is some sort of API update in 1.3.1 which will basically require almost all mods/apps to recompile for compatibility and perhaps functionality.  This applies even to 1.3.0 -> 1.3.1 (apparently Squad devs missed this incompatibility until it was too late to change it).  It appears that game simply crashes whilst loading with any of the affected apps/mods

So perhaps now is the time to push the 1.2 apps to the outdated section, and put the 1.3.0 and 1.3.1 as the two primary active selections, since there are now even larger incompatibilities in the system.

I was away for a bit of time so I haven't followed the 1.3.1 release and its effects on mods. I'll read up on that update to see which mods are/could be affected.

Since I've lost quite a bit of time because of various issues and haven't been able to work on the library in that time, I think I'll just forget about moving 1.2 mods to the outdated section and start working on the spreadsheet instead (which will make it easier to keep track of updates).

 

On 07/10/2017 at 2:44 PM, Quoniam Kerman said:

I can confirm that the Warp, Drives mod Alcubierre warp drive by Rover Dude works in 1.3.1 as well as KW Rocketry and Modular Pods/Modular Rockets.

Thanks for the notification! Though, as the library is still "officially" maintained for 1.3 and as I don't know the extent of the incompatbilities between 1.3 and 1.3.1, I won't edit these changes for the time. I'll start building the spreadsheet and will include the updates there, whenever it is released.

 

On 19/10/2017 at 11:10 PM, SamBelanger said:

@Gaarst add DoubleDouble on community mods library! :D

 

DoubleDouble is a mod in development. This library is meant to be for released mods, so I will not be adding it for now. Ask @CarnageINC to include it in his Development Mod Library if you want it referenced now.

The status of mods in development is ill-defined ATM: we have in-dev mods in the "release" library that normally shouldn't be there, but there are in-dev mods with very advanced releases that should be there. We need to sort this out, and hopefully things will get easier once we implement the spreadsheet as main support for the library.

 

_____________________

 

[Important stuff about the library below, please read]

I was originally planning on moving 1.2 mods to the outdated section before doing major changes to the library so that mods for the latest version of KSP would be easier to find. However, I was not able to edit the library for about a month and I couldn't do the updates I was planning. In the meantime, 1.3.1 was released and apparently there are compatibility issues between the latest patch and the 1.3 release. I haven't really followed the release and the mods activity recently so I don't know much about this yet.
All in all, I have two possibilities now. Either I move 1.2 mods to the outdated section and look at which 1.3 mods are affected by the update to get up to date with mods releases and updates. Or I start working on the spreadsheet which, among other things, will remove the need for an outdated section and make updating mods easier now, leaving the library on standby for a bit longer but allowing for easier upkeep in the future.
Since I've been pushing back the spreadsheet thing for quite a few months now, I figured it might be a good time to actually start it. I don't really know how long it will take for the spreadsheet to be "complete" but don't expect big changes to the library in that time (I will still update/add mods when notified, but I won't be moving 1.2 mods anywhere, for example). I will try to keep you updated on the status of the spreadsheet regularly, and if things go well I will be releasing the incomplete version of the spreadsheet (that only I will be able to edit, for now) pretty soon so that I can get direct feedback and suggestions.

 

Edit: spreadsheet link: https://docs.google.com/spreadsheets/d/1SxrQS319Vup1NcE9ehrk5hHAtosynH9_O0Qqq4q3nfM/edit?usp=sharing

Edited by Gaarst

Share this post


Link to post
Share on other sites

Id say go after the big rocks in the rockpile first - that means the spreadsheet.  It will allow many of the other big rocks (1.2.x vs 1.3.0 vs 1.3.1) to become smaller rocks by default.

Share this post


Link to post
Share on other sites

You have kOS listed as bering only up to KSP 1.2.2.  It has a KSP 1.3.1 version.

Admittedly it's a bit confusing because we're trying to support BOTH KSP 1.2.2 AND KSP 1.3.1 with two different releases of kOS.  We're keeping KSP 1.2.2 compatibility for a little while because of Realism Overhaul being unable to update to KSP 1.3.1, but the fact that we *do* have a version for KSP 1.2.2 doesn't mean that we *don't* also have a version for KSP 1.3.1.  We're currently supporting both, with two different releases.

Share this post


Link to post
Share on other sites
On 25/10/2017 at 12:44 PM, Murdabenne said:

Id say go after the big rocks in the rockpile first - that means the spreadsheet.  It will allow many of the other big rocks (1.2.x vs 1.3.0 vs 1.3.1) to become smaller rocks by default.

My thoughts exactly, which is why I have started writing the spreadsheet and put the transfer of outdated mods on hold.

On 26/10/2017 at 8:40 AM, Steven Mading said:

You have kOS listed as bering only up to KSP 1.2.2.  It has a KSP 1.3.1 version.

Admittedly it's a bit confusing because we're trying to support BOTH KSP 1.2.2 AND KSP 1.3.1 with two different releases of kOS.  We're keeping KSP 1.2.2 compatibility for a little while because of Realism Overhaul being unable to update to KSP 1.3.1, but the fact that we *do* have a version for KSP 1.2.2 doesn't mean that we *don't* also have a version for KSP 1.3.1.  We're currently supporting both, with two different releases.

It was listed as 1.2.2 simply because I didn't update the versions recently. :)

For the library I've chosen to only show the latest released version, even when previous versions are still available for download, to keep the formatting tidy, however I never really considered the case when previous versions would be supported in parallel with the latest. So I've updated the kOS entry on the list to 1.3.1 and I've added a note saying that the 1.2.2 version was still supported.

 

____________________________

 

For the spreadsheet, I've been thinking about adding a "tags" column for each mod. It has been puzzling me for some time that the list was not great for actually finding new mods, which is a function that I would enjoy having, to give the library an utility other than simple archiving (right now, it does pretty much the same thing as CKAN minus the automatic installation).

If you don't know what mod you are looking for, you obviously cannot search for the mod name, and even though I want to improve our current categories they will never be great for finding a new mod. Since the description are (thankfully) not exhaustive they are not that useful either when searching for a specific mod.

By using generic tags, you would be able to find mods by Ctrl-F'ing a lot quicker and more easily. For example, you'd be able to find Real Solar System by searching for "RSS", or TweakScale by searching for "resize" (these are not great examples since the download links use the mods initialisms and TweakScale's description already includes the word "resize", but you get what I mean).

Edited by Gaarst

Share this post


Link to post
Share on other sites
1 hour ago, Bej Kerman said:

The link for principia is broken. Heres a new link:

 

Thanks for the info, I fixed the link!

Share this post


Link to post
Share on other sites

I'm planning on rearranging the "Efficiency" and "In Game Utility" categories which are not well defined right now and pretty much the same.

I was thinking about making a "In Flight Utility" category containing mods helping specifically in-flight (eg: Easy Vessel Switch, Precise Maneuver Editor...) and a "General Utility" category for mods which don't really fit into any other "utility" category (eg: KAC, Transfer Window Planner, Alshain's Modlets...). Thoughts?

Share this post


Link to post
Share on other sites

Categorization of utility?  How about starting with use? That gives 3 strong initial categories:

Flight (flying ship foscus).  Construction/Building (VAB/SPH). Planning (all those other wonderful buildings at the space center).

Then there are things like What do they affect?  Appearance (all the graphics stuff), Roleplay (kerbals like Final Frontier), Realism (FAR, Real Fuels), Environment (Planetary mods, physics mods other than realism), etc

that's a start. 

Note: I imagine this to work like Google Tags, there should be multiple tags applied and few if any are exclusive.

Kerbal addons individually seem to exist across categories by their very nature, no matter what taxonomic system you apply

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now