linuxgurugamer

[1.7] State Funding Continued - MM added as dependency

Recommended Posts

any eta on a update for this ... i dont play career mode without it and im itching to get it up and running

 

Share this post


Link to post
Share on other sites

New release, 0.6.15

  • Updated to use latest version of ToolbarController
  • Updated version to do all of 1.4.x

Share this post


Link to post
Share on other sites
46 minutes ago, JoE Smash said:

So this only functions if you start it with a new career?

No, it should work with an existing one, but make a backup first

Share this post


Link to post
Share on other sites
1 minute ago, linuxgurugamer said:

No, it should work with an existing one, but make a backup first

OK thanks, m8!

Share this post


Link to post
Share on other sites

Hey @linuxgurugamer, the mod seems to be counting ships as destroyed even if I reloaded my save due to the explosion.....

Is there any way to turn that off?

I had some reentry problems with a poorly designed ship and it blew up like 8 times in a row, however I kept reloading my save until I was able to compensate by burning retrograde with my final stage before decoupling it. Eventually I managed to salvage the mission....

However now this mod is saying 8 ships were destroyed.....

I mean this is technically correct, but also I technically reversed time with my save game and inevitably succeeded with the mission.....the destroyed ships were all in an alternate timeline that was discontinued....

Share this post


Link to post
Share on other sites

Nevermind, I found where this information was stored in my persistent save. I'll just edit it back to 0....

Share this post


Link to post
Share on other sites
16 hours ago, JoE Smash said:

Hey @linuxgurugamer, the mod seems to be counting ships as destroyed even if I reloaded my save due to the explosion.....

Is there any way to turn that off?

I had some reentry problems with a poorly designed ship and it blew up like 8 times in a row, however I kept reloading my save until I was able to compensate by burning retrograde with my final stage before decoupling it. Eventually I managed to salvage the mission....

However now this mod is saying 8 ships were destroyed.....

I mean this is technically correct, but also I technically reversed time with my save game and inevitably succeeded with the mission.....the destroyed ships were all in an alternate timeline that was discontinued....

 

9 minutes ago, JoE Smash said:

Nevermind, I found where this information was stored in my persistent save. I'll just edit it back to 0....

I still need to fix this, it does sound like a bug

Share this post


Link to post
Share on other sites
2 minutes ago, linuxgurugamer said:

 

I still need to fix this, it does sound like a bug

I'm not 100% sure how or why it happened. I don't think it counted explosions from "reverting flight." I want to say it was somehow counting explosions from reloading saves while in Kerbin's upper atmosphere.

As far as recreating the bug goes, what "I think" was happening was I was in reentry about 80 or so kilometers above Kerbin coming in way too fast, like almost 3000m/s. I still had my last stage with about 800 delta V that I didn't need and I was decoupling it while reentering. I was using the mod that adds probe functionality to all decouplers for the sake of using Stage Recovery and having "powered landings" with spent stages. My main stage full of my kerbals kept blowing up. After it blew up the flight automatically switched view to the stage I decoupled because it hadn't blown up yet and counted as a "command-able vessel" due to the probe core decoupler mod, and it must have still been within 2000 meters from my main ship. LIke switching vessels by hitting the bracket key. I would then hit escape and then reload the same save  from a few minutes earlier in the upper atmosphere and tried to do things a little differently to get a better result. I eventually played around with things until I got it to work....

 

Now that I just wrote this explanation out I think I know what must be going on.....it isn't from that....

What must be going on is every once in a while from successful missions I lose a stage or two due to burning up in reentry. Since my lost stages are always powered with batteries and technically have probe cores these stages must be being counted as "lost non-crewed" vessels by this mod.

The simplest solution would for me to stop trying to land spent stages with a probe core-decoupler and batteries and just throw parachutes on them. That may fix the problem.

Or you could write an exception to somehow not count things being commanded by "decoupler probe cores" as a vessel for the sake of the mod. I'm sure that would be too complicated, because of the way part definitions are. Just because they are a decoupler they are still a probe core....

Lastly you could just have the mod weigh all lost un-crewed vessels as much more insignificant over crewed ones. That's what probe cores are for.....risky missions and to prevent the loss of life. As a space agency you still look bad if your uncrewed rockets keep failing and exploding, but it really isn't as bad as losing space vessels full of people.....or kerbals....

 

I'm not 100% sure on any of what I just said. This is my working theory on what I think is occurring.....now that I thought about it more....

Share this post


Link to post
Share on other sites

What constitutes a "government contract" for the sake of this mod? Any completed contract, or only certain agencies? 

If it's any contract, then this mod isn't counting contracts from "Experimental Engineering (from Career Evolutuon Contract Pack), or MRS....

I'm thinking government contracts must be something very specific....that I haven't done yet....as I have 0, despite me completing like 10 different contracts yesterday....

Share this post


Link to post
Share on other sites

First, the craft which kept remembering the lost missions, was that launched BEFORE or AFTER you installed the mod?

Second, the contracts, were they accepted before or after you installed the mod?

Share this post


Link to post
Share on other sites

Just an FYI, the mod currently isn't recording anything about the contracts, I'll have to fix that

Share this post


Link to post
Share on other sites

How about a way to flag a probecore as expendable?  I'm not sure yet the best way to do this, but it should be doable.  I  can think of at least two ways to do it

Share this post


Link to post
Share on other sites

New release, 0.6.16

  • Added recording of completed and failed contracts
  • Added new field to indicate whether part is a disposable part, if it is, does not get counted in the destroyed vessels list
  • Added MM script to add new module to all command parts
  • Added code to remove callbacks when leaving scene or reverting

 

Note:  The mod now REQUIRES ModuleManager

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

Will try this out soon, been up all night....I will probably sleep soon. I'll let you know if anything else goes boom after I play again.....

Share this post


Link to post
Share on other sites
3 hours ago, JoE Smash said:

Will try this out soon, been up all night....I will probably sleep soon. I'll let you know if anything else goes boom after I play again.....

sleep?  Who needs sleep?

Share this post


Link to post
Share on other sites
9 hours ago, linuxgurugamer said:

sleep?  Who needs sleep?

I haven't experienced anthing game breaking with the new update you created. I did notice a few things that were different though....

While starting the game mod manager found like 43 errors relating to "decouplewithcontrol.cfg" that needed to be "patched." Also once in the game most of my inline stack decouplers now have information written in orange text that I had never noticed about "crossfeed" of fuel.

I'm seeing when I right click on my decouplers now that there is a toggle about enabling or disabling crossfeed and a toggle for making the part "disposable" or "not disposable." 

Obviously that last bit is pertaining to the State Funding mod.

Was the crossfeed bit always like that and I just never noticed before, or did you fiddle with that too?

Lastly whem mod manager detects errors and "patches" them.....what does that mean exactly? I ask because that happened for a while back in my old install that I deleted with InlineBalutes relating to realchute.cfg. It said the thing about errors every time I started the game. It seemed to go away after my clean install....

So when mod manager finds "errors" and "patches" them what does that mean? When I think of a "patch" I think of a fix....once applied it should be fixed. With mod manager if it's fixing something....it doesn't seem to do a very good job if it has to be "fixed" every time you load the game until you delete everything and start over.....lol.

Oh....I also noticed through KSP-AVC that the version of decouple with control being offered through CKAN isn't the most recent version. It looks like he must have submitted his mod to CKAN incorrectly last time or something.....as there are files included with the most recent version's zip folder pertaining to CKAN....I'm thinking he did something not quite correct....

Share this post


Link to post
Share on other sites
8 hours ago, JoE Smash said:

While starting the game mod manager found like 43 errors relating to "decouplewithcontrol.cfg" that needed to be "patched."

Then there are errors in the patch, they should be fixed.

8 hours ago, JoE Smash said:

Also once in the game most of my inline stack decouplers now have information written in orange text that I had never noticed about "crossfeed" of fuel.

No idea, nothing to do with StateFunding

8 hours ago, JoE Smash said:

I'm seeing when I right click on my decouplers now that there is a toggle about enabling or disabling crossfeed and a toggle for making the part "disposable" or "not disposable." 

Obviously that last bit is pertaining to the State Funding mod.

Yup.  Parts marked as disposable won't be counted as destroyed vessels

9 hours ago, JoE Smash said:

Was the crossfeed bit always like that and I just never noticed before, or did you fiddle with that too?

I didn't fiddle with it.

9 hours ago, JoE Smash said:

Lastly whem mod manager detects errors and "patches" them.....what does that mean exactly? I ask because that happened for a while back in my old install that I deleted with InlineBalutes relating to realchute.cfg. It said the thing about errors every time I started the game. It seemed to go away after my clean install....

It means there is an error in a patch file, and the patches in question won't be applied.

I would need to see the log file to know which files are causing errors.

9 hours ago, JoE Smash said:

Oh....I also noticed through KSP-AVC that the version of decouple with control being offered through CKAN isn't the most recent version. It looks like he must have submitted his mod to CKAN incorrectly last time or something.....as there are files included with the most recent version's zip folder pertaining to CKAN....I'm thinking he did something not quite correct....

I just installed the version through CKAN, and it looks correct. 

 

Share this post


Link to post
Share on other sites
15 minutes ago, linuxgurugamer said:

Then there are errors in the patch, they should be fixed.

No idea, nothing to do with StateFunding

Yup.  Parts marked as disposable won't be counted as destroyed vessels

I didn't fiddle with it.

It means there is an error in a patch file, and the patches in question won't be applied.

I would need to see the log file to know which files are causing errors.

I just installed the version through CKAN, and it looks correct. 

 

Ok so there is an issue with my decouple with control cfg file. I'm assuming deleting the folder and reinstalling it should remedy it....?

Share this post


Link to post
Share on other sites
3 hours ago, JoE Smash said:

Ok so there is an issue with my decouple with control cfg file. I'm assuming deleting the folder and reinstalling it should remedy it....?

I would guess.  Try installing my branch for now

Share this post


Link to post
Share on other sites
4 minutes ago, linuxgurugamer said:

I would guess.  Try installing my branch for now

What branch?

Share this post


Link to post
Share on other sites

Okies....I guess I'll go smoke while KSP loads for 10 minutes....

I'll fork your branch with a spork

(Me using lingo I no comprendo)

Still loading, but mod manager patch part finished.....no errors now

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.