GregroxMun

[1.7.3] Seven Worlds around SLIPPIST-1 (v0.8.0) Update August 8th 2019

Recommended Posts

6 minutes ago, GregroxMun said:
  • Renamed SLIPPIST-1b "Beta" to "Bravo." Dunno why I thought the NATO alphabet used Beta for "B", but a few months ago a friend of mine who's a pilot notified me that it should be Bravo, and she's right. Frankly it's more fitting like this, because if you land and launch from there... bravo.

Hm, this means we will have to update the Principia TRAPPIST-1 patch.

Opened #2129 to track this.

Share this post


Link to post
Share on other sites

Another hotfix, 0.7.2. https://github.com/GregroxMun/Seven-Worlds-of-SLIPPIST-1/releases/tag/0.7.2

  • Fix identifier on Echo. (Which would have broken the Exoplanet patch)
  • Fix descriptions config file which failed to correctly replace the default placeholder descriptions
  • Update Kopernicus Expansions download to 1.7.0.

 

Share this post


Link to post
Share on other sites
Posted (edited)

@GregroxMun A small Problem... I cannot timewarp at all in the soi of bravo. I have no idea why...

Edited by Mangu
Forgot tag

Share this post


Link to post
Share on other sites
On 4/27/2019 at 3:07 PM, Mangu said:

@GregroxMun A small Problem... I cannot timewarp at all in the soi of bravo. I have no idea why...

Hmm. I'll look into it some time.

Share this post


Link to post
Share on other sites

slight problem with this mod -- i can't access slippist or hotel in the tracking station. i'm double clicking on them and trying to tab to them, but for some reason the game just won't switch to them. not sure if this happens in the inflight map mode yet, but it's still a problem (i assume at least).

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/30/2019 at 8:53 AM, electricpants said:

slight problem with this mod -- i can't access slippist or hotel in the tracking station. i'm double clicking on them and trying to tab to them, but for some reason the game just won't switch to them. not sure if this happens in the inflight map mode yet, but it's still a problem (i assume at least).

Maybe your Kopernicus Expansion is outdated since I encountered the same problem with you.

Just delete the KopernicusExpansion folder in GameData and drop the one comes with this planet pack in, and this problem will likely get solved!

Nope, not the reason... Sorry for misinformation.

Edited by Miracle Magician

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/12/2019 at 4:29 PM, GregroxMun said:

Another hotfix, 0.7.2. https://github.com/GregroxMun/Seven-Worlds-of-SLIPPIST-1/releases/tag/0.7.2

  • Fix identifier on Echo. (Which would have broken the Exoplanet patch)
  • Fix descriptions config file which failed to correctly replace the default placeholder descriptions
  • Update Kopernicus Expansions download to 1.7.0.

 

@GregroxMun  Hi!

The most recent Kopernicus Backport 1.4.5-15 (=1.7.1-5) plus Kopernicus Expansion 1.7.1-5 loads v.0.6.0 SLIPPIST-1 (& TRAPPIST1) just fine as far as I can tell in KerbalEDU 1.4.5

However, did anything change with your recent updates to SLIPPIST-1 that ties anything in 0.7.2 to a specific version of KSP or Kopernicus? 

So far, I just can not get any version of Kopernicus backports for 1.4.5 & Kopernicus Expansion to load the SLIPPIST v.0.7.2 in KerbalEDU 1.4.5

I get the same Kopernicus error message that @LoonyLadel reports getting: 

On 5/6/2019 at 7:34 PM, LoonyLadel said:

"Kopernicus was not able to load the custom planetary system due to an exception in the loading process."

In my case, the SLIPPIST v.0.7.2 settings are the default = Home config used with Principia

the ksp.log suggests that KopernicusStar is what encounters trouble with version 0.7.2 of SLIPPIST1 and it throws thousands of "NullReferenceException"

Would appreciate your thoughts on what may likely be going wrong & thus further things I can check/try to get Kopernicus to load 0.7.2 SLIPPIST-1

Thanks!

@LoonyLadel ksp.log posted at GitHub shows the same issue...so we may be experiencing a SLIPPIST <--> Kopernicus issue: see log excerpts pasted here:

Spoiler

KerbalEDU 1.4.5 ksp.log excerpt:

[LOG 14:30:02.952] ******* Log Initiated for Kerbal Space Program - 1.4.5.0 (WindowsPlayer x64)  *******

...........

[LOG 13:56:41.275] [OD] ---> Map Echo_IceMultiplier (G) for Kerbin enabling self. Path = SLIPPIST-1/PluginData/Echo_IceMultiplier.png
[LOG 13:56:41.276] [Kopernicus] LoadWholeFile reallocating buffer to 2097152
[LOG 13:56:41.321] [OD] ---> Map Echo_PQS (G) for Kerbin enabling self. Path = SLIPPIST-1/PluginData/Echo_PQS.png
[LOG 13:56:41.353] [OD] ---> Map Echo_Height (G) for Kerbin enabling self. Path = SLIPPIST-1/PluginData/Echo_Height.png
[LOG 13:56:41.368] Replacing DateTime formatter
[LOG 13:56:41.376] [ModuleManager] Total loading Time = 52.735s
[EXC 13:56:41.383] IndexOutOfRangeException: Array index is out of range.
    Kopernicus.Components.KopernicusStar.Start ()
[EXC 13:56:41.390] NullReferenceException: Object reference not set to an instance of an object
    Kopernicus.Components.KopernicusStar.LateUpdate ()

........

[LOG 14:31:05.118] [ApplicationLauncher] OnSceneLoadedGUIReady: scene MAINMENU ShouldBeVisible() True ShouldBeOnTop() True iIsPositionedAtTop True
[LOG 14:31:05.119] EduToolbar OnApplicationLauncherReady
[ERR 14:31:05.119] Exception handling event onLevelWasLoadedGUIReady in class <>c:System.NullReferenceException: Object reference not set to an instance of an object
  at Kopernicus.StarLightSwitcher+<>c.<Start>b__2_1 (GameScenes scene) [0x00000] in <filename unknown>:0 
  at EventData`1[GameScenes].Fire (GameScenes data) [0x00000] in <filename unknown>:0 

[EXC 14:31:05.119] NullReferenceException: Object reference not set to an instance of an object
    Kopernicus.StarLightSwitcher+<>c.<Start>b__2_1 (GameScenes scene)
    EventData`1[GameScenes].Fire (GameScenes data)
    UnityEngine.Debug:LogException(Exception)
    EventData`1:Fire(GameScenes)
    <FireLoadedEventGUIReady>c__Iterator2:MoveNext()
    UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)
[EXC 14:31:05.121] NullReferenceException: Object reference not set to an instance of an object
    Kopernicus.Components.KopernicusStar.LateUpdate ()
[EXC 14:31:05.137] NullReferenceException: Object reference not set to an instance of an object
    Kopernicus.Components.KopernicusStar.LateUpdate ()

 

ksp.log excerpt from @LoonyLadel

[LOG 13:26:30.877] ******* Log Initiated for Kerbal Space Program - 1.7.0.2483 (WindowsPlayer x64) en-us *******

.......

[LOG 13:27:42.824] [ApplicationLauncher] OnSceneLoadedGUIReady: scene MAINMENU ShouldBeVisible() True ShouldBeOnTop() True iIsPositionedAtTop True
[ERR 13:27:42.826] Exception handling event onLevelWasLoadedGUIReady in class <>c:System.NullReferenceException: Object reference not set to an instance of an object
  at Kopernicus.StarLightSwitcher+<>c.<Start>b__2_1 (GameScenes scene) [0x00000] in <filename unknown>:0 
  at EventData`1[GameScenes].Fire (GameScenes data) [0x00000] in <filename unknown>:0 

[EXC 13:27:42.826] NullReferenceException: Object reference not set to an instance of an object
    Kopernicus.StarLightSwitcher+<>c.<Start>b__2_1 (GameScenes scene)
    EventData`1[GameScenes].Fire (GameScenes data)
    UnityEngine.Debug:LogException(Exception)
    EventData`1:Fire(GameScenes)
    <FireLoadedEventGUIReady>c__Iterator2:MoveNext()
    UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)
[EXC 13:27:42.827] NullReferenceException: Object reference not set to an instance of an object
    Kopernicus.Components.KopernicusStar.LateUpdate ()
[EXC 13:27:42.846] NullReferenceException: Object reference not set to an instance of an object
    Kopernicus.Components.KopernicusStar.LateUpdate ()

 

Edited by AloE

Share this post


Link to post
Share on other sites
Posted (edited)

@GregroxMun  also, Squad appears to only have 1.7.2 available for download...since I do not have a copy of 1.7.0 or 1.7.1,

so I tried the Kopernicus 1.7.1-5 in  1.7.2 and Module Manager is of course throwing a swarm of rainbow nycats saying Kopernicus is not version unlocked  yet for 1.7.2...

consequently my attempt of testing SLIPPIST-1 v.0.7.2 in KSP 1.7.x has not yet been possible

enjoy Sarbian's nycats...lol:

Spoiler

iiNSNQF.png

 

Edited by AloE

Share this post


Link to post
Share on other sites
Posted (edited)

Based on the OP I"m a little confused as to whether I need to download base Kopernicus or not.  Can anyone let me know? 

Edited by jpinard

Share this post


Link to post
Share on other sites
On 2/26/2017 at 8:07 PM, GregroxMun said:

Requires Kopernicus, and Kopernicus Expansions Continued RegionalPQSMods

@jpinard Like the name implies, kopernicusexpansion is an expansion for kopernicus, also i dont know of any planet mods that dont use kopernicus nowadays..

Share this post


Link to post
Share on other sites

Seven Worlds of SLIPPIST-1 0.8.0 is released.

https://github.com/GregroxMun/Seven-Worlds-of-SLIPPIST-1/releases/tag/0.8.0

 

* Increased Bravo's cloud height.
* Increased Charlie's cloud height.
* Tweaked Scaledspace RimBlend and RimPower settings for all planets.
* Made SLIPPIST-1's lens flare brighter.
* **Remove Exoplanet Patch. Use IC.**
* Add new name/description settings patch.
* Add a new pale light mode as an optional (but default) setting, based upon the Gememma light tweaks in Whirligig World.
* Science definitions moved over to Scientific Revolution format.
* Add KEX-Regional PQS to the repository
* Add SciRev to the repository
* Move KEX, SciRev, and SLIPPIST-1 to GameData folder.
* Fix the luminosity of SLIPPIST-1 against Echo's orbit. Solar power generation should work properly.
* Add new science definitions for every planet.
* Add Sigma88LoadingScreens
* Add a few loading tips. Loading art to come later.
* New orbit icon for SLIPPIST-1 in Interstellar Consortium: 8-pointed star.
* **Scatterer DOES NOT WORK**

Share this post


Link to post
Share on other sites

0.8.0 is now out on Spacedock.

Share this post


Link to post
Share on other sites

@GregroxMun:

Tried it, love it. Everything looks great so far! Planets are just beauty!
I have a couple of questions:

1) I'm getting some extra luminosity from Kerbol (a lot actually)
2) Where would I do some tweaking with the distances between Kerbol and Slippest-1? (ie putting them farther away....alot farther away. I like to make things hard on myself. :P).

Share this post


Link to post
Share on other sites
Just now, GDJ said:

@GregroxMun:

Tried it, love it. Everything looks great so far! Planets are just beauty!
I have a couple of questions:

1) I'm getting some extra luminosity from Kerbol (a lot actually)
2) Where would I do some tweaking with the distances between Kerbol and Slippest-1? (ie putting them farther away....alot farther away. I like to make things hard on myself. :P).

1) If by "luminosity" you mean just light from Kerbol, then you'll need a patch to reduce the interstellar light of the sun. On the other hand if by that you mean heat and solar panel stuff, then for now you're just straight out of luck. No fix for that yet.

@Kopernicus:FOR[InterstellarConsortium]
{
	@Body:HAS[#identifier[Squad/Sun]]
	{
		%Orbit
		{
			%color = 1,1,1,1
		}
		@ScaledVersion
		{
			Light
			{
				sunAU = 261600000
				brightnessCurve
                {
                    key = 0.0000000005 0.03 0 0
					key = 0.00000005 0.04 0 0
                    key = 0.0001 0.1 0 0
                    key = 0.001 0.3 0 0
                    key = 0.01 0.4 0 0
                    key = 0.1 4 0 0
                    key = 0.2 6 0 0
                    key = 0.3 10 0 0
					key = 0.5 22 0 0
					key = 0.65 0 0 0
                }
				IntensityCurve
				{
					key = 0 1 0 0
					key = 6.044e9 0.9 0 0
					key = 2e+12 0 0 0
				}
				IVAIntensityCurve
				{
					key = 0 1 0 0
					key = 6.044e9 0.9 0 0
					key = 2e+12 0 0 0
				}
				ScaledIntensityCurve
				{
					key = 0 1 0 0
					key = 1007333.33333 0.9 0 0
					key = 333333333.333 0 0 0
				}
			}
		}
	}
}

Add that in a .cfg file somewhere in GameData to fix the sun light intensity.

2) You can redefine the size of the "ki" kerbal-interstellar unit in the Interstellar Consortium settings file.

Share this post


Link to post
Share on other sites

@GregroxMun

I'll give your suggestions a try. Thank you!

Share this post


Link to post
Share on other sites

Hello,

Good to see the newest ksp game of 1.7.3 having all these new mod packs!

However, Every time I tried to load any of these mods using CKAN,

I have found that there is a problem with even the newest Kopernicus

updated mod for 1.7.3 game? 

CKAN reports this mod can't be installed in this game version.

Same goes for any other mods that need Kopernius

Or it's other types of that mod and that's even when they

are stated to be compatible?

Very frustrating.

So sadly I will not download it even though it looks cool!

;.;

Share this post


Link to post
Share on other sites

1.Will it work in 1.7.3?

2.How far is the star from the sun?(in the exoplanet patch)

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks!

0.8.0 loads nicely in 1.7.3, however even more significantly it also resolves my previously posted issue with 0.7.x &

0.8.0 mjow loads well as TRAPPIST1 in 1.4.5 using MM 4.0.2 (MM 4.0.3 is throwing errors with the Principia x2 atm curves up scaling) Kopernicus backports & Principia Fatou (the last version for 1.4.5) & trappist-1 for principia fáry.zip  (& RO & Scatterer, etc...-)

The lighting adjustments are definitely different in the new version (especially since scatterer settings are still applied in 1.4.5) !   I'll check in the Principia version to see if 1e has about 895 (W/m2) Star Radiation at Atmospheric Boundary  (& try to plot pressure & T & altitude using the KerbalEDU flight recorder with the still missing [EDIT: now fixed for next release] close bracket added to the echo.cfg so the 1e atm curves replace the Kerbin ones) ;-)

q9wIp5k.png
On 4/10/2019 at 7:50 PM, eggrobin said:

Hm, this means we will have to update the Principia TRAPPIST-1 patch.

Opened #2129 to track this.

On 8/9/2019 at 12:58 AM, GregroxMun said:

0.8.0 is now out on Spacedock.

On 8/10/2019 at 11:26 AM, Space Nerd said:

1.Will it work in 1.7.3?

 

Edited by AloE
atm bracket fix

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, AloE said:

Thanks!

0.8.0 loads nicely in 1.7.3, however even more significantly it also resolves my previously posted issue with 0.7.x &

0.8.0 loads well as TRAPPIST1 in 1.4.5 using MM 4.0.2 (MM 4.0.3 is throwing errors with the Principia x2 atm curves up scaling) Kopernicus backports & Principia Fatou (the last version for 1.4.5) & trappist-1 for principia fáry.zip  (& RO & Scatterer, etc...-)

The lighting adjustments are definitely different in the new version (especially since scatterer settings are applied in 1.4.5) !   I'll check in the Principia version to see if 1e has about 895 (W/m2) Star Radiation at Atmospheric Boundary  (with the still missing close bracket added to the echo.cfg so the 1e atm curves replace the Kerbin ones) ;-)

 

I have just fixed that bracket and the change is available at the github repository. I may wait a little longer to release the patch (until I have some more fixes or features to release) since Echo's atmosphere isn't that different from the stock model and it's easily fixed by the end user. I'd like to get scatterer working again some time, since the newest scatterer versions broke support for old configs, and the color doesn't really make sense in the new defualt lighting.

@eggrobin What's this about doubling the atmospheres? "(MM 4.0.3 is throwing errors with the Principia x2 atm curves up scaling)" Atmospheres in KSP scale are 7/8ths of their real-scale value (Kerbin uses an atmosphere model based on Earth that cuts off at 80 km, but in-game it cuts off at 70 km) so the correct atmosphere height rescale should be 8/7 times that of the stock scale.

 

Edited by GregroxMun

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/12/2019 at 8:37 PM, GregroxMun said:

wait a little longer to release the patch (until I have some more fixes or features to release) since Echo's atmosphere isn't that different from the stock model and it's easily fixed by the end user. I'd like to get scatterer working again

Thanks :-) 

what has caused issues with Scatterer in 1.7.3?  will fixing it there break it in 1.4.5...scatterer seems to behave in SLIPIST1 in 1.4.5 with sun flares & planet dark sides & atm haze...(thought not so well in TRAPPIST1 with lakes & oceans which show as 'black-ish' which I suspect is likely due to the scaling factor) ...the dominant factor I've noticed so far seems to be (I assume) the luminosity adjustment(s) made in 0.8.0)? (TRAPPIST1 appears much brighter now from 1e...not able to see planet transits anymore from the Space Center...which brings up the interesting question as to if planet transits across TRAPPIST1 would actually be visible to the unaided human eye standing below a minimal cloud atmosphere on 1e, 1f, 1g, 1h.) 

SLIPPIST1 0.8.0 & TRAPPIST1 EVE Scatterer KerbalEDU 1.4.5
QeuFgtH.gif F69OKCu.png

 

Here is a crude Pressure (pink line & right side scale in kPa (it says atm but  it is actually in kPa) by Altitude (and other ship factors) plot for 0.8.0 Principia TRAPPIST 1e BEFORE the MM TAB to Space correction...but T stayed constant again after the correction...so I will need to investigate further...vacuum at 165km and very thin by 115km so my speculative guess is that @eggrobin set the multiplier to achieve that ~160km (similar to minimum LEO) result...

Spoiler

A4nyX0V.png

1itYxkA.png

OpjsRI4.png

I have been continuing to ponder various models for environmental conditions in a M star solar system like Trappist1 system starting from the concepts in your astronomy lesson & reading OhioBob's work...I posted some of the links to data/concepts of related published articles I have found and been reading through at this link.  Would be happy to hear on discord the various insights you included in your atm models so far (since your astronomy lesson for example does not describe choice of T curves etc...) !

 

Edited by AloE
pictures & updates based on more comparisons

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.