Jump to content

[1.12.x] Flight Manager for Reusable Stages (FMRS), now with RecoveryController integration


linuxgurugamer
 Share

Recommended Posts

On 6/18/2017 at 7:21 AM, TheCrafterESP said:

Just one question. Which folder do I have to put in the GameData directory? Because there are some FMRS folders in the Zip file.

Assuming you have the correct file, there should be two folders:

FMRS

RecoveryController

 

You only need the RecoveryController if you also have StageRecovery installed, but it won't hurt to install it.

Put one (or both) folders into GameData

Link to comment
Share on other sites

18 hours ago, linuxgurugamer said:

Assuming you have the correct file, there should be two folders:

FMRS

RecoveryController

 

You only need the RecoveryController if you also have StageRecovery installed, but it won't hurt to install it.

Put one (or both) folders into GameData

Yeah but when I do so, the tool doesn't appear in the toolbar. Does it have something to do with mod compatibility 'cause I have only EngineerRedux installed.

Link to comment
Share on other sites

  • 3 weeks later...

Some logging:

Exception handling event onVesselWasModified in class RecoveryController:System.NullReferenceException: Object reference not set to an instance of an object
  at RecoveryController.RecoveryController.onVesselWasModified (.Vessel v) [0x00000] in <filename unknown>:0 
  at EventData`1[Vessel].Fire (.Vessel data) [0x00000] in <filename unknown>:0 
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

NullReferenceException: Object reference not set to an instance of an object
  at RecoveryController.RecoveryController.onVesselWasModified (.Vessel v) [0x00000] in <filename unknown>:0 
  at EventData`1[Vessel].Fire (.Vessel data) [0x00000] in <filename unknown>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
EventData`1:Fire(Vessel)
RemoteTech.Modules.ModuleRTAntenna:AddTransmitter()
RemoteTech.Modules.ModuleRTAntenna:SetState(Boolean)
RemoteTech.Modules.ModuleRTAntenna:OnStart(StartState)
Part:ModulesOnStart()
<Start>c__Iterator3A:MoveNext()
UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)
 
(Filename:  Line: -1)

The same log as on the other thread :D :
https://www.dropbox.com/s/ei6y6xdxjbn1dh9/2017-07-11-2 KSP.log.zip?dl=1

Link to comment
Share on other sites

8 minutes ago, MattPlaysSimulations said:

@linuxgurugamer, I don't know if this is you choice or the original owners, do you mind if i include this mod with my modpack as I am producing a SpaceX Falcon 9 modpack and this would be useful. Thanks!

It's my choice on the current maintainer of the mod.   I would rather this not be included in the mod pack.  I have no problem with you referring to it, but if you include it in the mod pack then that won't get updated if and when I make updates to the mud. 

It would be much better if you included a CKAN config file so that people can use CKAN to install whatever mods you feel are necessary for the mod pack.

thank you for asking before just including it.

Edited by linuxgurugamer
Link to comment
Share on other sites

Hi! When I launch Falcon 9-style sub-orbital tourism missions where both stages are manned, I end up with "KIA" status for one of the crews, even though both vessels land safely.

Are there any special precautions I need to take, in addition to my existing checklist?

  1. Make sure the decoupler has FMRS as staging manager
  2. Make sure FMRS is armed before launch
  3. Do not use KSP's vessel switch keybinds, only the FMRS UI.
  4. Land the sub-stage first, then return to main mission and land it.

I've performed three test missions, (the first of which permanently killed Bob and Valentina since I did not perform a KSC-level save before launching :/ ) - All resulted in the deaths of one of the two vessel crews.

Link to comment
Share on other sites

  • 1 month later...

As requested by @linuxgurugamer, my comment on FMRS from the Kaptain's Log topic:

Quote

Did some more testing.  Helped that I finally tracked down and removed what appears to be the source of the intermittent UI lockout bugs (Malah's QuickGoto, reported in its topic).  Still not quite used to all the config options now in the standard settings menu for various mods.  But I played around a bit with Kaptain's.  Logs here.

http://www.cuug.ab.ca/jacke/KSP/v1.3.0/_logs/20170826c-Kaptains-FMRS-testing.7z

....

BTW, I've noticed that on Revert to Launch, FMRS will pop up its window by default.  Still haven't had a chance to use it much.  Is that the intended operation to jive with its usually process of handling stages?

 

Link to comment
Share on other sites

  • 3 weeks later...

I figured this would be a best place if any to ask this question, I am coming from Kurrikane thread @linuxgurugamer. I was wondering; If I would like to keep kerbal's inside say, a Processing lab and let them research for science and be able to return to the KSC and not have them "MIA" on roster or "Recovered" once out of render distance by Stage Recovery. Would this work, FMRS? Or should I build additional Pylons? (Seek Answers Elsewhere.)

 

Thanks for the time and much love on all the mods you upkeep, update, create, and manage <3 I will try to catch you on stream :D

Link to comment
Share on other sites

  • 3 weeks later...

@linuxgurugamer Any clue what could be causing this? When I revert to the staging point my rockets go haywire. I have used this mod many time without any issue so I'm kinda stumped on what is causing it to happen. I guess what I'm asking are their any known conflicts that may be causing this? The only two mods I'm currently using, I believe, that I don't always use are interstellar extended and bon voy yage. Already confirmed the latter isn't the issue. I know it has to be something on my end because It worked fine for me less than a week ago.

37124718550_0b3f102b49_b.jpg

 

Link to comment
Share on other sites

@linuxgurugamerThe game isn't crashing to desktop so no log is being recorded. Correct? If not, please tell  me where to find it as I'm interested.

Did the picture not define haywire:D? Those tanks should not be where they are. Essentially, my initial stage goes smoothly. When I click the button to return to a previous stage the tanks nose dip in and begin to almost dance around the rocket for a sec before clipping into a huge explosion. Its almost as if everything is under the physics easing you see at launch. 

Edited by harrisjosh2711
Link to comment
Share on other sites

26 minutes ago, harrisjosh2711 said:

@linuxgurugamerThe game isn't crashing to desktop so no log is being recorded. Correct? If not, please tell  me where to find it as I'm interested.

Did the picture not define haywire:D? Those tanks should not be where they are. Essentially, my initial stage goes smoothly. When I click the button to return to a previous stage the tanks nose dip in and begin to almost dance around the rocket for a sec before clipping into a huge explosion. Its almost as if everything is under the physics easing you see at launch. 

Here:

 

Link to comment
Share on other sites

 

Nothing. Try increasing the time before the save is done.  That's why I put the option there.  It defaults to 0.2 second, try increasing it to 1 or two seconds.  You can set it globally in the settings (called Save Delay), and then adjust for each launch in the options

 

Would this work for the issue I have been experiencing? Guess you didn't find anything wrong in my log?

Edited by harrisjosh2711
Link to comment
Share on other sites

 

Would this work for the issue I'm have been experiencing? Guess you didn't find anything wrong in my log?

The log file you posted didn't have any flight in it, it loads, gets to the main menu.  Please send a complete log (ie:  start the game, do a flight, get the issue, then exit)

But off hand, I have no idea what might be going on.

Ummm, it might be the physics.  Are you using any autostruts?

Link to comment
Share on other sites

 

The log file you posted didn't have any flight in it, it loads, gets to the main menu.  Please send a complete log (ie:  start the game, do a flight, get the issue, then exit)

But off hand, I have no idea what might be going on.

Ummm, it might be the physics.  Are you using any autostruts?

No auto strut, I use KJR. I always use KJR with this though. Honestly, I really think something else is messing with it. As, I told you before, I used this mod successfully last week, I know it works right. I just need to find the culprit. I will get a flight log up at some point.

What I can tell you is the physics kicks in before the decoupler engines. When I revert my rockets noses will dive in, hit the main rocket and destroy it. Then the decoupler engines cut on. If I revert enough times sometimes the damage isn't catastrophic and I can still land the boosters. Its a hit or miss kinda thing though. (if you look at the picture a few post up you will see the rocket has already collided but the decopler engines aren't firing yet.)

Edited by harrisjosh2711
Link to comment
Share on other sites

Well, I cant confirm anything because I re-installed all my mods, absent interstellar extended this time. And every thing is working absolutely perfectly. I'm going to assume the culprit was interstellar extended, as my module manager plugins go from around 3000 to 11000 with it installed. Has anyone else experienced any issues using these mods in-tandem?

37504942731_c1ae2c78db_b.jpg

Edited by harrisjosh2711
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...