Artyomka15

[1.2.2] Kargantua System [v0.2a] - the first PROPER black hole system in KSP

Recommended Posts

Just now, Gameslinx said:

What do you mean by this?

Oh sorry. I was trying to reply to @Artyomka15 :blush: damn eyes... I'll edit the post right away.

Share this post


Link to post
Share on other sites
5 hours ago, Sirius628 said:

Hey, what happens if you fall into the black hole?

Probably the same thing that happens when you crash into the sun. :P

Share this post


Link to post
Share on other sites

Hey man!! great Mod!!

Just to let you know, letting Kargantua with 100g made all manuever nodes crazy when out of Kerbon influence. I got it reduced to SOL standard to solve it on my game.

Share this post


Link to post
Share on other sites
On 3/18/2017 at 10:19 PM, wadusher1 said:

Probably the same thing that happens when you crash into the sun. :P

poof!

Share this post


Link to post
Share on other sites
On 19.03.2017 at 1:57 AM, Sirius628 said:

Hey, what happens if you fall into the black hole?

I think you should test it. :P

Share this post


Link to post
Share on other sites

Speaking of falling into the black hole without being torn apart, or just an idea for the wormhole, Astronomer's Visual Pack: Interstellar v2 has an optional feature which adds a solid "cloud layer" of wormhole over the sun, and makes this wormhole layer move super fast to give the illusion of traveling quickly through it. It can be seen in action here.

Perhaps, if the developer hasn't found a better or more complex method, this can be implemented into the mod over the black hole and future wormhole?

 

Share this post


Link to post
Share on other sites

Hey, man! Pulsar looks cool and black hole is even better. And if you put your system to a higher orbit, then my new warp drive mod will become more usefull :D

jQzDYsW.png

GcGwTND.png

TAqdowL.png

Just sixteen kerbal days and I'm at Valentine :cool:

Share this post


Link to post
Share on other sites
Posted (edited)

Sorry for the long absence, I was busy on my other project.

The new update will be released in 3-4 days.

It will include:

-Completely redone corona & accretion disk.

-Lightnings on Limmer, snow on Namm and dust storms on Admun and all the planets will have aurora (thank to @Artem Kerman for helping with it)

-Some new moons and an asteroid orbiting EXTREMELY close to the central black hole (the best place to take screenshots :D )

-And much more!

 

w7d7Ucx.jpg

Edited by Artyomka15

Share this post


Link to post
Share on other sites

Will it work with RSS

Share this post


Link to post
Share on other sites
11 hours ago, mark7 said:

Will it work with RSS

Well, technically it will, but probably horribly. I'm working on an RSS-compatible edition right now, and under the OP's permission, I might release it.

Share this post


Link to post
Share on other sites

Testing out the volumetric accretion disk ...

 

 

Share this post


Link to post
Share on other sites

@Artyomka15 How will this mod look without any visual enchantments (i.e. without EVE, Scatterer, etc)? 

Share this post


Link to post
Share on other sites
1 hour ago, Artyomka15 said:

Testing out the volumetric accretion disk ...

Is that cloud texture final or do you have a better idea in mind?

Share this post


Link to post
Share on other sites
1 minute ago, The Raging Sandwich said:

In the new update, will Kargantua semi-major axis be pushed back beyound OPM's Plock's orbit?

Yes

Share this post


Link to post
Share on other sites
Posted (edited)

There's anything you could make so time gets messed up when close to Kargantua? (Stuff like every second in close orbit asteroid is an hour in the mission time) But to don't interrupt other missions, this thing could be made to turn on or off.

Just an idea:wink:

By the way, how did you get the disc to have clouds? I've been looking for a gas debris ring for ages... 

Edited by Nailed it!

Share this post


Link to post
Share on other sites

I doubt that KSP API (and even Unity itself) will permit such distortion :D

Share this post


Link to post
Share on other sites

@Artyomka15

21 hours ago, TheEpicSquared said:

How will this mod look without any visual enchantments (i.e. without EVE, Scatterer, etc)? 

Because my computer toaster doesn't have the power to run Scatterer and EVE. Thanks

Share this post


Link to post
Share on other sites

KerbalItalia saw the mod and did a review (I don't speak Italian so I can't tell anything that was said!)

Those volumetrics are looking awesome. Will that be coming to the Instantiator mod?

Share this post


Link to post
Share on other sites
47 minutes ago, Gameslinx said:

KerbalItalia saw the mod and did a review (I don't speak Italian so I can't tell anything that was said!)

Those volumetrics are looking awesome. Will that be coming to the Instantiator mod?

 

Think the volumetric disc is just an E.V.E. effect :(

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Gameslinx said:

KerbalItalia saw the mod and did a review (I don't speak Italian so I can't tell anything that was said!)

Those volumetrics are looking awesome. Will that be coming to the Instantiator mod?

It's actially too complicated to be configurable. But I think I can make some kind of preset for the volumetric disks. I need to think on that.

@themaster401 Aaand no, that's not EVE. That's another small custom plugin

Edited by Artyomka15

Share this post


Link to post
Share on other sites

That's weird... the planets in this pack aren't loading.

And this is what happens at the end of every log (Admun, Limmer, and Namm)

[LOG 16:45:09]: Exception Was Recorded: Object reference not set to an instance of an object
  at Kopernicus.Configuration.MapSOParser_RGB`1[CBAttributeMapSO].SetFromString (System.String s) [0x00000] in <filename unknown>:0 
  at Kopernicus.Parser.LoadObjectMemberFromConfigurationNode (System.Reflection.MemberInfo member, System.Object o, .ConfigNode node, System.String modName, Boolean getChilds) [0x00000] in <filename unknown>:0 
  at Kopernicus.Parser.LoadObjectFromConfigurationNode (System.Object o, .ConfigNode node, System.String modName, Boolean getChilds) [0x00000] in <filename unknown>:0 
  at Kopernicus.Parser.CreateObjectFromConfigNode (System.Type type, .ConfigNode node, System.String modName, Boolean getChilds) [0x00000] in <filename unknown>:0 
  at Kopernicus.Parser.LoadObjectMemberFromConfigurationNode (System.Reflection.MemberInfo member, System.Object o, .ConfigNode node, System.String modName, Boolean getChilds) [0x00000] in <filename unknown>:0 
  at Kopernicus.Parser.LoadObjectFromConfigurationNode (System.Object o, .ConfigNode node, System.String modName, Boolean getChilds) [0x00000] in <filename unknown>:0 
  at Kopernicus.Configuration.Loader.Kopernicus.IParserEventSubscriber.PostApply (.ConfigNode node) [0x00000] in <filename unknown>:0 

Can anyone make sense of this?

Share this post


Link to post
Share on other sites
Posted (edited)
15 hours ago, EricL said:

That's weird... the planets in this pack aren't loading.

And this is what happens at the end of every log (Admun, Limmer, and Namm)


[LOG 16:45:09]: Exception Was Recorded: Object reference not set to an instance of an object
  at Kopernicus.Configuration.MapSOParser_RGB`1[CBAttributeMapSO].SetFromString (System.String s) [0x00000] in <filename unknown>:0 
  at Kopernicus.Parser.LoadObjectMemberFromConfigurationNode (System.Reflection.MemberInfo member, System.Object o, .ConfigNode node, System.String modName, Boolean getChilds) [0x00000] in <filename unknown>:0 
  at Kopernicus.Parser.LoadObjectFromConfigurationNode (System.Object o, .ConfigNode node, System.String modName, Boolean getChilds) [0x00000] in <filename unknown>:0 
  at Kopernicus.Parser.CreateObjectFromConfigNode (System.Type type, .ConfigNode node, System.String modName, Boolean getChilds) [0x00000] in <filename unknown>:0 
  at Kopernicus.Parser.LoadObjectMemberFromConfigurationNode (System.Reflection.MemberInfo member, System.Object o, .ConfigNode node, System.String modName, Boolean getChilds) [0x00000] in <filename unknown>:0 
  at Kopernicus.Parser.LoadObjectFromConfigurationNode (System.Object o, .ConfigNode node, System.String modName, Boolean getChilds) [0x00000] in <filename unknown>:0 
  at Kopernicus.Configuration.Loader.Kopernicus.IParserEventSubscriber.PostApply (.ConfigNode node) [0x00000] in <filename unknown>:0 

Can anyone make sense of this?

Do you have any non-english characters in the game folder path?

-----------------------

The new version is out!

pfmB2Mc.png

 

Edited by Artyomka15

Share this post


Link to post
Share on other sites
Posted (edited)
8 hours ago, Artyomka15 said:

Do you have any non-english characters in the game folder path?

My folder path is KSP_win64/ GameData/ KargantuaMod_0.2

Edited by EricL

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now