• 0
Sign in to follow this  
Warzouz

High speed rover (x4 warp)

Question

Back in 1.0, I did a quite resilient rover which was able to be driven at x4 warp without exploding on nearly any body.

But as 1.2, everything changed. If I can do a high speed rover at warp x1, it don't survive long at x3 or x4. It starts being shaky and losing control. Even MJ autopilot can't manage it.

Do you have some hint on dampeners to get this work ?

PS : the rover is VERy basic. It's a derivative of that old rover.

 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 2
Posted (edited)

For 1.1.0, KSP needed a new version of Unity. The new Unity uses a new version of PhysX that has a bug in the springs and in the joints between parts. The devs are under the impression that the spring bug and the joint bug will be fixed at some point by Unity. The devs gave us spring settings and damping settings to try to make up for the bug. But there is a bug, and it can't be fixed by Squad.

As far as spring and damping settings, there is no specific rule. If there were, the devs would have implemented the rule and not bothered with putting the settings in the tweakables.

You basically want the springs set according to the weight of the vehicle. So on the Mun, you need to set them extra soft. On Minmus, you need them even softer. On Tylo, you want them harder.

After you have the springs set properly, you can adjust the damping to minimize bouncing. Usually it doesn't need to be changed much. I find that moving it a little bit in the direction that the springs were adjusted seems to help.

There are some other people who are a bit religious about never touching those settings. I think they are making a small mistake.

But the devs and the game make no promises at all that the game is playable or stable during physics warp. Use that at your own risk, and if your ship blows up it's your own fault for being impatient.

 

Edited by bewing

Share this post


Link to post
Share on other sites
  • 0

I did a test on Kerbin, by setting Springs to the min and dampers to the max. It did well, at 35m/s at x4. But regular lags makes the car blow (vehicle temporary pass through ground)... The car survived 4 minutes in the grasslands behind KSC.

At x3 and x4 it's hard, but it seems to be better at x2.

Sadly the springs and dampers can't be modified in the game, only in the editor.

Share this post


Link to post
Share on other sites
  • 0
20 minutes ago, Warzouz said:

Sadly the springs and dampers can't be modified in the game, only in the editor.

That is true for the current versions of the game. So if you only are taking the rover to one place, adjust the settings for that place. If you are taking the rover to many places, then pick a number in the middle and drive slow.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this