linuxgurugamer

[1.4.1, 1.5.1, 1.6.1, 1.7.x] Fusebox Continued - electric charge tracker and build helper

Recommended Posts

1 hour ago, Alshain said:

@linuxgurugamer  If you enter the game until the app loads and then exit back out to the main menu, the icon is still present at the menu.  It needs this to fix...


        public void Awake()
			GameEvents.onGUIApplicationLauncherUnreadifying.Add(DestroyLauncher);
        {

 

Thanks, I'll get it out tonight, if I have time.

Share this post


Link to post
Share on other sites
1 minute ago, linuxgurugamer said:

Thanks, I'll get it out tonight, if I have time.

Oh, well no rush.  I mean it can wait till you have other things to release with it :D

Share this post


Link to post
Share on other sites

True.  It's been done and tested, but since it doesn't really hurt anything, I'll hold for for a bit.

Thanks

Share this post


Link to post
Share on other sites

New release, 0.1.12:

  • Fixed button showing up on menu screen, thanks to forum user @alshain for the fix
  • Make Blizzy toolbar optional
     

Share this post


Link to post
Share on other sites

@linuxgurugamer

Since updating my modlist with Fusebox with the new release from yesterday (0.1.12) I've been getting NullReferenceException spam in the VAB. I deleted the old folder before installing the new one.

KSP: 1.3 Windows 64-bit

Problem: NullRefenceException spam in VAB.
NullReferenceException: Object reference not set to an instance of an object
  at Ratzap.FuseBox_Core.setTBIcon () [0x00000] in <filename unknown>:0 
  at Ratzap.Fusebox_Editor.OnGUI () [0x00000] in <filename unknown>:0

Mods:
Around 112 mods installed. Just let me know if there seems to be an issue regarding those and I'll post those.

Reproduction steps:
Enter VAB. Can confirm it does also happen in SPH but NOT in Flight Scene.

Output log:
https://www.dropbox.com/s/m6tid07yapo6klw/output_log.txt?dl=1

Share this post


Link to post
Share on other sites
3 hours ago, Phiido said:

@linuxgurugamer

Since updating my modlist with Fusebox with the new release from yesterday (0.1.12) I've been getting NullReferenceException spam in the VAB. I deleted the old folder before installing the new one.

KSP: 1.3 Windows 64-bit

Problem: NullRefenceException spam in VAB.
NullReferenceException: Object reference not set to an instance of an object
  at Ratzap.FuseBox_Core.setTBIcon () [0x00000] in <filename unknown>:0 
  at Ratzap.Fusebox_Editor.OnGUI () [0x00000] in <filename unknown>:0

Mods:
Around 112 mods installed. Just let me know if there seems to be an issue regarding those and I'll post those.

Reproduction steps:
Enter VAB. Can confirm it does also happen in SPH but NOT in Flight Scene.

Output log:
https://www.dropbox.com/s/m6tid07yapo6klw/output_log.txt?dl=1

I don't see it.It's working fine for me. but I do see the error in your file.

Please send me the craft file.

It's acting as if it's missing an icon file, but they all seem to be there.

Are you are running Kerbalism?  That's been known to cause problems in many different mods.

Share this post


Link to post
Share on other sites
49 minutes ago, linuxgurugamer said:

I don't see it.It's working fine for me. but I do see the error in your file.

Please send me the craft file.

It's acting as if it's missing an icon file, but they all seem to be there.

Are you are running Kerbalism?  That's been known to cause problems in many different mods.

It seems it didn't give an error in the Flight Scene when i switched to a craft before the update. However it starting showing there as well in newly built craft.
Giving this error instead.

NullReferenceException: Object reference not set to an instance of an object
  at Ratzap.FuseBox_Core.setTBIcon () [0x00000] in <filename unknown>:0 
  at Ratzap.FuseBox_Flight.OnGUI () [0x00000] in <filename unknown>:0 

No, I'm not running Kerbalism.

Here's one of the craft files:
https://www.dropbox.com/s/eouzk0m5ykbcvpm/Gemini.craft?dl=1

 

Though I could remark since updating Fusebox that it did change icon. It had a icon with bars before and now with the lightning bolt. If that helps in any way.

Keep up the great work!

Share this post


Link to post
Share on other sites

Oh, I've been able to replicat the problem.  You didn't mention you were using the Blizzy Toolbar, it's specific to that.

New release, 0.1.13:

  • Fixed NullRef which occured when Blizzy toolbar was installed, but not being used by this mod.
     

Share this post


Link to post
Share on other sites
On 7/2/2017 at 1:56 PM, linuxgurugamer said:

Oh, I've been able to replicat the problem.  You didn't mention you were using the Blizzy Toolbar, it's specific to that.

New release, 0.1.13:

  • Fixed NullRef which occured when Blizzy toolbar was installed, but not being used by this mod.

On a question - from this, it sounds like Blizzy toolbar *can* still be used, but I can't find a way to switch from using the stock toolbar to using Blizzy's.  Is it still intended to be possible?

Share this post


Link to post
Share on other sites
1 minute ago, DStaal said:

On a question - from this, it sounds like Blizzy toolbar *can* still be used, but I can't find a way to switch from using the stock toolbar to using Blizzy's.  Is it still intended to be possible?

Yes.  At the Space Center scene, hit escape to get into the Settings, then hit the button saying "Difficulty Options", and finally, click the tab for Fusebox.  There is an option there for Blizzy toolbar

Share this post


Link to post
Share on other sites

New release, 0.1.14:

  • Fixed a couple of nullrefs which creeped in during work and the 1.3 upgrade
  • Updated .version to look at github for current version

Share this post


Link to post
Share on other sites

does this calculate needs from MKS modules? (kerbal life support, recylers, habitation modules, etc?)

Share this post


Link to post
Share on other sites
18 hours ago, toric5 said:

does this calculate needs from MKS modules? (kerbal life support, recylers, habitation modules, etc?)

No

Share this post


Link to post
Share on other sites

Two items:

  1. I don't recall if this supported Radiators as specific category. It currently doesn't (and I don't think it ever did, but again, not sure...) Radiators take EC to use for quite some time now, if I recall correctly. Any chance of adding them to the filter list?
  2. I recall Ratzap once telling me that certain categories in the filter for Fusebox are dependent on mod version-specific dlls being present when Fusebox is compiled to actually support that mod properly. This is because some mods reference EC usage with atypical methods that Fusebox has to specifically account and look for. SCANsat in particular seems to be notorious (well, to me) for breaking support in Fusebox each time they release an update. (Ratzap basically had to recompile each time certain optional supported mods updated, like SCANsat.) I'm on 1.3.0 currently and don't see SCANsat as part of the Fusebox filters. Any ideas about SCANsat support in FB-Continued?

On a side-note: Kinda wished you called it Fusebox Rewired :sticktongue:

Share this post


Link to post
Share on other sites

just a FYI, the ckan installer is borking on it.

 

it only creates the /fusebox directory instead of /fuseboxcontinued which is inside the zip, so no files are copied.

 

(manual install works fine, its just ckan not being skynet intuitive)

Edited by TK421d

Share this post


Link to post
Share on other sites
39 minutes ago, TK421d said:

just a FYI, the ckan installer is borking on it.

 

it only creates the /fusebox directory instead of /fuseboxcontinued which is inside the zip, so no files are copied.

 

(manual install works fine, its just ckan not being skynet intuitive)

Oh yuck. 

Thanks, I'll fix it this evening

Share this post


Link to post
Share on other sites

New release, 0.1.15.2:

  • Rebuild to fix install dir

No code changes, the install directory got changed, this is reverting back to FuseBox

Share this post


Link to post
Share on other sites

New release, 0.1.15.3

  • Revert last change

The problem was actually in the CKAN file, I just fixed that, give it a little time to update

You might have to exit CKAN and restart it, sometimes the refresh doesn't catch these changes

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

I think I have an incompatibility to report.

FuseBox does not recognize any solar panel power generation (in the VAB/SPH) at all, and I'm reasonably certain that the culprit is Kopernicus.

I have Kopernicus installed as a dependecy of another (biome) mod. Now, Kopernicus has the ability to add additional suns to the game, and to that effect it overrides every solar panel with its own module which AmpYear reports as KopernicusSolarPanel,  to (presumably) set the tracking to the correct sun. -- FuseBox power generation info works fine in flight, it's solely an editor issue.

 

EDIT: Ugh, should have checked Github first. There's already a PR. - Now to set up a dev env for the dozens of dependencies...

 

Also, while I'm here, a feature request:

Could you add a "Blind Load" feature to FuseBox? Something with a slider and/or edit box where we can set a manual value for modules that FuseBox does not recognize. Maybe also a "Blind Generation" feature for the opposite. Or just allow negative load numbers.

Edited by jinks

Share this post


Link to post
Share on other sites

feature request: configurable orbit altitude for darkness time

UPD. it is there. 

Edited by flart

Share this post


Link to post
Share on other sites
On ‎11‎/‎4‎/‎2017 at 5:06 PM, jinks said:

I think I have an incompatibility to report.

FuseBox does not recognize any solar panel power generation (in the VAB/SPH) at all, and I'm reasonably certain that the culprit is Kopernicus.

I have Kopernicus installed as a dependecy of another (biome) mod. Now, Kopernicus has the ability to add additional suns to the game, and to that effect it overrides every solar panel with its own module which AmpYear reports as KopernicusSolarPanel,  to (presumably) set the tracking to the correct sun. -- FuseBox power generation info works fine in flight, it's solely an editor issue.

 

EDIT: Ugh, should have checked Github first. There's already a PR. - Now to set up a dev env for the dozens of dependencies...

+1 to this, commented on GitHub, willing to test a fix as necessary.

Edited by eightiesboi

Share this post


Link to post
Share on other sites

I'm wondering if there is a mod similar to this that can do antenna calculations for the stock commnet.   I can look it up online, but when you involve a rescaled world and mod added parts it gets a little complicated.  

Share this post


Link to post
Share on other sites
12 hours ago, eberkain said:

I'm wondering if there is a mod similar to this that can do antenna calculations for the stock commnet.   I can look it up online, but when you involve a rescaled world and mod added parts it gets a little complicated.  

There is:

 

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.